kterm16c port. Files were repository copied from ports/japanese/kterm.
kterm16c is a 16 color-support version of kterm. It is useful for console hardcopy on a VGA terminal. 16 color patch was made by KANDA Toshihiro <candy@kgc.co.jp>. PR: 9976 Submitted by: KIRIYAMA Kazuhiko <kiri@pis.toba-cmt.ac.jp>
This commit is contained in:
parent
1ce78a113c
commit
25304384e7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16608
13 changed files with 392 additions and 29 deletions
|
@ -1,18 +1,23 @@
|
|||
# New ports collection makefile for: kterm
|
||||
# New ports collection makefile for: kterm of 16 colors
|
||||
# Version required: 6.2
|
||||
# Date created: 18 November 1994
|
||||
# Whom: asami
|
||||
#
|
||||
# $Id: Makefile,v 1.16 1997/12/25 22:29:38 asami Exp $
|
||||
# $Id: Makefile,v 1.17 1998/12/23 01:47:23 steve Exp $
|
||||
#
|
||||
|
||||
DISTNAME= kterm-6.2.0
|
||||
PKGNAME= ja-kterm-6.2.0
|
||||
PKGNAME= ja-kterm16c-6.2.0
|
||||
CATEGORIES= japanese x11
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
|
||||
ftp://ftp.interface-business.de/pub/outgoing/ \
|
||||
ftp://ftp.cs.bris.ac.uk/pub/users/hedley/
|
||||
DISTFILES= kterm-6.2.0.tar.gz pcemu1.01alpha.tar.gz
|
||||
EXTRACT_ONLY= kterm-6.2.0.tar.gz
|
||||
|
||||
MASTER_SITE_SUBDIR= applications
|
||||
|
||||
MAINTAINER= shige@kuis.kyoto-u.ac.jp
|
||||
MAINTAINER= kiri@pis.toba-cmt.ac.jp
|
||||
|
||||
BUILD_DEPENDS= nkf:${PORTSDIR}/japanese/nkf
|
||||
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
|
||||
|
@ -24,10 +29,15 @@ PATCHFILES= kterm-6.2.0.NFS-xauth.patch \
|
|||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
USE_IMAKE= yes
|
||||
MAN1= kterm.1
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
DOCDIR= ${PREFIX}/share/doc/kterm
|
||||
DOCDIR= ${PREFIX}/share/doc/kterm16c
|
||||
|
||||
post-extract:
|
||||
@${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/pcemu1.01alpha.tar.gz \
|
||||
${EXTRACT_AFTER_ARGS} -C ${WRKDIR} pcemu1.01alpha/vga.bdf
|
||||
@cd ${WRKDIR}/pcemu1.01alpha; \
|
||||
bdftopcf vga.bdf > vga.pcf; \
|
||||
${GZIP_CMD} vga.pcf
|
||||
|
||||
.if !defined(PACKAGE_BUILDING)
|
||||
|
||||
|
@ -54,16 +64,19 @@ post-patch:
|
|||
.endif
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/kterm ${PREFIX}/bin/kterm16c
|
||||
@${INSTALL_DATA} ${WRKSRC}/KTerm.ad ${PREFIX}/lib/X11/app-defaults/KTerm.16-colors
|
||||
@${INSTALL_DATA} ${WRKDIR}/pcemu1.01alpha/vga.pcf.gz \
|
||||
${PREFIX}/lib/X11/fonts/misc
|
||||
@mkfontdir ${PREFIX}/lib/X11/fonts/misc
|
||||
|
||||
post-install:
|
||||
# install japanese manual
|
||||
@${MV} ${WRKSRC}/kterm.jman ${WRKSRC}/kterm.jman.jis
|
||||
@nkf -e -u ${WRKSRC}/kterm.jman.jis >${WRKSRC}/kterm.jman
|
||||
@${INSTALL_MAN} ${WRKSRC}/kterm.jman ${PREFIX}/man/ja/man1/kterm.1
|
||||
@${GZIP_CMD} ${PREFIX}/man/ja/man1/kterm.1
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README.kt ${DOCDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README.wallpaper ${DOCDIR}/README.wallpaper.ja
|
||||
@${INSTALL_DATA} ${FILESDIR}/dot.termcap ${DOCDIR}
|
||||
@${INSTALL_DATA} ${FILESDIR}/kterm16c.doc ${DOCDIR}
|
||||
.endif
|
||||
@${CAT} ${PKGDIR}/MESSAGE
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,4 @@
|
|||
MD5 (kterm-6.2.0.tar.gz) = 9cc72841b50dfba92bce01dbbebf3039
|
||||
MD5 (pcemu1.01alpha.tar.gz) = 1fed124b199839e439bec0f45abf006b
|
||||
MD5 (kterm-6.2.0.NFS-xauth.patch) = a2f11334e14929997e987e463f004dd0
|
||||
MD5 (kterm-6.2.0-wpr1.patch.gz) = 139c824069743f8aa2ed85d55a2b0dfc
|
||||
|
|
4
japanese/kterm16c/files/dot.termcap
Normal file
4
japanese/kterm16c/files/dot.termcap
Normal file
|
@ -0,0 +1,4 @@
|
|||
ktermc|kanji terminal with 16 colors:\
|
||||
:op=:pa#64:Co#8:Sf=\E[3%dm:Sb=\E[4%dm:\
|
||||
:mb=\E[5m:md=\E[1m:mr=\E[7m:mh=\E[2m:me=\E[m:\
|
||||
:tc=kterm:
|
195
japanese/kterm16c/files/kterm16c.doc
Normal file
195
japanese/kterm16c/files/kterm16c.doc
Normal file
|
@ -0,0 +1,195 @@
|
|||
Subject: [FreeBSD-users-jp 36743] Re: Console dump?
|
||||
From: Toshihiro Kanda <candy@kgc.co.jp>
|
||||
To: FreeBSD-users-jp@jp.freebsd.org
|
||||
Date: Thu, 24 Dec 1998 11:56:05 +0900 (JST)
|
||||
Reply-To: FreeBSD-users-jp@jp.freebsd.org
|
||||
|
||||
> /stand/sysinstall の 16色カラー表示をビットマップにするのが目
|
||||
> 的であれば、以前神田さんが users-jp で kterm-6.1.0 で 16色表示す
|
||||
> るためのパッチを公開されているので、それがが使えます(kterm 上で
|
||||
> 動かして、普通に grab する)。
|
||||
> # 手元では kterm-6.2.0 に無理矢理手でパッチあてて使っています。
|
||||
|
||||
こんな古いものを覚えていらっしゃる方がいるとはびっくりです。無理矢理手
|
||||
パッチさせてしまっては恐縮なので、kterm-6.2.0 用のパッチを作りました。
|
||||
|
||||
神田敏広 <candy@kgc.co.jp>
|
||||
|
||||
------------------------------------------------------------
|
||||
kterm-6.2.0 用 16 色パッチ & コンソール(sc)互換 termcap エントリ
|
||||
|
||||
このパッチは無保証です。
|
||||
|
||||
●パッチの使い方
|
||||
kterm-6.2.0/ のあるディレクトリで以下を実行してください。16 色対応
|
||||
kterm をインストールします。
|
||||
|
||||
# patch -p < this-patch
|
||||
# cd kterm-6.2.0
|
||||
# xmkmf -a
|
||||
# make all install
|
||||
|
||||
●termcap エントリの追加
|
||||
次のようなエントリを $HOME/.termcap に追加してください。16 色対応
|
||||
kterm を起動したら、環境変数 TERM を ktermc に設定してください。
|
||||
|
||||
--------8<-------- $HOME/.termcap --------8<--------
|
||||
ktermc|kanji terminal with 16 colors:\
|
||||
:op=:pa#64:Co#8:Sf=\E[3%dm:Sb=\E[4%dm:\
|
||||
:mb=\E[5m:md=\E[1m:mr=\E[7m:mh=\E[2m:me=\E[m:\
|
||||
:tc=kterm:
|
||||
--------8<--------8<--------8<--------8<--------8<--------
|
||||
|
||||
●VGA font の作り方
|
||||
VGA フォントはpackages/emulators/pcemu-1.01a の vga.pcf.Z を利用すると
|
||||
それらしく見えます。
|
||||
|
||||
$ su
|
||||
# cp vga.pcf.Z /usr/X11R6/lib/X11/fonts/misc
|
||||
# cd /usr/X11R6/lib/X11/fonts/misc
|
||||
# mkfontdir
|
||||
# exit
|
||||
$ xset fp rehash
|
||||
|
||||
kterm の起動(例)
|
||||
$ kterm -fn vga -fk kanji16 -rv &
|
||||
|
||||
●kterm-6.2.0 用 16 色パッチ
|
||||
--------8<--------8<--------8<--------8<--------8<--------
|
||||
diff --exclude=Makefile -ur kterm-6.2.0.orig/KTerm.ad kterm-6.2.0/KTerm.ad
|
||||
--- kterm-6.2.0.orig/KTerm.ad Sun Jun 23 17:00:22 1996
|
||||
+++ kterm-6.2.0/KTerm.ad Thu Dec 24 11:47:10 1998
|
||||
@@ -97,14 +97,22 @@
|
||||
!*VT100*kanjiMode: jis
|
||||
!*VT100*lineSpace: 0
|
||||
|
||||
-!*VT100*textColor0: Black
|
||||
-!*VT100*textColor1: Red
|
||||
-!*VT100*textColor2: Green
|
||||
-!*VT100*textColor3: Yellow
|
||||
-!*VT100*textColor4: Blue
|
||||
-!*VT100*textColor5: Magenta
|
||||
-!*VT100*textColor6: Cyan
|
||||
-!*VT100*textColor7: White
|
||||
+*VT100*textColor0: #505050
|
||||
+*VT100*textColor1: Red
|
||||
+*VT100*textColor2: Green
|
||||
+*VT100*textColor3: Yellow
|
||||
+*VT100*textColor4: Blue
|
||||
+*VT100*textColor5: Magenta
|
||||
+*VT100*textColor6: Cyan
|
||||
+*VT100*textColor7: White
|
||||
+*VT100*textColor8: Black
|
||||
+*VT100*textColor9: #c00000
|
||||
+*VT100*textColor10: #00c000
|
||||
+*VT100*textColor11: #c0c000
|
||||
+*VT100*textColor12: #0000c0
|
||||
+*VT100*textColor13: #c000c0
|
||||
+*VT100*textColor14: #00c0c0
|
||||
+*VT100*textColor15: #c0c0c0
|
||||
|
||||
*tekMenu.Label: Tek Options
|
||||
*tekMenu*tektextlarge*Label: Large Characters
|
||||
diff --exclude=Makefile -ur kterm-6.2.0.orig/charproc.c kterm-6.2.0/charproc.c
|
||||
--- kterm-6.2.0.orig/charproc.c Fri Jul 12 14:01:36 1996
|
||||
+++ kterm-6.2.0/charproc.c Thu Dec 24 11:46:28 1998
|
||||
@@ -143,6 +143,16 @@
|
||||
#define XtNtextColor5 "textColor5"
|
||||
#define XtNtextColor6 "textColor6"
|
||||
#define XtNtextColor7 "textColor7"
|
||||
+#ifdef COLOR_16
|
||||
+#define XtNtextColor8 "textColor8"
|
||||
+#define XtNtextColor9 "textColor9"
|
||||
+#define XtNtextColor10 "textColor10"
|
||||
+#define XtNtextColor11 "textColor11"
|
||||
+#define XtNtextColor12 "textColor12"
|
||||
+#define XtNtextColor13 "textColor13"
|
||||
+#define XtNtextColor14 "textColor14"
|
||||
+#define XtNtextColor15 "textColor15"
|
||||
+#endif
|
||||
#endif /* KTERM_COLOR */
|
||||
#define XtNcutNewline "cutNewline"
|
||||
#define XtNcutToBeginningOfLine "cutToBeginningOfLine"
|
||||
@@ -576,6 +586,32 @@
|
||||
{XtNtextColor7, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
XtOffsetOf(XtermWidgetRec, screen.textcolor[7]),
|
||||
XtRString, "White"},
|
||||
+#ifdef COLOR_16 /* [ */
|
||||
+{XtNtextColor8, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[8]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor9, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[9]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor10, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[10]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor11, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[11]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor12, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[12]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor13, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[13]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor14, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[14]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor15, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[15]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+#endif /* ] */
|
||||
#endif /* KTERM_COLOR */
|
||||
{XtNeightBitInput, XtCEightBitInput, XtRBoolean, sizeof(Boolean),
|
||||
XtOffsetOf(XtermWidgetRec, screen.input_eight_bits),
|
||||
@@ -4979,6 +5015,9 @@
|
||||
screen->fnt_norm = nfs;
|
||||
screen->fnt_bold = bfs;
|
||||
screen->enbolden = (nfs == bfs);
|
||||
+#ifdef COLOR_16
|
||||
+ screen->enbolden = 0;
|
||||
+#endif
|
||||
set_menu_font (False);
|
||||
screen->menu_font_number = fontnum;
|
||||
set_menu_font (True);
|
||||
diff --exclude=Makefile -ur kterm-6.2.0.orig/kterm.h kterm-6.2.0/kterm.h
|
||||
--- kterm-6.2.0.orig/kterm.h Fri Jul 12 14:01:37 1996
|
||||
+++ kterm-6.2.0/kterm.h Thu Dec 24 11:46:28 1998
|
||||
@@ -37,5 +37,6 @@
|
||||
#define KTERM_COLOR /* color sequence */
|
||||
#define KTERM_NOTEK /* disables Tektronix emulation */
|
||||
#undef KTERM_XAW3D /* Xaw3d -DARROW_SCROLLBAR support */
|
||||
+#define COLOR_16 /* 16 palets, BOLD means hilight */
|
||||
|
||||
#endif /* !_KTERM_H_ */
|
||||
diff --exclude=Makefile -ur kterm-6.2.0.orig/ptyx.h kterm-6.2.0/ptyx.h
|
||||
--- kterm-6.2.0.orig/ptyx.h Tue Jul 2 14:01:53 1996
|
||||
+++ kterm-6.2.0/ptyx.h Thu Dec 24 11:46:28 1998
|
||||
@@ -300,7 +300,11 @@
|
||||
Pixel mousecolor; /* Mouse color */
|
||||
Pixel mousecolorback; /* Mouse color background */
|
||||
#ifdef KTERM_COLOR
|
||||
+#ifndef COLOR_16
|
||||
Pixel textcolor[8]; /* text colors */
|
||||
+#else
|
||||
+ Pixel textcolor[16]; /* text colors */
|
||||
+#endif
|
||||
#endif /* KTERM_COLOR */
|
||||
int border; /* inner border */
|
||||
Cursor arrow; /* arrow cursor */
|
||||
@@ -656,6 +660,12 @@
|
||||
#define BACKCOLORMASK 0x7000
|
||||
#define BACKCOLOR(c) ((c) << 12)
|
||||
#define BACKCOLORNUM(f) (((f) & BACKCOLORMASK) >> 12)
|
||||
+#ifdef COLOR_16
|
||||
+#undef FORECOLORNUM
|
||||
+#undef BACKCOLORNUM
|
||||
+#define FORECOLORNUM(f) ((((f) & FORECOLORMASK) >> 8) + (((f) & BOLD)?0:8))
|
||||
+#define BACKCOLORNUM(f) ((((f) & BACKCOLORMASK) >> 12) + (((f) & BOLD)?8:8))
|
||||
+#endif
|
||||
#endif /* KTERM_COLOR */
|
||||
/* global flags */
|
||||
#ifdef KTERM
|
||||
--------8<--------8<--------8<--------8<--------8<--------
|
||||
|
34
japanese/kterm16c/files/patch-ab
Normal file
34
japanese/kterm16c/files/patch-ab
Normal file
|
@ -0,0 +1,34 @@
|
|||
diff --exclude=Makefile -ur kterm-6.2.0.orig/KTerm.adKTerm.ad
|
||||
--- kterm-6.2.0.orig/KTerm.ad Sun Jun 23 17:00:22 1996
|
||||
+++ KTerm.ad Thu Dec 24 11:47:10 1998
|
||||
@@ -97,14 +97,22 @@
|
||||
!*VT100*kanjiMode: jis
|
||||
!*VT100*lineSpace: 0
|
||||
|
||||
-!*VT100*textColor0: Black
|
||||
-!*VT100*textColor1: Red
|
||||
-!*VT100*textColor2: Green
|
||||
-!*VT100*textColor3: Yellow
|
||||
-!*VT100*textColor4: Blue
|
||||
-!*VT100*textColor5: Magenta
|
||||
-!*VT100*textColor6: Cyan
|
||||
-!*VT100*textColor7: White
|
||||
+*VT100*textColor0: #505050
|
||||
+*VT100*textColor1: Red
|
||||
+*VT100*textColor2: Green
|
||||
+*VT100*textColor3: Yellow
|
||||
+*VT100*textColor4: Blue
|
||||
+*VT100*textColor5: Magenta
|
||||
+*VT100*textColor6: Cyan
|
||||
+*VT100*textColor7: White
|
||||
+*VT100*textColor8: Black
|
||||
+*VT100*textColor9: #c00000
|
||||
+*VT100*textColor10: #00c000
|
||||
+*VT100*textColor11: #c0c000
|
||||
+*VT100*textColor12: #0000c0
|
||||
+*VT100*textColor13: #c000c0
|
||||
+*VT100*textColor14: #00c0c0
|
||||
+*VT100*textColor15: #c0c0c0
|
||||
|
||||
*tekMenu.Label: Tek Options
|
||||
*tekMenu*tektextlarge*Label: Large Characters
|
63
japanese/kterm16c/files/patch-ac
Normal file
63
japanese/kterm16c/files/patch-ac
Normal file
|
@ -0,0 +1,63 @@
|
|||
diff --exclude=Makefile -ur kterm-6.2.0.orig/charproc.ccharproc.c
|
||||
--- kterm-6.2.0.orig/charproc.c Fri Jul 12 14:01:36 1996
|
||||
+++ charproc.c Thu Dec 24 11:46:28 1998
|
||||
@@ -143,6 +143,16 @@
|
||||
#define XtNtextColor5 "textColor5"
|
||||
#define XtNtextColor6 "textColor6"
|
||||
#define XtNtextColor7 "textColor7"
|
||||
+#ifdef COLOR_16
|
||||
+#define XtNtextColor8 "textColor8"
|
||||
+#define XtNtextColor9 "textColor9"
|
||||
+#define XtNtextColor10 "textColor10"
|
||||
+#define XtNtextColor11 "textColor11"
|
||||
+#define XtNtextColor12 "textColor12"
|
||||
+#define XtNtextColor13 "textColor13"
|
||||
+#define XtNtextColor14 "textColor14"
|
||||
+#define XtNtextColor15 "textColor15"
|
||||
+#endif
|
||||
#endif /* KTERM_COLOR */
|
||||
#define XtNcutNewline "cutNewline"
|
||||
#define XtNcutToBeginningOfLine "cutToBeginningOfLine"
|
||||
@@ -576,6 +586,32 @@
|
||||
{XtNtextColor7, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
XtOffsetOf(XtermWidgetRec, screen.textcolor[7]),
|
||||
XtRString, "White"},
|
||||
+#ifdef COLOR_16 /* [ */
|
||||
+{XtNtextColor8, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[8]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor9, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[9]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor10, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[10]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor11, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[11]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor12, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[12]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor13, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[13]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor14, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[14]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+{XtNtextColor15, XtCForeground, XtRPixel, sizeof(Pixel),
|
||||
+ XtOffsetOf(XtermWidgetRec, screen.textcolor[15]),
|
||||
+ XtRString, "XtDefaultForeground"},
|
||||
+#endif /* ] */
|
||||
#endif /* KTERM_COLOR */
|
||||
{XtNeightBitInput, XtCEightBitInput, XtRBoolean, sizeof(Boolean),
|
||||
XtOffsetOf(XtermWidgetRec, screen.input_eight_bits),
|
||||
@@ -4979,6 +5015,9 @@
|
||||
screen->fnt_norm = nfs;
|
||||
screen->fnt_bold = bfs;
|
||||
screen->enbolden = (nfs == bfs);
|
||||
+#ifdef COLOR_16
|
||||
+ screen->enbolden = 0;
|
||||
+#endif
|
||||
set_menu_font (False);
|
||||
screen->menu_font_number = fontnum;
|
||||
set_menu_font (True);
|
10
japanese/kterm16c/files/patch-ad
Normal file
10
japanese/kterm16c/files/patch-ad
Normal file
|
@ -0,0 +1,10 @@
|
|||
diff --exclude=Makefile -ur kterm-6.2.0.orig/kterm.hkterm.h
|
||||
--- kterm-6.2.0.orig/kterm.h Fri Jul 12 14:01:37 1996
|
||||
+++ kterm.h Thu Dec 24 11:46:28 1998
|
||||
@@ -37,5 +37,6 @@
|
||||
#define KTERM_COLOR /* color sequence */
|
||||
#define KTERM_NOTEK /* disables Tektronix emulation */
|
||||
#undef KTERM_XAW3D /* Xaw3d -DARROW_SCROLLBAR support */
|
||||
+#define COLOR_16 /* 16 palets, BOLD means hilight */
|
||||
|
||||
#endif /* !_KTERM_H_ */
|
28
japanese/kterm16c/files/patch-ae
Normal file
28
japanese/kterm16c/files/patch-ae
Normal file
|
@ -0,0 +1,28 @@
|
|||
diff --exclude=Makefile -ur kterm-6.2.0.orig/ptyx.hptyx.h
|
||||
--- kterm-6.2.0.orig/ptyx.h Tue Jul 2 14:01:53 1996
|
||||
+++ ptyx.h Thu Dec 24 11:46:28 1998
|
||||
@@ -300,7 +300,11 @@
|
||||
Pixel mousecolor; /* Mouse color */
|
||||
Pixel mousecolorback; /* Mouse color background */
|
||||
#ifdef KTERM_COLOR
|
||||
+#ifndef COLOR_16
|
||||
Pixel textcolor[8]; /* text colors */
|
||||
+#else
|
||||
+ Pixel textcolor[16]; /* text colors */
|
||||
+#endif
|
||||
#endif /* KTERM_COLOR */
|
||||
int border; /* inner border */
|
||||
Cursor arrow; /* arrow cursor */
|
||||
@@ -656,6 +660,12 @@
|
||||
#define BACKCOLORMASK 0x7000
|
||||
#define BACKCOLOR(c) ((c) << 12)
|
||||
#define BACKCOLORNUM(f) (((f) & BACKCOLORMASK) >> 12)
|
||||
+#ifdef COLOR_16
|
||||
+#undef FORECOLORNUM
|
||||
+#undef BACKCOLORNUM
|
||||
+#define FORECOLORNUM(f) ((((f) & FORECOLORMASK) >> 8) + (((f) & BOLD)?0:8))
|
||||
+#define BACKCOLORNUM(f) ((((f) & BACKCOLORMASK) >> 12) + (((f) & BOLD)?8:8))
|
||||
+#endif
|
||||
#endif /* KTERM_COLOR */
|
||||
/* global flags */
|
||||
#ifdef KTERM
|
|
@ -1 +1 @@
|
|||
An xterm that speaks Japanese
|
||||
An xterm that speaks Japanese with 16 colors like on a VGA.
|
||||
|
|
3
japanese/kterm16c/pkg-deinstall
Normal file
3
japanese/kterm16c/pkg-deinstall
Normal file
|
@ -0,0 +1,3 @@
|
|||
#!/bin/sh
|
||||
|
||||
perl -pi -e 's/^vga\.pcf\.gz[ \t]+.*\n$//' ${PKG_PREFIX}/lib/X11/fonts/misc/fonts.dir
|
|
@ -1,11 +1,12 @@
|
|||
kterm is a xterm replacement with Japanese (Kanji) support. It also
|
||||
understands ANSI color sequences. This version is 6.1.0, available
|
||||
from the X11R6 contrib tape.
|
||||
understands ANSI color sequences. This version is 6.2.0.
|
||||
|
||||
kterm16c is for console hardcopy on a VGA terminal. It enables to get
|
||||
bitmaps of VGA terminal mode. Conversion for 16 color kterm was made by
|
||||
KANDA Toshihiro<candy@kgc.co.jp>.
|
||||
|
||||
Also included is support for Xaw3d arrow-style scrollbars. You can
|
||||
now hold down the arrow buttons to scroll continuously. I made this
|
||||
patch (patch-ae) by modifying the source while looking at the xterm
|
||||
patch available with Xaw3d for R5.
|
||||
now hold down the arrow buttons to scroll continuously.
|
||||
|
||||
Satoshi Asami
|
||||
asami@cs.berkeley.edu
|
||||
-KIRIYAMA Kazuhiko
|
||||
<kiri@pis.toba-cmt.ac.jp>
|
||||
|
|
10
japanese/kterm16c/pkg-message
Normal file
10
japanese/kterm16c/pkg-message
Normal file
|
@ -0,0 +1,10 @@
|
|||
***********************************************************************
|
||||
* You must reset X, copy .termcap to your home directory and set TERM *
|
||||
* ktermc: *
|
||||
* % xset fp rehash *
|
||||
* % xrdb -m /usr/X11R6/lib/X11/app-defaults/KTerm.16-colors *
|
||||
* % cp /usr/X11R6/share/doc/kterm16c/dot.termcap $HOME/.termcap *
|
||||
* % kterm16c -fn vga -rv & (for VGA terminal) *
|
||||
* % kterm16c -fn kanji14 -fk kanji14 -rv & (for kon on VGA) *
|
||||
* % setenv TERM ktermc *
|
||||
***********************************************************************
|
|
@ -1,6 +1,7 @@
|
|||
bin/kterm
|
||||
lib/X11/app-defaults/KTerm
|
||||
man/ja/man1/kterm.1.gz
|
||||
share/doc/kterm/README.kt
|
||||
share/doc/kterm/README.wallpaper.ja
|
||||
@dirrm share/doc/kterm
|
||||
bin/kterm16c
|
||||
lib/X11/app-defaults/KTerm.16-colors
|
||||
lib/X11/fonts/misc/vga.pcf.gz
|
||||
@exec /usr/X11R6/bin/mkfontdir %B
|
||||
share/doc/kterm16c/dot.termcap
|
||||
share/doc/kterm16c/kterm16c.doc
|
||||
@dirrm share/doc/kterm16c
|
||||
|
|
Loading…
Reference in a new issue