Unbreak on 4.x.

PR:		ports/62073
Submitted by:	Hiroki Sato <hrs@freebsd.org>
This commit is contained in:
Mark Linimon 2004-01-30 10:30:07 +00:00
parent dc6e53815b
commit 253cf23efa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99490
2 changed files with 26 additions and 7 deletions

View file

@ -21,10 +21,4 @@ GNU_CONFIGURE= yes
MAN1= iverilog-vpi.1 iverilog.1 vvp.1 iverilog-fpga.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 500000
BROKEN= "Does not install on FreeBSD ${OSVERSION}"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,25 @@
--- _pli_types.h.in Wed Nov 12 11:38:44 2003
+++ _pli_types.h.in.new Fri Jan 30 01:44:38 2004
@@ -45,7 +45,21 @@
typedef signed char PLI_BYTE8;
typedef unsigned char PLI_UBYTE8;
-# define PLI_UINT64_FMT PRIu64
+#ifndef PRIu64
+
+#if defined(__i386__) || defined(__powerpc__)
+#define PLI_UINT64_FMT "llu"
+#endif /* defined(__i386__) || defined(__powerpc__) */
+
+#if defined(__sparc64__) || defined(__alpha__) || defined(__amd64__) || defined(__ia64__)
+#define PLI_UINT64_FMT "lu"
+#endif /* defined(__sparc64__) || defined(__alpha__) || defined(__amd64__) || defined(__ia64__) */
+
+#else /* PRIu64 defined */
+
+#define PLI_UINT64_FMT PRIu64
+
+#endif /* PRIu64 */
#else