- Revert to 1.6.7, update breaks dependencies
This commit is contained in:
parent
3f9032fcb3
commit
254cbcab56
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219368
7 changed files with 299 additions and 27 deletions
|
@ -6,9 +6,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= devil
|
||||
PORTVERSION= 1.7.0
|
||||
PORTVERSION= 1.6.7
|
||||
PORTREVISION= 6
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/openil
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= openil
|
||||
DISTNAME= DevIL-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
@ -20,22 +23,14 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
|
|||
mng.1:${PORTSDIR}/graphics/libmng \
|
||||
lcms.1:${PORTSDIR}/graphics/lcms
|
||||
|
||||
OPTIONS= SDL "Enable SDL support" off
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
USE_GL= glu
|
||||
USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262 libtool:15
|
||||
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
|
||||
AUTOMAKE_ARGS= --add-missing --copy --force-missing
|
||||
CONFIGURE_ARGS= --disable-allegro --disable-directx8 --disable-directx9 \
|
||||
--disable-altivec --disable-sse --disable-sse2 --disable-sse3
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GL= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-allegro
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
|
||||
|
||||
CPPFLAGS= -I${LOCALBASE}/include
|
||||
LDFLAGS= -L${LOCALBASE}/lib
|
||||
OPTIONS= SDL "Enable SDL support" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -46,6 +41,7 @@ CONFIGURE_ARGS+=--disable-sdl
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/configure.ac
|
||||
${FIND} ${WRKSRC} \( -name '*.c' -o -name '*.cpp' -o -name '*.h' \) -print0 |\
|
||||
${XARGS} -0 ${REINPLACE_CMD} 's|ILvoid|void|g'
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (DevIL-1.7.0.tar.gz) = 6b3e1cee164e5319e5bb7c879a3959bb
|
||||
SHA256 (DevIL-1.7.0.tar.gz) = 0a19f8cd5ea00d682c1df640e0f0bf23828f47b16cd71e079113c556ef17ab7e
|
||||
SIZE (DevIL-1.7.0.tar.gz) = 698579
|
||||
MD5 (DevIL-1.6.7.tar.gz) = 0d0c3842196d85c4e24bedabcd84f626
|
||||
SHA256 (DevIL-1.6.7.tar.gz) = 61cc4d203d9c4272d10b7ba19b45ef53882bb545936389092361302d94b5f907
|
||||
SIZE (DevIL-1.6.7.tar.gz) = 3013312
|
||||
|
|
175
graphics/devil/files/patch-include-IL_il.h
Normal file
175
graphics/devil/files/patch-include-IL_il.h
Normal file
|
@ -0,0 +1,175 @@
|
|||
--- include/IL/il.h.orig Mon Jul 12 18:55:08 2004
|
||||
+++ include/IL/il.h Mon Sep 17 19:36:05 2007
|
||||
@@ -125,7 +125,6 @@
|
||||
typedef float ILclampf;
|
||||
typedef double ILdouble;
|
||||
typedef double ILclampd;
|
||||
-typedef void ILvoid;
|
||||
|
||||
#ifdef _UNICODE
|
||||
#ifndef _WIN32_WCE
|
||||
@@ -460,7 +459,7 @@
|
||||
|
||||
// Callback functions for file reading
|
||||
typedef void* ILHANDLE;
|
||||
-typedef ILvoid (ILAPIENTRY *fCloseRProc)(ILHANDLE);
|
||||
+typedef void (ILAPIENTRY *fCloseRProc)(ILHANDLE);
|
||||
typedef ILboolean (ILAPIENTRY *fEofProc) (ILHANDLE);
|
||||
typedef ILint (ILAPIENTRY *fGetcProc) (ILHANDLE);
|
||||
typedef ILHANDLE (ILAPIENTRY *fOpenRProc) (const ILstring);
|
||||
@@ -469,7 +468,7 @@
|
||||
typedef ILint (ILAPIENTRY *fTellRProc) (ILHANDLE);
|
||||
|
||||
// Callback functions for file writing
|
||||
-typedef ILvoid (ILAPIENTRY *fCloseWProc)(ILHANDLE);
|
||||
+typedef void (ILAPIENTRY *fCloseWProc)(ILHANDLE);
|
||||
typedef ILHANDLE (ILAPIENTRY *fOpenWProc) (const ILstring);
|
||||
typedef ILint (ILAPIENTRY *fPutcProc) (ILubyte, ILHANDLE);
|
||||
typedef ILint (ILAPIENTRY *fSeekWProc) (ILHANDLE, ILint, ILint);
|
||||
@@ -477,8 +476,8 @@
|
||||
typedef ILint (ILAPIENTRY *fWriteProc) (const void*, ILuint, ILuint, ILHANDLE);
|
||||
|
||||
// Callback functions for allocation and deallocation
|
||||
-typedef ILvoid* (ILAPIENTRY *mAlloc)(ILuint);
|
||||
-typedef ILvoid (ILAPIENTRY *mFree) (ILvoid*);
|
||||
+typedef void* (ILAPIENTRY *mAlloc)(ILuint);
|
||||
+typedef void (ILAPIENTRY *mFree) (void*);
|
||||
|
||||
// Registered format procedures
|
||||
typedef ILenum (ILAPIENTRY *IL_LOADPROC)(const ILstring);
|
||||
@@ -491,91 +490,91 @@
|
||||
ILAPI ILboolean ILAPIENTRY ilActiveMipmap(ILuint Number);
|
||||
ILAPI ILboolean ILAPIENTRY ilApplyPal(const ILstring FileName);
|
||||
ILAPI ILboolean ILAPIENTRY ilApplyProfile(const ILstring InProfile, const ILstring OutProfile);
|
||||
-ILAPI ILvoid ILAPIENTRY ilBindImage(ILuint Image);
|
||||
+ILAPI void ILAPIENTRY ilBindImage(ILuint Image);
|
||||
ILAPI ILboolean ILAPIENTRY ilBlit(ILuint Source, ILint DestX, ILint DestY, ILint DestZ, ILuint SrcX, ILuint SrcY, ILuint SrcZ, ILuint Width, ILuint Height, ILuint Depth);
|
||||
-ILAPI ILvoid ILAPIENTRY ilClearColour(ILclampf Red, ILclampf Green, ILclampf Blue, ILclampf Alpha);
|
||||
-ILAPI ILboolean ILAPIENTRY ilClearImage(ILvoid);
|
||||
-ILAPI ILuint ILAPIENTRY ilCloneCurImage(ILvoid);
|
||||
+ILAPI void ILAPIENTRY ilClearColour(ILclampf Red, ILclampf Green, ILclampf Blue, ILclampf Alpha);
|
||||
+ILAPI ILboolean ILAPIENTRY ilClearImage(void);
|
||||
+ILAPI ILuint ILAPIENTRY ilCloneCurImage(void);
|
||||
ILAPI ILboolean ILAPIENTRY ilCompressFunc(ILenum Mode);
|
||||
ILAPI ILboolean ILAPIENTRY ilConvertImage(ILenum DestFormat, ILenum DestType);
|
||||
ILAPI ILboolean ILAPIENTRY ilConvertPal(ILenum DestFormat);
|
||||
ILAPI ILboolean ILAPIENTRY ilCopyImage(ILuint Src);
|
||||
-ILAPI ILuint ILAPIENTRY ilCopyPixels(ILuint XOff, ILuint YOff, ILuint ZOff, ILuint Width, ILuint Height, ILuint Depth, ILenum Format, ILenum Type, ILvoid *Data);
|
||||
+ILAPI ILuint ILAPIENTRY ilCopyPixels(ILuint XOff, ILuint YOff, ILuint ZOff, ILuint Width, ILuint Height, ILuint Depth, ILenum Format, ILenum Type, void *Data);
|
||||
ILAPI ILuint ILAPIENTRY ilCreateSubImage(ILenum Type, ILuint Num);
|
||||
-ILAPI ILboolean ILAPIENTRY ilDefaultImage(ILvoid);
|
||||
-ILAPI ILvoid ILAPIENTRY ilDeleteImages(ILsizei Num, const ILuint *Images);
|
||||
+ILAPI ILboolean ILAPIENTRY ilDefaultImage(void);
|
||||
+ILAPI void ILAPIENTRY ilDeleteImages(ILsizei Num, const ILuint *Images);
|
||||
ILAPI ILboolean ILAPIENTRY ilDisable(ILenum Mode);
|
||||
ILAPI ILboolean ILAPIENTRY ilEnable(ILenum Mode);
|
||||
ILAPI ILboolean ILAPIENTRY ilFormatFunc(ILenum Mode);
|
||||
-ILAPI ILvoid ILAPIENTRY ilGenImages(ILsizei Num, ILuint *Images);
|
||||
+ILAPI void ILAPIENTRY ilGenImages(ILsizei Num, ILuint *Images);
|
||||
ILAPI ILubyte* ILAPIENTRY ilGetAlpha(ILenum Type);
|
||||
-ILAPI ILvoid ILAPIENTRY ilModAlpha( ILdouble AlphaValue );
|
||||
-ILAPI ILvoid ILAPIENTRY ilSetAlpha( ILdouble AlphaValue );
|
||||
+ILAPI void ILAPIENTRY ilModAlpha( ILdouble AlphaValue );
|
||||
+ILAPI void ILAPIENTRY ilSetAlpha( ILdouble AlphaValue );
|
||||
ILAPI ILboolean ILAPIENTRY ilGetBoolean(ILenum Mode);
|
||||
-ILAPI ILvoid ILAPIENTRY ilGetBooleanv(ILenum Mode, ILboolean *Param);
|
||||
-ILAPI ILubyte* ILAPIENTRY ilGetData(ILvoid);
|
||||
-ILAPI ILuint ILAPIENTRY ilGetDXTCData(ILvoid *Buffer, ILuint BufferSize, ILenum DXTCFormat);
|
||||
-ILAPI ILenum ILAPIENTRY ilGetError(ILvoid);
|
||||
+ILAPI void ILAPIENTRY ilGetBooleanv(ILenum Mode, ILboolean *Param);
|
||||
+ILAPI ILubyte* ILAPIENTRY ilGetData(void);
|
||||
+ILAPI ILuint ILAPIENTRY ilGetDXTCData(void *Buffer, ILuint BufferSize, ILenum DXTCFormat);
|
||||
+ILAPI ILenum ILAPIENTRY ilGetError(void);
|
||||
ILAPI ILint ILAPIENTRY ilGetInteger(ILenum Mode);
|
||||
-ILAPI ILvoid ILAPIENTRY ilGetIntegerv(ILenum Mode, ILint *Param);
|
||||
-ILAPI ILuint ILAPIENTRY ilGetLumpPos(ILvoid);
|
||||
-ILAPI ILubyte* ILAPIENTRY ilGetPalette(ILvoid);
|
||||
+ILAPI void ILAPIENTRY ilGetIntegerv(ILenum Mode, ILint *Param);
|
||||
+ILAPI ILuint ILAPIENTRY ilGetLumpPos(void);
|
||||
+ILAPI ILubyte* ILAPIENTRY ilGetPalette(void);
|
||||
ILAPI const ILstring ILAPIENTRY ilGetString(ILenum StringName);
|
||||
-ILAPI ILvoid ILAPIENTRY ilHint(ILenum Target, ILenum Mode);
|
||||
-ILAPI ILvoid ILAPIENTRY ilInit(ILvoid);
|
||||
+ILAPI void ILAPIENTRY ilHint(ILenum Target, ILenum Mode);
|
||||
+ILAPI void ILAPIENTRY ilInit(void);
|
||||
ILAPI ILboolean ILAPIENTRY ilIsDisabled(ILenum Mode);
|
||||
ILAPI ILboolean ILAPIENTRY ilIsEnabled(ILenum Mode);
|
||||
ILAPI ILboolean ILAPIENTRY ilIsImage(ILuint Image);
|
||||
ILAPI ILboolean ILAPIENTRY ilIsValid(ILenum Type, const ILstring FileName);
|
||||
ILAPI ILboolean ILAPIENTRY ilIsValidF(ILenum Type, ILHANDLE File);
|
||||
-ILAPI ILboolean ILAPIENTRY ilIsValidL(ILenum Type, ILvoid *Lump, ILuint Size);
|
||||
-ILAPI ILvoid ILAPIENTRY ilKeyColour(ILclampf Red, ILclampf Green, ILclampf Blue, ILclampf Alpha);
|
||||
+ILAPI ILboolean ILAPIENTRY ilIsValidL(ILenum Type, void *Lump, ILuint Size);
|
||||
+ILAPI void ILAPIENTRY ilKeyColour(ILclampf Red, ILclampf Green, ILclampf Blue, ILclampf Alpha);
|
||||
ILAPI ILboolean ILAPIENTRY ilLoad(ILenum Type, const ILstring FileName);
|
||||
ILAPI ILboolean ILAPIENTRY ilLoadF(ILenum Type, ILHANDLE File);
|
||||
ILAPI ILboolean ILAPIENTRY ilLoadImage(const ILstring FileName);
|
||||
-ILAPI ILboolean ILAPIENTRY ilLoadL(ILenum Type, ILvoid *Lump, ILuint Size);
|
||||
+ILAPI ILboolean ILAPIENTRY ilLoadL(ILenum Type, void *Lump, ILuint Size);
|
||||
ILAPI ILboolean ILAPIENTRY ilLoadPal(const ILstring FileName);
|
||||
ILAPI ILboolean ILAPIENTRY ilOriginFunc(ILenum Mode);
|
||||
ILAPI ILboolean ILAPIENTRY ilOverlayImage(ILuint Source, ILint XCoord, ILint YCoord, ILint ZCoord);
|
||||
-ILAPI ILvoid ILAPIENTRY ilPopAttrib(ILvoid);
|
||||
-ILAPI ILvoid ILAPIENTRY ilPushAttrib(ILuint Bits);
|
||||
-ILAPI ILvoid ILAPIENTRY ilRegisterFormat(ILenum Format);
|
||||
+ILAPI void ILAPIENTRY ilPopAttrib(void);
|
||||
+ILAPI void ILAPIENTRY ilPushAttrib(ILuint Bits);
|
||||
+ILAPI void ILAPIENTRY ilRegisterFormat(ILenum Format);
|
||||
ILAPI ILboolean ILAPIENTRY ilRegisterLoad(const ILstring Ext, IL_LOADPROC Load);
|
||||
ILAPI ILboolean ILAPIENTRY ilRegisterMipNum(ILuint Num);
|
||||
ILAPI ILboolean ILAPIENTRY ilRegisterNumImages(ILuint Num);
|
||||
-ILAPI ILvoid ILAPIENTRY ilRegisterOrigin(ILenum Origin);
|
||||
-ILAPI ILvoid ILAPIENTRY ilRegisterPal(ILvoid *Pal, ILuint Size, ILenum Type);
|
||||
+ILAPI void ILAPIENTRY ilRegisterOrigin(ILenum Origin);
|
||||
+ILAPI void ILAPIENTRY ilRegisterPal(void *Pal, ILuint Size, ILenum Type);
|
||||
ILAPI ILboolean ILAPIENTRY ilRegisterSave(const ILstring Ext, IL_SAVEPROC Save);
|
||||
-ILAPI ILvoid ILAPIENTRY ilRegisterType(ILenum Type);
|
||||
+ILAPI void ILAPIENTRY ilRegisterType(ILenum Type);
|
||||
ILAPI ILboolean ILAPIENTRY ilRemoveLoad(const ILstring Ext);
|
||||
ILAPI ILboolean ILAPIENTRY ilRemoveSave(const ILstring Ext);
|
||||
-ILAPI ILvoid ILAPIENTRY ilResetMemory(ILvoid);
|
||||
-ILAPI ILvoid ILAPIENTRY ilResetRead(ILvoid);
|
||||
-ILAPI ILvoid ILAPIENTRY ilResetWrite(ILvoid);
|
||||
+ILAPI void ILAPIENTRY ilResetMemory(void);
|
||||
+ILAPI void ILAPIENTRY ilResetRead(void);
|
||||
+ILAPI void ILAPIENTRY ilResetWrite(void);
|
||||
ILAPI ILboolean ILAPIENTRY ilSave(ILenum Type, const ILstring FileName);
|
||||
ILAPI ILuint ILAPIENTRY ilSaveF(ILenum Type, ILHANDLE File);
|
||||
ILAPI ILboolean ILAPIENTRY ilSaveImage(const ILstring FileName);
|
||||
-ILAPI ILuint ILAPIENTRY ilSaveL(ILenum Type, ILvoid *Lump, ILuint Size);
|
||||
+ILAPI ILuint ILAPIENTRY ilSaveL(ILenum Type, void *Lump, ILuint Size);
|
||||
ILAPI ILboolean ILAPIENTRY ilSavePal(const ILstring FileName);
|
||||
-ILAPI ILboolean ILAPIENTRY ilSetData(ILvoid *Data);
|
||||
+ILAPI ILboolean ILAPIENTRY ilSetData(void *Data);
|
||||
ILAPI ILboolean ILAPIENTRY ilSetDuration(ILuint Duration);
|
||||
-ILAPI ILvoid ILAPIENTRY ilSetInteger(ILenum Mode, ILint Param);
|
||||
-ILAPI ILvoid ILAPIENTRY ilSetMemory(mAlloc, mFree);
|
||||
-ILAPI ILvoid ILAPIENTRY ilSetPixels(ILint XOff, ILint YOff, ILint ZOff, ILuint Width, ILuint Height, ILuint Depth, ILenum Format, ILenum Type, ILvoid *Data);
|
||||
-ILAPI ILvoid ILAPIENTRY ilSetRead(fOpenRProc, fCloseRProc, fEofProc, fGetcProc, fReadProc, fSeekRProc, fTellRProc);
|
||||
-ILAPI ILvoid ILAPIENTRY ilSetString(ILenum Mode, const char *String);
|
||||
-ILAPI ILvoid ILAPIENTRY ilSetWrite(fOpenWProc, fCloseWProc, fPutcProc, fSeekWProc, fTellWProc, fWriteProc);
|
||||
-ILAPI ILvoid ILAPIENTRY ilShutDown(ILvoid);
|
||||
-ILAPI ILboolean ILAPIENTRY ilTexImage(ILuint Width, ILuint Height, ILuint Depth, ILubyte Bpp, ILenum Format, ILenum Type, ILvoid *Data);
|
||||
+ILAPI void ILAPIENTRY ilSetInteger(ILenum Mode, ILint Param);
|
||||
+ILAPI void ILAPIENTRY ilSetMemory(mAlloc, mFree);
|
||||
+ILAPI void ILAPIENTRY ilSetPixels(ILint XOff, ILint YOff, ILint ZOff, ILuint Width, ILuint Height, ILuint Depth, ILenum Format, ILenum Type, void *Data);
|
||||
+ILAPI void ILAPIENTRY ilSetRead(fOpenRProc, fCloseRProc, fEofProc, fGetcProc, fReadProc, fSeekRProc, fTellRProc);
|
||||
+ILAPI void ILAPIENTRY ilSetString(ILenum Mode, const char *String);
|
||||
+ILAPI void ILAPIENTRY ilSetWrite(fOpenWProc, fCloseWProc, fPutcProc, fSeekWProc, fTellWProc, fWriteProc);
|
||||
+ILAPI void ILAPIENTRY ilShutDown(void);
|
||||
+ILAPI ILboolean ILAPIENTRY ilTexImage(ILuint Width, ILuint Height, ILuint Depth, ILubyte Bpp, ILenum Format, ILenum Type, void *Data);
|
||||
ILAPI ILboolean ILAPIENTRY ilTypeFunc(ILenum Mode);
|
||||
|
||||
ILAPI ILboolean ILAPIENTRY ilLoadData(const ILstring FileName, ILuint Width, ILuint Height, ILuint Depth, ILubyte Bpp);
|
||||
ILAPI ILboolean ILAPIENTRY ilLoadDataF(ILHANDLE File, ILuint Width, ILuint Height, ILuint Depth, ILubyte Bpp);
|
||||
-ILAPI ILboolean ILAPIENTRY ilLoadDataL(ILvoid *Lump, ILuint Size, ILuint Width, ILuint Height, ILuint Depth, ILubyte Bpp);
|
||||
+ILAPI ILboolean ILAPIENTRY ilLoadDataL(void *Lump, ILuint Size, ILuint Width, ILuint Height, ILuint Depth, ILubyte Bpp);
|
||||
ILAPI ILboolean ILAPIENTRY ilSaveData(const ILstring FileName);
|
||||
|
||||
-ILAPI ILboolean ILAPIENTRY ilLoadFromJpegStruct(ILvoid* JpegDecompressorPtr);
|
||||
-ILAPI ILboolean ILAPIENTRY ilSaveFromJpegStruct(ILvoid* JpegCompressorPtr);
|
||||
+ILAPI ILboolean ILAPIENTRY ilLoadFromJpegStruct(void* JpegDecompressorPtr);
|
||||
+ILAPI ILboolean ILAPIENTRY ilSaveFromJpegStruct(void* JpegCompressorPtr);
|
||||
|
||||
// For all those weirdos that spell "colour" without the 'u'.
|
||||
#define ilClearColor ilClearColour
|
72
graphics/devil/files/patch-include-IL_ilu.h
Normal file
72
graphics/devil/files/patch-include-IL_ilu.h
Normal file
|
@ -0,0 +1,72 @@
|
|||
--- include/IL/ilu.h.orig 2007-09-17 17:42:11.000000000 +0200
|
||||
+++ include/IL/ilu.h 2007-09-17 17:43:47.000000000 +0200
|
||||
@@ -132,40 +132,40 @@
|
||||
|
||||
|
||||
// ImageLib Utility Functions
|
||||
-ILAPI ILboolean ILAPIENTRY iluAlienify(ILvoid);
|
||||
+ILAPI ILboolean ILAPIENTRY iluAlienify(void);
|
||||
ILAPI ILboolean ILAPIENTRY iluBlurAvg(ILuint Iter);
|
||||
ILAPI ILboolean ILAPIENTRY iluBlurGaussian(ILuint Iter);
|
||||
-ILAPI ILboolean ILAPIENTRY iluBuildMipmaps(ILvoid);
|
||||
-ILAPI ILuint ILAPIENTRY iluColoursUsed(ILvoid);
|
||||
+ILAPI ILboolean ILAPIENTRY iluBuildMipmaps(void);
|
||||
+ILAPI ILuint ILAPIENTRY iluColoursUsed(void);
|
||||
ILAPI ILboolean ILAPIENTRY iluCompareImage(ILuint Comp);
|
||||
ILAPI ILboolean ILAPIENTRY iluContrast(ILfloat Contrast);
|
||||
ILAPI ILboolean ILAPIENTRY iluCrop(ILuint XOff, ILuint YOff, ILuint ZOff, ILuint Width, ILuint Height, ILuint Depth);
|
||||
-ILAPI ILvoid ILAPIENTRY iluDeleteImage(ILuint Id);
|
||||
-ILAPI ILboolean ILAPIENTRY iluEdgeDetectE(ILvoid);
|
||||
-ILAPI ILboolean ILAPIENTRY iluEdgeDetectP(ILvoid);
|
||||
-ILAPI ILboolean ILAPIENTRY iluEdgeDetectS(ILvoid);
|
||||
-ILAPI ILboolean ILAPIENTRY iluEmboss(ILvoid);
|
||||
+ILAPI void ILAPIENTRY iluDeleteImage(ILuint Id);
|
||||
+ILAPI ILboolean ILAPIENTRY iluEdgeDetectE(void);
|
||||
+ILAPI ILboolean ILAPIENTRY iluEdgeDetectP(void);
|
||||
+ILAPI ILboolean ILAPIENTRY iluEdgeDetectS(void);
|
||||
+ILAPI ILboolean ILAPIENTRY iluEmboss(void);
|
||||
ILAPI ILboolean ILAPIENTRY iluEnlargeCanvas(ILuint Width, ILuint Height, ILuint Depth);
|
||||
ILAPI ILboolean ILAPIENTRY iluEnlargeImage(ILfloat XDim, ILfloat YDim, ILfloat ZDim);
|
||||
-ILAPI ILboolean ILAPIENTRY iluEqualize(ILvoid);
|
||||
+ILAPI ILboolean ILAPIENTRY iluEqualize(void);
|
||||
ILAPI const ILstring ILAPIENTRY iluErrorString(ILenum Error);
|
||||
-ILAPI ILboolean ILAPIENTRY iluFlipImage(ILvoid);
|
||||
+ILAPI ILboolean ILAPIENTRY iluFlipImage(void);
|
||||
ILAPI ILboolean ILAPIENTRY iluGammaCorrect(ILfloat Gamma);
|
||||
-ILAPI ILuint ILAPIENTRY iluGenImage(ILvoid);
|
||||
-ILAPI ILvoid ILAPIENTRY iluGetImageInfo(ILinfo *Info);
|
||||
+ILAPI ILuint ILAPIENTRY iluGenImage(void);
|
||||
+ILAPI void ILAPIENTRY iluGetImageInfo(ILinfo *Info);
|
||||
ILAPI ILint ILAPIENTRY iluGetInteger(ILenum Mode);
|
||||
-ILAPI ILvoid ILAPIENTRY iluGetIntegerv(ILenum Mode, ILint *Param);
|
||||
+ILAPI void ILAPIENTRY iluGetIntegerv(ILenum Mode, ILint *Param);
|
||||
ILAPI const ILstring ILAPIENTRY iluGetString(ILenum StringName);
|
||||
-ILAPI ILvoid ILAPIENTRY iluImageParameter(ILenum PName, ILenum Param);
|
||||
-ILAPI ILvoid ILAPIENTRY iluInit(ILvoid);
|
||||
-ILAPI ILboolean ILAPIENTRY iluInvertAlpha(ILvoid);
|
||||
+ILAPI void ILAPIENTRY iluImageParameter(ILenum PName, ILenum Param);
|
||||
+ILAPI void ILAPIENTRY iluInit(void);
|
||||
+ILAPI ILboolean ILAPIENTRY iluInvertAlpha(void);
|
||||
ILAPI ILuint ILAPIENTRY iluLoadImage(const ILstring FileName);
|
||||
-ILAPI ILboolean ILAPIENTRY iluMirror(ILvoid);
|
||||
-ILAPI ILboolean ILAPIENTRY iluNegative(ILvoid);
|
||||
+ILAPI ILboolean ILAPIENTRY iluMirror(void);
|
||||
+ILAPI ILboolean ILAPIENTRY iluNegative(void);
|
||||
ILAPI ILboolean ILAPIENTRY iluNoisify(ILclampf Tolerance);
|
||||
ILAPI ILboolean ILAPIENTRY iluPixelize(ILuint PixSize);
|
||||
-ILAPI ILvoid ILAPIENTRY iluRegionfv(ILpointf *Points, ILuint n);
|
||||
-ILAPI ILvoid ILAPIENTRY iluRegioniv(ILpointi *Points, ILuint n);
|
||||
+ILAPI void ILAPIENTRY iluRegionfv(ILpointf *Points, ILuint n);
|
||||
+ILAPI void ILAPIENTRY iluRegioniv(ILpointi *Points, ILuint n);
|
||||
ILAPI ILboolean ILAPIENTRY iluReplaceColour(ILubyte Red, ILubyte Green, ILubyte Blue, ILfloat Tolerance);
|
||||
ILAPI ILboolean ILAPIENTRY iluRotate(ILfloat Angle);
|
||||
ILAPI ILboolean ILAPIENTRY iluRotate3D(ILfloat x, ILfloat y, ILfloat z, ILfloat Angle);
|
||||
@@ -174,7 +174,7 @@
|
||||
ILAPI ILboolean ILAPIENTRY iluScale(ILuint Width, ILuint Height, ILuint Depth);
|
||||
ILAPI ILboolean ILAPIENTRY iluScaleColours(ILfloat r, ILfloat g, ILfloat b);
|
||||
ILAPI ILboolean ILAPIENTRY iluSharpen(ILfloat Factor, ILuint Iter);
|
||||
-ILAPI ILboolean ILAPIENTRY iluSwapColours(ILvoid);
|
||||
+ILAPI ILboolean ILAPIENTRY iluSwapColours(void);
|
||||
ILAPI ILboolean ILAPIENTRY iluWave(ILfloat Angle);
|
||||
|
||||
#define iluColorsUsed iluColoursUsed
|
11
graphics/devil/files/patch-src-IL-src-Makefile.in
Normal file
11
graphics/devil/files/patch-src-IL-src-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src-IL/src/Makefile.in.orig Tue Jan 10 16:09:29 2006
|
||||
+++ src-IL/src/Makefile.in Tue Jan 10 16:09:45 2006
|
||||
@@ -312,7 +312,7 @@
|
||||
|
||||
AM_CFLAGS = @LIBIL_CFLAGS@
|
||||
libIL_la_LDFLAGS = -no-undefined @VERSIONINFO@
|
||||
-libIL_la_LIBADD = @LIBPNG@ @LIBJPG@ @LIBTIFF@ @LIBGIF@ @LIBMNG@ @LIBLCMS@
|
||||
+libIL_la_LIBADD = @LIBPNG@ @LIBJPG@ @LIBTIFF@ @LIBMNG@ @LIBLCMS@
|
||||
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src-IL/include
|
||||
all: all-am
|
||||
|
18
graphics/devil/files/patch-src-IL-src-il_png.c
Normal file
18
graphics/devil/files/patch-src-IL-src-il_png.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- src-IL/src/il_png.c.orig Thu Jun 24 11:38:54 2004
|
||||
+++ src-IL/src/il_png.c Wed Oct 5 22:44:17 2005
|
||||
@@ -282,11 +282,11 @@
|
||||
|
||||
ILboolean readpng_get_image(ILdouble display_exponent)
|
||||
{
|
||||
- ILuint i;
|
||||
png_bytepp row_pointers = NULL;
|
||||
- ILuint width, height, channels;
|
||||
- ILdouble screen_gamma = 1.0, image_gamma;
|
||||
- ILuint bit_depth;
|
||||
+ png_uint_32 width, height;
|
||||
+ ILuint i, channels, bit_depth;
|
||||
+ ILdouble screen_gamma = 1.0, image_gamma;
|
||||
+
|
||||
|
||||
|
||||
/* setjmp() must be called in every function that calls a PNG-reading
|
|
@ -1,10 +1,3 @@
|
|||
include/IL/config.h
|
||||
include/IL/devil_internal_exports.h
|
||||
include/IL/il.h
|
||||
include/IL/il_wrap.h
|
||||
include/IL/ilu.h
|
||||
include/IL/ilu_region.h
|
||||
include/IL/ilut.h
|
||||
lib/libIL.a
|
||||
lib/libIL.la
|
||||
lib/libIL.so
|
||||
|
@ -17,4 +10,11 @@ lib/libILUT.a
|
|||
lib/libILUT.la
|
||||
lib/libILUT.so
|
||||
lib/libILUT.so.1
|
||||
include/IL/il.h
|
||||
include/IL/ilu.h
|
||||
include/IL/ilut.h
|
||||
include/IL/il_wrap.h
|
||||
include/IL/config.h
|
||||
include/IL/devil_internal_exports.h
|
||||
include/IL/ilu_region.h
|
||||
@dirrm include/IL
|
||||
|
|
Loading…
Reference in a new issue