Approved by:	portmgr (blanket approval)
This commit is contained in:
Vanilla I. Shu 2014-06-24 03:59:16 +00:00
parent 62eae3dbd3
commit 25688aefa3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=359034
2 changed files with 14 additions and 4 deletions

View file

@ -10,9 +10,6 @@ MASTER_SITES= http://www.spinellis.gr/sw/unix/socketpipe/ \
MAINTAINER= dds@FreeBSD.org
COMMENT= Zero overhead remote process plumbing
MAN1= socketpipe.1
MANCOMPRESSED= yes
PLIST_FILES= bin/socketpipe
PLIST_FILES= bin/socketpipe man/man1/socketpipe.1.gz
NO_STAGE= yes
.include <bsd.port.mk>

View file

@ -0,0 +1,13 @@
--- Makefile.orig 2014-06-24 11:56:55.409948485 +0800
+++ Makefile 2014-06-24 11:57:17.105948669 +0800
@@ -8,8 +8,8 @@ $(NAME): $(NAME).c
$(CC) $(CFLAGS) -o $@ $?
install: $(NAME)
- $(INSTALL) -s $(NAME) $(PREFIX)/bin
- gzip -c $(NAME).1 >$(PREFIX)/man/man1/$(NAME).1.gz
+ $(INSTALL) -s $(NAME) $(DESTDIR)$(PREFIX)/bin
+ gzip -c $(NAME).1 > $(DESTDIR)$(PREFIX)/man/man1/$(NAME).1.gz
socketpipe.exe: socketpipe-win.c
cl -o socketpipe.exe -W3 -Ox socketpipe-win.c mswsock.lib Ws2_32.lib Kernel32.lib