Update to 0.7.4.
Submitted by: maintainer
This commit is contained in:
parent
fe7d25ef48
commit
259327933b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48407
6 changed files with 65 additions and 32 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= modlogan
|
||||
PORTVERSION= 0.7.2
|
||||
PORTVERSION= 0.7.4
|
||||
CATEGORIES= textproc www
|
||||
MASTER_SITES= http://www.kneschke.de/projekte/modlogan/download/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
|
@ -47,7 +47,7 @@ DOC1= faq.txt glosar manual.txt plugin-options.txt \
|
|||
using-plugins.txt writing-plugins.txt
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's:\@sysconfdir\@:${PREFIX}/etc/modlogan:g' ${WRKSRC}/doc/modlogan.conf-dist
|
||||
@${PERL} -pi -e 's:\@sysconfdir\@:${PREFIX}/etc/modlogan:g' ${WRKSRC}/doc/modlogan.conf-dist.in
|
||||
|
||||
post-configure:
|
||||
${TOUCH} ${WRKSRC}/libltdl/config.status
|
||||
|
@ -60,7 +60,7 @@ post-install:
|
|||
.endfor
|
||||
.endif
|
||||
${MKDIR} ${PREFIX}/share/examples/modlogan
|
||||
.for i in footer.ihtml header.ihtml convert_to_055.pl convert_to_060.pl
|
||||
.for i in footer.ihtml header.ihtml convert_history_to_07x.pl convert_to_055.pl convert_to_060.pl
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/examples/modlogan/${i}
|
||||
.endfor
|
||||
@# remove .la (can't use USE_LIBTOOL)
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (modlogan-0.7.2.tar.gz) = 6e40dac4df582439f40e4431b2848338
|
||||
MD5 (modlogan-0.7.4.tar.gz) = 74d481b225a45bf7e1a3816ffa987395
|
||||
|
|
|
@ -1,13 +1,5 @@
|
|||
--- configure.orig Wed Sep 5 16:56:33 2001
|
||||
+++ configure Thu Sep 6 14:00:42 2001
|
||||
@@ -260,7 +260,6 @@
|
||||
: ${ac_max_here_lines=38}
|
||||
|
||||
ac_unique_file="src/main.c"
|
||||
-ac_subdirs_all="$ac_subdirs_all libltdl"
|
||||
# Factoring default headers for most tests.
|
||||
ac_includes_default="\
|
||||
#include <stdio.h>
|
||||
@@ -7610,6 +7609,9 @@
|
||||
# PORTME does your system automatically load deplibs for dlopen()?
|
||||
libltdl_cv_sys_dlopen_deplibs=unknown
|
||||
|
@ -18,15 +10,6 @@
|
|||
linux*)
|
||||
libltdl_cv_sys_dlopen_deplibs=yes
|
||||
;;
|
||||
@@ -11850,7 +11852,7 @@
|
||||
|
||||
CFLAGS="${ac_save_CFLAGS}" # don't use CFLAGS from libtool
|
||||
|
||||
-subdirs="$subdirs libltdl"
|
||||
+subdirs="$subdirs"
|
||||
|
||||
echo "$as_me:11855: checking for dmalloc.h" >&5
|
||||
echo $ECHO_N "checking for dmalloc.h... $ECHO_C" >&6
|
||||
@@ -14476,7 +14478,9 @@
|
||||
if test "$gt_cv_func_gettext_libintl" = "yes"; then
|
||||
INTLLIBS='-lintl'
|
||||
|
|
57
textproc/modlogan/files/patch-fix_segfault
Normal file
57
textproc/modlogan/files/patch-fix_segfault
Normal file
|
@ -0,0 +1,57 @@
|
|||
Index: mconfig.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/modlogan/modlogan/src/mconfig.c,v
|
||||
retrieving revision 1.40
|
||||
diff -c -r1.40 mconfig.c
|
||||
*** src/mconfig.c 2001/09/23 22:54:00 1.40
|
||||
--- src/mconfig.c 2001/09/24 09:29:37
|
||||
***************
|
||||
*** 665,670 ****
|
||||
--- 665,672 ----
|
||||
int mconfig_free(mconfig *conf) {
|
||||
if (!conf) return -1;
|
||||
|
||||
+ mplugins_free(conf);
|
||||
+
|
||||
if (conf->outputdir) free(conf->outputdir);
|
||||
|
||||
#ifdef HAVE_LIBADNS
|
||||
***************
|
||||
*** 672,678 ****
|
||||
if (conf->adns) free(conf->adns);
|
||||
if (conf->query_hash) mhash_free(conf->query_hash);
|
||||
#endif
|
||||
- mplugins_free(conf);
|
||||
mlist_free(conf->loadplugins);
|
||||
mlist_free(conf->includepath);
|
||||
|
||||
--- 674,679 ----
|
||||
Index: misc.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/modlogan/modlogan/src/misc.c,v
|
||||
retrieving revision 1.13
|
||||
diff -c -r1.13 misc.c
|
||||
*** src/misc.c 2001/09/04 22:47:23 1.13
|
||||
--- src/misc.c 2001/09/24 09:29:37
|
||||
***************
|
||||
*** 278,283 ****
|
||||
--- 278,285 ----
|
||||
/* x and y denote the position in source respective destination string */
|
||||
register int x, y;
|
||||
unsigned char *str;
|
||||
+
|
||||
+ if (!s) return NULL;
|
||||
|
||||
/* allocate memory for encoded string */
|
||||
str = (unsigned char *) malloc(3 * strlen(s) + 1);
|
||||
***************
|
||||
*** 307,312 ****
|
||||
--- 309,316 ----
|
||||
/* work pointers */
|
||||
unsigned char *data;
|
||||
unsigned char *dest;
|
||||
+
|
||||
+ if (!s) return NULL;
|
||||
|
||||
/* allocate memory for decoded string */
|
||||
str = (unsigned char *) malloc(strlen(s) + 1);
|
|
@ -1,11 +0,0 @@
|
|||
--- libltdl/Makefile.in.orig Sat Sep 15 19:24:49 2001
|
||||
+++ libltdl/Makefile.in Sun Sep 16 11:27:00 2001
|
||||
@@ -83,7 +83,7 @@
|
||||
|
||||
AUTOMAKE_OPTIONS = no-dependencies foreign
|
||||
|
||||
-mkinstalldirs = $(SHELL) $(top_srcdir)/../mkinstalldirs
|
||||
+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
|
||||
@INSTALL_LTDL_TRUE@include_HEADERS = ltdl.h
|
||||
@INSTALL_LTDL_TRUE@lib_LTLIBRARIES = libltdl.la
|
|
@ -66,6 +66,7 @@ lib/libmla_processor_web.so
|
|||
%%PORTDOCS%%share/doc/modlogan/plugin-options.txt
|
||||
%%PORTDOCS%%share/doc/modlogan/using-plugins.txt
|
||||
%%PORTDOCS%%share/doc/modlogan/writing-plugins.txt
|
||||
share/examples/modlogan/convert_history_to_07x.pl
|
||||
share/examples/modlogan/convert_to_055.pl
|
||||
share/examples/modlogan/convert_to_060.pl
|
||||
share/examples/modlogan/footer.ihtml
|
||||
|
@ -73,6 +74,7 @@ share/examples/modlogan/header.ihtml
|
|||
share/locale/cs/LC_MESSAGES/modlogan.mo
|
||||
share/locale/de/LC_MESSAGES/modlogan.mo
|
||||
share/locale/es/LC_MESSAGES/modlogan.mo
|
||||
share/locale/fr/LC_MESSAGES/modlogan.mo
|
||||
share/locale/it/LC_MESSAGES/modlogan.mo
|
||||
@dirrm share/doc/modlogan
|
||||
@dirrm share/examples/modlogan
|
||||
|
@ -80,6 +82,8 @@ share/locale/it/LC_MESSAGES/modlogan.mo
|
|||
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/de 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/fr 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/es 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
|
||||
|
|
Loading…
Reference in a new issue