devel/py-robotframework-ride: update to 1.7.3.1

PR:		238867
Submitted by:	vladimir.chukharev@gmail.com (maintainer)
This commit is contained in:
Steve Wills 2019-06-30 21:52:10 +00:00
parent 15f7ec5caf
commit 25a30f747c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=505514
4 changed files with 54 additions and 10 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= robotframework-ride
PORTVERSION= 1.5.2.1
PORTREVISION= 1
PORTVERSION= 1.7.3.1
CATEGORIES= devel www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -13,16 +12,17 @@ COMMENT= Test data editor for Robot Framework
LICENSE= APACHE20
BROKEN= Not compatible with wxWidgets 3.0 or later
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}robotframework>=2.7.5:devel/py-robotframework@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}robotframework-seleniumlibrary>=1.1.0:devel/py-robotframework-seleniumlibrary@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments@${PY_FLAVOR}
NO_ARCH= yes
USES= python:-2.7
USES= dos2unix python:2.7 zip
# py36 needs WX 4.0.4 wich is not ported yet
USE_PYTHON= autoplist distutils
USE_WX= 3.0+
WX_COMPS= python:run
DOS2UNIX_GLOB= *.py PKG-INFO settings.cfg MANIFEST.in
NO_ARCH= yes
WX_COMPS= wx python
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1526112371
SHA256 (robotframework-ride-1.5.2.1.tar.gz) = 50c929f2629b0e86fc39d45887061df784a4ac9df39ccfcb87660c49897d1862
SIZE (robotframework-ride-1.5.2.1.tar.gz) = 576271
TIMESTAMP = 1561701714
SHA256 (robotframework-ride-1.7.3.1.zip) = f0c15a278be5084c99c1df3ba8d4ebc73e7f5ec95846a186cace6ee1e21d4caf
SIZE (robotframework-ride-1.7.3.1.zip) = 1054823

View file

@ -0,0 +1,29 @@
--- setup.py.orig 2019-06-28 07:27:57 UTC
+++ setup.py
@@ -47,8 +47,8 @@ Programming Language :: Python
Topic :: Software Development :: Testing
""".strip().splitlines()
-with open(join(ROOT_DIR, 'requirements.txt')) as f:
- REQUIREMENTS = f.read().splitlines()
+#with open(join(ROOT_DIR, 'requirements.txt')) as f:
+# REQUIREMENTS = f.read().splitlines()
# This solution is found at http://stackoverflow.com/a/26490820/5889853
from setuptools.command.install import install
@@ -75,7 +75,7 @@ setup(
author_email='robotframework@gmail.com',
url='https://github.com/robotframework/RIDE/',
download_url='https://pypi.python.org/pypi/robotframework-ride',
- install_requires = REQUIREMENTS,
+# install_requires = REQUIREMENTS,
package_dir={'': SOURCE_DIR},
packages=find_packages(SOURCE_DIR),
package_data=package_data,
@@ -84,5 +84,5 @@ setup(
options={'install': {'force': True}},
scripts=['src/bin/ride.py', 'src/bin/ride_postinstall.py'],
cmdclass={'install': CustomInstallCommand},
- requires=['Pygments', 'wxPython', 'PyPubSub']
+ requires=['Pygments', 'wxPython']
)

View file

@ -0,0 +1,15 @@
--- src/robotide/publish/publisher.py.orig 2019-06-28 07:27:57 UTC
+++ src/robotide/publish/publisher.py
@@ -18,10 +18,10 @@ if PY3:
from robotide.utils import basestring, unicode
try:
- from pubsub import Publisher
+ from wx.lib.pubsub import Publisher
WxPublisher = Publisher()
except ImportError:
- from pubsub import pub
+ from wx.lib.pubsub import pub
WxPublisher = pub.getDefaultPublisher()