multimedia/obs-v4l2sink: Remove: obs-studio-28.1.2 now contains same functionality

This commit is contained in:
Yuri Victorovich 2022-12-29 13:54:33 -08:00
parent fab1af0bc9
commit 25a5061f72
6 changed files with 1 additions and 49 deletions

1
MOVED
View file

@ -17706,3 +17706,4 @@ audio/ardour6|audio/ardour|2022-12-26|Remove major version from portname as we u
multimedia/obs-transition-matrix||2022-12-29|Removed: not compatible with obs-studio-28.1.2
multimedia/obs-websocket||2022-12-29|Removed: included in obs-studio-28.1.2
multimedia/obs-ndi||2022-12-29|Removed: it depends on a closed commercial library
multimedia/obs-v4l2sink||2022-12-29|Removed: obs-studio-28.1.2 now contains same functionality

View file

@ -265,7 +265,6 @@
SUBDIR += obs-scrab
SUBDIR += obs-streamfx
SUBDIR += obs-studio
SUBDIR += obs-v4l2sink
SUBDIR += obs-waveform
SUBDIR += oggvideotools
SUBDIR += ogmrip

View file

@ -1,28 +0,0 @@
PORTNAME= obs-v4l2sink
DISTVERSION= 0.1.0-12
DISTVERSIONSUFFIX= -g1ec3c8a
CATEGORIES= multimedia
MAINTAINER= yuri@FreeBSD.org
COMMENT= OBS Studio Plugin: Output as Video4Linux2 device
WWW= https://github.com/CatxFish/obs-v4l2sink
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= v4l_compat>0:multimedia/v4l_compat
LIB_DEPENDS= libobs.so:multimedia/obs-studio
USES= cmake compiler:c++11-lang qt:5
USE_GITHUB= yes
GH_ACCOUNT= CatxFish
USE_QT= core gui widgets buildtools:build qmake:build
CMAKE_ARGS= -DLIBOBS_INCLUDE_DIR=${LOCALBASE}/include/obs
PLIST_FILES= lib/obs-plugins/v4l2sink.so \
share/obs/obs-plugins/v4l2sink/locale/de-DE.ini \
share/obs/obs-plugins/v4l2sink/locale/en-US.ini \
share/obs/obs-plugins/v4l2sink/locale/zh-TW.ini
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1586128495
SHA256 (CatxFish-obs-v4l2sink-0.1.0-12-g1ec3c8a_GH0.tar.gz) = 5ba383c28b8b366489e56b231a66e3ef64629e3fdd9f92895ab8dd512df3b467
SIZE (CatxFish-obs-v4l2sink-0.1.0-12-g1ec3c8a_GH0.tar.gz) = 21399

View file

@ -1,11 +0,0 @@
--- external/FindLibObs.cmake.orig 2020-04-05 23:16:36 UTC
+++ external/FindLibObs.cmake
@@ -95,7 +95,7 @@ if(LIBOBS_FOUND)
set(LIBOBS_INCLUDE_DIRS ${LIBOBS_INCLUDE_DIR} ${W32_PTHREADS_INCLUDE_DIR})
set(LIBOBS_LIBRARIES ${LIBOBS_LIB} ${W32_PTHREADS_LIB})
- include(${LIBOBS_INCLUDE_DIR}/../cmake/external/ObsPluginHelpers.cmake)
+ include(${CMAKE_INSTALL_PREFIX}/lib/cmake/ObsPluginHelpers.cmake)
# allows external plugins to easily use/share common dependencies that are often included with libobs (such as FFmpeg)
if(NOT DEFINED INCLUDED_LIBOBS_CMAKE_MODULES)

View file

@ -1,6 +0,0 @@
An OBS Studio plugin that provides output capabilities to a Video4Linux2 device.
It is basically a Linux version of obs-virtual-cam, but only contains the video
sink part. You can use it with v4l2loopback to achieve cross-program video
transfer between OBS Studio and third party software supporting Video4Linux2,
e.g. to present an OBS session in proprietary browser-based conferencing systems
by selecting the OBS session as a webcam.