- Fix build with gcc 4.2
- Pass maintainership to submitter PR: 118464 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (erwin)
This commit is contained in:
parent
575b87ed27
commit
25c606a18d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202936
3 changed files with 74 additions and 9 deletions
|
@ -12,7 +12,7 @@ CATEGORIES= audio net
|
|||
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= gahr@gahr.ch
|
||||
COMMENT= A program for finding and playing free music from the Internet
|
||||
|
||||
LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
|
||||
|
@ -29,17 +29,13 @@ USE_AUTOTOOLS= libtool:15
|
|||
USE_LDCONFIG= yes
|
||||
LIBTOOLFLAGS= --tag=CXX
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Broken with gcc 4.2
|
||||
.endif
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|CCLD = $$(CC)|CCLD = $$(CXX)|; \
|
||||
s|-lpthread|${PTHREAD_LIBS}|' \
|
||||
${WRKSRC}/roboradio/mp3/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|static char|static const char|' \
|
||||
${WRKSRC}/gnomoradio/*.xpm
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
audio/gnomoradio/files/patch-gnomoradio_browser-link.cc
Normal file
11
audio/gnomoradio/files/patch-gnomoradio_browser-link.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- gnomoradio/browser-link.cc.orig 2007-12-06 15:46:11.000000000 +0100
|
||||
+++ gnomoradio/browser-link.cc 2007-12-06 15:48:02.000000000 +0100
|
||||
@@ -32,7 +32,7 @@
|
||||
{
|
||||
gchar *my_url = g_strdup(Glib::locale_from_utf8(url).c_str());
|
||||
if (fork() == 0) {
|
||||
- char *const argv[] = {"gnome-moz-remote", "--newwin", my_url, 0};
|
||||
+ char *const argv[] = {(char *)"gnome-moz-remote", (char *)"--newwin", my_url, 0};
|
||||
execvp(argv[0], argv);
|
||||
|
||||
// if we made it here something went wrong
|
58
audio/gnomoradio/files/patch-roboradio-audio_prober.cc
Normal file
58
audio/gnomoradio/files/patch-roboradio-audio_prober.cc
Normal file
|
@ -0,0 +1,58 @@
|
|||
--- roboradio/audio/prober.cc.orig 2007-12-06 15:39:58.000000000 +0100
|
||||
+++ roboradio/audio/prober.cc 2007-12-06 15:40:19.000000000 +0100
|
||||
@@ -21,6 +21,30 @@
|
||||
#include "../mp3/esd-audio.h"
|
||||
}
|
||||
|
||||
+namespace Roboradio
|
||||
+{
|
||||
+ namespace Audio
|
||||
+ {
|
||||
+ gboolean probe (gpointer s)
|
||||
+ {
|
||||
+ Prober *sng = static_cast<Prober*>(s);
|
||||
+ if (esdout_playing()) {
|
||||
+ int pos = sng->get_position();
|
||||
+ if (pos >= 0)
|
||||
+ sng->signal_position_changed(pos);
|
||||
+ return true;
|
||||
+ } else if (sng->get_position() >= 0) {
|
||||
+ return true;
|
||||
+ } else {
|
||||
+ sng->stop();
|
||||
+ sng->signal_done();
|
||||
+ sng->activated = false;
|
||||
+ return false;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
Roboradio::Audio::Prober::Prober ()
|
||||
: activated(false)
|
||||
{
|
||||
@@ -31,24 +55,6 @@
|
||||
stop_prober();
|
||||
}
|
||||
|
||||
-gboolean Roboradio::Audio::probe (gpointer s)
|
||||
-{
|
||||
- Prober *sng = static_cast<Prober*>(s);
|
||||
- if (esdout_playing()) {
|
||||
- int pos = sng->get_position();
|
||||
- if (pos >= 0)
|
||||
- sng->signal_position_changed(pos);
|
||||
- return true;
|
||||
- } else if (sng->get_position() >= 0) {
|
||||
- return true;
|
||||
- } else {
|
||||
- sng->stop();
|
||||
- sng->signal_done();
|
||||
- sng->activated = false;
|
||||
- return false;
|
||||
- }
|
||||
-}
|
||||
-
|
||||
void Roboradio::Audio::Prober::start_prober ()
|
||||
{
|
||||
if (activated)
|
Loading…
Reference in a new issue