audio/drumstick: Update 1.1.1 -> 1.1.2

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2018-11-26 06:02:26 +00:00
parent 60ba5d1af8
commit 25f7e84943
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=485918
4 changed files with 13 additions and 33 deletions

View file

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= drumstick
DISTVERSION= 1.1.1
PORTREVISION= 1
DISTVERSION= 1.1.2
CATEGORIES= audio multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1519663446
SHA256 (drumstick-1.1.1.tar.bz2) = 367743764c8f5c6e40bb19b9581f083da2881b9c9516d6b3b247e5644dee7c2b
SIZE (drumstick-1.1.1.tar.bz2) = 1011275
TIMESTAMP = 1543211012
SHA256 (drumstick-1.1.2.tar.bz2) = 7791b439aab9a5c24a53cbf5ce9ab1dcaf40a33a9d8828ca1731e823b1c7924e
SIZE (drumstick-1.1.2.tar.bz2) = 1012371

View file

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2018-02-24 20:04:23 UTC
--- CMakeLists.txt.orig 2018-11-25 16:14:19 UTC
+++ CMakeLists.txt
@@ -22,7 +22,7 @@ endif()
@@ -25,7 +25,7 @@ endif()
project(DRUMSTICK)
if(CMAKE_SIZEOF_VOID_P MATCHES "8")
@ -9,14 +9,7 @@
else()
set(_INIT_LIB_SUFFIX "")
endif()
@@ -63,13 +63,13 @@ add_definitions(-DVERSION=${VERSION})
message(STATUS "drumstick ${VERSION} prefix: ${CMAKE_INSTALL_PREFIX}")
set(_DBUS_INIT OFF)
-if(${CMAKE_SYSTEM} MATCHES "Linux")
+if(${CMAKE_SYSTEM} MATCHES "Linux|FreeBSD")
set(_DBUS_INIT ON)
endif()
@@ -72,7 +72,7 @@ set(_DBUS_INIT OFF)
# User options
option(STATIC_DRUMSTICK "Build static libraries instead of dynamic" OFF)
@ -25,7 +18,7 @@
message(STATUS "Build configuration: ${CMAKE_BUILD_TYPE}")
@@ -97,8 +97,8 @@ else()
@@ -100,8 +100,8 @@ else()
message(FATAL_ERROR "Program pkg-config not found")
endif()
@ -36,19 +29,18 @@
if(ALSA_FOUND)
set(ALSA_LIBS ${ALSA_LIBRARIES})
list(APPEND ALSA_LIB_DIR ${ALSA_LIBRARY_DIRS} ${ALSA_LIBDIR})
@@ -107,7 +107,10 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
message(STATUS "Warning: ALSA library not found.")
@@ -111,7 +111,9 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
endif()
endif()
-pkg_check_modules(PULSE libpulse-simple)
+#pkg_check_modules(PULSE libpulse-simple)
+if (USE_PULSEAUDIO)
+ pkg_check_modules(PULSE libpulse-simple)
+endif()
if(NOT PULSE_FOUND)
message(STATUS "Warning: PulseAudio library not found.")
endif()
@@ -126,7 +129,7 @@ if(BUILD_TESTING)
@@ -134,7 +136,7 @@ if(BUILD_TESTING)
add_subdirectory(tests)
endif()
@ -57,7 +49,7 @@
find_package(Doxygen)
if(DOXYGEN_FOUND)
configure_file(
@@ -137,12 +140,14 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
@@ -145,12 +147,14 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
${DOXYGEN} Doxyfile
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
endif()
@ -77,7 +69,7 @@
# XML mime types
set( SHARED_MIME_INFO_MINIMUM_VERSION "0.30" )
set( XDG_MIME_INSTALL_DIR "${CMAKE_INSTALL_DATAROOTDIR}/mime/packages" )
@@ -172,7 +177,7 @@ configure_file(
@@ -180,7 +184,7 @@ configure_file(
add_custom_target( uninstall
"${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")

View file

@ -1,11 +0,0 @@
--- library/rt/backendmanager.cpp.orig 2016-09-24 21:08:23 UTC
+++ library/rt/backendmanager.cpp
@@ -140,7 +140,7 @@ namespace rt {
d->appendDir( appPath + QStringLiteral("../PlugIns/") + QSTR_DRUMSTICK, result );
#endif // Linux, Unix...
QStringList libs;
- libs << "../lib/" << "../lib32/" << "../lib64/";
+ libs << "../lib/";
foreach(const QString& lib, libs) {
d->appendDir( appPath + lib + QSTR_DRUMSTICK, result );
}