devel/intel-graphics-compiler: update to 1.0.4756
Changes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4361 Changes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4427 Changes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4479 Changes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4521 Changes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4594 Changes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4756 Reported by: GitHub (watch releases), Repology
This commit is contained in:
parent
c7225b381c
commit
261fa25f00
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=546966
4 changed files with 15 additions and 9 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
PORTNAME= intel-graphics-compiler
|
||||
DISTVERSIONPREFIX= igc-
|
||||
DISTVERSION= 1.0.4312
|
||||
DISTVERSION= 1.0.4756
|
||||
CATEGORIES= devel
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
|
@ -23,6 +23,9 @@ USES= bison cmake compiler:c++17-lang python:build
|
|||
USE_GITHUB= yes
|
||||
USE_LDCONFIG= yes
|
||||
GH_ACCOUNT= intel
|
||||
GH_TUPLE= intel:vc-intrinsics:55124bb:vcintrin
|
||||
CMAKE_OFF= INSTALL_SPIRVDLL
|
||||
CMAKE_ARGS= -DVC_INTRINSICS_SRC:PATH="${WRKSRC_vcintrin}"
|
||||
CFLAGS+= -Wno-macro-redefined # __fastcall
|
||||
PLIST_SUB= ARCH_SUFX=${ARCH:S/i386/32/:S/amd//:S/x86_//}
|
||||
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
TIMESTAMP = 1593779742
|
||||
SHA256 (intel-intel-graphics-compiler-igc-1.0.4312_GH0.tar.gz) = 6a36b13639d24416cd3c47020ba917813801f0935a55c11c46a4450d918e7a7b
|
||||
SIZE (intel-intel-graphics-compiler-igc-1.0.4312_GH0.tar.gz) = 5800590
|
||||
TIMESTAMP = 1597743403
|
||||
SHA256 (intel-intel-graphics-compiler-igc-1.0.4756_GH0.tar.gz) = 25b93adddc4ca5da0988af7d012c7c3d00b628670297c703f252f3b321856055
|
||||
SIZE (intel-intel-graphics-compiler-igc-1.0.4756_GH0.tar.gz) = 6606990
|
||||
SHA256 (intel-vc-intrinsics-55124bb_GH0.tar.gz) = e59ecabbf2a3c8dec26013f3d72353dfd3e1d8c3b7437a5db8a4cb56bfe592f6
|
||||
SIZE (intel-vc-intrinsics-55124bb_GH0.tar.gz) = 96981
|
||||
SHA256 (b4e40a433077.patch) = 56950deb485a4c1dc844f4864f42b80907919b61132b0e797f7955989fed0597
|
||||
SIZE (b4e40a433077.patch) = 9585
|
||||
|
|
|
@ -260,9 +260,9 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
|
|||
#define LINUX_RELEASE_MODE
|
||||
#endif
|
||||
|
||||
--- visa/BuildCISAIRImpl.cpp.orig 2020-01-09 09:46:51 UTC
|
||||
--- visa/BuildCISAIRImpl.cpp.orig 2020-08-18 09:36:43 UTC
|
||||
+++ visa/BuildCISAIRImpl.cpp
|
||||
@@ -684,7 +684,6 @@ extern void CISA_delete_buffer(YY_BUFFER_STATE buf);
|
||||
@@ -568,7 +568,6 @@ extern void CISA_delete_buffer(YY_BUFFER_STATE buf);
|
||||
|
||||
int CISA_IR_Builder::ParseVISAText(const std::string& visaHeader, const std::string& visaText, const std::string& visaTextFile)
|
||||
{
|
||||
|
@ -270,12 +270,12 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
|
|||
// Direct output of parser to null
|
||||
#if defined(_WIN64) || defined(_WIN32)
|
||||
CISAout = fopen("nul", "w");
|
||||
@@ -746,16 +745,11 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
|
||||
@@ -612,16 +611,11 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
|
||||
}
|
||||
|
||||
return VISA_SUCCESS;
|
||||
-#else
|
||||
- assert(0 && "Asm parsing not supported on this platform");
|
||||
- assert(0 && "vISA asm parsing not supported on this platform");
|
||||
- return VISA_FAILURE;
|
||||
-#endif
|
||||
}
|
||||
|
@ -287,7 +287,7 @@ CMake Error at IGC/CMakeLists.txt:1974 (message):
|
|||
// Direct output of parser to null
|
||||
#if defined(_WIN64) || defined(_WIN32)
|
||||
CISAout = fopen("nul", "w");
|
||||
@@ -781,10 +775,6 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
|
||||
@@ -647,10 +641,6 @@ int CISA_IR_Builder::ParseVISAText(const std::string&
|
||||
fclose(CISAout);
|
||||
}
|
||||
return VISA_SUCCESS;
|
||||
|
|
|
@ -2,6 +2,7 @@
|
|||
|
||||
PORTNAME= compute-runtime
|
||||
DISTVERSION= 20.34.17727
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= lang
|
||||
PKGNAMEPREFIX= intel-
|
||||
|
||||
|
|
Loading…
Reference in a new issue