- Update *_DEPENDS
- Add LICENSE [1] - Fix build with newer Inline::MakeMaker [2] - Bump PORTREVISION for dependency change - While I'm here, add tweak to build dump_usb.pl and its manpage Approved by: portmgr (implicit) [1] Obtained from: Tim Retout <diocles@debian.org> [2] With hat: perl
This commit is contained in:
parent
da1782cab8
commit
2621812bdf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=376086
2 changed files with 25 additions and 3 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= Device-USB
|
||||
PORTVERSION= 0.35
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= CPAN \
|
||||
http://personalpages.tds.net/~jwbacon/Ports/distfiles/
|
||||
|
@ -12,11 +12,19 @@ PKGNAMEPREFIX= p5-
|
|||
MAINTAINER= josh.carroll@gmail.com
|
||||
COMMENT= Perl wrapper for libusb
|
||||
|
||||
BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
|
||||
RUN_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
|
||||
LICENSE= ART10 GPLv1
|
||||
LICENSE_COMB= dual
|
||||
|
||||
BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
|
||||
p5-Inline-C>=0:${PORTSDIR}/devel/p5-Inline-C
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
USES= perl5
|
||||
USE_PERL5= configure
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|dump_usb.pl|lib/Device/&|' ${WRKSRC}/MANIFEST
|
||||
@${MV} ${WRKSRC}/dump_usb.pl ${WRKSRC}/lib/Device/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
14
devel/p5-Device-USB/files/patch-Makefile.PL
Normal file
14
devel/p5-Device-USB/files/patch-Makefile.PL
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- Makefile.PL.orig 2010-03-21 23:29:00.000000000 +0800
|
||||
--- Makefile.PL 2015-01-03 03:18:10.000000000 +0800
|
||||
@@ -2,6 +2,11 @@
|
||||
use warnings;
|
||||
use Inline::MakeMaker;
|
||||
|
||||
+sub MY::libscan {
|
||||
+ return if ($_[1] eq 'USB.pm' or $_[1] eq 'lib/Device/dump_usb.pl');
|
||||
+ return $_[1];
|
||||
+}
|
||||
+
|
||||
if($^O eq 'MSWin32')
|
||||
{
|
||||
if(!$ENV{LIBUSB_LIBDIR} or !$ENV{LIBUSB_INCDIR})
|
Loading…
Reference in a new issue