- Strip binaries
- Add a new INFO option - Build and install html documents when DOCS option enabled - Fix the problem of examples were installed twice PR: 246605 Submitted by: felix@palmen-it.de
This commit is contained in:
parent
e7658bd082
commit
26305f4689
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=537143
3 changed files with 133 additions and 52 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= cc65
|
||||
PORTVERSION= 2.18
|
||||
PORTREVISION= 1
|
||||
DISTVERSIONPREFIX= V
|
||||
CATEGORIES= devel
|
||||
|
||||
|
@ -17,22 +18,42 @@ USE_PERL5= build
|
|||
USE_GITHUB= yes
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
MAKE_ARGS= samplesdir=${EXAMPLESDIR} infodir=${PREFIX}/${INFO_PATH}/cc65
|
||||
ALL_TARGET= all
|
||||
|
||||
SHEBANG_FILES= util/ca65html
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES INFO
|
||||
OPTIONS_DEFAULT= DOCS EXAMPLES INFO
|
||||
|
||||
DOCS_BUILD_DEPENDS= linuxdoc:textproc/linuxdoc-tools
|
||||
DOCS_ALL_TARGET= html
|
||||
INFO_BUILD_DEPENDS= linuxdoc:textproc/linuxdoc-tools
|
||||
INFO_INFO= cc65/apple2 cc65/apple2enh cc65/ar65 cc65/atari \
|
||||
cc65/atari2600 cc65/atari5200 cc65/atmos cc65/c128 cc65/c16 \
|
||||
cc65/c64 cc65/ca65 cc65/cbm510 cc65/cbm610 cc65/cc65-intern \
|
||||
cc65/cc65 cc65/chrcvt65 cc65/cl65 cc65/co65 cc65/coding \
|
||||
cc65/creativision cc65/customizing cc65/da65 cc65/debugging \
|
||||
cc65/dio cc65/funcref cc65/gamate cc65/geos cc65/grc65 \
|
||||
cc65/index cc65/intro cc65/ld65 cc65/library cc65/lynx \
|
||||
cc65/nes cc65/od65 cc65/osi cc65/pce cc65/pet cc65/plus4 \
|
||||
cc65/sim65 cc65/smc cc65/sp65 cc65/supervision cc65/telestrat \
|
||||
cc65/tgi cc65/using-make cc65/vic20
|
||||
INFO_USES= makeinfo
|
||||
INFO_ALL_TARGET= info
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
'/gcc/s|^CC|#CC| ; \
|
||||
/-O2/s|^CFLAGS|#CFLAGS|'
|
||||
|
||||
post-install:
|
||||
.for b in ar65 ca65 cc65 chrcvt65 cl65 co65 da65 grc65 ld65 od65 sim65 sp65
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
|
||||
.endfor
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
post-install-EXAMPLES-on:
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
(cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
58
devel/cc65/files/patch-doc_ca65.sgml
Normal file
58
devel/cc65/files/patch-doc_ca65.sgml
Normal file
|
@ -0,0 +1,58 @@
|
|||
--- doc/ca65.sgml.orig 2020-05-20 11:15:00 UTC
|
||||
+++ doc/ca65.sgml
|
||||
@@ -621,10 +621,10 @@ problem in most cases.
|
||||
<table>
|
||||
<tabular ca="clc">
|
||||
<bf/Operator/| <bf/Description/| <bf/Precedence/@<hline>
|
||||
-| Built-in string functions| 0@
|
||||
-||~@
|
||||
-| Built-in pseudo-variables| 1@
|
||||
-| Built-in pseudo-functions| 1@
|
||||
+ | Built-in string functions| 0@
|
||||
+ | |~@
|
||||
+ | Built-in pseudo-variables| 1@
|
||||
+ | Built-in pseudo-functions| 1@
|
||||
+| Unary positive| 1@
|
||||
-| Unary negative| 1@
|
||||
˜<newline>
|
||||
@@ -635,7 +635,7 @@ problem in most cases.
|
||||
.HIBYTE| Unary high-byte operator| 1@
|
||||
^<newline>
|
||||
.BANKBYTE| Unary bank-byte operator| 1@
|
||||
-||~@
|
||||
+ | |~@
|
||||
*| Multiplication| 2@
|
||||
/| Division| 2@
|
||||
.MOD| Modulo operator| 2@
|
||||
@@ -647,26 +647,26 @@ problem in most cases.
|
||||
.SHL| Shift-left operator| 2@
|
||||
>><newline>
|
||||
.SHR| Shift-right operator| 2@
|
||||
-||~@
|
||||
+ | |~@
|
||||
+| Binary addition| 3@
|
||||
-| Binary subtraction| 3@
|
||||
|<newline>
|
||||
.BITOR| Bitwise or| 3@
|
||||
-||~@
|
||||
+ | |~@
|
||||
= | Compare operator (equal)| 4@
|
||||
<>| Compare operator (not equal)| 4@
|
||||
<| Compare operator (less)| 4@
|
||||
>| Compare operator (greater)| 4@
|
||||
<=| Compare operator (less or equal)| 4@
|
||||
>=| Compare operator (greater or equal)| 4@
|
||||
-||~@
|
||||
+ | |~@
|
||||
&&<newline>
|
||||
.AND| Boolean and| 5@
|
||||
.XOR| Boolean xor| 5@
|
||||
-||~@
|
||||
+ | |~@
|
||||
||<newline>
|
||||
.OR| Boolean or| 6@
|
||||
-||~@
|
||||
+ | |~@
|
||||
!<newline>
|
||||
.NOT| Boolean not| 7@<hline>
|
||||
</tabular>
|
|
@ -277,53 +277,6 @@ bin/sp65
|
|||
%%DATADIR%%/lib/supervision.lib
|
||||
%%DATADIR%%/lib/telestrat.lib
|
||||
%%DATADIR%%/lib/vic20.lib
|
||||
%%DATADIR%%/samples/Makefile
|
||||
%%DATADIR%%/samples/Makefile.bak
|
||||
%%DATADIR%%/samples/README
|
||||
%%DATADIR%%/samples/ascii.c
|
||||
%%DATADIR%%/samples/atari2600hello.c
|
||||
%%DATADIR%%/samples/diodemo.c
|
||||
%%DATADIR%%/samples/enumdevdir.c
|
||||
%%DATADIR%%/samples/fire.c
|
||||
%%DATADIR%%/samples/geos/bitmap-demo.c
|
||||
%%DATADIR%%/samples/geos/bitmap-demores.grc
|
||||
%%DATADIR%%/samples/geos/dialog.c
|
||||
%%DATADIR%%/samples/geos/filesel.c
|
||||
%%DATADIR%%/samples/geos/fileselres.grc
|
||||
%%DATADIR%%/samples/geos/geosconio.c
|
||||
%%DATADIR%%/samples/geos/geosconiores.grc
|
||||
%%DATADIR%%/samples/geos/geosver.c
|
||||
%%DATADIR%%/samples/geos/geosverres.grc
|
||||
%%DATADIR%%/samples/geos/getid.c
|
||||
%%DATADIR%%/samples/geos/getidres.grc
|
||||
%%DATADIR%%/samples/geos/grphstr.c
|
||||
%%DATADIR%%/samples/geos/hello1.c
|
||||
%%DATADIR%%/samples/geos/hello1res.grc
|
||||
%%DATADIR%%/samples/geos/hello2.c
|
||||
%%DATADIR%%/samples/geos/hello2res.grc
|
||||
%%DATADIR%%/samples/geos/inittab.c
|
||||
%%DATADIR%%/samples/geos/logo.pcx
|
||||
%%DATADIR%%/samples/geos/menu.c
|
||||
%%DATADIR%%/samples/geos/overlay-demo.c
|
||||
%%DATADIR%%/samples/geos/overlay-demores.grc
|
||||
%%DATADIR%%/samples/geos/rmvprot.c
|
||||
%%DATADIR%%/samples/geos/rmvprotres.grc
|
||||
%%DATADIR%%/samples/geos/vector-demo.c
|
||||
%%DATADIR%%/samples/geos/vector-demores.grc
|
||||
%%DATADIR%%/samples/geos/yesno.c
|
||||
%%DATADIR%%/samples/geos/yesnores.grc
|
||||
%%DATADIR%%/samples/gunzip65.c
|
||||
%%DATADIR%%/samples/hello.c
|
||||
%%DATADIR%%/samples/mandelbrot.c
|
||||
%%DATADIR%%/samples/mousedemo.c
|
||||
%%DATADIR%%/samples/multidemo.c
|
||||
%%DATADIR%%/samples/nachtm.c
|
||||
%%DATADIR%%/samples/overlaydemo.c
|
||||
%%DATADIR%%/samples/plasma.c
|
||||
%%DATADIR%%/samples/sieve.c
|
||||
%%DATADIR%%/samples/tgidemo.c
|
||||
%%DATADIR%%/samples/tutorial/hello.c
|
||||
%%DATADIR%%/samples/tutorial/text.s
|
||||
%%DATADIR%%/target/apple2/drv/emd/a2.auxmem.emd
|
||||
%%DATADIR%%/target/apple2/drv/joy/a2.stdjoy.joy
|
||||
%%DATADIR%%/target/apple2/drv/mou/a2.stdmou.mou
|
||||
|
@ -463,6 +416,55 @@ bin/sp65
|
|||
%%DATADIR%%/target/vic20/drv/joy/vic20-stdjoy.joy
|
||||
%%DATADIR%%/target/vic20/drv/emd/vic20-georam.emd
|
||||
%%DATADIR%%/target/vic20/drv/emd/vic20-rama.emd
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/apple2.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/apple2enh.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/ar65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/atari.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/atari2600.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/atari5200.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/atmos.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/c128.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/c16.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/c64.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/ca65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/cbm510.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/cbm610.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/cc65-intern.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/cc65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/chrcvt65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/cl65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/co65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/coding.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/creativision.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/customizing.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/da65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/debugging.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/dio.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/doc.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/doc.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/funcref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/gamate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/geos.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/grc65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/intro.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/ld65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/library.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/lynx.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/nes.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/od65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/osi.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pce.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pet.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/plus4.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/sim65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/smc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/sp65.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/supervision.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/telestrat.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/tgi.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/using-make.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/vic20.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.md
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.bak
|
||||
|
|
Loading…
Reference in a new issue