misc/py-powerline-status: update to 2.8.2

While here:

* Fix docs build with non-default python versions
* Add missing dependency on psutil [1]

PR:		255563 [1]
Reported by:	stephan@lichtenauer.co.za [1]
This commit is contained in:
Steve Wills 2021-05-20 13:31:21 -04:00
parent 57a3995a94
commit 268f414bdf
5 changed files with 23 additions and 20 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= powerline-status
PORTVERSION= 2.8.1
PORTREVISION= 1
PORTVERSION= 2.8.2
CATEGORIES= misc python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -10,6 +9,8 @@ COMMENT= Statusline plugin for vim, zsh, bash, and more
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/docs/source/license-and-credits.rst
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=3.2.0:sysutils/py-psutil@${PY_FLAVOR}
USES= python:3.6+ shebangfix
OPTIONS_DEFINE= DOCS
@ -30,6 +31,11 @@ GH_PROJECT= powerline
PORTDOCS= *
SPHINX_BUILD_CMD= sphinx-build-${PYTHON_VER}
post-patch:
@${REINPLACE_CMD} -e 's/%%SPHINXBUILD%%/${SPHINX_BUILD_CMD}/g' ${WRKSRC}/docs/Makefile
do-build-DOCS-on:
@make -C ${WRKSRC}/docs man html

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1609304473
SHA256 (powerline-powerline-2.8.1_GH0.tar.gz) = a4f36ad9d88a6c90b82427d574c8b5518b3c8b11b6eaf38acf2336064c63565d
SIZE (powerline-powerline-2.8.1_GH0.tar.gz) = 363814
TIMESTAMP = 1621521899
SHA256 (powerline-powerline-2.8.2_GH0.tar.gz) = ea4ca0df45b8ea3870ff135cd3c4623ba4b785630be81db7f13bf5e94b3753c7
SIZE (powerline-powerline-2.8.2_GH0.tar.gz) = 366573

View file

@ -0,0 +1,10 @@
--- docs/Makefile.orig 2021-05-20 16:12:08 UTC
+++ docs/Makefile
@@ -1,6 +1,6 @@
# Makefile for Sphinx documentation
SPHINXOPTS =
-SPHINXBUILD = sphinx-build
+SPHINXBUILD = %%SPHINXBUILD%%
PAPER =
BUILDDIR = _build

View file

@ -1,13 +0,0 @@
--- powerline/version.py.orig 2021-01-17 14:39:35 UTC
+++ powerline/version.py
@@ -7,9 +7,5 @@ from traceback import print_exc
__version__ = "2.8.1"
def get_version():
- try:
- return __version__ + '.dev9999+git.' + str(subprocess.check_output(['git', 'rev-parse', 'HEAD']).strip())
- except Exception:
- print_exc()
- return __version__
+ return __version__

View file

@ -12,7 +12,7 @@ To display powerline-status accurately in X Window System
terminal emulators make sure the following requirements are met:
- A font from port x11-fonts/powerline-fonts must be specified
in the X Window Systems X resource file ~/.Xdefaults or the
in the X Window Systems X resource file ~/.Xdefaults or the
terminals preferences
- Locale must be set UTF-8 to the login shell in the user's
@ -26,7 +26,7 @@ terminal emulators make sure the following requirements are met:
:lang=C.UTF-8:
Execute "cap_mkdb /etc/login.conf" to update the login class
capability database.
capability database.
EOM
}
]