Enable the internal editor, through using libslang. Compile with
WITH_SLANG=yes.
This commit is contained in:
parent
56b636ee70
commit
26b2ddb99b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25741
4 changed files with 74 additions and 13 deletions
|
@ -17,13 +17,21 @@ LIB_DEPENDS= glib12.3:${PORTSDIR}/devel/glib12 \
|
|||
intl.1:${PORTSDIR}/devel/gettext
|
||||
.if defined(USE_NCURSES_PORT)
|
||||
LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
|
||||
.elif defined(WITH_SLANG)
|
||||
LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
|
||||
BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
|
||||
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
|
||||
.endif
|
||||
|
||||
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
.if defined(WITH_SLANG)
|
||||
CONFIGURE_ARGS= --with-slang --without-gnome --with-edit
|
||||
.else
|
||||
CONFIGURE_ARGS= --with-ncurses --without-gnome --without-edit
|
||||
.endif
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
MAKE="gmake" \
|
||||
GLIB_CONFIG="${GLIB_CONFIG}" \
|
||||
|
@ -32,7 +40,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
|||
MAN1= midc.1
|
||||
MAN8= mcserv.8
|
||||
|
||||
post-patch:
|
||||
${PERL} -i -p -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/vfs/extfs/uzip.in
|
||||
.if defined(WITH_SLANG)
|
||||
PLIST= ${WRKDIR}/PLIST
|
||||
pre-install:
|
||||
@${CAT} ${PKGDIR}/PLIST > ${PLIST}
|
||||
@${ECHO} bin/mcedit >> ${PLIST}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.orig Sun Apr 11 04:38:29 1999
|
||||
+++ configure Sun May 9 15:58:08 1999
|
||||
@@ -3267,15 +3267,15 @@
|
||||
--- configure.orig Mon Dec 6 15:49:54 1999
|
||||
+++ configure Wed Jan 5 23:31:22 2000
|
||||
@@ -3383,15 +3383,15 @@
|
||||
fi
|
||||
|
||||
|
||||
|
@ -20,7 +20,25 @@
|
|||
fi
|
||||
|
||||
if test "$XGETTEXT" != ":"; then
|
||||
@@ -10524,13 +10524,13 @@
|
||||
@@ -10049,7 +10049,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lslang $LIBS"
|
||||
+LIBS="-lslang -ltermcap $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 10055 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -10290,7 +10290,7 @@
|
||||
#define HAVE_SYSTEM_SLANG 1
|
||||
EOF
|
||||
|
||||
- LSLANG="-lslang"
|
||||
+ LSLANG="-lslang -ltermcap"
|
||||
screen_manager="SLang (system-installed library)"
|
||||
echo "$ac_t""Using system installed SLang library" 1>&6
|
||||
rm -f slang/slang.h
|
||||
@@ -10736,13 +10736,13 @@
|
||||
|
||||
if $search_ncurses
|
||||
then
|
||||
|
@ -39,7 +57,7 @@
|
|||
cat >> confdefs.h <<\EOF
|
||||
#define HAS_CURSES 1
|
||||
EOF
|
||||
@@ -10546,13 +10546,13 @@
|
||||
@@ -10758,13 +10758,13 @@
|
||||
|
||||
if $search_ncurses
|
||||
then
|
||||
|
@ -58,7 +76,7 @@
|
|||
cat >> confdefs.h <<\EOF
|
||||
#define HAS_CURSES 1
|
||||
EOF
|
||||
@@ -10568,13 +10568,13 @@
|
||||
@@ -10780,13 +10780,13 @@
|
||||
|
||||
if $search_ncurses
|
||||
then
|
||||
|
@ -77,7 +95,7 @@
|
|||
cat >> confdefs.h <<\EOF
|
||||
#define HAS_CURSES 1
|
||||
EOF
|
||||
@@ -10590,13 +10590,13 @@
|
||||
@@ -10802,13 +10802,13 @@
|
||||
|
||||
if $search_ncurses
|
||||
then
|
||||
|
@ -96,7 +114,7 @@
|
|||
cat >> confdefs.h <<\EOF
|
||||
#define HAS_CURSES 1
|
||||
EOF
|
||||
@@ -10655,6 +10655,8 @@
|
||||
@@ -10867,6 +10867,8 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
|
@ -105,7 +123,16 @@
|
|||
|
||||
if $search_ncurses
|
||||
then
|
||||
@@ -11465,7 +11467,7 @@
|
||||
@@ -11071,7 +11073,7 @@
|
||||
#define HAVE_SYSTEM_SLANG 1
|
||||
EOF
|
||||
|
||||
- LSLANG="-lslang"
|
||||
+ LSLANG="-lslang -ltermcap"
|
||||
screen_manager="SLang (system-installed library)"
|
||||
echo "$ac_t""Using system installed SLang library" 1>&6
|
||||
rm -f slang/slang.h
|
||||
@@ -11688,7 +11690,7 @@
|
||||
vfs/extfs/ftplist vfs/extfs/uzip vfs/extfs/uzoo vfs/extfs/lslR vfs/extfs/ulha
|
||||
vfs/extfs/uha vfs/extfs/ucpio vfs/extfs/deb vfs/extfs/urar vfs/extfs/uar
|
||||
|
||||
|
@ -114,7 +141,7 @@
|
|||
|
||||
intl/Makefile po/Makefile.in
|
||||
config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
|
||||
@@ -11684,7 +11686,7 @@
|
||||
@@ -11932,7 +11934,7 @@
|
||||
vfs/extfs/ftplist vfs/extfs/uzip vfs/extfs/uzoo vfs/extfs/lslR vfs/extfs/ulha
|
||||
vfs/extfs/uha vfs/extfs/ucpio vfs/extfs/deb vfs/extfs/urar vfs/extfs/uar
|
||||
|
||||
|
@ -123,3 +150,14 @@
|
|||
|
||||
intl/Makefile po/Makefile.in
|
||||
"}
|
||||
@@ -12237,10 +12239,6 @@
|
||||
*) # Relative path.
|
||||
ac_sub_cache_file="$ac_dots$cache_file" ;;
|
||||
esac
|
||||
- case "$ac_given_INSTALL" in
|
||||
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
|
||||
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
|
||||
- esac
|
||||
|
||||
echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
|
||||
# The eval makes quoting arguments work.
|
||||
|
|
|
@ -83,3 +83,14 @@
|
|||
for I in $(TIFILES); \
|
||||
do $(INSTALL_DATA) $(srcdir)/$$I $(DESTDIR)$(tidir)/$$I; done
|
||||
$(MKINSTALLDIRS) $(DESTDIR)$(confdir)
|
||||
--- edit/Makefile.in.orig Wed Jan 5 23:49:36 2000
|
||||
+++ edit/Makefile.in Wed Jan 5 23:49:58 2000
|
||||
@@ -58,7 +58,7 @@
|
||||
|
||||
mcedit:
|
||||
-$(RMF) $(DESTDIR)$(bindir)/$(binprefix)mcedit
|
||||
- $(LN_S) mc $(DESTDIR)$(bindir)/$(binprefix)mcedit
|
||||
+ $(LN_S) midc $(DESTDIR)$(bindir)/$(binprefix)mcedit
|
||||
|
||||
showlibdep:
|
||||
@echo 'OBJS="$(EDITOBJS)"'
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
#
|
||||
|
||||
-DZIP=/usr/bin
|
||||
+DZIP=%%PREFIX%%/bin
|
||||
+DZIP=@prefix@/bin
|
||||
XZIP="$DZIP/zip -g"
|
||||
XDZIP="$DZIP/zip -d"
|
||||
XUNZIP="$DZIP/unzip"
|
||||
|
|
Loading…
Reference in a new issue