Update to 0.9.2.
This commit is contained in:
parent
aaea9c3db3
commit
26d7b8c9f4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66017
6 changed files with 50 additions and 40 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= py-MySQLdb
|
||||
PORTVERSION= 0.9.1
|
||||
PORTVERSION= 0.9.2
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= mysql-python
|
||||
|
@ -21,9 +21,6 @@ USE_PYDISTUTILS= yes
|
|||
|
||||
DOCS= MANIFEST README doc/*.html
|
||||
|
||||
do-configure:
|
||||
@${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (MySQL-python-0.9.1.tar.gz) = 802e271d46e3d845045ce0378f82fd85
|
||||
MD5 (MySQL-python-0.9.2.tar.gz) = afef758f56289f98408dd9f379d8fc8d
|
||||
|
|
|
@ -1,15 +1,23 @@
|
|||
--- setup.py.orig Wed Oct 17 05:17:30 2001
|
||||
+++ setup.py Tue Jan 22 00:33:59 2002
|
||||
@@ -24,9 +24,9 @@
|
||||
libraries = [mysqlclient, "z"]
|
||||
runtime_library_dirs = []
|
||||
extra_objects = []
|
||||
-elif sys.platform in ("freebsd4", "openbsd2"):
|
||||
- include_dirs = ['/usr/local/include/mysql']
|
||||
- library_dirs = ['/usr/local/lib/mysql']
|
||||
+elif sys.platform[:7] in ("freebsd", "openbsd"):
|
||||
+ include_dirs = ['%%LOCALBASE%%/include/mysql']
|
||||
+ library_dirs = ['%%LOCALBASE%%/lib/mysql']
|
||||
libraries = [mysqlclient, "z"]
|
||||
runtime_library_dirs = []
|
||||
extra_objects = []
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- setup.py.orig Thu Jul 18 22:55:36 2002
|
||||
+++ setup.py Tue Sep 10 10:51:52 2002
|
||||
@@ -11,7 +11,7 @@
|
||||
NO = 0
|
||||
|
||||
# set this to YES if you have the thread-safe mysqlclient library
|
||||
-thread_safe_library = YES
|
||||
+thread_safe_library = NO
|
||||
|
||||
# You probably don't have to do anything past this point. If you
|
||||
# do, please mail me the configuration for your platform. Don't
|
||||
@@ -51,7 +51,7 @@
|
||||
if sys.platform == "netbsd1":
|
||||
include_dirs = ['/usr/pkg/include/mysql']
|
||||
library_dirs = ['/usr/pkg/lib/mysql']
|
||||
-elif sys.platform in ("freebsd4", "openbsd3"):
|
||||
+elif sys.platform[:7] in ("freebsd", "openbsd"):
|
||||
LOCALBASE = os.environ.get('LOCALBASE', '/usr/local')
|
||||
include_dirs = ['%s/include/mysql' % LOCALBASE]
|
||||
library_dirs = ['%s/lib/mysql' % LOCALBASE]
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= py-MySQLdb
|
||||
PORTVERSION= 0.9.1
|
||||
PORTVERSION= 0.9.2
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= mysql-python
|
||||
|
@ -21,9 +21,6 @@ USE_PYDISTUTILS= yes
|
|||
|
||||
DOCS= MANIFEST README doc/*.html
|
||||
|
||||
do-configure:
|
||||
@${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (MySQL-python-0.9.1.tar.gz) = 802e271d46e3d845045ce0378f82fd85
|
||||
MD5 (MySQL-python-0.9.2.tar.gz) = afef758f56289f98408dd9f379d8fc8d
|
||||
|
|
|
@ -1,15 +1,23 @@
|
|||
--- setup.py.orig Wed Oct 17 05:17:30 2001
|
||||
+++ setup.py Tue Jan 22 00:33:59 2002
|
||||
@@ -24,9 +24,9 @@
|
||||
libraries = [mysqlclient, "z"]
|
||||
runtime_library_dirs = []
|
||||
extra_objects = []
|
||||
-elif sys.platform in ("freebsd4", "openbsd2"):
|
||||
- include_dirs = ['/usr/local/include/mysql']
|
||||
- library_dirs = ['/usr/local/lib/mysql']
|
||||
+elif sys.platform[:7] in ("freebsd", "openbsd"):
|
||||
+ include_dirs = ['%%LOCALBASE%%/include/mysql']
|
||||
+ library_dirs = ['%%LOCALBASE%%/lib/mysql']
|
||||
libraries = [mysqlclient, "z"]
|
||||
runtime_library_dirs = []
|
||||
extra_objects = []
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- setup.py.orig Thu Jul 18 22:55:36 2002
|
||||
+++ setup.py Tue Sep 10 10:51:52 2002
|
||||
@@ -11,7 +11,7 @@
|
||||
NO = 0
|
||||
|
||||
# set this to YES if you have the thread-safe mysqlclient library
|
||||
-thread_safe_library = YES
|
||||
+thread_safe_library = NO
|
||||
|
||||
# You probably don't have to do anything past this point. If you
|
||||
# do, please mail me the configuration for your platform. Don't
|
||||
@@ -51,7 +51,7 @@
|
||||
if sys.platform == "netbsd1":
|
||||
include_dirs = ['/usr/pkg/include/mysql']
|
||||
library_dirs = ['/usr/pkg/lib/mysql']
|
||||
-elif sys.platform in ("freebsd4", "openbsd3"):
|
||||
+elif sys.platform[:7] in ("freebsd", "openbsd"):
|
||||
LOCALBASE = os.environ.get('LOCALBASE', '/usr/local')
|
||||
include_dirs = ['%s/include/mysql' % LOCALBASE]
|
||||
library_dirs = ['%s/lib/mysql' % LOCALBASE]
|
||||
|
|
Loading…
Reference in a new issue