www/baculum-*: add baculum.app

Connect to the build.

PR:	233061
This commit is contained in:
Sergey A. Osokin 2022-04-08 14:16:21 -04:00
parent feb9778ce9
commit 26e974155c
12 changed files with 2525 additions and 0 deletions

View file

@ -38,6 +38,9 @@
SUBDIR += awstats
SUBDIR += axis2
SUBDIR += bacula-web
SUBDIR += baculum-api
SUBDIR += baculum-common
SUBDIR += baculum-web
SUBDIR += baikal
SUBDIR += bareos-webui
SUBDIR += bareos18-webui

31
www/baculum-api/Makefile Normal file
View file

@ -0,0 +1,31 @@
# Created by: Sergey Osipov <sipopo@yandex.ru>
PKGNAMESUFFIX= -api
COMMENT= Baculum API
LICENSE= AGPLv3
RUN_DEPENDS= baculum-common>0:www/baculum-common
PLIST= ${.CURDIR}/pkg-plist
OPTIONS_DEFINE= MYSQL PGSQL
OPTIONS_DEFAULT=PGSQL
MYSQL_DESC= Enable MySQL PDO support
PGSQL_DESC= Enable PostgreSQL PDO support
USE_PHP= bcmath pdo
.if !empty(PORT_OPTIONS:MMYSQL)
USE_PHP+= pdo_mysql
.endif
.if !empty(PORT_OPTIONS:MPGSQL)
USE_PHP+= pdo_pgsql
.endif
MASTERDIR= ${.CURDIR}/../baculum-common
.include "${MASTERDIR}/Makefile"

View file

@ -0,0 +1,7 @@
The Baculum API is a web application that is used to work with the Baculum Web.
It provides an interface, which serves data for Baculum Web.
The Baculum API is also capable to take actions with Bconsole, the Bacula configuration and the Bacula components.
There is possible to use the Baculum API separately (without Baculum Web) as a Bacula programming interface but using Baculum Web without Baculum API is not possible.
WWW: https://www.bacula.org/

183
www/baculum-api/pkg-plist Normal file
View file

@ -0,0 +1,183 @@
%%WWWDIR%%/htdocs/protected/API/Class/APIConfig.php
%%WWWDIR%%/htdocs/protected/API/Class/APIDbModule.php
%%WWWDIR%%/htdocs/protected/API/Class/APIInterfaces.php
%%WWWDIR%%/htdocs/protected/API/Class/APIModule.php
%%WWWDIR%%/htdocs/protected/API/Class/APIServer.php
%%WWWDIR%%/htdocs/protected/API/Class/APIServerV1.php
%%WWWDIR%%/htdocs/protected/API/Class/APIServerV2.php
%%WWWDIR%%/htdocs/protected/API/Class/APIUrlMapping.php
%%WWWDIR%%/htdocs/protected/API/Class/BAPIException.php
%%WWWDIR%%/htdocs/protected/API/Class/BLStat.php
%%WWWDIR%%/htdocs/protected/API/Class/BList.php
%%WWWDIR%%/htdocs/protected/API/Class/BVFS.php
%%WWWDIR%%/htdocs/protected/API/Class/BaculaConfig.php
%%WWWDIR%%/htdocs/protected/API/Class/BaculaSetting.php
%%WWWDIR%%/htdocs/protected/API/Class/BaculumAPIPage.php
%%WWWDIR%%/htdocs/protected/API/Class/BaculumAPIServer.php
%%WWWDIR%%/htdocs/protected/API/Class/BasicAPIUserConfig.php
%%WWWDIR%%/htdocs/protected/API/Class/Bconsole.php
%%WWWDIR%%/htdocs/protected/API/Class/ChangerCommand.php
%%WWWDIR%%/htdocs/protected/API/Class/ClientManager.php
%%WWWDIR%%/htdocs/protected/API/Class/ClientRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/ComponentActions.php
%%WWWDIR%%/htdocs/protected/API/Class/ComponentStatusModule.php
%%WWWDIR%%/htdocs/protected/API/Class/ConsoleOutputPage.php
%%WWWDIR%%/htdocs/protected/API/Class/Database.php
%%WWWDIR%%/htdocs/protected/API/Class/DeviceConfig.php
%%WWWDIR%%/htdocs/protected/API/Class/FileSetManager.php
%%WWWDIR%%/htdocs/protected/API/Class/FileSetRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/JSONTools.php
%%WWWDIR%%/htdocs/protected/API/Class/JobManager.php
%%WWWDIR%%/htdocs/protected/API/Class/JobRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/LogManager.php
%%WWWDIR%%/htdocs/protected/API/Class/LogRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/Ls.php
%%WWWDIR%%/htdocs/protected/API/Class/OAuth2/AuthIdManager.php
%%WWWDIR%%/htdocs/protected/API/Class/OAuth2/AuthIdRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/OAuth2/BaculumOAuth2.php
%%WWWDIR%%/htdocs/protected/API/Class/OAuth2/OAuth2Config.php
%%WWWDIR%%/htdocs/protected/API/Class/OAuth2/TokenManager.php
%%WWWDIR%%/htdocs/protected/API/Class/OAuth2/TokenRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/OAuthUrlMapping.php
%%WWWDIR%%/htdocs/protected/API/Class/PanelUrlMapping.php
%%WWWDIR%%/htdocs/protected/API/Class/PoolManager.php
%%WWWDIR%%/htdocs/protected/API/Class/PoolRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/StatusClient.php
%%WWWDIR%%/htdocs/protected/API/Class/StatusDirector.php
%%WWWDIR%%/htdocs/protected/API/Class/StatusStorage.php
%%WWWDIR%%/htdocs/protected/API/Class/StorageManager.php
%%WWWDIR%%/htdocs/protected/API/Class/StorageRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/VersionManager.php
%%WWWDIR%%/htdocs/protected/API/Class/VersionRecord.php
%%WWWDIR%%/htdocs/protected/API/Class/VolumeManager.php
%%WWWDIR%%/htdocs/protected/API/Class/VolumeRecord.php
%%WWWDIR%%/htdocs/protected/API/Config
%%WWWDIR%%/htdocs/protected/API/Lang/en/messages.mo
%%WWWDIR%%/htdocs/protected/API/Lang/en/messages.po
%%WWWDIR%%/htdocs/protected/API/Lang/pl/messages.mo
%%WWWDIR%%/htdocs/protected/API/Lang/pl/messages.po
%%WWWDIR%%/htdocs/protected/API/Lang/pt/messages.mo
%%WWWDIR%%/htdocs/protected/API/Lang/pt/messages.po
%%WWWDIR%%/htdocs/protected/API/Lang/ru/messages.mo
%%WWWDIR%%/htdocs/protected/API/Lang/ru/messages.po
%%WWWDIR%%/htdocs/protected/API/Layouts/Main.php
%%WWWDIR%%/htdocs/protected/API/Layouts/Main.tpl
%%WWWDIR%%/htdocs/protected/API/Layouts/Wizard.php
%%WWWDIR%%/htdocs/protected/API/Layouts/Wizard.tpl
%%WWWDIR%%/htdocs/protected/API/Logs
%%WWWDIR%%/htdocs/protected/API/Pages/API/Actions.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Authorize.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSCleanUp.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSClearCache.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSGetJobids.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSLsDirs.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSLsFiles.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSRestore.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSUpdate.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/BVFSVersions.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Catalog.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ChangerDriveLoad.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ChangerDriveLoaded.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ChangerDriveUnload.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ChangerList.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ChangerListAll.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ChangerSlots.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ChangerSlotsTransfer.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Client.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ClientBandwidthLimit.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ClientLs.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ClientShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ClientStatus.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Clients.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ClientsShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ComponentStatus.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Config.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ConsoleCommand.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/DbSize.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/DirectorStatus.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Directors.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/FileSet.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/FileSetResNames.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/FileSets.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Job.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobBandwidthLimit.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobCancel.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobEstimate.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobFiles.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobListFiles.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobLog.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobResNames.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobRun.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobTotals.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Jobs.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobsForClient.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobsOnVolume.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobsRecent.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/JobsShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Messages.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/OAuth2Client.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/OAuth2Clients.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Pool.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/PoolShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/PoolUpdate.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/PoolUpdateVolumes.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Pools.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/PoolsShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/RequestToken.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/RestoreRun.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/ScheduleStatus.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Schedules.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/SlotsUpdate.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Storage.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageMount.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageMountV1.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageRelease.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageReleaseV1.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageStatus.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageUmount.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StorageUmountV1.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Storages.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/StoragesShow.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Volume.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/VolumeLabel.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/VolumeLabelBarcodes.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/VolumePrune.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/VolumePurge.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Volumes.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/VolumesInPool.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/VolumesRequired.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/Welcome.php
%%WWWDIR%%/htdocs/protected/API/Pages/API/config.xml
%%WWWDIR%%/htdocs/protected/API/Pages/API/endpoints.xml
%%WWWDIR%%/htdocs/protected/API/Pages/OAuth2/Authorize.php
%%WWWDIR%%/htdocs/protected/API/Pages/OAuth2/RequestToken.php
%%WWWDIR%%/htdocs/protected/API/Pages/OAuth2/config.xml
%%WWWDIR%%/htdocs/protected/API/Pages/OAuth2/endpoints.xml
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIBasicUsers.php
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIBasicUsers.tpl
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIDevices.page
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIDevices.php
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIHome.page
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIHome.php
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIInstallWizard.page
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIInstallWizard.php
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIOAuth2Clients.php
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APIOAuth2Clients.tpl
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APISettings.page
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/APISettings.php
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/config.xml
%%WWWDIR%%/htdocs/protected/API/Pages/Panel/endpoints.xml
%%WWWDIR%%/htdocs/protected/API/Pages/Requirements.php
%%WWWDIR%%/htdocs/protected/API/Portlets/APISideBar.php
%%WWWDIR%%/htdocs/protected/API/Portlets/APISideBar.tpl
%%WWWDIR%%/htdocs/protected/API/Portlets/SudoConfig.php
%%WWWDIR%%/htdocs/protected/API/Portlets/SudoConfig.tpl
%%WWWDIR%%/htdocs/protected/API/openapi_baculum.json
@dir %%ETCDIR%%/Config/API
@dir %%WWWDIR%%/htdocs/framework
@dir %%WWWDIR%%/htdocs/protected/Common
@dir %%WWWDIR%%/htdocs/themes
@dir /var/cache/baculum
@dir /var/log/baculum

View file

@ -0,0 +1,89 @@
# Created by: Sergey Osipov <sipopo@yandex.ru>
PORTNAME= baculum
PORTVERSION= 11.0.5
CATEGORIES?= www
MASTER_SITES= SF/bacula/bacula/${PORTVERSION}
PKGNAMESUFFIX?= -common
DISTNAME= bacula-gui-${PORTVERSION}
MAINTAINER= sipopo@yandex.ru
COMMENT?= common libraries for baculum
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/${PORTNAME}/LICENSE
USES+= php
PHP_VER= 74
BCL_VARDIR?= /var
BCL_CACHEDIR?= ${BCL_VARDIR}/cache/${PORTNAME}
BCL_LOGDIR?= ${BCL_VARDIR}/log/${PORTNAME}
NO_ARCH= yes
NO_BUILD= yes
USE_PHP+= ctype dom json session xml
OPTIONS_DEFINE?=EXAMPLES
.include <bsd.port.options.mk>
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}/htdocs/protected/Common
${MKDIR} ${STAGEDIR}${WWWDIR}/htdocs/framework
${MKDIR} ${STAGEDIR}${WWWDIR}/htdocs/themes
${MKDIR} ${STAGEDIR}${BCL_CACHEDIR}
${MKDIR} ${STAGEDIR}${BCL_LOGDIR}
${MKDIR} ${STAGEDIR}${ETCDIR}/Config
.if ${PKGNAMESUFFIX} == "-common"
${CP} -R ${WRKSRC}/${PORTNAME}/framework ${STAGEDIR}${WWWDIR}/htdocs
${CP} -R ${WRKSRC}/${PORTNAME}/protected/Common ${STAGEDIR}${WWWDIR}/htdocs/protected
${CP} ${WRKSRC}/${PORTNAME}/protected/application.xml ${STAGEDIR}${WWWDIR}/htdocs/protected
${CP} -R ${WRKSRC}/${PORTNAME}/themes ${STAGEDIR}${WWWDIR}/htdocs
${RLN} ${STAGEDIR}${BCL_CACHEDIR} ${STAGEDIR}${WWWDIR}/htdocs/protected/runtime
${RLN} ${STAGEDIR}${BCL_CACHEDIR} ${STAGEDIR}${WWWDIR}/htdocs/assets
.for i in AUTHORS INSTALL LICENSE LICENSE-FOSS README ReleaseNotes UPGRADE index.php
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${i} ${STAGEDIR}${WWWDIR}/htdocs/${i}
.endfor
.endif
.if ${PKGNAMESUFFIX} == "-api"
${MKDIR} ${STAGEDIR}${ETCDIR}/Config/API
${CP} -R ${WRKSRC}/${PORTNAME}/protected/API ${STAGEDIR}${WWWDIR}/htdocs/protected
${RM} -Rf ${STAGEDIR}${WWWDIR}/htdocs/protected/API/Config
${RM} -Rf ${STAGEDIR}${WWWDIR}/htdocs/protected/API/Logs
${RLN} ${STAGEDIR}${BCL_LOGDIR} ${STAGEDIR}${WWWDIR}/htdocs/protected/API/Logs
${RLN} ${STAGEDIR}${ETCDIR}/Config/API ${STAGEDIR}${WWWDIR}/htdocs/protected/API/Config
.endif
.if ${PKGNAMESUFFIX} == "-web"
${MKDIR} ${STAGEDIR}${ETCDIR}/Config/WEB
${CP} -R ${WRKSRC}/${PORTNAME}/protected/Web ${STAGEDIR}${WWWDIR}/htdocs/protected
${RM} -Rf ${STAGEDIR}${WWWDIR}/htdocs/protected/Web/Config
${RM} -Rf ${STAGEDIR}${WWWDIR}/htdocs/protected/Web/Logs
${RLN} ${STAGEDIR}${BCL_LOGDIR} ${STAGEDIR}${WWWDIR}/htdocs/protected/Web/Logs
${RLN} ${STAGEDIR}${ETCDIR}/Config/WEB ${STAGEDIR}${WWWDIR}/htdocs/protected/Web/Config
.endif
@${ECHO_CMD} \
'@postexec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}/htdocs' \
>> ${TMPPLIST}
@${ECHO_CMD} \
'@postexec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${BCL_LOGDIR}' \
>> ${TMPPLIST}
@${ECHO_CMD} \
'@postexec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${BCL_LOGDIR}' \
>> ${TMPPLIST}
@${ECHO_CMD} \
'@postexec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${ETCDIR}' \
>> ${TMPPLIST}
post-install:
.if ${PKGNAMESUFFIX} == "-common"
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/${PORTNAME}/examples/sudo ${STAGEDIR}${EXAMPLESDIR}
${CP} ${WRKSRC}/${PORTNAME}/examples/deb/*conf ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1624882099
SHA256 (bacula-gui-11.0.5.tar.gz) = 44c2b4f0986e56aa85258fee91d40b25848df3ba41e3632a46b2dbd1c9c0114f
SIZE (bacula-gui-11.0.5.tar.gz) = 5786895

View file

@ -0,0 +1,11 @@
--- baculum/protected/Web/Class/WebUserManager.php.orig 2021-09-29 12:58:20 UTC
+++ baculum/protected/Web/Class/WebUserManager.php
@@ -233,7 +233,7 @@ class WebUserManager extends WebModule implements IUse
*/
// For basic auth take username from web server.
if (key_exists('PHP_AUTH_USER' , $_SERVER) && !empty($_SERVER['PHP_AUTH_USER'])) {
- $username = $_SERVER['PHP_AUTH_USER'];
+ $username = strtolower($_SERVER['PHP_AUTH_USER']);
$password = '';
$this->getModule('auth')->login($username, $password);
$this->Response->redirect('/');

View file

@ -0,0 +1,3 @@
Baculum - Common libraries for Bacula web/api interface
WWW: https://www.bacula.org/

1938
www/baculum-common/pkg-plist Normal file

File diff suppressed because it is too large Load diff

21
www/baculum-web/Makefile Normal file
View file

@ -0,0 +1,21 @@
# Created by: Sergey Osipov <sipopo@yandex.ru>
PKGNAMESUFFIX= -web
COMMENT= Baculum Web
LICENSE= AGPLv3
RUN_DEPENDS= baculum-common>0:www/baculum-common
PLIST= ${.CURDIR}/pkg-plist
USE_PHP= curl ldap
OPTIONS_DEFINE= LCUSER
LCUSER_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-baculum_protected_Web_Class_WebUserManager.php
LCUSER_DESC= Force username to lowercase. (Useful for kerberos)
MASTERDIR= ${.CURDIR}/../baculum-common
.include "${MASTERDIR}/Makefile"

View file

@ -0,0 +1,6 @@
The Baculum Web is a complete web interface (WebGUI) to manage Bacula.
It provides the Bacula administration and configuration functions using by the Bacula API interface.
There can be one or more Baculum API hosts managed by one Baculum Web interface.
WWW: https://www.bacula.org/

230
www/baculum-web/pkg-plist Normal file
View file

@ -0,0 +1,230 @@
%%WWWDIR%%/htdocs/protected/Web/Class/BaculumAPIClient.php
%%WWWDIR%%/htdocs/protected/Web/Class/BaculumWebPage.php
%%WWWDIR%%/htdocs/protected/Web/Class/BasicWebUserConfig.php
%%WWWDIR%%/htdocs/protected/Web/Class/DataDependencies.php
%%WWWDIR%%/htdocs/protected/Web/Class/DataDescription.php
%%WWWDIR%%/htdocs/protected/Web/Class/HostConfig.php
%%WWWDIR%%/htdocs/protected/Web/Class/HostRecord.php
%%WWWDIR%%/htdocs/protected/Web/Class/JobInfo.php
%%WWWDIR%%/htdocs/protected/Web/Class/LogParser.php
%%WWWDIR%%/htdocs/protected/Web/Class/MessagesLog.php
%%WWWDIR%%/htdocs/protected/Web/Class/OAuth2Record.php
%%WWWDIR%%/htdocs/protected/Web/Class/PageCategory.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebBasicUserManager.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebConfig.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebLdapUserManager.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebLocalUserManager.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebModule.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebRoleConfig.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebUrlMapping.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebUser.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebUserConfig.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebUserManager.php
%%WWWDIR%%/htdocs/protected/Web/Class/WebUserRoles.php
%%WWWDIR%%/htdocs/protected/Web/Config
%%WWWDIR%%/htdocs/protected/Web/Data/data_deps.json
%%WWWDIR%%/htdocs/protected/Web/Data/data_desc.json
%%WWWDIR%%/htdocs/protected/Web/Init.php
%%WWWDIR%%/htdocs/protected/Web/JavaScript/bacula-config.js
%%WWWDIR%%/htdocs/protected/Web/JavaScript/flotr2.js
%%WWWDIR%%/htdocs/protected/Web/JavaScript/gauge.js
%%WWWDIR%%/htdocs/protected/Web/JavaScript/graph.js
%%WWWDIR%%/htdocs/protected/Web/JavaScript/misc.js
%%WWWDIR%%/htdocs/protected/Web/JavaScript/opentip.js
%%WWWDIR%%/htdocs/protected/Web/JavaScript/statistics.js
%%WWWDIR%%/htdocs/protected/Web/JavaScript/tooltip.js
%%WWWDIR%%/htdocs/protected/Web/Lang/en/messages.mo
%%WWWDIR%%/htdocs/protected/Web/Lang/en/messages.po
%%WWWDIR%%/htdocs/protected/Web/Lang/ja/messages.mo
%%WWWDIR%%/htdocs/protected/Web/Lang/ja/messages.po
%%WWWDIR%%/htdocs/protected/Web/Lang/pl/messages.mo
%%WWWDIR%%/htdocs/protected/Web/Lang/pl/messages.po
%%WWWDIR%%/htdocs/protected/Web/Lang/pt/messages.mo
%%WWWDIR%%/htdocs/protected/Web/Lang/pt/messages.po
%%WWWDIR%%/htdocs/protected/Web/Lang/ru/messages.mo
%%WWWDIR%%/htdocs/protected/Web/Lang/ru/messages.po
%%WWWDIR%%/htdocs/protected/Web/Layouts/Main.php
%%WWWDIR%%/htdocs/protected/Web/Layouts/Main.tpl
%%WWWDIR%%/htdocs/protected/Web/Layouts/MessageBox.php
%%WWWDIR%%/htdocs/protected/Web/Layouts/MessageBox.tpl
%%WWWDIR%%/htdocs/protected/Web/Layouts/Simple.php
%%WWWDIR%%/htdocs/protected/Web/Layouts/Simple.tpl
%%WWWDIR%%/htdocs/protected/Web/Layouts/Wizard.php
%%WWWDIR%%/htdocs/protected/Web/Layouts/Wizard.tpl
%%WWWDIR%%/htdocs/protected/Web/Logs
%%WWWDIR%%/htdocs/protected/Web/Pages/ApplicationSettings.page
%%WWWDIR%%/htdocs/protected/Web/Pages/ApplicationSettings.php
%%WWWDIR%%/htdocs/protected/Web/Pages/BaculumError.page
%%WWWDIR%%/htdocs/protected/Web/Pages/BaculumError.php
%%WWWDIR%%/htdocs/protected/Web/Pages/ClientList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/ClientList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/ClientView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/ClientView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/ConfigureHosts.page
%%WWWDIR%%/htdocs/protected/Web/Pages/ConfigureHosts.php
%%WWWDIR%%/htdocs/protected/Web/Pages/Console.page
%%WWWDIR%%/htdocs/protected/Web/Pages/Console.php
%%WWWDIR%%/htdocs/protected/Web/Pages/Dashboard.page
%%WWWDIR%%/htdocs/protected/Web/Pages/Dashboard.php
%%WWWDIR%%/htdocs/protected/Web/Pages/DeviceView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/DeviceView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/FileSetList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/FileSetList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/FileSetView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/FileSetView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/Graphs.page
%%WWWDIR%%/htdocs/protected/Web/Pages/Graphs.php
%%WWWDIR%%/htdocs/protected/Web/Pages/JobHistoryList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/JobHistoryList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/JobHistoryView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/JobHistoryView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/JobList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/JobList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/JobView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/JobView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/LoginPage.page
%%WWWDIR%%/htdocs/protected/Web/Pages/LoginPage.php
%%WWWDIR%%/htdocs/protected/Web/Pages/Monitor.php
%%WWWDIR%%/htdocs/protected/Web/Pages/NewJobWizard.page
%%WWWDIR%%/htdocs/protected/Web/Pages/NewJobWizard.php
%%WWWDIR%%/htdocs/protected/Web/Pages/NewResource.page
%%WWWDIR%%/htdocs/protected/Web/Pages/NewResource.php
%%WWWDIR%%/htdocs/protected/Web/Pages/OAuth2Redirect.php
%%WWWDIR%%/htdocs/protected/Web/Pages/PoolList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/PoolList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/PoolView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/PoolView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/Requirements.php
%%WWWDIR%%/htdocs/protected/Web/Pages/RestoreWizard.page
%%WWWDIR%%/htdocs/protected/Web/Pages/RestoreWizard.php
%%WWWDIR%%/htdocs/protected/Web/Pages/ScheduleList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/ScheduleList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/ScheduleStatusList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/ScheduleStatusList.tpl
%%WWWDIR%%/htdocs/protected/Web/Pages/ScheduleView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/ScheduleView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/Security.page
%%WWWDIR%%/htdocs/protected/Web/Pages/Security.php
%%WWWDIR%%/htdocs/protected/Web/Pages/SelectAPIHost.page
%%WWWDIR%%/htdocs/protected/Web/Pages/SelectAPIHost.php
%%WWWDIR%%/htdocs/protected/Web/Pages/StatisticsList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/StatisticsList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/StatisticsView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/StatisticsView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/StorageList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/StorageList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/StorageView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/StorageView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/VolumeList.page
%%WWWDIR%%/htdocs/protected/Web/Pages/VolumeList.php
%%WWWDIR%%/htdocs/protected/Web/Pages/VolumeView.page
%%WWWDIR%%/htdocs/protected/Web/Pages/VolumeView.php
%%WWWDIR%%/htdocs/protected/Web/Pages/WebConfigWizard.page
%%WWWDIR%%/htdocs/protected/Web/Pages/WebConfigWizard.php
%%WWWDIR%%/htdocs/protected/Web/Pages/config.xml
%%WWWDIR%%/htdocs/protected/Web/Portlets/BConditional.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigComponents.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigComponents.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigDirectives.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigDirectives.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigResourceList.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigResourceList.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigResources.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaConfigResources.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaHosts.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/BaculaHosts.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/Bconsole.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/Bconsole.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/BulkActionsModal.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/BulkActionsModal.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/ClientBandwidthLimit.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/ClientBandwidthLimit.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/ComponentActionsMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/ComponentActionsMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/ComponentListTemplate.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/ConfigListTemplate.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveCheckBox.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveCheckBox.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveComboBox.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveComboBox.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveControlTemplate.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveFileSet.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveFileSet.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveInteger.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveInteger.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveListBox.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveListBox.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveListTemplate.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveMessages.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveMessages.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveMultiComboBox.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveMultiComboBox.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveMultiTextBox.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveMultiTextBox.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectivePassword.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectivePassword.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveRenderer.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveRunscript.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveRunscript.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSchedule.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSchedule.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSetting.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSetting.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSize.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSize.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSpeed.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveSpeed.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveTemplate.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveTextBox.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveTextBox.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveTimePeriod.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/DirectiveTimePeriod.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/FileSetBrowser.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/FileSetBrowser.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/FileSetOptionRenderer.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/HostListTemplate.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/IDirectiveField.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/JobBandwidthLimit.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/JobBandwidthLimit.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/JobGraphs.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/JobGraphs.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/JobListFiles.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/JobListFiles.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/JobRunscriptRenderer.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/LabelVolume.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/LabelVolume.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/MainSideBar.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/MainSideBar.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/MessageTypes.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/MessageTypes.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/MsgEnvelope.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/MsgEnvelope.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewFileSetExcMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewFileSetExcMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewFileSetFileOptMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewFileSetFileOptMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewFileSetIncExcMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewFileSetIncExcMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewMessagesMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewMessagesMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewResourceMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewResourceMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewRunscriptMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewRunscriptMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewScheduleMenu.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/NewScheduleMenu.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/Portlets.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/ResourceListTemplate.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/RunJob.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/RunJob.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/StatusSchedule.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/StatusSchedule.tpl
%%WWWDIR%%/htdocs/protected/Web/Portlets/UpdateSlots.php
%%WWWDIR%%/htdocs/protected/Web/Portlets/UpdateSlots.tpl
%%WWWDIR%%/htdocs/protected/Web/endpoints.xml
@dir %%ETCDIR%%/Config/WEB
@dir %%WWWDIR%%/htdocs/framework
@dir %%WWWDIR%%/htdocs/protected/Common
@dir %%WWWDIR%%/htdocs/themes
@dir /var/cache/baculum
@dir /var/log/baculum