net-p2p/go-ethereum: Update to 1.9.0

* Remove no longer required patch "fdlimit_freebsd.go" as those changes have
  been merged by upstream.
* Add a pkg-message to give users some advice when upgrading from releases
  lower than 1.9.0. [1]

Changelog:

https://github.com/ethereum/go-ethereum/releases/tag/v1.9.0

PR:		239111
Submitted by:	Enrique Fynn <me@enriquefynn.com> (maintainer)
Approved by:	Enrique Fynn (maintainer) [1]
This commit is contained in:
Kai Knoblich 2019-07-22 11:36:10 +00:00
parent 041e4d3978
commit 27a2d8cffb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=507138
5 changed files with 19 additions and 17 deletions

View file

@ -2,7 +2,7 @@
PORTNAME= go-ethereum
DISTVERSIONPREFIX= v
DISTVERSION= 1.8.27
DISTVERSION= 1.9.0
CATEGORIES= net-p2p
MAINTAINER= me@enriquefynn.com
@ -30,7 +30,7 @@ do-install-DEVTOOLS-on:
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/bootnode ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/evm ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/rlpdump ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/swarm ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/clef ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/puppeth ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1558944912
SHA256 (ethereum-go-ethereum-v1.8.27_GH0.tar.gz) = 45d264106991d0e2a4c34ac5d6539fc9460c768fc70588ea38a25f467039ece8
SIZE (ethereum-go-ethereum-v1.8.27_GH0.tar.gz) = 10545102
TIMESTAMP = 1563666425
SHA256 (ethereum-go-ethereum-v1.9.0_GH0.tar.gz) = 94843ce7715ff2ce2ee4f463b09dbd9209303ad9aa8e5fad3381376b0f1a075d
SIZE (ethereum-go-ethereum-v1.9.0_GH0.tar.gz) = 16399034

View file

@ -1,11 +0,0 @@
--- common/fdlimit/fdlimit_freebsd.go.orig 2019-04-08 13:16:05 UTC
+++ common/fdlimit/fdlimit_freebsd.go
@@ -43,7 +43,7 @@ func Raise(max uint64) (uint64, error) {
if err := syscall.Getrlimit(syscall.RLIMIT_NOFILE, &limit); err != nil {
return 0, err
}
- return limit.Cur, nil
+ return uint64(limit.Cur), nil
}
// Current retrieves the number of file descriptors allowed to be opened by this

View file

@ -0,0 +1,13 @@
[
{
message: <<EOD
* It's recommended to make a backup as the v1.9.0 release contains database
schema changes, meaning it's not possible to downgrade once updated!
* It's also recommended to do a fresh fast sync as it can drastically reduce
the database size.
EOD
maximum_version: "1.9.0"
type: upgrade
}
]

View file

@ -3,5 +3,5 @@ bin/geth
%%DEVTOOLS%%bin/bootnode
%%DEVTOOLS%%bin/evm
%%DEVTOOLS%%bin/rlpdump
%%DEVTOOLS%%bin/swarm
%%DEVTOOLS%%bin/clef
%%DEVTOOLS%%bin/puppeth