Fix mtree issues caught by QAT
Approved by: wxs (mentor)
This commit is contained in:
parent
bb7addc507
commit
27ba6875c2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=232585
3 changed files with 22 additions and 38 deletions
|
@ -25,11 +25,16 @@ RUN_DEPENDS= ${SITE_PERL}/Exporter/Tidy.pm:${PORTSDIR}/devel/p5-Exporter-Tidy \
|
|||
${SITE_PERL}/Env/PS1.pm:${PORTSDIR}/devel/p5-Env-PS1
|
||||
|
||||
PERL_MODBUILD= yes
|
||||
CONFIGURE_ARGS= install_path=doc="${DOCSDIR}" \
|
||||
install_path=share="${DATADIR}" \
|
||||
CONFIGURE_ARGS= install_path=share="${DATADIR}" \
|
||||
install_path=share="${ETCDIR}"
|
||||
|
||||
PORTDOCS= *
|
||||
.if !defined(NOPORTDOCS)
|
||||
PORTDOCS= Changes README
|
||||
.endif
|
||||
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
PORTEXAMPLES= Menu.pl cpan.pl word_expansion.pl
|
||||
.endif
|
||||
|
||||
MAN1= zoid.1 zoiddevel.1 zoidfaq.1 zoiduser.1 zoidbuiltins.1
|
||||
MAN3= Bundle::Zoidberg.3 \
|
||||
|
@ -50,18 +55,21 @@ MAN3= Bundle::Zoidberg.3 \
|
|||
Zoidberg::Utils::GetOpt.3 \
|
||||
Zoidberg::Utils::Output.3
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-extract:
|
||||
.if defined(NOPORTDOCS)
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-MANIFEST
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD} ${PREFIX}/bin/zoid >> /etc/shells
|
||||
.if defined(NOPORTDOCS)
|
||||
${ECHO_CMD} "share/doc/zoidberg/README" >> ${TMPPLIST}
|
||||
${ECHO_CMD} "share/doc/zoidberg/Changes" >> ${TMPPLIST}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for file in ${PORTDOCS}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
.for file in ${PORTEXAMPLES}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/doc/examples/${file} ${EXAMPLESDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
--- MANIFEST.orig 2006-02-11 05:32:34.000000000 -0900
|
||||
+++ MANIFEST 2008-12-29 17:31:03.000000000 -0900
|
||||
@@ -9,12 +9,6 @@
|
||||
bin/AppRun
|
||||
bin/fluff
|
||||
Build.PL
|
||||
-Changes
|
||||
-configure
|
||||
-doc/examples/cpan.pl
|
||||
-doc/examples/Menu.pl
|
||||
-doc/examples/word_expansion.pl
|
||||
-doc/index.html
|
||||
etc/zoidrc
|
||||
lib/Bundle/Zoidberg.pm
|
||||
lib/Zoidberg.pm
|
||||
@@ -41,7 +35,6 @@
|
||||
man1/zoiduser.pod
|
||||
MANIFEST
|
||||
META.yml
|
||||
-README
|
||||
share/AppInfo.xml
|
||||
share/pixmaps/zoid16.png
|
||||
share/pixmaps/zoid32.png
|
|
@ -81,4 +81,3 @@ etc/zoidberg/plugins/ReadLine.pl
|
|||
@dirrm etc/zoidberg/plugins
|
||||
@dirrm etc/zoidberg/pixmaps
|
||||
@dirrm etc/zoidberg
|
||||
@dirrmtry %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue