- Fix build on AMD64

Approved by:	maintainer informed
This commit is contained in:
Kirill Ponomarev 2004-02-09 18:48:54 +00:00
parent c28a6eb18b
commit 27bfb5725e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100508
2 changed files with 7 additions and 3 deletions

View file

@ -35,5 +35,6 @@ VERSION=3.0
.endif
MAKE_ENV+= VERSION="${VERSION}" SONAME="${SONAME}"
CFLAGS+= -fPIC
.include <bsd.port.post.mk>

View file

@ -1,11 +1,14 @@
--- lib/des-private.h.orig Tue May 6 07:48:47 2003
+++ lib/des-private.h Tue May 6 07:28:57 2003
@@ -10,6 +10,9 @@
--- lib/des-private.h.orig Thu Sep 24 15:02:11 1998
+++ lib/des-private.h Mon Feb 9 19:41:07 2004
@@ -10,6 +10,12 @@
#ifdef i386
#define LITTLE_ENDIAN 1
#endif
+#ifdef __ia64
+#define LITTLE_ENDIAN 1
+#endif
+#ifdef __amd64
+#define LITTLE_ENDIAN 1
+#endif
#ifdef sun386
#define LITTLE_ENDIAN 1