[New port] chinese/fqterm: a Chinese BBS client
FQterm is a BBS client based on Qt4 libraries, supports Simplified and Traditional Chinese BBSs, and with full SSH2 support. PR: ports/124267 Submitted by: "Denise H. G." <darcsis@gmail.com>
This commit is contained in:
parent
25eabe0ac5
commit
27d77b0a30
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=216353
13 changed files with 354 additions and 0 deletions
|
@ -41,6 +41,7 @@
|
|||
SUBDIR += firebird
|
||||
SUBDIR += fireflyttf
|
||||
SUBDIR += fortunetw
|
||||
SUBDIR += fqterm
|
||||
SUBDIR += gb2jis
|
||||
SUBDIR += gb2ps
|
||||
SUBDIR += gbk2uni
|
||||
|
|
63
chinese/fqterm/Makefile
Normal file
63
chinese/fqterm/Makefile
Normal file
|
@ -0,0 +1,63 @@
|
|||
# New ports collection makefile for: fqterm
|
||||
# Date created: 1 Jun 2008
|
||||
# Whom: Denise H. G. <darcsis@gmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fqterm
|
||||
PORTVERSION= 0.9.3
|
||||
CATEGORIES= chinese
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMEPREFIX= zh-
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src-r569${SUTRACT_SUFFIX}
|
||||
|
||||
MAINTAINER= darcsis@gmail.com
|
||||
COMMENT= FQTerm is a BBS client for BSD/Linux
|
||||
|
||||
PKGINSTALL= ${WRKDIR}/pkg-install
|
||||
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
|
||||
SUB_FILES= pkg-install pkg-deinstall ${PORTNAME}.desktop
|
||||
USE_XORG= x11 ice xext xt xaw xpm xi xproto xextproto
|
||||
USE_ZIP= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= gui imageformats moc network qmake rcc script uic \
|
||||
codecs-cn codecs-tw codecs-jp codecs-kr qt3support \
|
||||
linguist
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_DOS2UNIX= src/ui/popwidget.cpp
|
||||
USE_GMAKE= yes
|
||||
USE_CMAKE= yes
|
||||
CMAKE_USE_PTHREAD= yes
|
||||
CMAKE_INSTALL_PREFIX= ${PREFIX}
|
||||
CMAKE_ARGS= -Wno-dev
|
||||
|
||||
DATADIR= ${PREFIX}/share/FQTerm
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC} && ${MKDIR} build
|
||||
@cd ${WRKSRC}/build && \
|
||||
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${WRKSRC}
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC}/build && ${GMAKE}
|
||||
|
||||
do-install:
|
||||
@cd ${WRKSRC}/build && ${GMAKE} install/strip
|
||||
@${MKDIR} ${PREFIX}/share/applications
|
||||
@${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop \
|
||||
${PREFIX}/share/applications
|
||||
|
||||
post-install:
|
||||
.if !defined(PACKAGE_BUILDING)
|
||||
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
chinese/fqterm/distinfo
Normal file
3
chinese/fqterm/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (fqterm-0.9.3-src-r569.zip) = c3a9956e0818c4f581aa83d9d2dff988
|
||||
SHA256 (fqterm-0.9.3-src-r569.zip) = 593107f8955e46eb7bffc109e2d0612f0bb3773e71d41a6bb028a62bf88c341d
|
||||
SIZE (fqterm-0.9.3-src-r569.zip) = 923120
|
13
chinese/fqterm/files/fqterm.desktop.in
Normal file
13
chinese/fqterm/files/fqterm.desktop.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
[Desktop Entry]
|
||||
Categories=Application;Network;
|
||||
Encoding=UTF-8
|
||||
Type=Application
|
||||
Name=FQTerm
|
||||
Exec=fqterm -caption "%c" %i %m %u
|
||||
GenericName=BBS Client
|
||||
GenericName[zh_CN]=BBS
|
||||
GenericName[zh_TW]=BBS
|
||||
Comment=BBS client based on Qt library in linux
|
||||
MimeTypes=
|
||||
Terminal=false
|
||||
Icon=%%PREFIX%%/share/pixmaps/fqterm.png
|
37
chinese/fqterm/files/patch-CMakeLists.txt.linux
Normal file
37
chinese/fqterm/files/patch-CMakeLists.txt.linux
Normal file
|
@ -0,0 +1,37 @@
|
|||
--- CMakeLists.txt.linux.orig 2008-05-19 17:36:29.000000000 +0800
|
||||
+++ CMakeLists.txt.linux 2008-06-21 08:50:58.000000000 +0800
|
||||
@@ -7,6 +7,7 @@
|
||||
endif(FQTERM_USE_STATIC_QT)
|
||||
|
||||
ADD_DEFINITIONS(-Wall)
|
||||
+ADD_DEFINITIONS(-D_OS_FREEBSD_)
|
||||
ADD_DEFINITIONS(-DFQTERM_VERSION_STRING="\\"${FQTERM_VERSION}\\"")
|
||||
|
||||
add_subdirectory(src)
|
||||
@@ -42,6 +43,18 @@
|
||||
${QT_PLUGINS_DIR}/codecs/libqtwcodecs.a
|
||||
jpeg
|
||||
)
|
||||
+else(FQTERM_USE_STATIC_QT)
|
||||
+ set(FQ_QT_SHARED_PLUGINS
|
||||
+ ${QT_PLUGINS_DIR}/imageformats/libqgif.so
|
||||
+ ${QT_PLUGINS_DIR}/imageformats/libqjpeg.so
|
||||
+ ${QT_PLUGINS_DIR}/imageformats/libqmng.so
|
||||
+ ${QT_PLUGINS_DIR}/imageformats/libqsvg.so
|
||||
+ ${QT_PLUGINS_DIR}/imageformats/libqtiff.so
|
||||
+ ${QT_PLUGINS_DIR}/codecs/libqcncodecs.so
|
||||
+ ${QT_PLUGINS_DIR}/codecs/libqjpcodecs.so
|
||||
+ ${QT_PLUGINS_DIR}/codecs/libqkrcodecs.so
|
||||
+ ${QT_PLUGINS_DIR}/codecs/libqtwcodecs.so
|
||||
+ )
|
||||
endif(FQTERM_USE_STATIC_QT)
|
||||
|
||||
target_link_libraries(fqterm.bin
|
||||
@@ -54,6 +67,7 @@
|
||||
${QT_QTNETWORK_LIBRARIES}
|
||||
${QT_QTSCRIPT_LIBRARIES}
|
||||
${FQ_QT_STATIC_PLUGINS}
|
||||
+ ${FQ_QT_SHARED_PLUGINS}
|
||||
${QT_LIBRARIES}
|
||||
${OPENSSL_LIBRARIES}
|
||||
)
|
11
chinese/fqterm/files/patch-cmake_FindQt4.cmake
Normal file
11
chinese/fqterm/files/patch-cmake_FindQt4.cmake
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- cmake/FindQt4.cmake.orig 2008-07-05 05:20:44.000000000 +0000
|
||||
+++ cmake/FindQt4.cmake 2008-07-05 05:20:52.000000000 +0000
|
||||
@@ -859,7 +859,7 @@
|
||||
)
|
||||
|
||||
FIND_PROGRAM(QT_LRELEASE_EXECUTABLE
|
||||
- NAMES lrelease
|
||||
+ NAMES lrelease-qt4
|
||||
PATHS ${QT_BINARY_DIR}
|
||||
NO_DEFAULT_PATH
|
||||
)
|
11
chinese/fqterm/files/patch-src_ui-fqterm_tool_button.h
Normal file
11
chinese/fqterm/files/patch-src_ui-fqterm_tool_button.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/ui/fqterm_tool_button.h.orig 2008-05-18 08:46:46.000000000 +0800
|
||||
+++ src/ui/fqterm_tool_button.h 2008-06-21 08:52:08.000000000 +0800
|
||||
@@ -21,7 +21,7 @@
|
||||
#ifndef FQTERM_TOOL_BUTTON_H
|
||||
#define FQTERM_TOOL_BUTTON_H
|
||||
|
||||
-#include <qtoolbutton.h>
|
||||
+#include <QToolButton>
|
||||
|
||||
namespace FQTerm {
|
||||
|
21
chinese/fqterm/files/patch-src_ui-popwidget.cpp
Normal file
21
chinese/fqterm/files/patch-src_ui-popwidget.cpp
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- src/ui/popwidget.cpp.orig 2008-05-18 08:46:46.000000000 +0800
|
||||
+++ src/ui/popwidget.cpp 2008-06-21 08:54:12.000000000 +0800
|
||||
@@ -20,13 +20,13 @@
|
||||
|
||||
#include "popwidget.h"
|
||||
|
||||
-#include <qpixmap.h>
|
||||
-#include <qapplication.h>
|
||||
+#include <QPixmap>
|
||||
+#include <QApplication>
|
||||
#if (QT_VERSION>=300)
|
||||
-#include <qdesktopwidget.h>
|
||||
+#include <QDesktopWidget>
|
||||
#endif
|
||||
-#include <qtimer.h>
|
||||
-#include <qlabel.h>
|
||||
+#include <QTimer>
|
||||
+#include <QLabel>
|
||||
|
||||
#include <QMouseEvent>
|
||||
#include <QPalette>
|
28
chinese/fqterm/files/pkg-deinstall.in
Normal file
28
chinese/fqterm/files/pkg-deinstall.in
Normal file
|
@ -0,0 +1,28 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
if [ "$2" != "POST-DEINSTALL" ]; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
TARGET_DIR=%%PREFIX%%/share/icons/hicolor
|
||||
|
||||
fqterm_icon=%%PREFIX%%/share/pixmaps/fqterm.png
|
||||
fqterm_icon_128=$TARGET_DIR/128x128/apps/fqterm_128x128.png
|
||||
fqterm_icon_64=$TARGET_DIR/64x64/apps/fqterm_64x64.png
|
||||
fqterm_icon_48=$TARGET_DIR/48x48/apps/fqterm_48x48.png
|
||||
fqterm_icon_32=$TARGET_DIR/32x32/apps//fqterm_32x32.png
|
||||
fqterm_icon_16=$TARGET_DIR/16x16/apps/fqterm_16x16.png
|
||||
|
||||
|
||||
|
||||
[ -h $fqterm_icon ] && rm -f $fqterm_icon
|
||||
[ -h $fqterm_icon_128 ] && rm -f $fqterm_icon_128
|
||||
[ -h $fqterm_icon_64 ] && rm -f $fqterm_icon_64
|
||||
[ -h $fqterm_icon_48 ] && rm -f $fqterm_icon_48
|
||||
[ -h $fqterm_icon_32 ] && rm -f $fqterm_icon_32
|
||||
[ -h $fqterm_icon_16 ] && rm -f $fqterm_icon_16
|
||||
|
||||
exit 0
|
26
chinese/fqterm/files/pkg-install.in
Normal file
26
chinese/fqterm/files/pkg-install.in
Normal file
|
@ -0,0 +1,26 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
if [ "$2" != "POST-INSTALL" ]; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
fqterm_icon=%%DATADIR%%/pic/fqterm.png
|
||||
fqterm_icon_128=%%DATADIR%%/pic/fqterm_128x128.png
|
||||
fqterm_icon_64=%%DATADIR%%/pic/fqterm_64x64.png
|
||||
fqterm_icon_48=%%DATADIR%%/pic/fqterm_48x48.png
|
||||
fqterm_icon_32=%%DATADIR%%/pic/fqterm_32x32.png
|
||||
fqterm_icon_16=%%DATADIR%%/pic/fqterm_16x16.png
|
||||
|
||||
TARGET_DIR=%%PREFIX%%/share/icons/hicolor
|
||||
|
||||
[ -f $fqterm_icon ] && ln -s $fqterm_icon %%PREFIX%%/share/pixmaps/
|
||||
[ -f $fqterm_icon_128 ] && ln -s $fqterm_icon_128 $TARGET_DIR/128x128/apps/
|
||||
[ -f $fqterm_icon_64 ] && ln -s $fqterm_icon_64 $TARGET_DIR/64x64/apps/
|
||||
[ -f $fqterm_icon_48 ] && ln -s $fqterm_icon_48 $TARGET_DIR/48x48/apps/
|
||||
[ -f $fqterm_icon_32 ] && ln -s $fqterm_icon_32 $TARGET_DIR/32x32/apps/
|
||||
[ -f $fqterm_icon_16 ] && ln -s $fqterm_icon_16 $TARGET_DIR/16x16/apps/
|
||||
|
||||
exit 0
|
5
chinese/fqterm/pkg-descr
Normal file
5
chinese/fqterm/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
FQTerm is a cross-platform terminal emulator program which supports
|
||||
telnet/ssh1/ssh2 protocols and can process ANSI control sequences. It
|
||||
can be used to login BBS sites or *NIX hosts.
|
||||
|
||||
WWW: http://fqterm.googlecode.com/
|
6
chinese/fqterm/pkg-message
Normal file
6
chinese/fqterm/pkg-message
Normal file
|
@ -0,0 +1,6 @@
|
|||
*************************************************************************
|
||||
If you want to enable the IP location detection feature, please
|
||||
download the IP location database file "QQWry.dat" and put a copy of
|
||||
it under "$HOME/.fqterm". You can get "QQWry.dat" from this
|
||||
project's home page or from other websites.
|
||||
*************************************************************************
|
129
chinese/fqterm/pkg-plist
Normal file
129
chinese/fqterm/pkg-plist
Normal file
|
@ -0,0 +1,129 @@
|
|||
bin/fqterm
|
||||
bin/fqterm.bin
|
||||
%%DATADIR%%/credits
|
||||
%%DATADIR%%/cursor/end.xpm
|
||||
%%DATADIR%%/cursor/enter.xpm
|
||||
%%DATADIR%%/cursor/exit.xpm
|
||||
%%DATADIR%%/cursor/hand.xpm
|
||||
%%DATADIR%%/cursor/home.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/end.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/enter.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/exit.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/hand.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/home.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/next.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/pagedown.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/pageup.xpm
|
||||
%%DATADIR%%/cursor/mac_16x16/prev.xpm
|
||||
%%DATADIR%%/cursor/next.xpm
|
||||
%%DATADIR%%/cursor/pagedown.xpm
|
||||
%%DATADIR%%/cursor/pageup.xpm
|
||||
%%DATADIR%%/cursor/prev.xpm
|
||||
%%DATADIR%%/default_font.conf
|
||||
%%DATADIR%%/dict/fqterm_zh_CN.ts
|
||||
%%DATADIR%%/dict/ui_zh_CN.ts
|
||||
%%DATADIR%%/fqterm.desktop.in
|
||||
%%DATADIR%%/fqterm.icns
|
||||
%%DATADIR%%/fqterm.sh
|
||||
%%DATADIR%%/pic/address_book.png
|
||||
%%DATADIR%%/pic/ansi_color.png
|
||||
%%DATADIR%%/pic/anti_idle.png
|
||||
%%DATADIR%%/pic/auto_reconnect.png
|
||||
%%DATADIR%%/pic/auto_reply.png
|
||||
%%DATADIR%%/pic/beep.png
|
||||
%%DATADIR%%/pic/change_fonts.png
|
||||
%%DATADIR%%/pic/connect.png
|
||||
%%DATADIR%%/pic/copy.png
|
||||
%%DATADIR%%/pic/copy_with_color.png
|
||||
%%DATADIR%%/pic/disconnect.png
|
||||
%%DATADIR%%/pic/fqterm.png
|
||||
%%DATADIR%%/pic/fqterm_128x128.ico
|
||||
%%DATADIR%%/pic/fqterm_128x128.png
|
||||
%%DATADIR%%/pic/fqterm_16x16.ico
|
||||
%%DATADIR%%/pic/fqterm_16x16.png
|
||||
%%DATADIR%%/pic/fqterm_256x256.ico
|
||||
%%DATADIR%%/pic/fqterm_256x256.png
|
||||
%%DATADIR%%/pic/fqterm_32x32.ico
|
||||
%%DATADIR%%/pic/fqterm_32x32.png
|
||||
%%DATADIR%%/pic/fqterm_48x48.ico
|
||||
%%DATADIR%%/pic/fqterm_48x48.png
|
||||
%%DATADIR%%/pic/fqterm_64x64.ico
|
||||
%%DATADIR%%/pic/fqterm_64x64.png
|
||||
%%DATADIR%%/pic/fqterm_tray.png
|
||||
%%DATADIR%%/pic/get_article_fulltext.png
|
||||
%%DATADIR%%/pic/image_viewer.png
|
||||
%%DATADIR%%/pic/messagebox_critical.png
|
||||
%%DATADIR%%/pic/messagebox_info.png
|
||||
%%DATADIR%%/pic/messagebox_warning.png
|
||||
%%DATADIR%%/pic/mouse.png
|
||||
%%DATADIR%%/pic/paste.png
|
||||
%%DATADIR%%/pic/popwidget.png
|
||||
%%DATADIR%%/pic/preferences.png
|
||||
%%DATADIR%%/pic/quick_login.png
|
||||
%%DATADIR%%/pic/rectangle_selection.png
|
||||
%%DATADIR%%/pic/refresh.png
|
||||
%%DATADIR%%/pic/setup_shortcuts.png
|
||||
%%DATADIR%%/pic/shadow.png
|
||||
%%DATADIR%%/pic/tabpad.png
|
||||
%%DATADIR%%/pic/view_messages.png
|
||||
%%DATADIR%%/pic/ViewerButtons/adjustsize.png
|
||||
%%DATADIR%%/pic/ViewerButtons/next.png
|
||||
%%DATADIR%%/pic/ViewerButtons/open.png
|
||||
%%DATADIR%%/pic/ViewerButtons/prev.png
|
||||
%%DATADIR%%/pic/ViewerButtons/zoomin.png
|
||||
%%DATADIR%%/pic/ViewerButtons/zoomout.png
|
||||
%%DATADIR%%/schema/default.schema
|
||||
%%DATADIR%%/schema/Linux.schema
|
||||
%%DATADIR%%/schema/Softness.schema
|
||||
%%DATADIR%%/schema/VIM.schema
|
||||
%%DATADIR%%/schema/XTerm.schema
|
||||
%%DATADIR%%/skin/dpstyle/dpstyle.qss
|
||||
%%DATADIR%%/skin/dpstyle/image/checkbox_checked.png
|
||||
%%DATADIR%%/skin/dpstyle/image/checkbox_checked_hover.png
|
||||
%%DATADIR%%/skin/dpstyle/image/checkbox_checked_pressed.png
|
||||
%%DATADIR%%/skin/dpstyle/image/checkbox_unchecked.png
|
||||
%%DATADIR%%/skin/dpstyle/image/checkbox_unchecked_hover.png
|
||||
%%DATADIR%%/skin/dpstyle/image/checkbox_unchecked_pressed.png
|
||||
%%DATADIR%%/skin/dpstyle/image/down_arrow.png
|
||||
%%DATADIR%%/skin/dpstyle/image/down_arrow_disabled.png
|
||||
%%DATADIR%%/skin/dpstyle/image/frame.png
|
||||
%%DATADIR%%/skin/dpstyle/image/pagefold.png
|
||||
%%DATADIR%%/skin/dpstyle/image/pushbutton.png
|
||||
%%DATADIR%%/skin/dpstyle/image/pushbutton_hover.png
|
||||
%%DATADIR%%/skin/dpstyle/image/pushbutton_pressed.png
|
||||
%%DATADIR%%/skin/dpstyle/image/radiobutton_checked.png
|
||||
%%DATADIR%%/skin/dpstyle/image/radiobutton_checked_hover.png
|
||||
%%DATADIR%%/skin/dpstyle/image/radiobutton_checked_pressed.png
|
||||
%%DATADIR%%/skin/dpstyle/image/radiobutton_unchecked.png
|
||||
%%DATADIR%%/skin/dpstyle/image/radiobutton_unchecked_hover.png
|
||||
%%DATADIR%%/skin/dpstyle/image/radiobutton_unchecked_pressed.png
|
||||
%%DATADIR%%/skin/dpstyle/image/sizegrip.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spindown.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spindown_hover.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spindown_off.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spindown_pressed.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spinup.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spinup_hover.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spinup_off.png
|
||||
%%DATADIR%%/skin/dpstyle/image/spinup_pressed.png
|
||||
%%DATADIR%%/skin/dpstyle/image/up_arrow.png
|
||||
%%DATADIR%%/skin/dpstyle/image/up_arrow_disabled.png
|
||||
%%DATADIR%%/skin/dpstyle/ReadMe.txt
|
||||
%%DATADIR%%/userconf/address.cfg.orig
|
||||
%%DATADIR%%/userconf/fqterm.cfg.orig
|
||||
%%DATADIR%%/userconf/language.cfg.orig
|
||||
%%DATADIR%%/userconf/README.txt
|
||||
%%DATADIR%%/dict/fqterm_zh_CN.qm
|
||||
%%DATADIR%%/dict/ui_zh_CN.qm
|
||||
share/applications/fqterm.desktop
|
||||
@dirrm %%DATADIR%%/cursor/mac_16x16
|
||||
@dirrm %%DATADIR%%/cursor
|
||||
@dirrm %%DATADIR%%/dict
|
||||
@dirrm %%DATADIR%%/pic/ViewerButtons
|
||||
@dirrm %%DATADIR%%/pic
|
||||
@dirrm %%DATADIR%%/schema
|
||||
@dirrm %%DATADIR%%/skin/dpstyle/image
|
||||
@dirrm %%DATADIR%%/skin/dpstyle
|
||||
@dirrm %%DATADIR%%/skin
|
||||
@dirrm %%DATADIR%%/userconf
|
||||
@dirrm %%DATADIR%%/
|
Loading…
Reference in a new issue