databases/py-bsddb3: update 6.0.1 -> 6.1.0
PR: 192988 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com> Reviewed by: marino (mentor) Approved by: implicit (mentors)
This commit is contained in:
parent
41729a405d
commit
27d9c2c368
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=367188
3 changed files with 17 additions and 17 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bsddb3
|
||||
PORTVERSION= 6.0.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 6.1.0
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -13,10 +12,9 @@ COMMENT= Python extension module for BerkeleyDB 3 and 4
|
|||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
USE_BDB= 43+
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_AUTOPLIST= yes
|
||||
USE_BDB= yes
|
||||
USES= python
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
PYDISTUTILS_CONFIGUREARGS=--libs="-l${BDB_LIB_NAME}" --berkeley-db=${LOCALBASE}
|
||||
PYDISTUTILS_BUILDARGS= --libs="-l${BDB_LIB_NAME}" --berkeley-db=${LOCALBASE}
|
||||
|
@ -33,5 +31,6 @@ post-patch:
|
|||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
|
||||
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/bsddb3/_pybsddb.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (bsddb3-6.0.1.tar.gz) = abc34d83d6cbb40f1626ecc2b62e8163ba204f4bb6a65c23b125a171d224bf6d
|
||||
SIZE (bsddb3-6.0.1.tar.gz) = 347002
|
||||
SHA256 (bsddb3-6.1.0.tar.gz) = b13163e3891c32390aea66edcf7880eb245abc89199a766b7b1907fc5c1efd15
|
||||
SIZE (bsddb3-6.1.0.tar.gz) = 340966
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- setup2.py.orig 2011-03-08 22:16:14.000000000 +0800
|
||||
+++ setup2.py 2011-03-15 16:00:42.000000000 +0800
|
||||
@@ -86,10 +86,7 @@
|
||||
@@ -86,11 +86,7 @@
|
||||
category=DeprecationWarning)
|
||||
|
||||
|
||||
|
@ -8,11 +8,12 @@
|
|||
- from setuptools import setup, Extension
|
||||
-except :
|
||||
- from distutils.core import setup, Extension
|
||||
-
|
||||
+from distutils.core import setup, Extension
|
||||
|
||||
from distutils.dep_util import newer
|
||||
import distutils.ccompiler
|
||||
@@ -292,8 +289,8 @@
|
||||
|
||||
@@ -295,8 +291,8 @@
|
||||
incdir = os.path.join(BERKELEYDB_DIR, 'include')
|
||||
if not libdir:
|
||||
libdir = os.path.join(BERKELEYDB_DIR, 'lib')
|
||||
|
@ -23,12 +24,12 @@
|
|||
else:
|
||||
if debug: print "LIBS already contains '-ldb' not adding our own", "'-l"+dblib+"'"
|
||||
libname = []
|
||||
@@ -332,7 +329,7 @@
|
||||
|
||||
@@ -336,7 +332,7 @@
|
||||
# read db.h to figure out what version of Berkeley DB this is
|
||||
ver = None
|
||||
- db_h_lines = open(os.path.join(incdir, 'db.h'), 'r').readlines()
|
||||
+ db_h_lines = open('%%BDB_INCLUDE_DIR%%/db.h', 'r').readlines()
|
||||
# This should move to "with" when we drop support for Python 2.4 and 2.5
|
||||
- f = open(os.path.join(incdir, 'db.h'), 'r')
|
||||
+ f = open('%%BDB_INCLUDE_DIR%%/db.h', 'r')
|
||||
db_h_lines = f.readlines()
|
||||
f.close()
|
||||
db_ver_re = re.compile(
|
||||
r'^#define\s+DB_VERSION_STRING\s.*Berkeley DB (\d+\.\d+).*')
|
||||
db_ver2 = db_ver
|
||||
|
|
Loading…
Reference in a new issue