- Update to 0.11.0

The storage was moved to sqlite database! Follow steps in UPDATING.

PR:		ports/96301
Submitted by:	Alastair Rankine <arsptr@optusnet.com.au> (maintainer)
This commit is contained in:
Pav Lucistnik 2006-05-01 14:32:28 +00:00
parent 25d521c0a9
commit 27dfc6465a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161065
7 changed files with 1152 additions and 973 deletions

View file

@ -6,39 +6,40 @@
#
PORTNAME= instiki
PORTVERSION= 0.10.2
PORTREVISION= 2
PORTVERSION= 0.11.0
CATEGORIES= www ruby
MASTER_SITES= http://rubyforge.lauschmusik.de/instiki/ \
http://rubyforge.planetargon.com/instiki/ \
http://rubyforge.rubyuser.de/instiki/
MASTER_SITES= http://rubyforge.org/frs/download.php/9296/
EXTRACT_SUFX= .tgz
MAINTAINER= arsptr@optusnet.com.au
COMMENT= Easy to set up wiki clone implemented in ruby
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/sqlite3_api.so:${PORTSDIR}/databases/ruby-sqlite3
BUILD_DEPENDS+= ${RUN_DEPENDS} rake:${PORTSDIR}/devel/rubygem-rake
PATCH_DEPENDS= ${BUILD_DEPENDS}
NO_BUILD= yes
USE_RUBY= yes
USE_RUBY_FEATURES= 1.8
INSTIKIDIR?= instiki
PLIST_SUB= INSTIKIDIR=${INSTIKIDIR}/
USE_RC_SUBR= ${PORTNAME}
SED_LIST+= -e 's,%%INSTIKIDIR%%,${INSTIKIDIR},g' \
-e 's,%%INSTIKIPORT%%,${INSTIKIPORT},g' \
-e 's,%%RUBY_WITH_SUFFIX%%,${RUBY_WITH_SUFFIX},g'
RUBY_SHEBANG_FILES=instiki
INSTIKIPORT?= 2500
USE_RC_SUBR= ${PORTNAME}
PLIST_SUB= INSTIKIDIR=${INSTIKIDIR}/
SUB_LIST+= INSTIKIDIR=${INSTIKIDIR} \
INSTIKIPORT=${INSTIKIPORT} \
RUBY_WITH_SUFFIX=${RUBY_WITH_SUFFIX}
SUB_FILES+= pkg-deinstall
RUBY_SHEBANG_FILES=instiki
post-patch:
@${FIND} ${WRKSRC} -name '*.orig' -delete
( cd ${WRKSRC}/db/ && \
rake environment RAILS_ENV=production migrate )
do-install:
${CP} -pR ${WRKSRC}/ ${PREFIX}/${INSTIKIDIR}
${MKDIR} ${PREFIX}/${INSTIKIDIR}/storage/${INSTIKIPORT}
${CP} ${PREFIX}/${INSTIKIDIR}/db/production.db.sqlite3 ${PREFIX}/${INSTIKIDIR}/db/default.db.sqlite3
${CHMOD} +x ${PREFIX}/${INSTIKIDIR}/instiki
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (instiki-0.10.2.tgz) = a6bc31dff04b7c5d29be091bff00c599
SHA256 (instiki-0.10.2.tgz) = 22fc8a00b3ded2c981ab2d671afb12c75aca2cb614638f06343380ba615040c6
SIZE (instiki-0.10.2.tgz) = 988302
MD5 (instiki-0.11.0.tgz) = c8d86d05ef9a801e21e12d661fc737ab
SHA256 (instiki-0.11.0.tgz) = 4bc1315c73ecf2dbaef9c243b5073aa49ca3ea2c64a61c54b8fd57e4baf039ce
SIZE (instiki-0.11.0.tgz) = 1483964

View file

@ -6,7 +6,7 @@
# Add the following line to /etc/rc.conf[.local] to enable instiki:
# instiki_enable (bool): Set to "NO" by default
# Set it to "YES" to enable instiki
# instiki_flags (str): Set to "--port %%INSTIKIPORT%% --storage %%PREFIX%%/%%INSTIKIDIR%%/storage --daemon" by default.
# instiki_flags (str): Set to "--port %%INSTIKIPORT%% --daemon" by default.
# Extra flags passed to start command
#
@ -20,9 +20,12 @@ rcvar=${name}_enable
command="%%PREFIX%%/%%INSTIKIDIR%%/instiki"
command_interpreter="%%RUBY_WITH_SUFFIX%%"
: ${doormand_enable="NO"}
: ${instiki_flags="--port %%INSTIKIPORT%% --storage %%PREFIX%%/%%INSTIKIDIR%%/storage --daemon"}
: ${instiki_enable="NO"}
: ${instiki_flags="--port %%INSTIKIPORT%% --daemon"}
sig_stop=-TERM
sig_stop=-KILL
load_rc_config $name
run_rc_command "$1"

View file

@ -1,14 +0,0 @@
--- vendor/rails/activesupport/lib/active_support/clean_logger.rb.orig 2005-09-21 00:31:08.000000000 -0700
+++ vendor/rails/activesupport/lib/active_support/clean_logger.rb 2005-09-21 00:45:36.000000000 -0700
@@ -10,7 +10,9 @@
end
private
- remove_const "Format"
+ if const_defined?(:Format) # Not defined in Ruby 1.8.3
+ remove_const "Format"
+ end
Format = "%s\n"
def format_message(severity, timestamp, msg, progname)
Format % [msg]
--- patch-as_clean_logger_rb ends here ---

View file

@ -0,0 +1,18 @@
#!/bin/sh
#
if [ "$2" != "DEINSTALL" ]; then
exit 0
fi
echo "comparing databases in %%PREFIX%%/%%INSTIKIDIR%%/db"
cd %%PREFIX%%/%%INSTIKIDIR%%/db || exit 1
if ! cmp -s -z production.db.sqlite3 default.db.sqlite3; then
echo "production.db.sqlite3 changed from default, not removing"
else
echo "production.db.sqlite3 unchanged from default, removing"
rm production.db.sqlite3
fi
exit 0

View file

@ -1,8 +1,4 @@
Instiki is a wiki clone implemented in ruby with no dependencies
other than ruby-1.8.1 or greater. Instiki was written and is
maintained by David Heinemeier Hansson. Homepage is
Textile- and Markdown- based Wiki with its own webserver and SQLite
database, which makes for simple installation and running.
WWW: http://www.instiki.org/show/HomePage
- Kelley Reynolds
kelley@insidesystems.net

File diff suppressed because it is too large Load diff