Add libgsasl 1.8.1 (split from gsasl)

- Add LICENSE
- Add GSSAPI_BASE, GSSAPI_HEIMDAL, GSSAPI_MIT and GSSAPI_NONE options

GNU SASL has been split into 2 ports:
- security/gsasl: the command-line utility
- security/libgsasl: the library
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2020-02-23 08:12:22 +00:00
parent 9587f90811
commit 2814c003e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=526901
8 changed files with 308 additions and 0 deletions

View file

@ -288,6 +288,7 @@
SUBDIR += libgnome-keyring
SUBDIR += libgpg-error
SUBDIR += libgringotts
SUBDIR += libgsasl
SUBDIR += libhijack
SUBDIR += libident
SUBDIR += libkleo

View file

@ -0,0 +1,49 @@
# Created by: ijliao
# $FreeBSD$
PORTNAME= gsasl
PORTVERSION= 1.8.1
CATEGORIES= security
MASTER_SITES= GNU
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= GNU SASL library
LICENSE= LGPL21
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgnutls.so:security/gnutls \
libidn.so:dns/libidn \
libntlm.so:security/libntlm
USES= charsetfix libtool pathfix pkgconfig ssl
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS NLS
OPTIONS_DEFAULT=GSSAPI_BASE
OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
OPTIONS_SUB= yes
GSSAPI_BASE_CONFIGURE_ON= --with-gssapi-impl=heimdal ${GSSAPI_CONFIGURE_ARGS}
GSSAPI_BASE_USES= gssapi
GSSAPI_HEIMDAL_CONFIGURE_WITH= --with-gssapi-impl=heimdal ${GSSAPI_CONFIGURE_ARGS}
GSSAPI_HEIMDAL_USES= gssapi:heimdal
GSSAPI_MIT_CONFIGURE_ON=--with-gssapi-impl=mit ${GSSAPI_CONFIGURE_ARGS}
GSSAPI_MIT_USES= gssapi:mit
GSSAPI_NONE_CONFIGURE_ON= --disable-gssapi
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
post-patch:
@${REINPLACE_CMD} -e '/^en@/d' ${WRKSRC}/lib/po/LINGUAS
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${DOCSDIR}/reference
${INSTALL_DATA} ${WRKSRC}/doc/reference/html/* ${STAGEDIR}${DOCSDIR}/reference
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1578125691
SHA256 (gsasl-1.8.1.tar.gz) = 4dda162a511976bfef14ad1fecd7733719dfd9c361b5d09dc8414ea9d472d8d2
SIZE (gsasl-1.8.1.tar.gz) = 5774550

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig 2019-08-02 11:28:31 UTC
+++ Makefile.in
@@ -1474,7 +1474,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = lib po gl src examples tests doc gltests
+SUBDIRS = lib gl examples tests doc gltests # po src
EXTRA_DIST = cfg.mk maint.mk .clcopying
ACLOCAL_AMFLAGS = -I m4
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-obsolete --with-gssapi-impl=no

View file

@ -0,0 +1,20 @@
--- configure.orig 2019-08-02 11:28:29 UTC
+++ configure
@@ -46537,7 +46537,7 @@ export WARN_CFLAGS
subdirs="$subdirs lib"
-ac_config_files="$ac_config_files Makefile doc/Makefile doc/cyclo/Makefile doc/doxygen/Doxyfile doc/reference/Makefile doc/reference/version.xml examples/Makefile examples/openid20/Makefile examples/saml20/Makefile gl/Makefile gltests/Makefile po/Makefile.in src/Makefile tests/Makefile"
+ac_config_files="$ac_config_files Makefile doc/Makefile doc/cyclo/Makefile doc/doxygen/Doxyfile doc/reference/Makefile doc/reference/version.xml examples/Makefile examples/openid20/Makefile examples/saml20/Makefile gl/Makefile gltests/Makefile tests/Makefile"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -47720,8 +47720,6 @@ do
"examples/saml20/Makefile") CONFIG_FILES="$CONFIG_FILES examples/saml20/Makefile" ;;
"gl/Makefile") CONFIG_FILES="$CONFIG_FILES gl/Makefile" ;;
"gltests/Makefile") CONFIG_FILES="$CONFIG_FILES gltests/Makefile" ;;
- "po/Makefile.in") CONFIG_FILES="$CONFIG_FILES po/Makefile.in" ;;
- "src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
"tests/Makefile") CONFIG_FILES="$CONFIG_FILES tests/Makefile" ;;
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;

View file

@ -0,0 +1,36 @@
--- doc/Makefile.in.orig 2020-01-17 05:17:36 UTC
+++ doc/Makefile.in
@@ -288,13 +288,13 @@ AM_V_texidevnull = $(am__v_texidevnull_@AM_V@)
am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
-INFO_DEPS = $(srcdir)/gsasl.info
+INFO_DEPS =
TEXINFO_TEX = $(top_srcdir)/lib/build-aux/texinfo.tex
am__TEXINFO_TEX_DIR = $(top_srcdir)/lib/build-aux
DVIS = gsasl.dvi
PDFS = gsasl.pdf
PSS = gsasl.ps
-HTMLS = gsasl.html
+HTMLS =
TEXINFOS = gsasl.texi
TEXI2PDF = $(TEXI2DVI) --pdf --batch
MAKEINFOHTML = $(MAKEINFO) --html
@@ -1552,7 +1552,7 @@ top_srcdir = @top_srcdir@
SUBDIRS = cyclo $(am__append_1)
EXTRA_DIST = gdoc \
controlflow.dia controlflow2.dia abstraction.dia \
- gsasl.html gsasl.ps gsasl.pdf texinfo.css \
+ texinfo.css \
doxygen/Doxyfile.in doxygen/gdoc2doxygen
info_TEXINFOS = gsasl.texi
@@ -1577,7 +1577,7 @@ TEXI2DVI = texi2dvi $(AM_MAKEINFOFLAGS)
AM_MAKEINFOHTMLFLAGS = $(AM_MAKEINFOFLAGS) \
--no-split --number-sections --css-include=texinfo.css
-dist_man_MANS = gsasl.1 $(gdoc_MANS)
+dist_man_MANS = $(gdoc_MANS)
MAINTAINERCLEANFILES = $(dist_man_MANS)
gdoc_MANS = man/gsasl_base64_to.3 man/gsasl_base64_from.3 \
man/gsasl_callback_set.3 man/gsasl_callback.3 \

View file

@ -0,0 +1,20 @@
GNU SASL is an implementation of the Simple Authentication and Security Layer
framework and a few common SASL mechanisms.
GNU SASL consists of a library (libgsasl), a command-line utility (gsasl) to
access the library from the shell, and a manual. The library includes support
for the framework (with authentication functions and application data privacy
and integrity functions) and at least partial support for the ANONYMOUS,
CRAM-MD5, DIGEST-MD5, EXTERNAL, GS2-KRB5, GSSAPI, LOGIN, NTLM, PLAIN,
SCRAM-SHA-1, SCRAM-SHA-1-PLUS, SAML20, OPENID20, and SECURID mechanisms.
The library is easily ported because it does not do network communication by
itself, but rather leaves it up to the calling application. The library is
flexible with regards to the authorization infrastructure used, as it utilizes a
callback into the application to decide whether a user is authorized or not.
GNU SASL has been split into 2 ports:
- security/gsasl: the command-line utility
- security/libgsasl: the library
WWW: https://www.gnu.org/software/gsasl/

168
security/libgsasl/pkg-plist Normal file
View file

@ -0,0 +1,168 @@
include/gsasl-compat.h
include/gsasl-mech.h
include/gsasl.h
lib/libgsasl.a
lib/libgsasl.so
lib/libgsasl.so.7
lib/libgsasl.so.7.9.7
libdata/pkgconfig/libgsasl.pc
man/man3/gsasl_appinfo_get.3.gz
man/man3/gsasl_appinfo_set.3.gz
man/man3/gsasl_application_data_get.3.gz
man/man3/gsasl_application_data_set.3.gz
man/man3/gsasl_base64_decode.3.gz
man/man3/gsasl_base64_encode.3.gz
man/man3/gsasl_base64_from.3.gz
man/man3/gsasl_base64_to.3.gz
man/man3/gsasl_callback.3.gz
man/man3/gsasl_callback_hook_get.3.gz
man/man3/gsasl_callback_hook_set.3.gz
man/man3/gsasl_callback_set.3.gz
man/man3/gsasl_check_version.3.gz
man/man3/gsasl_client_application_data_get.3.gz
man/man3/gsasl_client_application_data_set.3.gz
man/man3/gsasl_client_callback_anonymous_get.3.gz
man/man3/gsasl_client_callback_anonymous_set.3.gz
man/man3/gsasl_client_callback_authentication_id_get.3.gz
man/man3/gsasl_client_callback_authentication_id_set.3.gz
man/man3/gsasl_client_callback_authorization_id_get.3.gz
man/man3/gsasl_client_callback_authorization_id_set.3.gz
man/man3/gsasl_client_callback_maxbuf_get.3.gz
man/man3/gsasl_client_callback_maxbuf_set.3.gz
man/man3/gsasl_client_callback_passcode_get.3.gz
man/man3/gsasl_client_callback_passcode_set.3.gz
man/man3/gsasl_client_callback_password_get.3.gz
man/man3/gsasl_client_callback_password_set.3.gz
man/man3/gsasl_client_callback_pin_get.3.gz
man/man3/gsasl_client_callback_pin_set.3.gz
man/man3/gsasl_client_callback_qop_get.3.gz
man/man3/gsasl_client_callback_qop_set.3.gz
man/man3/gsasl_client_callback_realm_get.3.gz
man/man3/gsasl_client_callback_realm_set.3.gz
man/man3/gsasl_client_callback_service_get.3.gz
man/man3/gsasl_client_callback_service_set.3.gz
man/man3/gsasl_client_ctx_get.3.gz
man/man3/gsasl_client_finish.3.gz
man/man3/gsasl_client_listmech.3.gz
man/man3/gsasl_client_mechlist.3.gz
man/man3/gsasl_client_start.3.gz
man/man3/gsasl_client_step.3.gz
man/man3/gsasl_client_step_base64.3.gz
man/man3/gsasl_client_suggest_mechanism.3.gz
man/man3/gsasl_client_support_p.3.gz
man/man3/gsasl_ctx_get.3.gz
man/man3/gsasl_decode.3.gz
man/man3/gsasl_decode_inline.3.gz
man/man3/gsasl_done.3.gz
man/man3/gsasl_encode.3.gz
man/man3/gsasl_encode_inline.3.gz
man/man3/gsasl_finish.3.gz
man/man3/gsasl_free.3.gz
man/man3/gsasl_hmac_md5.3.gz
man/man3/gsasl_hmac_sha1.3.gz
man/man3/gsasl_init.3.gz
man/man3/gsasl_md5.3.gz
man/man3/gsasl_md5pwd_get_password.3.gz
man/man3/gsasl_mechanism_name.3.gz
man/man3/gsasl_nonce.3.gz
man/man3/gsasl_property_fast.3.gz
man/man3/gsasl_property_get.3.gz
man/man3/gsasl_property_set.3.gz
man/man3/gsasl_property_set_raw.3.gz
man/man3/gsasl_random.3.gz
man/man3/gsasl_randomize.3.gz
man/man3/gsasl_register.3.gz
man/man3/gsasl_saslprep.3.gz
man/man3/gsasl_server_application_data_get.3.gz
man/man3/gsasl_server_application_data_set.3.gz
man/man3/gsasl_server_callback_anonymous_get.3.gz
man/man3/gsasl_server_callback_anonymous_set.3.gz
man/man3/gsasl_server_callback_cipher_get.3.gz
man/man3/gsasl_server_callback_cipher_set.3.gz
man/man3/gsasl_server_callback_cram_md5_get.3.gz
man/man3/gsasl_server_callback_cram_md5_set.3.gz
man/man3/gsasl_server_callback_digest_md5_get.3.gz
man/man3/gsasl_server_callback_digest_md5_set.3.gz
man/man3/gsasl_server_callback_external_get.3.gz
man/man3/gsasl_server_callback_external_set.3.gz
man/man3/gsasl_server_callback_gssapi_get.3.gz
man/man3/gsasl_server_callback_gssapi_set.3.gz
man/man3/gsasl_server_callback_maxbuf_get.3.gz
man/man3/gsasl_server_callback_maxbuf_set.3.gz
man/man3/gsasl_server_callback_qop_get.3.gz
man/man3/gsasl_server_callback_qop_set.3.gz
man/man3/gsasl_server_callback_realm_get.3.gz
man/man3/gsasl_server_callback_realm_set.3.gz
man/man3/gsasl_server_callback_retrieve_get.3.gz
man/man3/gsasl_server_callback_retrieve_set.3.gz
man/man3/gsasl_server_callback_securid_get.3.gz
man/man3/gsasl_server_callback_securid_set.3.gz
man/man3/gsasl_server_callback_service_get.3.gz
man/man3/gsasl_server_callback_service_set.3.gz
man/man3/gsasl_server_callback_validate_get.3.gz
man/man3/gsasl_server_callback_validate_set.3.gz
man/man3/gsasl_server_ctx_get.3.gz
man/man3/gsasl_server_finish.3.gz
man/man3/gsasl_server_listmech.3.gz
man/man3/gsasl_server_mechlist.3.gz
man/man3/gsasl_server_start.3.gz
man/man3/gsasl_server_step.3.gz
man/man3/gsasl_server_step_base64.3.gz
man/man3/gsasl_server_suggest_mechanism.3.gz
man/man3/gsasl_server_support_p.3.gz
man/man3/gsasl_session_hook_get.3.gz
man/man3/gsasl_session_hook_set.3.gz
man/man3/gsasl_sha1.3.gz
man/man3/gsasl_simple_getpass.3.gz
man/man3/gsasl_step.3.gz
man/man3/gsasl_step64.3.gz
man/man3/gsasl_strerror.3.gz
man/man3/gsasl_strerror_name.3.gz
man/man3/gsasl_stringprep_nfkc.3.gz
man/man3/gsasl_stringprep_saslprep.3.gz
man/man3/gsasl_stringprep_trace.3.gz
%%PORTDOCS%%%%DOCSDIR%%/reference/abstraction.png
%%PORTDOCS%%%%DOCSDIR%%/reference/api-index-full.html
%%PORTDOCS%%%%DOCSDIR%%/reference/controlflow.png
%%PORTDOCS%%%%DOCSDIR%%/reference/controlflow2.png
%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl-gsasl-compat.html
%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl-gsasl-mech.html
%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl-gsasl.html
%%PORTDOCS%%%%DOCSDIR%%/reference/gsasl.devhelp2
%%PORTDOCS%%%%DOCSDIR%%/reference/home.png
%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
%%PORTDOCS%%%%DOCSDIR%%/reference/intro.html
%%PORTDOCS%%%%DOCSDIR%%/reference/ix02.html
%%PORTDOCS%%%%DOCSDIR%%/reference/ix03.html
%%PORTDOCS%%%%DOCSDIR%%/reference/ix04.html
%%PORTDOCS%%%%DOCSDIR%%/reference/ix05.html
%%PORTDOCS%%%%DOCSDIR%%/reference/ix06.html
%%PORTDOCS%%%%DOCSDIR%%/reference/ix07.html
%%PORTDOCS%%%%DOCSDIR%%/reference/ix08.html
%%PORTDOCS%%%%DOCSDIR%%/reference/left-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/reference/left.png
%%PORTDOCS%%%%DOCSDIR%%/reference/right-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/reference/right.png
%%PORTDOCS%%%%DOCSDIR%%/reference/style.css
%%PORTDOCS%%%%DOCSDIR%%/reference/up-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/reference/up.png
%%NLS%%share/locale/da/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/de/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/eo/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/es/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/fi/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/fr/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/ga/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/hu/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/id/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/it/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/nl/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/pl/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/ro/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/sk/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/sr/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/sv/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/uk/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/vi/LC_MESSAGES/libgsasl.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/libgsasl.mo