Partially revert "security/heimdal*: Remove LLVM_DEFAULT build prerequisite"

The suggested workaround will only work when autoreconf is not run.
The devel port still needs LLVM_DEFAULT while the non-devel port does
not

PR:	267814
Fixes:	22a683a337
MFH:	2022Q4

This partially reverts commit 22a683a337.
This commit is contained in:
Cy Schubert 2022-11-24 12:36:25 -08:00
parent 67fc2c392f
commit 286254e283
2 changed files with 7 additions and 13 deletions

View file

@ -23,7 +23,10 @@ USES= autoreconf:build cpe gettext-runtime gssapi:bootstrap,heimdal \
CPE_VENDOR= ${PORTNAME}_project
USE_LDCONFIG= ${GSSAPILIBDIR}
BUILD_DEPENDS= p5-JSON>0:converters/p5-JSON
# Needs clang-format which is only provided by the port.
# Else asm1_fails resulting in a command not found error.
BUILD_DEPENDS= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT} \
p5-JSON>0:converters/p5-JSON
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_fnmatch_h=yes \

View file

@ -1,15 +1,6 @@
--- configure.ac.orig 2022-11-17 16:55:32.000000000 -0800
+++ configure.ac 2022-11-24 07:19:25.053801000 -0800
@@ -19,7 +19,7 @@
AM_PROG_CC_C_O
AC_PROG_CPP
AM_PATH_PYTHON
-AC_CHECK_PROG(CLANG_FORMAT, clang-format, [clang-format], [no])
+AC_CHECK_PROG(CLANG_FORMAT, clang-format, [clang-format], [])
test "$CLANG_FORMAT" = no && CLANG_FORMAT=true
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -177,6 +177,7 @@
--- configure.ac.orig 2019-06-07 06:21:39 UTC
+++ configure.ac
@@ -153,6 +153,7 @@ AC_ARG_ENABLE(kx509,
if test "$enable_kx509" != no ;then
AC_DEFINE([KX509], 1, [Define to enable kx509.])
fi