Add xmms-fishmatic 0.0.1, an XMMS non-static OpenGL stereogram
visualization plugin. PR: 34723 Submitted by: David Yeske <dyeske@yahoo.com>
This commit is contained in:
parent
6bb92b02c9
commit
287d089ad9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55429
8 changed files with 108 additions and 0 deletions
|
@ -349,6 +349,7 @@
|
|||
SUBDIR += xmandel
|
||||
SUBDIR += xmfract
|
||||
SUBDIR += xmms-avi
|
||||
SUBDIR += xmms-fishmatic
|
||||
SUBDIR += xmms-gforce
|
||||
SUBDIR += xmms-goom
|
||||
SUBDIR += xmms-xvs
|
||||
|
|
35
graphics/xmms-fishmatic/Makefile
Normal file
35
graphics/xmms-fishmatic/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: xmms-fishmatic
|
||||
# Date created: 20 Jan 2002
|
||||
# Whom: David Yeske <dyeske@yahoo.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fishmatic
|
||||
PORTVERSION= 0.0.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://stukach.com/hosted/
|
||||
PKGNAMEPREFIX= xmms-
|
||||
DISTNAME= fishmatic
|
||||
|
||||
MAINTAINER= dyeske@yahoo.com
|
||||
|
||||
BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
|
||||
RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_GLIB= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
USE_MESA= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
CFLAGS+= -I${X11BASE}/include -L${X11BASE}/lib
|
||||
|
||||
post-patch:
|
||||
@${RM} -f ${WRKSRC}/config.cache
|
||||
@${PERL} -pi -e 's@glib-config@${GLIB_CONFIG}@g;' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/xmms-fishmatic/distinfo
Normal file
1
graphics/xmms-fishmatic/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (fishmatic.tar.gz) = bb6987ece670f22134aafe206d271e3b
|
31
graphics/xmms-fishmatic/files/patch-configure
Normal file
31
graphics/xmms-fishmatic/files/patch-configure
Normal file
|
@ -0,0 +1,31 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- configure.orig Sun Aug 12 19:11:07 2001
|
||||
+++ configure Thu Dec 27 00:05:42 2001
|
||||
@@ -3243,7 +3243,7 @@
|
||||
#include "confdefs.h"
|
||||
#include <GL/gl.h>
|
||||
EOF
|
||||
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
+ac_try="$ac_cpp $CFLAGS conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
{ (eval echo configure:3248: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
if test -z "$ac_err"; then
|
||||
@@ -3275,7 +3275,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lGL $LIBS"
|
||||
+LIBS="-lGL $PTHREAD_LIBS -lX11 -lXext $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 3281 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -3364,7 +3364,7 @@
|
||||
#include "confdefs.h"
|
||||
#include <GL/glx.h>
|
||||
EOF
|
||||
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
+ac_try="$ac_cpp $CFLAGS conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
{ (eval echo configure:3369: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
if test -z "$ac_err"; then
|
27
graphics/xmms-fishmatic/files/patch-ltmain.sh
Normal file
27
graphics/xmms-fishmatic/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,27 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh 2001/08/27 09:51:26 1.1
|
||||
+++ ltmain.sh 2001/08/27 09:51:42
|
||||
@@ -2408,6 +2408,9 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test "$build_libtool_need_lc" = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
1
graphics/xmms-fishmatic/pkg-comment
Normal file
1
graphics/xmms-fishmatic/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
An XMMS non-static OpenGL stereogram visualization plugin
|
11
graphics/xmms-fishmatic/pkg-descr
Normal file
11
graphics/xmms-fishmatic/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
Fishmatic is an OpenGL stereogram visualization plugin. It generates
|
||||
a backdrop, and the bubbles react to the music. The fish swim in
|
||||
three dimensions, with changing stereogram separation.
|
||||
|
||||
There are two types of fish: an angel fish, and a lamprologus.
|
||||
|
||||
This is not a static-dot stereogram. The bubbles look like bubbles,
|
||||
the fish are texture mapped with nice fish images.
|
||||
|
||||
- David
|
||||
dyeske@yahoo.com
|
1
graphics/xmms-fishmatic/pkg-plist
Normal file
1
graphics/xmms-fishmatic/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
lib/xmms/Visualization/libfishmatic.so
|
Loading…
Reference in a new issue