- Update to 1.3.0b2

- Add category: geography
- Add option: DEBUG
- Simplify patches
- Sort pkg-plist

PR:		ports/146200
Submitted by:	Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> (maintainer)
This commit is contained in:
Wen Heping 2010-05-07 06:06:53 +00:00
parent feb214d3d7
commit 288435bc39
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253891
5 changed files with 54 additions and 53 deletions

View file

@ -7,33 +7,32 @@
PORTNAME= shapelib
PORTVERSION= 1.3.0
PORTREVISION= 2
CATEGORIES= devel
PORTREVISION= 3
CATEGORIES= devel geography
MASTER_SITES= http://download.osgeo.org/shapelib/ \
ftp://ftp.remotesensing.org/shapelib/ \
http://sunpoet.net/distfiles/
DISTNAME= ${PORTNAME}-${SHAPELIB_VER}
MAINTAINER= sunpoet@sunpoet.net
COMMENT= C API for reading and writing ArcView Shapefiles
MAKE_JOBS_UNSAFE= yes
USE_AUTOTOOLS= libtool:22:env
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${SHAPELIB_VER}
MAKE_JOBS_UNSAFE= yes
OPTIONS= PROJ4 "Cartographic Projections library" off
OPTIONS= DEBUG "Debugging" off \
PROJ4 "Cartographic Projections library" off
SHAPELIB_VER= ${PORTVERSION}b1
SHAPELIB_VER= ${PORTVERSION}b2
.include <bsd.port.pre.mk>
.if defined(WITH_PROJ4)
LIB_DEPENDS+= proj.6:${PORTSDIR}/graphics/proj
PLIST_SUB+= PROJ4=""
PROJ4= -DPROJ4
.if defined(WITH_DEBUG)
DEBUG= -DDEBUG -DDEBUG2 -g
.else
PLIST_SUB+= PROJ4="@comment "
PROJ4= -DNO_PROJ4
DEBUG=
.endif
.if ${ARCH} == "amd64" || ${ARCH} == "i386" || ${ARCH} == "ia64"
@ -42,9 +41,20 @@ ENDIAN= -D_LITTLE_ENDIAN
ENDIAN= -D_BIG_ENDIAN
.endif
.if defined(WITH_PROJ4)
LIB_DEPENDS+= proj:${PORTSDIR}/graphics/proj
PLIST_SUB+= PROJ4=""
PROJ4= -DPROJ4
.else
PLIST_SUB+= PROJ4="@comment "
PROJ4= -DNO_PROJ4
.endif
post-patch:
@${REINPLACE_CMD} \
-e 's#%%DEBUG%%#${DEBUG}#g' \
-e 's#%%INSTALL%%#${INSTALL}#g' \
-e 's#%%INSTALL_PROGRAM%%#${INSTALL_PROGRAM}#g' \
-e 's#%%LIBTOOL%%#${LIBTOOL}#g' \
-e 's#%%PREFIX%%#${PREFIX}#g' \
-e 's#%%ENDIAN%%#${ENDIAN}#g' \

View file

@ -1,3 +1,3 @@
MD5 (shapelib-1.3.0b1.tar.gz) = b8da228374611880ab52179b70c72f16
SHA256 (shapelib-1.3.0b1.tar.gz) = 43ee1c4df76e9fb5c0bbebd3def7b6c02151547a5c447ee044419505bdf07d60
SIZE (shapelib-1.3.0b1.tar.gz) = 182144
MD5 (shapelib-1.3.0b2.tar.gz) = 708ea578bc299dcd9f723569d12bee8d
SHA256 (shapelib-1.3.0b2.tar.gz) = a3c6975730039668f5e89320ddfccbe0659dd31ff8f4cddd93f1cb8bb2541387
SIZE (shapelib-1.3.0b2.tar.gz) = 182558

View file

@ -1,52 +1,43 @@
--- contrib/Makefile.orig 2004-06-24 08:55:52.000000000 +0800
+++ contrib/Makefile 2009-09-06 05:35:24.000000000 +0800
@@ -3,19 +3,44 @@
--- contrib/Makefile.orig 2010-01-04 12:08:02.000000000 +0800
+++ contrib/Makefile 2010-05-01 05:26:53.000000000 +0800
@@ -3,19 +3,36 @@
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
+#ENDIAN = -D_LITTLE_ENDIAN
-CFLAGS = -g -I.. -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
+CFLAGS += -g -I.. -DDEBUG -DDEBUG2 %%ENDIAN%% %%PROJ4%% -I%%PREFIX%%/include -L%%PREFIX%%/lib
-CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
+CFLAGS += %%DEBUG%% %%ENDIAN%% %%PROJ4%% -I.. -I%%PREFIX%%/include -L%%PREFIX%%/lib
-SHPOBJ = ../shpopen.o ../dbfopen.o
+SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
-SHPGOBJ = ../shpopen.o ../dbfopen.o shpgeo.o
+SHPGOBJ = ../shpopen.o ../dbfopen.o ../safileio.o shpgeo.o
SHPGOBJ = ../shpopen.o ../dbfopen.o ../safileio.o shpgeo.o
GEOOBJ = ./shpgeo.o -lm -lproj
-GEOOBJ = ./shpgeo.o -lm -L$(HOME)/bld/lib -lproj
+GEOOBJ = ./shpgeo.o -lm -lproj
default: all
-all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
+#all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
+
+.if defined(PROJ4)
+all: allprog allproj
+install: allprog_install allproj_install
+.else
+all: allprog
+install: allprog_install
+.endif
+
+ALLPROG= dbfcat dbfinfo shpcat shpdxf shpfix Shape_PointInPoly
+ALLPROJ= shpcentrd shpdata shpinfo shpproj shpwkb shpsort
+
+allprog: $(ALLPROG)
+.if defined(PROJ4)
+all: $(ALLPROG) $(ALLPROJ)
+install: allprog_install allproj_install
+.else
+all: $(ALLPROG)
+install: allprog_install
+.endif
+
+allprog_install: $(ALLPROG)
+.for _ALLPROG in $(ALLPROG)
+ %%INSTALL%% -c -m 755 ${_ALLPROG} %%PREFIX%%/bin/${_ALLPROG}
+.endfor
+
+allproj: $(ALLPROJ)
+ %%INSTALL_PROGRAM%% $(ALLPROG) %%PREFIX%%/bin/
+
+allproj_install: $(ALLPROJ)
+.for _ALLPROJ in $(ALLPROJ)
+ %%INSTALL%% -c -m 755 ${_ALLPROJ} %%PREFIX%%/bin/${_ALLPROJ}
+.endfor
+ %%INSTALL_PROGRAM%% $(ALLPROJ) %%PREFIX%%/bin/
clean:
rm -f shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfcat dbfinfo shpinfo shpfix shpcat *.o

View file

@ -1,6 +1,6 @@
--- shapefil.h.orig 2008-11-12 22:28:15.000000000 +0800
+++ shapefil.h 2009-09-05 05:33:07.000000000 +0800
@@ -123,6 +123,8 @@
--- shapefil.h.orig 2010-01-28 19:34:34.000000000 +0800
+++ shapefil.h 2010-05-01 05:04:28.000000000 +0800
@@ -126,6 +126,8 @@
*/
#include <stdio.h>

View file

@ -1,18 +1,18 @@
bin/shpcreate
bin/shpadd
bin/shpdump
bin/shprewind
bin/dbfcreate
bin/dbfadd
bin/dbfdump
bin/shptest
bin/shputils
bin/shptreedump
bin/dbfcat
bin/dbfcreate
bin/dbfdump
bin/dbfinfo
bin/shpadd
bin/shpcat
bin/shpcreate
bin/shpdump
bin/shpdxf
bin/shpfix
bin/shprewind
bin/shptest
bin/shptreedump
bin/shputils
bin/Shape_PointInPoly
%%PROJ4%%bin/shpcentrd
%%PROJ4%%bin/shpdata