- Update to 4.0.0
- As OpenGL rendering now works, remove the -devel suffix - Enable staging - Use new LIB_DEPENDS format - Add new UPNP option - Handle -liconv removal on -CURRENT
This commit is contained in:
parent
b5b5d0716c
commit
2890f5b752
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=330484
25 changed files with 1968 additions and 1666 deletions
1
MOVED
1
MOVED
|
@ -5106,3 +5106,4 @@ lang/ruby-lua4||2013-10-15|Has expired: Does not work with Ruby 1.9
|
|||
dns/dnsdoctor||2013-10-15|Has expired: Does not work with Ruby 1.9
|
||||
devel/py-psyco||2013-10-15|Has expired: only bulds with lang/python26
|
||||
x11-toolkits/ruby-tk||2013-10-15|Has expired: Does not work with Ruby 1.9
|
||||
emulators/dolphin-emu-devel|emulators/dolphin-emu|2013-10-16|Has reached stable quality
|
||||
|
|
|
@ -24,7 +24,7 @@
|
|||
SUBDIR += dboxfe
|
||||
SUBDIR += desmume
|
||||
SUBDIR += dgen-sdl
|
||||
SUBDIR += dolphin-emu-devel
|
||||
SUBDIR += dolphin-emu
|
||||
SUBDIR += dosbox
|
||||
SUBDIR += doscmd
|
||||
SUBDIR += dtcyber
|
||||
|
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (dolphin-emu-3.5.r20130415.tgz) = 195f5a4793c4e87f81a334da2b301e2a048f7ff1339811d910362ee8c5b8cfb5
|
||||
SIZE (dolphin-emu-3.5.r20130415.tgz) = 17819718
|
|
@ -1,9 +0,0 @@
|
|||
--- Source/Core/DolphinWX/CMakeLists.txt.orig 2012-03-07 15:33:14.000000000 +0100
|
||||
+++ Source/Core/DolphinWX/CMakeLists.txt 2012-03-07 18:16:05.629985514 +0100
|
||||
@@ -1,4 +1,6 @@
|
||||
set(LIBS core
|
||||
+ execinfo
|
||||
+ iconv
|
||||
${LZO}
|
||||
discio
|
||||
bdisasm
|
|
@ -1,11 +0,0 @@
|
|||
--- Source/Core/DolphinWX/Src/LogWindow.h.orig 2012-03-14 18:12:23.066269697 +0100
|
||||
+++ Source/Core/DolphinWX/Src/LogWindow.h 2012-03-14 18:12:36.531263827 +0100
|
||||
@@ -79,7 +79,7 @@
|
||||
|
||||
DECLARE_EVENT_TABLE()
|
||||
|
||||
- wxTextCtrl * CreateTextCtrl(wxPanel* parent, wxWindowID id = wxID_ANY, long Style = NULL);
|
||||
+ wxTextCtrl * CreateTextCtrl(wxPanel* parent, wxWindowID id = wxID_ANY, long Style = 0);
|
||||
void CreateGUIControls();
|
||||
void PopulateBottom();
|
||||
void UnPopulateBottom();
|
|
@ -1,12 +0,0 @@
|
|||
===============================================================
|
||||
========================== ATTENTION ==========================
|
||||
===============================================================
|
||||
|
||||
This port should still be considered work-in-progress. It still
|
||||
needs testing, particularly OpenGL rendering.
|
||||
|
||||
Please, send feedback to the maintainer: %%MAINTAINER%%
|
||||
|
||||
Now, run dolphin-emu and enjoy !
|
||||
|
||||
===============================================================
|
File diff suppressed because it is too large
Load diff
|
@ -2,12 +2,10 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dolphin-emu
|
||||
PORTVERSION= 3.5.r${REVDATE}
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 4.0.0
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
|
||||
LOCAL/martymac
|
||||
PKGNAMESUFFIX= -devel
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= martymac@FreeBSD.org
|
||||
|
@ -15,16 +13,16 @@ COMMENT= Gamecube and Wii Emulator
|
|||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
|
||||
freetype:${PORTSDIR}/print/freetype2 \
|
||||
lzo2:${PORTSDIR}/archivers/lzo2 \
|
||||
sfml-network:${PORTSDIR}/devel/sfml
|
||||
|
||||
REVDATE= 20130415
|
||||
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
|
||||
libfreetype.so:${PORTSDIR}/print/freetype2 \
|
||||
liblzo2.so:${PORTSDIR}/archivers/lzo2 \
|
||||
libSoundTouch.so:${PORTSDIR}/audio/soundtouch \
|
||||
libsfml-network.so:${PORTSDIR}/devel/sfml \
|
||||
libpolarssl.so:${PORTSDIR}/security/polarssl
|
||||
|
||||
USE_SDL= sdl
|
||||
USE_OPENAL= yes
|
||||
USE_XORG= ice xext x11 xrandr
|
||||
USE_XORG= ice xext x11 xrandr xi
|
||||
USE_WX= 2.9+
|
||||
WX_UNICODE= yes
|
||||
USE_GL= gl glew glu
|
||||
|
@ -32,28 +30,23 @@ USE_GL= gl glew glu
|
|||
USE_DOS2UNIX= yes
|
||||
DOS2UNIX_REGEX= .*\.(h|c|cpp)
|
||||
|
||||
# XXX Has only been tested with clang and gcc
|
||||
.if ${CC} != "clang" && ${CXX} != "clang++"
|
||||
USE_GCC= yes
|
||||
.endif
|
||||
USE_GCC= 4.6+
|
||||
|
||||
USES= cmake pkgconfig iconv
|
||||
CMAKE_BUILD_TYPE= Release
|
||||
# Disable ao (seems buggy) and ALSA (emulated)
|
||||
CMAKE_ARGS+= -DDISABLE_AO:BOOL=ON \
|
||||
# Disable ALSA (emulated) and ao (buggy)
|
||||
CMAKE_ARGS+= -DOPENMP:BOOL=OFF \
|
||||
-DDISABLE_ALSA:BOOL=ON \
|
||||
-DDISABLE_AO:BOOL=ON \
|
||||
-DDISABLE_BLUEZ:BOOL=ON \
|
||||
-DUSE_X11:BOOL=ON \
|
||||
-DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=ON
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
SUB_LIST+= MAINTAINER=${MAINTAINER}
|
||||
|
||||
OPTIONS_DEFINE= PULSEAUDIO PORTAUDIO DEBUG FRAMEDUMPS
|
||||
OPTIONS_DEFINE= PULSEAUDIO PORTAUDIO DEBUG FRAMEDUMPS UPNP
|
||||
PORTAUDIO_DESC= Enable PortAudio (mic) support
|
||||
FRAMEDUMPS_DESC= Encode framedumps in AVI format
|
||||
OPTIONS_DEFAULT= PORTAUDIO FRAMEDUMPS
|
||||
OPTIONS_DEFAULT= PORTAUDIO FRAMEDUMPS UPNP
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MNLS}
|
||||
|
@ -73,28 +66,40 @@ MAKE_ENV+= VERBOSE=yes
|
|||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPULSEAUDIO}
|
||||
LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
|
||||
LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
|
||||
.else
|
||||
CMAKE_ARGS+= -DDISABLE_PULSEAUDIO:BOOL=ON
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPORTAUDIO}
|
||||
LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
|
||||
LIB_DEPENDS+= libportaudio.so.2:${PORTSDIR}/audio/portaudio2
|
||||
.else
|
||||
CMAKE_ARGS+= -DDISABLE_PORTAUDIO:BOOL=ON
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MFRAMEDUMPS}
|
||||
CMAKE_ARGS+= -DENCODE_FRAMEDUMPS:BOOL=ON
|
||||
LIB_DEPENDS+= avcodec1:${PORTSDIR}/multimedia/ffmpeg1 \
|
||||
avformat1:${PORTSDIR}/multimedia/ffmpeg1 \
|
||||
swscale1:${PORTSDIR}/multimedia/ffmpeg1 \
|
||||
avutil1:${PORTSDIR}/multimedia/ffmpeg1
|
||||
LIB_DEPENDS+= libavcodec1.so:${PORTSDIR}/multimedia/ffmpeg1 \
|
||||
libavformat1.so:${PORTSDIR}/multimedia/ffmpeg1 \
|
||||
libswscale1.so:${PORTSDIR}/multimedia/ffmpeg1 \
|
||||
libavutil1.so:${PORTSDIR}/multimedia/ffmpeg1
|
||||
.else
|
||||
CMAKE_ARGS+= -DENCODE_FRAMEDUMPS:BOOL=OFF
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
.if ${PORT_OPTIONS:MUPNP}
|
||||
CMAKE_ARGS+= -DUSE_UPNP:BOOL=ON
|
||||
LIB_DEPENDS+= libminiupnpc.so:${PORTSDIR}/net/miniupnpc
|
||||
.else
|
||||
CMAKE_ARGS+= -DUSE_UPNP:BOOL=OFF
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !empty(ICONV_LIB)
|
||||
CMAKE_ARGS+= -DUSE_ICONV:BOOL=ON
|
||||
.else
|
||||
CMAKE_ARGS+= -DUSE_ICONV:BOOL=OFF
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
emulators/dolphin-emu/distinfo
Normal file
2
emulators/dolphin-emu/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (dolphin-emu-4.0.0.tgz) = b738bbad1555292efd4c517cd56ed084a5489575d6652e3f26739f9a5f95dcbe
|
||||
SIZE (dolphin-emu-4.0.0.tgz) = 20543858
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2013-03-20 18:05:37.000000000 +0100
|
||||
+++ CMakeLists.txt 2013-03-20 18:21:02.000000000 +0100
|
||||
@@ -302,51 +302,81 @@
|
||||
--- CMakeLists.txt.orig 2013-09-16 04:58:51.000000000 +0200
|
||||
+++ CMakeLists.txt 2013-09-16 05:15:59.000000000 +0200
|
||||
@@ -351,51 +351,81 @@
|
||||
message("OpenMP parallelization disabled")
|
||||
endif()
|
||||
|
||||
|
@ -111,13 +111,12 @@
|
|||
+ message("OpenAL sound backend disabled")
|
||||
+ endif()
|
||||
|
||||
# Note: We do not need to explicitly check for X11 as it is done in the cmake
|
||||
# FindOpenGL module on linux.
|
||||
@@ -375,22 +405,33 @@
|
||||
if(UNIX AND NOT APPLE)
|
||||
# Note: The convention is to check USE_X11 or USE_WAYLAND where needed.
|
||||
@@ -455,21 +485,32 @@
|
||||
check_libav()
|
||||
endif()
|
||||
|
||||
- include(CheckCXXSourceRuns)
|
||||
- set(CMAKE_REQUIRED_LIBRARIES portaudio)
|
||||
- CHECK_CXX_SOURCE_RUNS(
|
||||
- "#include <portaudio.h>
|
||||
|
@ -130,7 +129,6 @@
|
|||
- set(PORTAUDIO_FOUND TRUE)
|
||||
+ option(DISABLE_PORTAUDIO "Disable PortAudio (mic) support" OFF)
|
||||
+ if(NOT DISABLE_PORTAUDIO)
|
||||
+ include(CheckCXXSourceRuns)
|
||||
+ include_directories(BEFORE ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
|
||||
+ link_directories(${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
|
||||
+ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
|
||||
|
@ -160,21 +158,3 @@
|
|||
|
||||
if(OPROFILING)
|
||||
check_lib(OPROFILE opagent opagent.h)
|
||||
@@ -668,10 +709,13 @@
|
||||
install(DIRECTORY Data/User/ DESTINATION ${datadir}/user PATTERN)
|
||||
install(DIRECTORY Data/Sys/ DESTINATION ${datadir}/sys PATTERN)
|
||||
endif()
|
||||
-include(FindGettext)
|
||||
-if(GETTEXT_FOUND AND NOT DISABLE_WX)
|
||||
- file(GLOB LINGUAS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} Languages/po/*.po)
|
||||
- GETTEXT_CREATE_TRANSLATIONS(Languages/po/dolphin-emu.pot ALL ${LINGUAS})
|
||||
+option(DISABLE_NLS "Disable native language support (NLS)" OFF)
|
||||
+if(NOT DISABLE_NLS)
|
||||
+ include(FindGettext)
|
||||
+ if(GETTEXT_FOUND AND NOT DISABLE_WX)
|
||||
+ file(GLOB LINGUAS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} Languages/po/*.po)
|
||||
+ GETTEXT_CREATE_TRANSLATIONS(Languages/po/dolphin-emu.pot ALL ${LINGUAS})
|
||||
+ endif()
|
||||
endif()
|
||||
if((NOT ${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|Darwin"))
|
||||
install(FILES Data/license.txt DESTINATION ${datadir})
|
12
emulators/dolphin-emu/files/patch-CMakeTests-FindGLEW.cmake
Normal file
12
emulators/dolphin-emu/files/patch-CMakeTests-FindGLEW.cmake
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- CMakeTests/FindGLEW.cmake.orig 2013-09-10 06:35:16.000000000 +0200
|
||||
+++ CMakeTests/FindGLEW.cmake 2013-09-16 16:04:12.000000000 +0200
|
||||
@@ -4,7 +4,9 @@
|
||||
# Ubuntu's version of glew is 1.8, but they have patched in most of glew 1.9.
|
||||
# So Ubuntu's version works for dolphin.
|
||||
macro(test_glew)
|
||||
+ link_directories(${GLEW_LIBRARY_DIRS})
|
||||
set(CMAKE_REQUIRED_INCLUDES ${GLEW_INCLUDE_DIRS})
|
||||
+ set(CMAKE_REQUIRED_FLAGS -L${GLEW_LIBRARY_DIRS})
|
||||
set(CMAKE_REQUIRED_LIBRARIES GLEW)
|
||||
check_cxx_source_runs("
|
||||
#include <GL/glew.h>
|
|
@ -0,0 +1,11 @@
|
|||
--- CMakeTests/FindLibUSB.cmake.orig 2013-09-17 08:41:32.000000000 +0200
|
||||
+++ CMakeTests/FindLibUSB.cmake 2013-09-17 08:41:41.000000000 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
/usr/local/include
|
||||
)
|
||||
|
||||
- find_library(LIBUSB_LIBRARIES NAMES usb-1.0
|
||||
+ find_library(LIBUSB_LIBRARIES NAMES usb
|
||||
PATHS
|
||||
${LIBUSB_PKG_LIBRARY_DIRS}
|
||||
/usr/lib
|
|
@ -0,0 +1,37 @@
|
|||
--- Source/Core/Common/Src/Thread.cpp.orig 2013-09-17 16:24:41.000000000 +0200
|
||||
+++ Source/Core/Common/Src/Thread.cpp 2013-09-17 16:41:54.000000000 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
#ifdef __APPLE__
|
||||
#include <mach/mach.h>
|
||||
-#elif defined BSD4_4
|
||||
+#elif defined BSD4_4 || defined __FreeBSD__
|
||||
#include <pthread_np.h>
|
||||
#endif
|
||||
|
||||
@@ -92,8 +92,12 @@
|
||||
#ifdef __APPLE__
|
||||
thread_policy_set(pthread_mach_thread_np(thread),
|
||||
THREAD_AFFINITY_POLICY, (integer_t *)&mask, 1);
|
||||
-#elif (defined __linux__ || defined BSD4_4) && !(defined ANDROID)
|
||||
+#elif (defined __linux__ || defined BSD4_4 || defined __FreeBSD__) && !(defined ANDROID)
|
||||
+#if defined __FreeBSD__
|
||||
+ cpuset_t cpu_set;
|
||||
+#else
|
||||
cpu_set_t cpu_set;
|
||||
+#endif
|
||||
CPU_ZERO(&cpu_set);
|
||||
|
||||
for (int i = 0; i != sizeof(mask) * 8; ++i)
|
||||
@@ -121,8 +125,10 @@
|
||||
|
||||
void SetCurrentThreadName(const char* szThreadName)
|
||||
{
|
||||
-#ifdef __APPLE__
|
||||
+#if defined __APPLE__
|
||||
pthread_setname_np(szThreadName);
|
||||
+#elif defined __FreeBSD__
|
||||
+ pthread_set_name_np(pthread_self(), szThreadName);
|
||||
#else
|
||||
pthread_setname_np(pthread_self(), szThreadName);
|
||||
#endif
|
|
@ -0,0 +1,13 @@
|
|||
--- Source/Core/Core/Src/IPC_HLE/WII_IPC_HLE_Device_hid.h.orig 2013-09-17 16:44:46.000000000 +0200
|
||||
+++ Source/Core/Core/Src/IPC_HLE/WII_IPC_HLE_Device_hid.h 2013-09-17 16:48:22.000000000 +0200
|
||||
@@ -16,6 +16,10 @@
|
||||
|
||||
#define HIDERR_NO_DEVICE_FOUND -4
|
||||
|
||||
+#if defined __FreeBSD__
|
||||
+#define LIBUSB_CALL
|
||||
+#endif
|
||||
+
|
||||
/* Connection timed out */
|
||||
|
||||
class CWII_IPC_HLE_Device_hid : public IWII_IPC_HLE_Device
|
|
@ -0,0 +1,29 @@
|
|||
--- Source/Core/Core/Src/IPC_HLE/WII_IPC_HLE_Device_net.cpp.orig 2013-09-18 06:59:39.000000000 +0200
|
||||
+++ Source/Core/Core/Src/IPC_HLE/WII_IPC_HLE_Device_net.cpp 2013-09-18 15:07:04.000000000 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
#define MALLOC(x) HeapAlloc(GetProcessHeap(), 0, (x))
|
||||
#define FREE(x) HeapFree(GetProcessHeap(), 0, (x))
|
||||
|
||||
-#elif defined(__linux__) or defined(__APPLE__)
|
||||
+#elif defined(__linux__) or defined(__APPLE__) or defined(__FreeBSD__)
|
||||
#include <netdb.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <sys/types.h>
|
||||
@@ -1004,7 +1004,7 @@
|
||||
Memory::Write_U32(wii_addr, BufferOut + 4);
|
||||
Memory::Write_U32(wii_addr + sizeof(u32), wii_addr);
|
||||
wii_addr += sizeof(u32);
|
||||
- Memory::Write_U32((u32)NULL, wii_addr);
|
||||
+ Memory::Write_U32((u32)0, wii_addr);
|
||||
wii_addr += sizeof(u32);
|
||||
|
||||
// hardcode to ipv4
|
||||
@@ -1025,7 +1025,7 @@
|
||||
wii_addr += sizeof(u32);
|
||||
}
|
||||
// NULL terminated list
|
||||
- Memory::Write_U32((u32)NULL, wii_addr);
|
||||
+ Memory::Write_U32((u32)0, wii_addr);
|
||||
wii_addr += sizeof(u32);
|
||||
// The actual IPs
|
||||
for (int i = 0; remoteHost->h_addr_list[i]; i++)
|
|
@ -0,0 +1,16 @@
|
|||
--- Source/Core/Core/Src/IPC_HLE/WII_Socket.cpp.orig 2013-09-17 16:50:52.000000000 +0200
|
||||
+++ Source/Core/Core/Src/IPC_HLE/WII_Socket.cpp 2013-09-17 16:51:58.000000000 +0200
|
||||
@@ -21,6 +21,13 @@
|
||||
#define EITHER(win32, posix) posix
|
||||
#endif
|
||||
|
||||
+#if defined __FreeBSD__
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
+#include <arpa/inet.h>
|
||||
+#endif
|
||||
+
|
||||
char* WiiSockMan::DecodeError(s32 ErrorCode)
|
||||
{
|
||||
#ifdef _WIN32
|
|
@ -0,0 +1,45 @@
|
|||
--- Source/Core/DolphinWX/CMakeLists.txt.orig 2013-09-17 07:16:04.000000000 +0200
|
||||
+++ Source/Core/DolphinWX/CMakeLists.txt 2013-09-25 05:06:25.000000000 +0200
|
||||
@@ -3,6 +3,7 @@
|
||||
endif()
|
||||
|
||||
set(LIBS core
|
||||
+ execinfo
|
||||
${LZO}
|
||||
discio
|
||||
bdisasm
|
||||
@@ -39,7 +40,13 @@
|
||||
endif()
|
||||
endif()
|
||||
else()
|
||||
- set(LIBS ${LIBS} png iconv)
|
||||
+ set(LIBS ${LIBS} png)
|
||||
+ set(USE_ICONV True)
|
||||
+endif()
|
||||
+
|
||||
+if(USE_ICONV)
|
||||
+ message( "-- Adding iconv")
|
||||
+ set(LIBS ${LIBS} iconv)
|
||||
endif()
|
||||
|
||||
if(LIBAV_FOUND)
|
||||
@@ -174,11 +181,14 @@
|
||||
set(LIBS ${LIBS} miniupnpc)
|
||||
endif()
|
||||
|
||||
-include(FindGettext)
|
||||
-if(GETTEXT_MSGMERGE_EXECUTABLE AND GETTEXT_MSGFMT_EXECUTABLE AND wxWidgets_FOUND)
|
||||
- file(GLOB LINGUAS ${CMAKE_SOURCE_DIR}/Languages/po/*.po)
|
||||
- add_custom_target(translations ALL)
|
||||
- GETTEXT_CREATE_TRANSLATIONS(${CMAKE_SOURCE_DIR}/Languages/po/dolphin-emu.pot ${LINGUAS})
|
||||
+option(DISABLE_NLS "Disable native language support (NLS)" OFF)
|
||||
+if(NOT DISABLE_NLS)
|
||||
+ include(FindGettext)
|
||||
+ if(GETTEXT_MSGMERGE_EXECUTABLE AND GETTEXT_MSGFMT_EXECUTABLE AND wxWidgets_FOUND)
|
||||
+ file(GLOB LINGUAS ${CMAKE_SOURCE_DIR}/Languages/po/*.po)
|
||||
+ add_custom_target(translations ALL)
|
||||
+ GETTEXT_CREATE_TRANSLATIONS(${CMAKE_SOURCE_DIR}/Languages/po/dolphin-emu.pot ${LINGUAS})
|
||||
+ endif()
|
||||
endif()
|
||||
|
||||
if(ANDROID)
|
|
@ -0,0 +1,15 @@
|
|||
--- Source/Core/DolphinWX/Src/NetWindow.cpp.orig 2013-09-18 15:49:16.000000000 +0200
|
||||
+++ Source/Core/DolphinWX/Src/NetWindow.cpp 2013-09-18 15:52:24.000000000 +0200
|
||||
@@ -38,7 +38,11 @@
|
||||
name = game.GetVolumeName(lang);
|
||||
|
||||
if (game.GetRevision() != 0)
|
||||
- return name + " (" + game.GetUniqueID() + ", Revision " + std::to_string((long long)game.GetRevision()) + ")";
|
||||
+ {
|
||||
+ std::stringstream tmp_stream;
|
||||
+ tmp_stream << game.GetRevision();
|
||||
+ return name + " (" + game.GetUniqueID() + ", Revision " + tmp_stream.str() + ")";
|
||||
+ }
|
||||
else
|
||||
return name + " (" + game.GetUniqueID() + ")";
|
||||
}
|
1744
emulators/dolphin-emu/pkg-plist
Normal file
1744
emulators/dolphin-emu/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue