- Move scorefile to /var/games
- Modernize plist - Remove useless pkg-message PR: 205626 Submitted by: amdmi3 Approved by: maintainer timeout (e@ik.nu, 2 weeks)
This commit is contained in:
parent
c18ca07ee1
commit
28a2a12cce
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=406109
5 changed files with 14 additions and 31 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= trojka
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.funet.fi/pub/unix/games/
|
||||
DISTNAME= ${PORTNAME}
|
||||
|
@ -12,9 +13,7 @@ COMMENT= Game of skill
|
|||
|
||||
LICENSE= TROJKA
|
||||
LICENSE_NAME= Trojka Copyright
|
||||
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- Makefile.orig Sat Oct 21 05:17:43 1995
|
||||
+++ Makefile Tue Jul 18 11:39:08 2000
|
||||
@@ -6,14 +6,25 @@
|
||||
--- Makefile.orig 1995-10-20 21:17:43 UTC
|
||||
+++ Makefile
|
||||
@@ -6,14 +6,24 @@
|
||||
#
|
||||
|
||||
|
||||
-
|
||||
+SCOREDIR=$(PREFIX)/share/trojka
|
||||
+SCOREDIR=/var/games
|
||||
+SCOREFILE=$(SCOREDIR)/trojka.scores
|
||||
+CFLAGS+= -DSCOREFILE=\"$(SCOREFILE)\"
|
||||
OBJS= trojka.o screen.o scan.o hiscore.o system.o
|
||||
|
@ -17,18 +17,17 @@
|
|||
|
||||
install:
|
||||
- cp trojka /usr/games
|
||||
+ install -c -d -m 0755 $(DESTDIR)$(SCOREDIR)
|
||||
+ install -c -s trojka $(DESTDIR)$(PREFIX)/bin
|
||||
+ install -c -m 0644 README $(DESTDIR)$(SCOREDIR)
|
||||
+ install -c -m 0664 /dev/null $(DESTDIR)$(SCOREFILE)
|
||||
+ install -c -m 0444 trojka.6.out $(DESTDIR)$(PREFIX)/man/man6/trojka.6
|
||||
+ ${BSD_INSTALL_PROGRAM} trojka $(DESTDIR)$(PREFIX)/bin
|
||||
+ ${BSD_INSTALL_MAN} trojka.6.out $(DESTDIR)$(PREFIX)/man/man6/trojka.6
|
||||
+ mkdir -p $(DESTDIR)$(SCOREDIR)
|
||||
+ touch $(DESTDIR)$(SCOREFILE).sample
|
||||
+
|
||||
+trojka.6.out: trojka.6
|
||||
+ sed "s|%%PREFIX%%|$(PREFIX)|" trojka.6 > trojka.6.out
|
||||
|
||||
clean:
|
||||
rm -f $(PROGS) *.o core a.out trojka.scores
|
||||
@@ -53,3 +64,5 @@
|
||||
@@ -53,3 +63,5 @@ hpux:
|
||||
|
||||
linux:
|
||||
make trojka "CFLAGS=-DLINUX"
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
.SH FILES
|
||||
.nf
|
||||
-/usr/local/games/lib/trojka.scores The Trojka hiscore file
|
||||
+%%PREFIX%%/share/trojka/trojka.scores The Trojka hiscore file
|
||||
+/var/games/trojka.scores The Trojka hiscore file
|
||||
|
||||
.SH HISTORY
|
||||
First version written in 1989 for MS-Dog. Not long thereafter (in 1990)
|
||||
|
|
|
@ -1,7 +0,0 @@
|
|||
============================================================
|
||||
You now have suid binary (2755):
|
||||
|
||||
%%PREFIX%%/bin/trojka
|
||||
|
||||
Scores will not be saved if you don't set suid.
|
||||
============================================================
|
|
@ -1,11 +1,3 @@
|
|||
@mode 2755
|
||||
@group games
|
||||
bin/trojka
|
||||
@group
|
||||
@mode
|
||||
@(,games,2755) bin/trojka
|
||||
man/man6/trojka.6.gz
|
||||
%%DATADIR%%/README
|
||||
@group games
|
||||
%%DATADIR%%/trojka.scores
|
||||
@group
|
||||
@dirrm %%DATADIR%%
|
||||
@sample(,games,664) /var/games/trojka.scores.sample
|
||||
|
|
Loading…
Reference in a new issue