- Update to 2.0.7
- Use own copy of GrabWeather instead of wmweather's, which disappeared in latest revision of that port - Bandaid lack of C99 builtins in gcc in FreeBSD 4 (untested - runtesting welcome!)
This commit is contained in:
parent
f018d5629a
commit
28eaef1ec7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=130135
5 changed files with 37 additions and 12 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= gkrellweather
|
||||
PORTVERSION= 2.0.6
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 2.0.7
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -16,8 +15,7 @@ MAINTAINER= pav@FreeBSD.org
|
|||
COMMENT= GKrellWeather is a weather plugin for GKrellM
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
|
||||
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
|
||||
${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
|
||||
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
@ -25,10 +23,18 @@ ALL_TARGET= gkrellweather.so
|
|||
|
||||
MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# uses C99 builtin lrintf
|
||||
.if ${OSVERSION} < 500000
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-lrintf
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
|
||||
${INSTALL_DATA} ${WRKSRC}/gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
|
||||
${MKDIR} ${PREFIX}/share/locale/ru/
|
||||
${INSTALL_DATA} ${WRKSRC}/po/ru.mo ${PREFIX}/share/locale/ru/LC_MESSAGES/gkrellweather.mo
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/GrabWeather ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gkrellweather-2.0.6.tgz) = 458125fe9276db3733a6c4b0e27eca86
|
||||
SIZE (gkrellweather-2.0.6.tgz) = 20399
|
||||
MD5 (gkrellweather-2.0.7.tgz) = 73f5ec4e950f933a5904317037d6add2
|
||||
SIZE (gkrellweather-2.0.7.tgz) = 19968
|
||||
|
|
11
misc/gkrellweather2/files/extra-patch-lrintf
Normal file
11
misc/gkrellweather2/files/extra-patch-lrintf
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- gkrellweather.c.orig Wed Mar 2 00:23:34 2005
|
||||
+++ gkrellweather.c Wed Mar 2 00:28:58 2005
|
||||
@@ -7,6 +7,8 @@
|
||||
#include <gkrellm2/gkrellm.h>
|
||||
#include <math.h>
|
||||
|
||||
+#define lrintf(x) (int)rintf(x)
|
||||
+
|
||||
#define DEFAULT_STATION_ID "YSSY"
|
||||
|
||||
#define STYLE_NAME "weather"
|
|
@ -1,9 +1,9 @@
|
|||
--- Makefile.orig Mon Mar 31 13:12:57 2003
|
||||
+++ Makefile Sun Jul 13 13:58:11 2003
|
||||
--- Makefile.orig Sun Feb 27 14:54:47 2005
|
||||
+++ Makefile Wed Mar 2 00:22:17 2005
|
||||
@@ -1,9 +1,9 @@
|
||||
PKGNAME = gkrellweather
|
||||
VERSION = 2.0.6
|
||||
-CFLAGS = -O2 -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
|
||||
VERSION = 2.0.7
|
||||
-CFLAGS = -O2 -std=gnu99 -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
|
||||
+CFLAGS += -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
|
||||
LIBS = `pkg-config gtk+-2.0 --libs`
|
||||
LFLAGS = -shared
|
||||
|
@ -12,7 +12,14 @@
|
|||
|
||||
LOCALEDIR := $(PREFIX)/share/locale
|
||||
|
||||
@@ -20,7 +20,7 @@
|
||||
@@ -14,13 +14,13 @@
|
||||
CFLAGS += -DPACKAGE="\"$(PKGNAME)\""
|
||||
export PKGNAME LOCALEDIR
|
||||
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
|
||||
OBJS = gkrellweather.o
|
||||
|
||||
gkrellweather.so: $(OBJS)
|
||||
(cd po && ${MAKE} all )
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
bin/GrabWeather
|
||||
libexec/gkrellm2/plugins/gkrellweather.so
|
||||
share/locale/ru/LC_MESSAGES/gkrellweather.mo
|
||||
|
|
Loading…
Reference in a new issue