While working on the ports fallout due to the private Heimdal in base
project, a port (www/squid-devel) was discovered to be grumpy due to numerous errors such as below: /usr/local/include/krb5/krb5.h:3566:19: error: 'register' storage class specifier is deprecated and incompatible with C++17 [-Werror,-Wdeprecated-register] register char **name); ^~~~~~~~~ The "register" keyword is meaningless and can cause grief among ports that build against any of the krb5 ports.
This commit is contained in:
parent
6ff5f18d04
commit
2946336f3c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472760
6 changed files with 225 additions and 3 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= krb5
|
||||
PORTVERSION= 1.14.6
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
|
||||
.if !defined(MASTERDIR)
|
||||
|
|
74
security/krb5-114/files/patch-include_krb5_krb5.hin
Normal file
74
security/krb5-114/files/patch-include_krb5_krb5.hin
Normal file
|
@ -0,0 +1,74 @@
|
|||
--- include/krb5/krb5.hin.orig 2017-09-25 09:29:00.000000000 -0700
|
||||
+++ include/krb5/krb5.hin 2018-06-18 22:55:26.074018000 -0700
|
||||
@@ -3542,7 +3542,7 @@
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV
|
||||
krb5_unparse_name(krb5_context context, krb5_const_principal principal,
|
||||
- register char **name);
|
||||
+ char **name);
|
||||
|
||||
/**
|
||||
* Convert krb5_principal structure to string and length.
|
||||
@@ -4364,7 +4364,7 @@
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV_WRONG
|
||||
krb5_principal2salt(krb5_context context,
|
||||
- register krb5_const_principal pr, krb5_data *ret);
|
||||
+ krb5_const_principal pr, krb5_data *ret);
|
||||
/* librc.spec--see rcache.h */
|
||||
|
||||
/* libcc.spec */
|
||||
@@ -4705,7 +4705,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_error(krb5_context context, register krb5_error *val);
|
||||
+krb5_free_error(krb5_context context, krb5_error *val);
|
||||
|
||||
/**
|
||||
* Free a krb5_creds structure.
|
||||
@@ -4738,7 +4738,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_checksum(krb5_context context, register krb5_checksum *val);
|
||||
+krb5_free_checksum(krb5_context context, krb5_checksum *val);
|
||||
|
||||
/**
|
||||
* Free the contents of a krb5_checksum structure.
|
||||
@@ -4749,7 +4749,7 @@
|
||||
* This function frees the contents of @a val, but not the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_checksum_contents(krb5_context context, register krb5_checksum *val);
|
||||
+krb5_free_checksum_contents(krb5_context context, krb5_checksum *val);
|
||||
|
||||
/**
|
||||
* Free a krb5_keyblock structure.
|
||||
@@ -4760,7 +4760,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_keyblock(krb5_context context, register krb5_keyblock *val);
|
||||
+krb5_free_keyblock(krb5_context context, krb5_keyblock *val);
|
||||
|
||||
/**
|
||||
* Free the contents of a krb5_keyblock structure.
|
||||
@@ -4771,7 +4771,7 @@
|
||||
* This function frees the contents of @a key, but not the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_keyblock_contents(krb5_context context, register krb5_keyblock *key);
|
||||
+krb5_free_keyblock_contents(krb5_context context, krb5_keyblock *key);
|
||||
|
||||
/**
|
||||
* Free a krb5_ap_rep_enc_part structure.
|
||||
@@ -4887,7 +4887,7 @@
|
||||
* Kerberos error codes
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV
|
||||
-krb5_timeofday(krb5_context context, register krb5_timestamp *timeret);
|
||||
+krb5_timeofday(krb5_context context, krb5_timestamp *timeret);
|
||||
|
||||
/**
|
||||
* Check if a timestamp is within the allowed clock skew of the current time.
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= krb5
|
||||
PORTVERSION= 1.15.3
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
|
||||
.if !defined(MASTERDIR)
|
||||
|
|
74
security/krb5-115/files/patch-include_krb5_krb5.hin
Normal file
74
security/krb5-115/files/patch-include_krb5_krb5.hin
Normal file
|
@ -0,0 +1,74 @@
|
|||
--- include/krb5/krb5.hin.orig 2018-05-03 11:24:57.000000000 -0700
|
||||
+++ include/krb5/krb5.hin 2018-06-18 22:52:23.012932000 -0700
|
||||
@@ -3550,7 +3550,7 @@
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV
|
||||
krb5_unparse_name(krb5_context context, krb5_const_principal principal,
|
||||
- register char **name);
|
||||
+ char **name);
|
||||
|
||||
/**
|
||||
* Convert krb5_principal structure to string and length.
|
||||
@@ -4373,7 +4373,7 @@
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV_WRONG
|
||||
krb5_principal2salt(krb5_context context,
|
||||
- register krb5_const_principal pr, krb5_data *ret);
|
||||
+ krb5_const_principal pr, krb5_data *ret);
|
||||
/* librc.spec--see rcache.h */
|
||||
|
||||
/* libcc.spec */
|
||||
@@ -4714,7 +4714,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_error(krb5_context context, register krb5_error *val);
|
||||
+krb5_free_error(krb5_context context, krb5_error *val);
|
||||
|
||||
/**
|
||||
* Free a krb5_creds structure.
|
||||
@@ -4747,7 +4747,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_checksum(krb5_context context, register krb5_checksum *val);
|
||||
+krb5_free_checksum(krb5_context context, krb5_checksum *val);
|
||||
|
||||
/**
|
||||
* Free the contents of a krb5_checksum structure.
|
||||
@@ -4758,7 +4758,7 @@
|
||||
* This function frees the contents of @a val, but not the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_checksum_contents(krb5_context context, register krb5_checksum *val);
|
||||
+krb5_free_checksum_contents(krb5_context context, krb5_checksum *val);
|
||||
|
||||
/**
|
||||
* Free a krb5_keyblock structure.
|
||||
@@ -4769,7 +4769,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_keyblock(krb5_context context, register krb5_keyblock *val);
|
||||
+krb5_free_keyblock(krb5_context context, krb5_keyblock *val);
|
||||
|
||||
/**
|
||||
* Free the contents of a krb5_keyblock structure.
|
||||
@@ -4780,7 +4780,7 @@
|
||||
* This function frees the contents of @a key, but not the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_keyblock_contents(krb5_context context, register krb5_keyblock *key);
|
||||
+krb5_free_keyblock_contents(krb5_context context, krb5_keyblock *key);
|
||||
|
||||
/**
|
||||
* Free a krb5_ap_rep_enc_part structure.
|
||||
@@ -4896,7 +4896,7 @@
|
||||
* Kerberos error codes
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV
|
||||
-krb5_timeofday(krb5_context context, register krb5_timestamp *timeret);
|
||||
+krb5_timeofday(krb5_context context, krb5_timestamp *timeret);
|
||||
|
||||
/**
|
||||
* Check if a timestamp is within the allowed clock skew of the current time.
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= krb5
|
||||
PORTVERSION= 1.16.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
|
||||
.if !defined(MASTERDIR)
|
||||
|
|
74
security/krb5-116/files/patch-include_krb5_krb5.hin
Normal file
74
security/krb5-116/files/patch-include_krb5_krb5.hin
Normal file
|
@ -0,0 +1,74 @@
|
|||
--- include/krb5/krb5.hin.orig 2018-05-03 07:34:47.000000000 -0700
|
||||
+++ include/krb5/krb5.hin 2018-06-18 22:42:49.668451000 -0700
|
||||
@@ -3560,7 +3560,7 @@
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV
|
||||
krb5_unparse_name(krb5_context context, krb5_const_principal principal,
|
||||
- register char **name);
|
||||
+ char **name);
|
||||
|
||||
/**
|
||||
* Convert krb5_principal structure to string and length.
|
||||
@@ -4383,7 +4383,7 @@
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV_WRONG
|
||||
krb5_principal2salt(krb5_context context,
|
||||
- register krb5_const_principal pr, krb5_data *ret);
|
||||
+ krb5_const_principal pr, krb5_data *ret);
|
||||
/* librc.spec--see rcache.h */
|
||||
|
||||
/* libcc.spec */
|
||||
@@ -4724,7 +4724,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_error(krb5_context context, register krb5_error *val);
|
||||
+krb5_free_error(krb5_context context, krb5_error *val);
|
||||
|
||||
/**
|
||||
* Free a krb5_creds structure.
|
||||
@@ -4757,7 +4757,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_checksum(krb5_context context, register krb5_checksum *val);
|
||||
+krb5_free_checksum(krb5_context context, krb5_checksum *val);
|
||||
|
||||
/**
|
||||
* Free the contents of a krb5_checksum structure.
|
||||
@@ -4768,7 +4768,7 @@
|
||||
* This function frees the contents of @a val, but not the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_checksum_contents(krb5_context context, register krb5_checksum *val);
|
||||
+krb5_free_checksum_contents(krb5_context context, krb5_checksum *val);
|
||||
|
||||
/**
|
||||
* Free a krb5_keyblock structure.
|
||||
@@ -4779,7 +4779,7 @@
|
||||
* This function frees the contents of @a val and the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_keyblock(krb5_context context, register krb5_keyblock *val);
|
||||
+krb5_free_keyblock(krb5_context context, krb5_keyblock *val);
|
||||
|
||||
/**
|
||||
* Free the contents of a krb5_keyblock structure.
|
||||
@@ -4790,7 +4790,7 @@
|
||||
* This function frees the contents of @a key, but not the structure itself.
|
||||
*/
|
||||
void KRB5_CALLCONV
|
||||
-krb5_free_keyblock_contents(krb5_context context, register krb5_keyblock *key);
|
||||
+krb5_free_keyblock_contents(krb5_context context, krb5_keyblock *key);
|
||||
|
||||
/**
|
||||
* Free a krb5_ap_rep_enc_part structure.
|
||||
@@ -4906,7 +4906,7 @@
|
||||
* Kerberos error codes
|
||||
*/
|
||||
krb5_error_code KRB5_CALLCONV
|
||||
-krb5_timeofday(krb5_context context, register krb5_timestamp *timeret);
|
||||
+krb5_timeofday(krb5_context context, krb5_timestamp *timeret);
|
||||
|
||||
/**
|
||||
* Check if a timestamp is within the allowed clock skew of the current time.
|
Loading…
Reference in a new issue