Update to 0.35.1

PR:		ports/95485
Submitted by:	Anderson S. Ferreira <anderson@cnpm.embrapa.br>
Approved by:	lawrance (mentor, implicit)
This commit is contained in:
Ion-Mihai Tetcu 2006-06-05 10:29:13 +00:00
parent 60c0057861
commit 294cd10759
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164415
8 changed files with 197 additions and 92 deletions

View file

@ -6,29 +6,38 @@
#
PORTNAME= klamav
PORTVERSION= 0.32
PORTVERSION= 0.35.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= klamav
DISTNAME= ${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= A KDE 3 front-end to Clam Anti-Virus
LIB_DEPENDS= clamav:${PORTSDIR}/security/clamav
LIB_DEPENDS= clamav:${PORTSDIR}/security/clamav \
sqlite3:${PORTSDIR}/databases/sqlite3
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
WRKSRC= ${WRKDIR}/${DISTNAME}/${DISTNAME}
USE_BZIP2= yes
USE_GMAKE= yes
PREFIX= ${KDE_PREFIX}
DOCSDIR= ${PREFIX}/share/doc/HTML/en/klamav02
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_GETTEXT= yes
INSTALLS_ICONS= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
CONFIGURE_ARGS+= --with-qt-dir=${X11BASE}
CONFIGURE_ENV= LDFLAGS=${PTHREAD_LIBS}
CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
--without-included-sqlite
.include <bsd.port.mk>
USE_KDELIBS_VER= 3
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
IGNORE= klamav doesn't compile on FreeBSD 4.X
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
SIZE (klamav-0.32.tar.bz2) = 867227
MD5 (klamav-0.32.tar.bz2) = f0226c6b2f64f2e9d2c4099b1812fdb6
SHA256 (klamav-0.32.tar.bz2) = dd27cba3f433c9930efee21972c40c4179c629f8cd8997638be1c2e05878c962
MD5 (klamav-0.35.1.tar.bz2) = acbd1f0367a43bb0440c50a6caeb3a34
SHA256 (klamav-0.35.1.tar.bz2) = a1d07b6c0fd98aed9928e9d7c1f4ae35d529d2f0ae10d4e376693e7ac890f6a8
SIZE (klamav-0.35.1.tar.bz2) = 1117310

View file

@ -0,0 +1,11 @@
--- configure Thu Mar 9 08:15:40 2006
+++ configure Thu Mar 9 08:16:11 2006
@@ -9,6 +9,8 @@
## M4sh Initialization. ##
## --------------------- ##
+PKGCONFIGFOUND=yes
+
# Be Bourne compatible
if test -n "${ZSH_VERSION+set}" && (emulate sh) >/dev/null 2>&1; then
emulate sh

View file

@ -1,71 +0,0 @@
--- src/klamav.cpp Mon Nov 21 17:21:59 2005
+++ src/klamav.cpp Thu Dec 15 09:30:42 2005
@@ -47,24 +47,33 @@
connect(_tray,SIGNAL(quitSelected()),SLOT(shuttingDown()));
KPopupMenu *conf_menu = _tray->contextMenu();
+
+/* --
EnableKlamd = new KAction(i18n("&Enable Auto-Scan"), "klamav", 0,this, SLOT(contextEnable()),actionCollection(),"klamd_enable");
DisableKlamd = new KAction(i18n("&Disable Auto-Scan"),"klamavbw", 0,this, SLOT(contextDisable()),actionCollection(),"klamd_disable");
-
+*/
+
EnableFreshklam = new KAction(i18n("&Enable Auto-Updates"), "klamavbwdl", 0,this, SLOT(contextEnableFK()),actionCollection(),"fk_enable");
DisableFreshklam = new KAction(i18n("&Disable Auto-Updates"),"klamavbw", 0,this, SLOT(contextDisableFK()),actionCollection(),"fk_disable");
EnableFreshklam->plug(conf_menu);
DisableFreshklam->plug(conf_menu);
+
+/* --
EnableKlamd->plug(conf_menu);
DisableKlamd->plug(conf_menu);
-
+*/
+
QToolTip::add( _tray, "KlamAV - Virus Protection for KDE" );
_tray->show();
DisableFreshklam->setEnabled(FALSE);
EnableFreshklam->setEnabled(TRUE);
+
+/* --
DisableKlamd->setEnabled(FALSE);
EnableKlamd->setEnabled(TRUE);
+*/
KConfig* config = KGlobal::config();
config->setGroup("Freshklam");
@@ -81,10 +90,15 @@
tab->addTab(klamscan, i18n("&Scan"));
klamd = new Klamd(this);
+
+ klamd->hide();
+
+/* --
tab->addTab(klamd, i18n("&Auto-Scan"));
connect(klamd->search_button,SIGNAL(clicked()),SLOT(contextEnable()));
connect(klamd->cancel_button,SIGNAL(clicked()),SLOT(contextDisable()));
+*/
freshklam = new Freshklam(this);
tab->addTab(freshklam, i18n("&Update"));
@@ -105,8 +119,6 @@
aboutklamav = new Aboutklamav(this);
tab->addTab(aboutklamav, i18n("Abou&t"));
-
-
top->addWidget(tab);
@@ -149,6 +161,7 @@
void Klamav::shuttingDown(){
this->topLevelWidget()->hide();
+ this->contextDisableFK();
}

View file

@ -0,0 +1,29 @@
--- src/klamd.cpp Wed Mar 8 15:47:12 2006
+++ src/klamd.cpp Wed Mar 8 15:49:18 2006
@@ -699,7 +699,7 @@
dazukoLoaded = FALSE;
- QString lsmodCommand="lsmod";
+ QString lsmodCommand="kldstat";
lsmodproc = new KProcIO();
QString curpath = (QString) getenv("PATH");
lsmodproc->setEnvironment("PATH",curpath + ":/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin");
@@ -730,7 +730,7 @@
{
if (!(dazukoLoaded)){
int result;
- result = KMessageBox::warningContinueCancel(this, i18n( "I need to load a module called 'dazuko' first. This module will allow KlamAV to gain real-time access to files. If you don't want this message to appear in future, put the following command in your initialization scripts: 'modprobe dazuko.o'. You will next be asked for the root password."),
+ result = KMessageBox::warningContinueCancel(this, i18n( "I need to load a module called 'dazuko' first. This module will allow KlamAV to gain real-time access to files. If you don't want this message to appear in future, put the following command in your initialization scripts: 'kldload dazuko.ko'. You will next be asked for the root password."),
i18n( "Load Module" ),
i18n( "Load Module" ),
i18n( "Delete2" ));
@@ -803,7 +803,7 @@
//
// //kdDebug() << release << endl;
// QString insmodCommand="insmod /lib/modules/" + release + "/dazuko.o";
- QString insmodCommand="modprobe dazuko";
+ QString insmodCommand="kldload /usr/local/modules/dazuko.ko";
//QString insmodCommand="insmod /opt/kde/bin/dazuko.o";
KProcIO *insmodproc = new KProcIO();

View file

@ -0,0 +1,112 @@
--- po/cs.po Wed Feb 8 20:58:15 2006
+++ po/cs.po Tue May 9 23:15:41 2006
@@ -610,10 +610,10 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
+"'kldload dazuko.ko'. You will next be asked for the root password."
msgstr ""
"KlamAV potřebuje nejprve zavést modul 'dazuko'. Tento modul KlamAVu umožní přístup k souborům v reálném čase. Pokud nechcete, aby se tato zpráva v budoucnu zobrazovala, přidejte následující řádek do vašeho init skriptu: "
-"'modprobe dazuko.o'. Nyní budete požádáni o heslo roota."
+"'kldload dazuko.ko'. Nyní budete požádáni o heslo roota."
#: klamd.cpp:733 klamd.cpp:734
msgid "Load Module"
--- po/de.po Mon Apr 24 15:37:37 2006
+++ po/de.po Mon Apr 24 22:33:22 2006
@@ -1080,7 +1080,7 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
+"'kldload dazuko.ko'. You will next be asked for the root password."
msgstr ""
"Es muß das Modul mit dem Namen \"dazuko\" geladen werden. Dies ermöglicht "
"einen verbesserten Zugriffn auf die Datein. Wenn sie nicht möchten, dass "
--- po/es.po Mon Apr 24 15:37:37 2006
+++ po/es.po Mon Apr 24 22:33:22 2006
@@ -747,12 +747,12 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
+"'kldload dazuko.ko'. You will next be asked for the root password."
msgstr ""
"Se necesita cargar un módulo llamado 'dazuko' primero. Este módulo le "
"permite a KlamAV acceso en tiempo real a los ficheros. Si no quiere que este "
"mensaje aparezca en el futuro, ponga lo siguiente en los scripts de "
-"inicialización: 'modprobe dazuko.o'. Necesita la clave de administrador."
+"inicialización: 'kldload dazuko.ko'. Necesita la clave de administrador."
#: klamd.cpp:718 klamd.cpp:719
msgid "Load Module"
--- po/hu.po Wed Feb 8 20:58:15 2006
+++ po/hu.po Tue May 9 23:29:30 2006
@@ -626,12 +626,12 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
+"'kldload dazuko.ko'. You will next be asked for the root password."
msgstr ""
"Először be kell tölteni a 'dazuko' nevű modult. Ez a modul teszi lehetővé a KlamAV számára "
"a fájlok valós idejű elérését. Ha azt szeretné, hogy ez az üzenet "
"ne jelenjen meg a jövőben, írja be a következő parancsot a rendszerinicializálási szkriptbe: "
-"'modprobe dazuko.o'. A rendszergazdai jelszót meg kell adni."
+"'kldload dazuko.ko'. A rendszergazdai jelszót meg kell adni."
#: klamd.cpp:718 klamd.cpp:719
msgid "Load Module"
--- po/it.po Mon Apr 24 15:37:37 2006
+++ po/it.po Mon Apr 24 22:33:22 2006
@@ -1067,7 +1067,7 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
+"'kldload dazuko.ko'. You will next be asked for the root password."
msgstr ""
#: klamd.cpp:734 klamd.cpp:735
--- po/pl.po Wed Feb 8 20:58:15 2006
+++ po/pl.po Tue May 9 23:34:26 2006
@@ -545,8 +545,8 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-msgstr "Konieczne jest załadowanie najpier modułu Dazuko. Moduł ten pozwoli programowi KlamAV uzyskać dostęp do skanowania plików w czasie rzeczywistym. Jeżeli nie chcesz, aby ta informacja pojawiała się w przyszłości, wklej następującą komendę w skrypcie inicjalizacyjnym: 'modeprobe dazuko.o'. Za chwilę pojawi się pytanie o hasło administratora."
+"'kldload dazuko.ko'. You will next be asked for the root password."
+msgstr "Konieczne jest załadowanie najpier modułu Dazuko. Moduł ten pozwoli programowi KlamAV uzyskać dostęp do skanowania plików w czasie rzeczywistym. Jeżeli nie chcesz, aby ta informacja pojawiała się w przyszłości, wklej następującą komendę w skrypcie inicjalizacyjnym: 'kldload dazuko.ko'. Za chwilę pojawi się pytanie o hasło administratora."
#: klamd.cpp:773 klamd.cpp:774
msgid "Load Module"
--- po/pt_BR.po Mon Apr 24 15:37:37 2006
+++ po/pt_BR.po Mon Apr 24 22:33:22 2006
@@ -1151,12 +1151,12 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
+"'kldload dazuko.ko'. You will next be asked for the root password."
msgstr ""
"Preciso carregar um módulo chamado 'dazuko' antes. Este módulo permitirá ao "
"KlamAV obter acesso em tempo real a arquivos. Se não desejar que esta "
"mensagem continue a aparecer, insire o seguinte comando nos seus scripts de "
-"inicialização: 'modprobe dazuko.o.' É necessário ser root para executar a "
+"inicialização: 'kldload dazuko.ko.' É necessário ser root para executar a "
"função."
#: klamd.cpp:734 klamd.cpp:735
--- po/ru.po Mon Apr 24 15:37:37 2006
+++ po/ru.po Mon Apr 24 22:33:22 2006
@@ -1081,7 +1081,7 @@
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
+"'kldload dazuko.ko'. You will next be asked for the root password."
msgstr ""
"Необходимо запустить модуль, называемый dazuko. Этот модуль разрешит KlamAV "
"получать доступ в реальном времени к файлам. Далее Вас попросят ввести "

View file

@ -0,0 +1,11 @@
--- src/freshklam.cpp Fri Mar 10 11:03:46 2006
+++ src/freshklam.cpp Fri Mar 10 11:04:15 2006
@@ -165,7 +165,7 @@
-
+ software_group->hide();
//Virus Database Directory

View file

@ -1,12 +1,13 @@
bin/ScanWithKlamAV.sh
bin/klammail
bin/klamd
bin/klamarkollon
share/doc/HTML/en/klamav02/index.docbook
share/doc/HTML/en/klamav02/index.cache.bz2
share/doc/HTML/en/klamav02/common
bin/ScanWithKlamAV
%%DOCSDIR%%/index.docbook
%%DOCSDIR%%/index.cache.bz2
%%DOCSDIR%%/common
share/locale/de/LC_MESSAGES/klamav.mo
share/locale/cs/LC_MESSAGES/klamav.mo
share/locale/hu/LC_MESSAGES/klamav.mo
share/locale/es/LC_MESSAGES/klamav.mo
share/locale/it/LC_MESSAGES/klamav.mo
share/locale/pl/LC_MESSAGES/klamav.mo
@ -17,6 +18,7 @@ share/apps/klamav/eventsrc
share/applnk/Utilities/klamav.desktop
share/apps/konqueror/servicemenus/klamav-dropdown.desktop
share/apps/klamav/klamavui.rc
share/config.kcfg/klamavconfig.kcfg
share/icons/locolor/32x32/apps/klamav.png
share/icons/locolor/32x32/actions/klamav.png
share/icons/locolor/16x16/apps/klamav.png
@ -44,11 +46,12 @@ share/apps/klamav/icons/hicolor/32x32/actions/klamav.png
share/apps/klamav/icons/locolor/16x16/actions/klamav.png
share/apps/klamav/about/main.html
share/apps/klamav/about/wait.html
share/apps/klamav/about/nodb.html
share/apps/klamav/about/aboutklamav.html
share/apps/klamav/about/klam.png
share/apps/klamav/about/tshirt.png
@dirrmtry share/applnk/Utilities
@dirrmtry share/doc/HTML/en/klamav02
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/apps/konqueror/servicemenus
@dirrmtry share/icons/locolor/32x32/apps
@dirrmtry share/icons/locolor/32x32/actions
@ -76,3 +79,4 @@ share/apps/klamav/about/tshirt.png
@dirrmtry share/apps/klamav/icons
@dirrmtry share/apps/klamav/about
@dirrmtry share/apps/klamav
@dirrmtry share/config.kcfg