Add devel/c4, a CVS-like Frontend to Perforce.
This commit is contained in:
parent
d1ceee18ae
commit
294ef6fe60
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47297
7 changed files with 58 additions and 0 deletions
|
@ -53,6 +53,7 @@
|
|||
SUBDIR += bonobo-conf
|
||||
SUBDIR += bugbuddy
|
||||
SUBDIR += c2lib
|
||||
SUBDIR += c4
|
||||
SUBDIR += c_c++_reference
|
||||
SUBDIR += camlp4
|
||||
SUBDIR += cbrowser
|
||||
|
|
29
devel/c4/Makefile
Normal file
29
devel/c4/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: C4
|
||||
# Date created: 2 September 2001
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= c4
|
||||
PORTVERSION= 1.6
|
||||
CATEGORIES+= devel
|
||||
MASTER_SITES= ftp://ftp.perforce.com/perforce/utils/c4/
|
||||
DISTNAME= ${PORTNAME}
|
||||
|
||||
MAINTAINER= knu@FreeBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
ALL_TARGET= c4
|
||||
|
||||
MAN1= c4.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/c4 ${PREFIX}/bin/
|
||||
.if !defined(NOPORTDOCS)
|
||||
${INSTALL_MAN} ${WRKSRC}/c4.1 ${PREFIX}/man/man1/
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/c4/distinfo
Normal file
1
devel/c4/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (c4.tar.gz) = ead31edecb2c22234703929a0a3a59ed
|
9
devel/c4/files/patch-Makefile
Normal file
9
devel/c4/files/patch-Makefile
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- Makefile.orig Fri Feb 11 17:11:52 2000
|
||||
+++ Makefile Sun Sep 2 06:45:15 2001
|
||||
@@ -4,4 +4,4 @@
|
||||
|
||||
-CC = gcc
|
||||
-CFLAGS = -O
|
||||
+CC ?= gcc
|
||||
+CFLAGS ?= -O
|
||||
# CFLAGS = -g
|
1
devel/c4/pkg-comment
Normal file
1
devel/c4/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A CVS-like Frontend to Perforce
|
14
devel/c4/pkg-descr
Normal file
14
devel/c4/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
C4: A CVS-like Frontend to Perforce
|
||||
|
||||
C4 provides a CVS-like feel to Perforce. C4 is not a substitute for
|
||||
CVS, in that it does not try to mimic CVS's command set. Rather, it
|
||||
provides a workspace (client) where every file is writable, and can be
|
||||
modified on an adhoc basis. C4 provides commands that search a
|
||||
client, looking for files that have been added or changed, and runs P4
|
||||
commands on them to add, edit, revert, refresh or update them. C4
|
||||
provides a control file that is placed at the top of each client to
|
||||
set environment variables, such as P4PORT and P4CLIENT. A manpage is
|
||||
included.
|
||||
|
||||
WWW: http://www.perforce.com/perforce/loadsupp.html
|
||||
Author: Neil Russell <caret@c-side.com>
|
3
devel/c4/pkg-plist
Normal file
3
devel/c4/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/c4
|
||||
share/doc/c4/index.html
|
||||
@dirrm share/doc/c4
|
Loading…
Reference in a new issue