audio/drumstick: Update to 1.1.1
Additional changes: * Added PLIST_SUB * Updated patches Reported by: portscout Approved by: tcberner (mentor, implicit)
This commit is contained in:
parent
698e0601c6
commit
29c9651a37
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=463032
7 changed files with 32 additions and 89 deletions
|
@ -1,8 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= drumstick
|
||||
DISTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 1.1.1
|
||||
CATEGORIES= audio multimedia
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
|
||||
|
||||
|
@ -28,6 +27,8 @@ MANPAGES_BUILD_DEPENDS= xsltproc:textproc/libxslt \
|
|||
docbook-xsl>0:textproc/docbook-xsl
|
||||
MANPAGES_CMAKE_BOOL= BUILD_DOCS
|
||||
|
||||
PLIST_SUB= SHL3=${PORTVERSION} SHL1=${PORTVERSION:R:R}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|"default.sf2"|"${LOCALBASE}/share/sounds/sf2/FluidR3_GM.sf2"|' \
|
||||
${WRKSRC}/utils/vpiano/fluidsettingsdialog.cpp \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1510117698
|
||||
SHA256 (drumstick-1.1.0.tar.bz2) = ae1d2c0d21b45d144e181b873ffbc2979a294fab31b8d71a5b0b8cad3276f38e
|
||||
SIZE (drumstick-1.1.0.tar.bz2) = 1012405
|
||||
TIMESTAMP = 1519663446
|
||||
SHA256 (drumstick-1.1.1.tar.bz2) = 367743764c8f5c6e40bb19b9581f083da2881b9c9516d6b3b247e5644dee7c2b
|
||||
SIZE (drumstick-1.1.1.tar.bz2) = 1011275
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2016-09-24 21:08:24 UTC
|
||||
--- CMakeLists.txt.orig 2018-02-24 20:04:23 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -24,7 +24,7 @@ endif()
|
||||
@@ -22,7 +22,7 @@ endif()
|
||||
project(DRUMSTICK)
|
||||
|
||||
if(CMAKE_SIZEOF_VOID_P MATCHES "8")
|
||||
|
@ -9,7 +9,7 @@
|
|||
else()
|
||||
set(_INIT_LIB_SUFFIX "")
|
||||
endif()
|
||||
@@ -65,13 +65,13 @@ add_definitions(-DVERSION=${VERSION})
|
||||
@@ -63,13 +63,13 @@ add_definitions(-DVERSION=${VERSION})
|
||||
message(STATUS "drumstick ${VERSION} prefix: ${CMAKE_INSTALL_PREFIX}")
|
||||
|
||||
set(_DBUS_INIT OFF)
|
||||
|
@ -25,7 +25,7 @@
|
|||
|
||||
message(STATUS "Build configuration: ${CMAKE_BUILD_TYPE}")
|
||||
|
||||
@@ -99,8 +99,8 @@ else()
|
||||
@@ -97,8 +97,8 @@ else()
|
||||
message(FATAL_ERROR "Program pkg-config not found")
|
||||
endif()
|
||||
|
||||
|
@ -36,18 +36,19 @@
|
|||
if(ALSA_FOUND)
|
||||
set(ALSA_LIBS ${ALSA_LIBRARIES})
|
||||
list(APPEND ALSA_LIB_DIR ${ALSA_LIBRARY_DIRS} ${ALSA_LIBDIR})
|
||||
@@ -108,7 +108,9 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
else()
|
||||
@@ -107,7 +107,10 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
message(STATUS "Warning: ALSA library not found.")
|
||||
endif()
|
||||
- pkg_check_modules(PULSE libpulse-simple)
|
||||
+ if (USE_PULSEAUDIO)
|
||||
+ pkg_check_modules(PULSE libpulse-simple)
|
||||
+ endif()
|
||||
if(NOT PULSE_FOUND)
|
||||
message(STATUS "Warning: PulseAudio library not found.")
|
||||
endif()
|
||||
@@ -128,7 +130,7 @@ if(BUILD_TESTING)
|
||||
endif()
|
||||
-pkg_check_modules(PULSE libpulse-simple)
|
||||
+#pkg_check_modules(PULSE libpulse-simple)
|
||||
+if (USE_PULSEAUDIO)
|
||||
+ pkg_check_modules(PULSE libpulse-simple)
|
||||
+endif()
|
||||
if(NOT PULSE_FOUND)
|
||||
message(STATUS "Warning: PulseAudio library not found.")
|
||||
endif()
|
||||
@@ -126,7 +129,7 @@ if(BUILD_TESTING)
|
||||
add_subdirectory(tests)
|
||||
endif()
|
||||
|
||||
|
@ -56,7 +57,7 @@
|
|||
find_package(Doxygen)
|
||||
if(DOXYGEN_FOUND)
|
||||
configure_file(
|
||||
@@ -139,12 +141,14 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
@@ -137,12 +140,14 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
${DOXYGEN} Doxyfile
|
||||
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
|
||||
endif()
|
||||
|
@ -76,7 +77,7 @@
|
|||
# XML mime types
|
||||
set( SHARED_MIME_INFO_MINIMUM_VERSION "0.30" )
|
||||
set( XDG_MIME_INSTALL_DIR "${CMAKE_INSTALL_DATAROOTDIR}/mime/packages" )
|
||||
@@ -174,7 +178,7 @@ configure_file(
|
||||
@@ -172,7 +177,7 @@ configure_file(
|
||||
add_custom_target( uninstall
|
||||
"${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
|
||||
|
||||
|
|
|
@ -1,48 +0,0 @@
|
|||
--- library/include/drumstickcommon.h.orig 2016-09-24 21:08:23 UTC
|
||||
+++ library/include/drumstickcommon.h
|
||||
@@ -27,7 +27,8 @@
|
||||
#include <QtDebug>
|
||||
|
||||
extern "C" {
|
||||
-#include <alsa/asoundlib.h>
|
||||
+// ALSA isn't disabled cleanly, see https://sourceforge.net/p/drumstick/bugs/9
|
||||
+//#include <alsa/asoundlib.h>
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -73,7 +74,7 @@ public:
|
||||
*/
|
||||
const QString qstrError() const
|
||||
{
|
||||
- return QString(snd_strerror(m_errCode));
|
||||
+ return QString((m_errCode));
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -110,7 +111,7 @@ private:
|
||||
inline int checkErrorAndThrow(int rc, const char *where)
|
||||
{
|
||||
if (rc < 0) {
|
||||
- qDebug() << "Error code:" << rc << "(" << snd_strerror(rc) << ")";
|
||||
+ qDebug() << "Error code:" << rc << "(" << (rc) << ")";
|
||||
qDebug() << "Location:" << where;
|
||||
throw SequencerError(QString(where), rc);
|
||||
}
|
||||
@@ -127,7 +128,7 @@ inline int checkErrorAndThrow(int rc, co
|
||||
inline int checkWarning(int rc, const char *where)
|
||||
{
|
||||
if (rc < 0) {
|
||||
- qWarning() << "Exception code:" << rc << "(" << snd_strerror(rc) << ")";
|
||||
+ qWarning() << "Exception code:" << rc << "(" << (rc) << ")";
|
||||
qWarning() << "Location:" << where;
|
||||
}
|
||||
return rc;
|
||||
@@ -152,7 +153,7 @@ inline int checkWarning(int rc, const ch
|
||||
* different to the runtime library.
|
||||
* @see getRuntimeALSALibraryVersion
|
||||
*/
|
||||
-const QString LIBRARY_VERSION(SND_LIB_VERSION_STR);
|
||||
+const QString LIBRARY_VERSION("???");
|
||||
|
||||
} /* namespace drumstick */
|
||||
|
|
@ -1,11 +1,11 @@
|
|||
--- library/rt-backends/CMakeLists.txt.orig 2016-09-24 21:08:23 UTC
|
||||
--- library/rt-backends/CMakeLists.txt.orig 2018-02-26 17:05:42 UTC
|
||||
+++ library/rt-backends/CMakeLists.txt
|
||||
@@ -19,7 +19,7 @@
|
||||
@@ -17,7 +17,7 @@
|
||||
#add_subdirectory(dummy-in)
|
||||
#add_subdirectory(dummy-out)
|
||||
|
||||
-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
+if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD")
|
||||
if(ALSA_FOUND)
|
||||
add_subdirectory(alsa-in)
|
||||
add_subdirectory(alsa-out)
|
||||
if(ALSA_FOUND)
|
||||
add_subdirectory(alsa-in)
|
||||
add_subdirectory(alsa-out)
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- library/rt-backends/eassynth/src/synthrenderer.cpp.orig 2016-09-24 21:08:23 UTC
|
||||
+++ library/rt-backends/eassynth/src/synthrenderer.cpp
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <pulse/simple.h>
|
||||
#include "synthrenderer.h"
|
||||
#include "drumstickcommon.h"
|
||||
+#include <assert.h>
|
||||
|
||||
namespace drumstick {
|
||||
namespace rt {
|
|
@ -13,14 +13,13 @@ lib/drumstick/libdrumstick-rt-net-in.so
|
|||
lib/drumstick/libdrumstick-rt-net-out.so
|
||||
lib/drumstick/libdrumstick-rt-oss-in.so
|
||||
lib/drumstick/libdrumstick-rt-oss-out.so
|
||||
lib/drumstick/libdrumstick-rt-synth.so
|
||||
%%PULSEAUDIO%%lib/drumstick/libdrumstick-rt-eassynth.so
|
||||
lib/libdrumstick-file.so
|
||||
lib/libdrumstick-file.so.1
|
||||
lib/libdrumstick-file.so.1.1.0
|
||||
lib/libdrumstick-file.so.%%SHL1%%
|
||||
lib/libdrumstick-file.so.%%SHL3%%
|
||||
lib/libdrumstick-rt.so
|
||||
lib/libdrumstick-rt.so.1
|
||||
lib/libdrumstick-rt.so.1.1.0
|
||||
lib/libdrumstick-rt.so.%%SHL1%%
|
||||
lib/libdrumstick-rt.so.%%SHL3%%
|
||||
libdata/pkgconfig/drumstick-file.pc
|
||||
libdata/pkgconfig/drumstick-rt.pc
|
||||
share/applications/drumstick-vpiano.desktop
|
||||
|
|
Loading…
Reference in a new issue