- Unbreak on versions after strndup MFC

- Pass maintainership to submitter

PR:		ports/132070
Submitted by:	Florian Smeets <flo@kasimir.com>
This commit is contained in:
Wesley Shields 2009-02-25 14:24:04 +00:00
parent e62e91a109
commit 29e4210013
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=229039
2 changed files with 39 additions and 12 deletions

View file

@ -5,25 +5,18 @@
# $FreeBSD$
#
PORTNAME= cvswrap
PORTNAME= cvswrap
PORTVERSION= 0.2
CATEGORIES= devel
CATEGORIES= devel
MASTER_SITES+= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= alfred
MAINTAINER= ports@FreeBSD.org
COMMENT= Helper for multiple CVS repositories.
MAINTAINER= flo@kasimir.com
COMMENT= Helper for multiple CVS repositories
GNU_CONFIGURE= yes
MAN1= cvswrap.1
MAN5= cvswrap.conf.5
.include <bsd.port.pre.mk>
# Redefines strndup(3)
.if ${OSVERSION} >= 800058 || (${OSVERSION} >= 701101 && ${OSVERSION} < 800000)
BROKEN= does not build
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,34 @@
--- cvswrap.c.orig 2009-02-24 15:40:55.000000000 +0100
+++ cvswrap.c 2009-02-24 15:38:24.000000000 +0100
@@ -94,7 +94,12 @@
char **cvsrootp);
static void slashfix(char *);
static int strings_have_line(char * const *strings, const char *line);
+#if defined(__FreeBSD__)
+#include <osreldate.h>
+#if __FreeBSD_version <= 800057 && __FreeBSD_version > 800000 || __FreeBSD_version <= 701100
static char * strndup(const char *str, size_t len);
+#endif
+#endif
static int timeval_diff(const struct timeval *tv1,
const struct timeval *tv2);
static int writebuf(int fd, const char *buf, size_t len);
@@ -324,6 +329,9 @@
return (0);
}
+#if defined(__FreeBSD__)
+#include <osreldate.h>
+#if __FreeBSD_version <= 800057 && __FreeBSD_version > 800000 || __FreeBSD_version <= 701100
/*
* return: a copy of "len" bytes from byte string "str" and NULL terminate.
*/
@@ -340,6 +348,8 @@
*(ret + len) = '\0';
return (ret);
}
+#endif
+#endif
/*
* Wait for child cvs process to exit.