Update from 2.0 to 2.2

Note: Matt Dillon's 2xP3/450 w/512MB can build world over NFS faster than my
      k6-2 333 can compile this port.  It was *NOT* fun to test this port.
	  Maybe someone else (with a super fast computer) could make sure
	  everything works.  This port does pass the make install deinstall
	  reinstall package deinstall test though so I assume everything
	  is fine.

PR:		11242
Submitted by:	maintainer with fixes by me
This commit is contained in:
Michael Haro 1999-04-21 06:52:10 +00:00
parent 9da1e234f4
commit 2a0f68dc16
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18044
7 changed files with 147 additions and 3783 deletions

View file

@ -3,32 +3,35 @@
# Date created: 23 Jan 1998
# Whom: housel@acm.org
#
# $Id: Makefile,v 1.3 1998/07/15 07:43:38 hsu Exp $
# $Id: Makefile,v 1.4 1998/10/14 00:08:48 jseger Exp $
#
DISTNAME= gd20-source
PKGNAME= dylan-2.0
DISTNAME= gd-2.2.0
PKGNAME= dylan-2.2.0
CATEGORIES= lang
MASTER_SITES= http://legend.gwydion.cs.cmu.edu/gwydion/dylan/release/ http://www.freebsd.org/~hsu/ports/files/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} d2c_2_0-FreeBSD.gz
MASTER_SITES= ftp://berlin.ccc.de/pub/gd/src/ \
ftp://berlin.ccc.de/pub/gd/FreeBSD/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} d2c-2.2.0-FreeBSD.gz
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= housel@acm.org
WRKSRC= $(WRKDIR)/src
BROKEN_ELF= yes
WRKSRC= $(WRKDIR)/gd/src
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=$(PREFIX) --srcdir=$(WRKSRC)
CONFIGURE_ENV= D2C="$(WRKDIR)/d2c -p$(WRKSRC)/d2c/compiler/platforms.descr"
CONFIGURE_ENV= D2C="$(WRKDIR)/d2c"
USE_GMAKE= yes
MAKEFILE= GNUmakefile
ALL_TARGET= default
MAN1= d2c.1 make-dylan-app.1 melange.1 mindy.1 mindycomp.1
MAN5= platforms.descr.5
MAN7= dylan.7 gwydion.7
post-extract:
$(GUNZIP_CMD) -c $(DISTDIR)/d2c_2_0-FreeBSD.gz > $(WRKDIR)/d2c
$(GUNZIP_CMD) -c $(DISTDIR)/d2c-2.2.0-FreeBSD.gz > $(WRKDIR)/d2c
chmod ugo+x $(WRKDIR)/d2c
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (gd20-source.tar.gz) = 86ae9486ef78104f2ad85d4fd9230bd0
MD5 (d2c_2_0-FreeBSD.gz) = a9ca1e7f9f2927efedf004c125a9b0fe
MD5 (gd-2.2.0.tar.gz) = f233d92c32abd6f9d32412010bd5b327
MD5 (d2c-2.2.0-FreeBSD.gz) = 610b2f20c19a7e6bb91c9f65ed45a5fd

File diff suppressed because it is too large Load diff

View file

@ -1,11 +1,29 @@
--- mindy/comp/Makefile.in.orig Fri May 9 20:45:36 1997
+++ mindy/comp/Makefile.in Sun Jul 12 00:32:35 1998
@@ -147,7 +147,7 @@
lexer-tab.o: ${SRCDIR}/lexer-tab.c ${SRCDIR}/lexer.h ${SRCDIR}/src.h \
${SRCDIR}/parser-tab.h
- ${CC} -c ${CFLAGS} ${SRCDIR}/lexer-tab.c
+ ${CC} -c -D_ANSI_SOURCE ${CFLAGS} ${SRCDIR}/lexer-tab.c
literal.o: ${SRCDIR}/literal.c ${SRCDIR}/../compat/std-c.h ${SRCDIR}/mindycomp.h \
${SRCDIR}/literal.h ${SRCDIR}/lose.h
--- configure~ Tue Apr 20 10:16:07 1999
+++ configure Tue Apr 20 10:16:42 1999
@@ -772,7 +772,7 @@
hppa*-hp-hpux*) d2c_build=hppa-hpux ;;
sparc*-solaris*) d2c_build=sparc-solaris ;;
i*86-*-freebsd2*) d2c_build=x86-freebsd-aout ;;
- i*86-*-freebsd3*) d2c_build=x86-freebsd-elf ;;
+ i*86-*-freebsd*) d2c_build=x86-freebsd-elf ;;
i*86-pc-cygwin32) d2c_build=x86-win32-gcc ;;
i*86-pc-none) d2c_build=x86-win32-vc ;;
*) d2c_build=unknown-unix ;;
@@ -789,7 +789,7 @@
hppa*-hp-hpux*) d2c_host=hppa-hpux ;;
sparc*-solaris*) d2c_host=sparc-solaris ;;
i*86-*-freebsd2*) d2c_host=x86-freebsd-aout ;;
- i*86-*-freebsd3*) d2c_host=x86-freebsd-elf ;;
+ i*86-*-freebsd*) d2c_host=x86-freebsd-elf ;;
i*86-pc-cygwin32) d2c_host=x86-win32-gcc ;;
i*86-pc-none) d2c_host=x86-win32-vc ;;
*) d2c_host=unknown-unix ;;
@@ -806,7 +806,7 @@
hppa*-hp-hpux*) d2c_target=hppa-hpux ;;
sparc*-solaris*) d2c_target=sparc-solaris ;;
i*86-*-freebsd2*) d2c_target=x86-freebsd-aout ;;
- i*86-*-freebsd3*) d2c_target=x86-freebsd-elf ;;
+ i*86-*-freebsd*) d2c_target=x86-freebsd-elf ;;
i*86-pc-cygwin32) d2c_target=x86-win32-gcc ;;
i*86-pc-none) d2c_target=x86-win32-vc ;;
*) d2c_target=unknown-unix ;;

11
lang/dylan/files/patch-ac Normal file
View file

@ -0,0 +1,11 @@
--- configure.in~ Tue Apr 20 10:15:59 1999
+++ configure.in Tue Apr 20 10:16:25 1999
@@ -69,7 +69,7 @@
hppa*-hp-hpux*) $2=hppa-hpux ;;
sparc*-solaris*) $2=sparc-solaris ;;
i*86-*-freebsd2*) $2=x86-freebsd-aout ;;
- i*86-*-freebsd3*) $2=x86-freebsd-elf ;;
+ i*86-*-freebsd*) $2=x86-freebsd-elf ;;
i*86-pc-cygwin32) $2=x86-win32-gcc ;;
i*86-pc-none) $2=x86-win32-vc ;;
*) $2=unknown-unix ;;

View file

@ -10,10 +10,9 @@ dynamic languages.
The Dylan language was originally developed by Apple, but the project
was dropped just as the language definition was being finished and
before a production-quality compiler was complete. The CMU Gwydion
before a production-quality compiler was complete. The Gwydion
project and Harlequin have continued use and development of the
language. For more information about the Dylan language, see the
Dylan World site at http://www-dylan.uchicago.edu/.
language.
Gwydion Dylan actually contains two implementations of the language.
One, called Mindy (Mindy Is Not Dylan Yet), is a bytecode compiler and
@ -22,18 +21,17 @@ facility. The other, d2c, is a compiler for the full language that
uses C as its target "assembly language". The d2c compiler was
written in Dylan and bootstrapped using Mindy.
A copy of the d2c compiler binary is included with the port to
A copy of the d2c compiler binary is required by the port to
bootstrap the entire system. As the Gwydion documentation says,
Recompiling the entire system takes over an hour on 64meg 200mhz
Pentium Pro running Windows/NT. This is almost all for the
compilation of the d2c runtime and compiler; compiling just Mindy
takes only a few minutes. d2c also uses lots of memory, especially
when compiling itself: you want at least 48 meg, and more is
better.
Recompiling the entire system takes over an hour on 64meg 200mhz
Pentium Pro running Windows/NT. This is almost all for the
compilation of the d2c runtime and compiler; compiling just Mindy
takes only a few minutes. d2c also uses lots of memory, especially
when compiling itself: you want at least 48 meg, and more is
better.
For more information about building Gwydion dylan, see
http://legend.gwydion.cs.cmu.edu/gwydion/dylan/docs/htdocs/unix-build.html.
The Gwydion project home page is at http://legend.gwydion.cs.cmu.edu/gwydion/
For more information about Gwydion Dylan, see the Gwydion Dylan maintainers
web site at http://www.gwydiondylan.org/
-Peter S. Housel- housel@acm.org

View file

@ -1,71 +1,77 @@
lib/dylan/collection-extensions-lib.dbc
lib/dylan/collection-extensions.lib.du
lib/dylan/dylan-lib.dbc
lib/dylan/dylan.lib.du
lib/dylan/elisp/dylan-mode.el
lib/dylan/elisp/dylan-params.el
lib/dylan/elisp/fill-comment.el
lib/dylan/elisp/goto-def.el
lib/dylan/elisp/mindy-comp.el
lib/dylan/elisp/page-cmds.el
lib/dylan/format-lib.dbc
lib/dylan/format-out-lib.dbc
lib/dylan/format-out.lib.du
lib/dylan/format.lib.du
lib/dylan/inspector-base-lib.dbc
lib/dylan/libcollext.a
lib/dylan/libdylan.a
lib/dylan/libformat.a
lib/dylan/libformatout.a
lib/dylan/libgc.a
lib/dylan/libmatrix.a
lib/dylan/libmelange.a
lib/dylan/libprint.a
lib/dylan/librandom.a
lib/dylan/libregexp.a
lib/dylan/libruntime.a
lib/dylan/libstdio.a
lib/dylan/libstreamext.a
lib/dylan/libstreams.a
lib/dylan/libstringext.a
lib/dylan/libtableext.a
lib/dylan/libtranscendental.a
lib/dylan/matrix-lib.dbc
lib/dylan/matrix.lib.du
lib/dylan/melange-support.lib.du
lib/dylan/print-lib.dbc
lib/dylan/print.lib.du
lib/dylan/random-lib.dbc
lib/dylan/random.lib.du
lib/dylan/regular-expressions-lib.dbc
lib/dylan/regular-expressions.lib.du
lib/dylan/standard-io-lib.dbc
lib/dylan/standard-io.lib.du
lib/dylan/stream-extensions-lib.dbc
lib/dylan/stream-extensions.lib.du
lib/dylan/streams-lib.dbc
lib/dylan/streams.lib.du
lib/dylan/string-extensions-lib.dbc
lib/dylan/string-extensions.lib.du
lib/dylan/table-extensions-lib.dbc
lib/dylan/table-extensions.lib.du
lib/dylan/text-inspector-lib.dbc
lib/dylan/tk-lib.dbc
lib/dylan/transcendental-lib.dbc
lib/dylan/transcendental.lib.du
lib/dylan/x-inspector-lib.dbc
bin/d2c
bin/gen-makefile
bin/line-count
bin/lisp2dylan
bin/make-exports
bin/melange
bin/mindy
bin/mindycomp
bin/mindyexec
bin/mk-build-tree
bin/mk-rcs-links
bin/gen-makefile
bin/mindycomp
bin/parsergen
bin/melange
bin/mk-build-tree
bin/line-count
bin/make-dylan-app
bin/mk-rcs-links
bin/lisp2dylan
bin/synopsis
bin/make-exports
etc/platforms.descr
include/runtime.h
lib/dylan/dylan-lib.dbc
lib/dylan/random-lib.dbc
lib/dylan/tk-lib.dbc
lib/dylan/inspector-base-lib.dbc
lib/dylan/text-inspector-lib.dbc
lib/dylan/x-inspector-lib.dbc
lib/dylan/streams.lib.du
lib/dylan/libstreams.a
lib/dylan/streams-lib.dbc
lib/dylan/standard-io.lib.du
lib/dylan/libstdio.a
lib/dylan/standard-io-lib.dbc
lib/dylan/print.lib.du
lib/dylan/libprint.a
lib/dylan/print-lib.dbc
lib/dylan/format.lib.du
lib/dylan/libformat.a
lib/dylan/format-lib.dbc
lib/dylan/libcollext.a
lib/dylan/libregexp.a
lib/dylan/collection-extensions.lib.du
lib/dylan/collection-extensions-lib.dbc
lib/dylan/table-extensions.lib.du
lib/dylan/libtableext.a
lib/dylan/table-extensions-lib.dbc
lib/dylan/string-extensions.lib.du
lib/dylan/libstringext.a
lib/dylan/string-extensions-lib.dbc
lib/dylan/regular-expressions.lib.du
lib/dylan/regular-expressions-lib.dbc
lib/dylan/format-out.lib.du
lib/dylan/libformatout.a
lib/dylan/format-out-lib.dbc
lib/dylan/matrix.lib.du
lib/dylan/libmatrix.a
lib/dylan/matrix-lib.dbc
lib/dylan/libstreamext.a
lib/dylan/stream-extensions.lib.du
lib/dylan/stream-extensions-lib.dbc
lib/dylan/transcendental.lib.du
lib/dylan/libtranscendental.a
lib/dylan/transcendental-lib.dbc
lib/dylan/libruntime.a
lib/dylan/libgc.a
lib/dylan/dylan.lib.du
lib/dylan/libdylan.a
lib/dylan/melange-support.lib.du
lib/dylan/libmelange.a
lib/dylan/random.lib.du
lib/dylan/librandom.a
lib/dylan/elisp/dylan-mode.el
lib/dylan/elisp/fill-comment.el
lib/dylan/elisp/page-cmds.el
lib/dylan/elisp/mindy-comp.el
lib/dylan/elisp/goto-def.el
lib/dylan/elisp/dylan-params.el
lib/dylan/parse-arguments.lib.du
lib/dylan/libgetopt.a
lib/dylan/parse-arguments-lib.dbc
@dirrm lib/dylan/elisp
@dirrm lib/dylan