Update to 5.35
Add missing dependencies as reported by poudriere. Enable XFT by default. Regenerate patches. Changelog: https://www.jwz.org/xscreensaver/changelog.html
This commit is contained in:
parent
fadaa1a12c
commit
2a780d2ad0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416630
10 changed files with 46 additions and 26 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xscreensaver
|
||||
PORTVERSION= 5.34
|
||||
PORTVERSION= 5.35
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.jwz.org/xscreensaver/
|
||||
|
||||
|
@ -11,15 +11,18 @@ COMMENT= Save your screen while you entertain your cat
|
|||
|
||||
RUN_DEPENDS= p5-libwww>0:www/p5-libwww \
|
||||
giftopnm:graphics/netpbm
|
||||
LIB_DEPENDS= libgle.so:graphics/gle
|
||||
LIB_DEPENDS= libgle.so:graphics/gle \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2
|
||||
|
||||
CONFLICTS= xscreensaver-gnome-[0-9]* xscreensaver-gnome-hacks-[0-9]*
|
||||
|
||||
USES= autoreconf gettext gmake jpeg perl5 pkgconfig
|
||||
USE_GL= yes
|
||||
USE_GNOME= gdkpixbuf2 gtk20 intltool libglade2 libxml2
|
||||
USE_GL= gl glu
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk20 intltool libglade2 libxml2
|
||||
USE_PERL5= run
|
||||
USE_XORG= xpm xext xxf86misc
|
||||
USE_XORG= ice sm x11 xext xi xinerama xmu xrandr xrender xpm xt \
|
||||
xxf86misc xxf86vm
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= PERL="${PERL}"
|
||||
|
@ -37,6 +40,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
|
|||
|
||||
OPTIONS_DEFINE= PAM SETUID_HACKS FIREF NLS XAOS1 XDALI XEARTH \
|
||||
XFT XMOUN XPLANET XSNOW
|
||||
OPTIONS_DEFAULT=XFT
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
PAM_CONFIGURE_WITH= pam
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (xscreensaver-5.34.tar.gz) = 6fff7ec4be743e5c042647ea9687dd0cdf48d1dd5e8e15098e5018bbd02e5e27
|
||||
SIZE (xscreensaver-5.34.tar.gz) = 10788657
|
||||
TIMESTAMP = 1464367058
|
||||
SHA256 (xscreensaver-5.35.tar.gz) = 1e6c8471a9af4862f38a6dd5c6e61fe12b052d35af44b2941904c6e333586b22
|
||||
SIZE (xscreensaver-5.35.tar.gz) = 10502468
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- config.h.in.orig 2014-10-08 18:09:49 UTC
|
||||
--- config.h.in.orig 2016-04-03 20:07:59 UTC
|
||||
+++ config.h.in
|
||||
@@ -304,6 +304,9 @@
|
||||
@@ -307,6 +307,9 @@
|
||||
/* Define to 1 if you have the <util.h> header file. */
|
||||
#undef HAVE_UTIL_H
|
||||
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- configure.in.orig 2014-10-08 18:09:41 UTC
|
||||
--- configure.in.orig 2016-05-19 17:59:17 UTC
|
||||
+++ configure.in
|
||||
@@ -3510,7 +3510,7 @@ fi
|
||||
@@ -3538,7 +3538,7 @@ fi
|
||||
###############################################################################
|
||||
|
||||
PTY_LIBS=
|
||||
-AC_CHECK_HEADERS(pty.h util.h)
|
||||
+AC_CHECK_HEADERS(pty.h util.h libutil.h)
|
||||
-AC_CHECK_HEADERS(pty.h util.h sys/termios.h)
|
||||
+AC_CHECK_HEADERS(pty.h util.h libutil.h sys/termios.h)
|
||||
AC_CHECK_X_LIB(util, forkpty,
|
||||
[PTY_LIBS="-lutil"
|
||||
ac_have_forkpty=yes
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- driver/Makefile.in.orig 2015-06-25 18:58:54 UTC
|
||||
--- driver/Makefile.in.orig 2016-05-24 18:02:30 UTC
|
||||
+++ driver/Makefile.in
|
||||
@@ -51,7 +51,7 @@ DEPEND_DEFINES = @DEPEND_DEFINES@
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- driver/XScreenSaver.ad.in.orig 2014-11-18 22:54:02 UTC
|
||||
--- driver/XScreenSaver.ad.in.orig 2016-05-24 18:02:30 UTC
|
||||
+++ driver/XScreenSaver.ad.in
|
||||
@@ -56,7 +56,7 @@
|
||||
*splashDuration: 0:00:05
|
||||
|
@ -18,7 +18,7 @@
|
|||
! To show the time only:
|
||||
! *dateFormat: %I:%M %p
|
||||
! For 24 hour time:
|
||||
@@ -157,6 +157,18 @@ GetViewPortIsFullOfLies: False
|
||||
@@ -158,6 +158,18 @@ GetViewPortIsFullOfLies: False
|
||||
! screen savers interactively.
|
||||
!
|
||||
*programs: \
|
||||
|
@ -37,11 +37,11 @@
|
|||
maze -root \n\
|
||||
@GL_KLUDGE@ GL: superquadrics -root \n\
|
||||
attraction -root \n\
|
||||
@@ -457,7 +469,6 @@ XScreenSaver.bourneShell: /bin/sh
|
||||
@@ -465,7 +477,6 @@ XScreenSaver.bourneShell: /bin/sh
|
||||
*hacks.cwaves.name: CWaves
|
||||
*hacks.dangerball.name: DangerBall
|
||||
*hacks.decayscreen.name: DecayScreen
|
||||
-*hacks.dnalogo.name: DNA Logo
|
||||
*hacks.dymaxionmap.name: DymaxionMap
|
||||
*hacks.energystream.name: EnergyStream
|
||||
*hacks.euler2d.name: Euler2D
|
||||
*hacks.fadeplot.name: FadePlot
|
||||
*hacks.flipflop.name: FlipFlop
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- hacks/config/sonar.xml.orig 2015-06-13 23:08:53 UTC
|
||||
--- hacks/config/sonar.xml.orig 2016-04-08 02:15:38 UTC
|
||||
+++ hacks/config/sonar.xml
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- hacks/memscroller.c.orig 2014-09-13 20:34:45 UTC
|
||||
--- hacks/memscroller.c.orig 2016-05-22 01:57:03 UTC
|
||||
+++ hacks/memscroller.c
|
||||
@@ -306,13 +306,6 @@ open_file (state *st)
|
||||
from earlier days before the advent of virtual memory management."
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- utils/textclient.c.orig 2014-11-05 00:08:06 UTC
|
||||
--- utils/textclient.c.orig 2016-04-28 02:29:36 UTC
|
||||
+++ utils/textclient.c
|
||||
@@ -50,6 +50,9 @@
|
||||
# ifdef HAVE_UTIL_H
|
||||
# include <util.h>
|
||||
@@ -55,6 +55,9 @@
|
||||
# ifdef HAVE_SYS_TERMIOS_H
|
||||
# include <sys/termios.h>
|
||||
# endif
|
||||
+# ifdef HAVE_LIBUTIL_H
|
||||
+# include <libutil.h>
|
||||
|
|
|
@ -57,7 +57,9 @@ bin/xscreensaver-hacks/demon
|
|||
bin/xscreensaver-hacks/discrete
|
||||
bin/xscreensaver-hacks/distort
|
||||
bin/xscreensaver-hacks/drift
|
||||
bin/xscreensaver-hacks/dymaxionmap
|
||||
bin/xscreensaver-hacks/endgame
|
||||
bin/xscreensaver-hacks/energystream
|
||||
bin/xscreensaver-hacks/engine
|
||||
bin/xscreensaver-hacks/epicycle
|
||||
bin/xscreensaver-hacks/eruption
|
||||
|
@ -101,6 +103,7 @@ bin/xscreensaver-hacks/helix
|
|||
bin/xscreensaver-hacks/hexadrop
|
||||
bin/xscreensaver-hacks/hilbert
|
||||
bin/xscreensaver-hacks/hopalong
|
||||
bin/xscreensaver-hacks/hydrostat
|
||||
bin/xscreensaver-hacks/hypertorus
|
||||
bin/xscreensaver-hacks/hypnowheel
|
||||
bin/xscreensaver-hacks/ifs
|
||||
|
@ -161,6 +164,7 @@ bin/xscreensaver-hacks/pyro
|
|||
bin/xscreensaver-hacks/qix
|
||||
bin/xscreensaver-hacks/quasicrystal
|
||||
bin/xscreensaver-hacks/queens
|
||||
bin/xscreensaver-hacks/raverhoop
|
||||
bin/xscreensaver-hacks/rd-bomb
|
||||
bin/xscreensaver-hacks/ripples
|
||||
bin/xscreensaver-hacks/rocks
|
||||
|
@ -203,6 +207,7 @@ bin/xscreensaver-hacks/triangle
|
|||
bin/xscreensaver-hacks/tronbit
|
||||
bin/xscreensaver-hacks/truchet
|
||||
bin/xscreensaver-hacks/twang
|
||||
bin/xscreensaver-hacks/unicrud
|
||||
bin/xscreensaver-hacks/unknownpleasures
|
||||
bin/xscreensaver-hacks/vermiculate
|
||||
bin/xscreensaver-hacks/vidwhacker
|
||||
|
@ -283,7 +288,9 @@ man/man6/demon.6.gz
|
|||
man/man6/discrete.6.gz
|
||||
man/man6/distort.6.gz
|
||||
man/man6/drift.6.gz
|
||||
man/man6/dymaxionmap.6.gz
|
||||
man/man6/endgame.6.gz
|
||||
man/man6/energystream.6.gz
|
||||
man/man6/engine.6.gz
|
||||
man/man6/epicycle.6.gz
|
||||
man/man6/eruption.6.gz
|
||||
|
@ -327,6 +334,7 @@ man/man6/helix.6.gz
|
|||
man/man6/hexadrop.6.gz
|
||||
man/man6/hilbert.6.gz
|
||||
man/man6/hopalong.6.gz
|
||||
man/man6/hydrostat.6.gz
|
||||
man/man6/hypertorus.6.gz
|
||||
man/man6/hypnowheel.6.gz
|
||||
man/man6/ifs.6.gz
|
||||
|
@ -385,10 +393,11 @@ man/man6/pyro.6.gz
|
|||
man/man6/qix.6.gz
|
||||
man/man6/quasicrystal.6.gz
|
||||
man/man6/queens.6.gz
|
||||
man/man6/romanboy.6.gz
|
||||
man/man6/raverhoop.6.gz
|
||||
man/man6/rd-bomb.6.gz
|
||||
man/man6/ripples.6.gz
|
||||
man/man6/rocks.6.gz
|
||||
man/man6/romanboy.6.gz
|
||||
man/man6/rorschach.6.gz
|
||||
man/man6/rotzoomer.6.gz
|
||||
man/man6/rubik.6.gz
|
||||
|
@ -425,6 +434,7 @@ man/man6/triangle.6.gz
|
|||
man/man6/tronbit.6.gz
|
||||
man/man6/truchet.6.gz
|
||||
man/man6/twang.6.gz
|
||||
man/man6/unicrud.6.gz
|
||||
man/man6/unknownpleasures.6.gz
|
||||
man/man6/vermiculate.6.gz
|
||||
man/man6/vidwhacker.6.gz
|
||||
|
@ -525,7 +535,9 @@ share/pixmaps/xscreensaver.xpm
|
|||
%%DATADIR%%/config/discrete.xml
|
||||
%%DATADIR%%/config/distort.xml
|
||||
%%DATADIR%%/config/drift.xml
|
||||
%%DATADIR%%/config/dymaxionmap.xml
|
||||
%%DATADIR%%/config/endgame.xml
|
||||
%%DATADIR%%/config/energystream.xml
|
||||
%%DATADIR%%/config/engine.xml
|
||||
%%DATADIR%%/config/epicycle.xml
|
||||
%%DATADIR%%/config/eruption.xml
|
||||
|
@ -569,6 +581,7 @@ share/pixmaps/xscreensaver.xpm
|
|||
%%DATADIR%%/config/hexadrop.xml
|
||||
%%DATADIR%%/config/hilbert.xml
|
||||
%%DATADIR%%/config/hopalong.xml
|
||||
%%DATADIR%%/config/hydrostat.xml
|
||||
%%DATADIR%%/config/hypertorus.xml
|
||||
%%DATADIR%%/config/hypnowheel.xml
|
||||
%%DATADIR%%/config/ifs.xml
|
||||
|
@ -628,6 +641,7 @@ share/pixmaps/xscreensaver.xpm
|
|||
%%DATADIR%%/config/qix.xml
|
||||
%%DATADIR%%/config/quasicrystal.xml
|
||||
%%DATADIR%%/config/queens.xml
|
||||
%%DATADIR%%/config/raverhoop.xml
|
||||
%%DATADIR%%/config/rd-bomb.xml
|
||||
%%DATADIR%%/config/ripples.xml
|
||||
%%DATADIR%%/config/rocks.xml
|
||||
|
@ -668,6 +682,7 @@ share/pixmaps/xscreensaver.xpm
|
|||
%%DATADIR%%/config/tronbit.xml
|
||||
%%DATADIR%%/config/truchet.xml
|
||||
%%DATADIR%%/config/twang.xml
|
||||
%%DATADIR%%/config/unicrud.xml
|
||||
%%DATADIR%%/config/unknownpleasures.xml
|
||||
%%DATADIR%%/config/vermiculate.xml
|
||||
%%DATADIR%%/config/vidwhacker.xml
|
||||
|
|
Loading…
Reference in a new issue