Update to 1.3.0.
This commit is contained in:
parent
93e78ee1ae
commit
2a900c3c1d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295531
4 changed files with 26 additions and 80 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= skrooge
|
||||
PORTVERSION= 1.2.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.3.0
|
||||
CATEGORIES= finance kde
|
||||
MASTER_SITES= http://skrooge.org/files/
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (skrooge-1.2.0.tar.bz2) = 059d2e1dd6feb8e7fcf86b61c0932359b182c207f9dda21642a50253b7857f2a
|
||||
SIZE (skrooge-1.2.0.tar.bz2) = 9709899
|
||||
SHA256 (skrooge-1.3.0.tar.bz2) = 7f8ec247084a005b743bb080ded5724f6c1ee3644c135e12002c80df93fddfe9
|
||||
SIZE (skrooge-1.3.0.tar.bz2) = 9775908
|
||||
|
|
|
@ -1,71 +0,0 @@
|
|||
commit 14baa0141315ac673f4d492ba84bc7d3befade3a
|
||||
Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
|
||||
Date: Tue Jan 31 22:23:40 2012 -0200
|
||||
|
||||
Install and load the grantlee plugin the right way.
|
||||
|
||||
This should hopefully solve the issues with the installation and loading
|
||||
of grantlee_skroogefilters once and for all.
|
||||
|
||||
Long story short: grantlee plugins are Qt plugins, and thus it makes the
|
||||
most sense to install them into ${PLUGIN_INSTALL_DIR}/plugins/whatever,
|
||||
so that the QT_PLUGIN_PATH environment variable can be used to let
|
||||
QCoreApplication::libraryPaths() automatically find it. To err on the
|
||||
safe side, we also add the paths via Grantlee::Engine::addPluginPath so
|
||||
the plugin is found even is QT_PLUGIN_PATH is not properly set.
|
||||
|
||||
Below is an account of the troubles we've had so far:
|
||||
|
||||
* Commit 87baaf5a hardcoded the installation to
|
||||
${PLUGIN_INSTALL_DIR}/../grantlee/0.1, and it was wrong because it
|
||||
assumed a certain directory layout and installed above
|
||||
PLUGIN_INSTALL_DIR.
|
||||
* Commit a2b5f2ab later changed that to
|
||||
${PLUGIN_INSTALL_DIR}/../grantlee/<GRANTLEE MAJOR>.<GRANTLEE MINOR>,
|
||||
which was only slightly better.
|
||||
* Commit 2be99742 then installed the plugin into
|
||||
${DATA_INSTALL_DIR}/skrooge/plugins/grantlee/<GRANTLEE
|
||||
MAJOR>.<GRANTLEE MINOR> and added some C++ code to add this directory to
|
||||
Grantlee's plugin search path. ${DATA_INSTALL_DIR} is not the right
|
||||
place to install plugins, though.
|
||||
* Commit 8eb59377 fixed the issue by installing the plugin into
|
||||
${LIB_INSTALL_DIR}/grantlee/<GRANTLEE MAJOR>.<GRANTLEE MINOR>. For
|
||||
some unfortunate reason, this commit also removed the C++ code added
|
||||
in the previous commit.
|
||||
|
||||
Reviewed-by: Guillaume DE BURE
|
||||
|
||||
CCMAIL: guillaume.debure@gmail.com
|
||||
CCMAIL: stephane@mankowski.fr
|
||||
|
||||
diff --git a/plugins/skrooge/skrooge_monthly/grantlee_filters/CMakeLists.txt b/plugins/skrooge/skrooge_monthly/grantlee_filters/CMakeLists.txt
|
||||
index ebeef7d..7c782d8 100644
|
||||
--- ./plugins/skrooge/skrooge_monthly/grantlee_filters/CMakeLists.txt
|
||||
+++ ./plugins/skrooge/skrooge_monthly/grantlee_filters/CMakeLists.txt
|
||||
@@ -13,7 +13,7 @@ TARGET_LINK_LIBRARIES(grantlee_skroogefilters skgbasemodeler skgbankmodeler skgb
|
||||
|
||||
########### install files ###############
|
||||
IF(WIN32)
|
||||
- INSTALL(TARGETS grantlee_skroogefilters ARCHIVE DESTINATION ${LIB_INSTALL_DIR}/grantlee/${Grantlee_VERSION_MAJOR}.${Grantlee_VERSION_MINOR} )
|
||||
+ INSTALL(TARGETS grantlee_skroogefilters ARCHIVE DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/grantlee/${Grantlee_VERSION_MAJOR}.${Grantlee_VERSION_MINOR} )
|
||||
ELSE(WIN32)
|
||||
- INSTALL(TARGETS grantlee_skroogefilters LIBRARY DESTINATION ${LIB_INSTALL_DIR}/grantlee/${Grantlee_VERSION_MAJOR}.${Grantlee_VERSION_MINOR} )
|
||||
-ENDIF(WIN32)
|
||||
\ No newline at end of file
|
||||
+ INSTALL(TARGETS grantlee_skroogefilters LIBRARY DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/grantlee/${Grantlee_VERSION_MAJOR}.${Grantlee_VERSION_MINOR} )
|
||||
+ENDIF(WIN32)
|
||||
diff --git a/plugins/skrooge/skrooge_monthly/skgmonthlypluginwidget.cpp b/plugins/skrooge/skrooge_monthly/skgmonthlypluginwidget.cpp
|
||||
index f82f1b1..91a7037 100644
|
||||
--- ./plugins/skrooge/skrooge_monthly/skgmonthlypluginwidget.cpp
|
||||
+++ ./plugins/skrooge/skrooge_monthly/skgmonthlypluginwidget.cpp
|
||||
@@ -652,6 +652,10 @@ QString SKGMonthlyPluginWidget::getReport()
|
||||
|
||||
//Prepare grantlee engine
|
||||
Grantlee::Engine gEngine(this);
|
||||
+ const QStringList pluginDirs = KGlobal::dirs()->resourceDirs("qtplugins");
|
||||
+ foreach (const QString& pluginDir, pluginDirs) {
|
||||
+ gEngine.addPluginPath(pluginDir);
|
||||
+ }
|
||||
gEngine.addDefaultLibrary("grantlee_skroogefilters");
|
||||
|
||||
Grantlee::FileSystemTemplateLoader::Ptr gLoader = Grantlee::FileSystemTemplateLoader::Ptr(new Grantlee::FileSystemTemplateLoader());
|
|
@ -10,7 +10,7 @@ lib/kde4/plasma_skroogoid_scheduledoperation.so
|
|||
lib/kde4/plasma_skroogoid_unit.so
|
||||
lib/kde4/plasma_widget_incomeexpenditure.so
|
||||
lib/kde4/plasma_widget_simulation.so
|
||||
lib/kde4/plugins/grantlee/0.2/grantlee_skroogefilters.so
|
||||
lib/kde4/plugins/grantlee/0.2/grantlee_skgfilters.so
|
||||
lib/kde4/skg_advice.so
|
||||
lib/kde4/skg_bookmark.so
|
||||
lib/kde4/skg_dashboard.so
|
||||
|
@ -18,6 +18,7 @@ lib/kde4/skg_debug.so
|
|||
lib/kde4/skg_delete.so
|
||||
lib/kde4/skg_file.so
|
||||
lib/kde4/skg_highlight.so
|
||||
lib/kde4/skg_monthly.so
|
||||
lib/kde4/skg_print.so
|
||||
lib/kde4/skg_properties.so
|
||||
lib/kde4/skg_selectall.so
|
||||
|
@ -40,7 +41,6 @@ lib/kde4/skrooge_import_skg.so
|
|||
lib/kde4/skrooge_import_xhb.so
|
||||
lib/kde4/skrooge_import_xml.so
|
||||
lib/kde4/skrooge_importexport.so
|
||||
lib/kde4/skrooge_monthly.so
|
||||
lib/kde4/skrooge_operation.so
|
||||
lib/kde4/skrooge_payee.so
|
||||
lib/kde4/skrooge_report.so
|
||||
|
@ -71,6 +71,7 @@ share/apps/skg_debug/skg_debug.rc
|
|||
share/apps/skg_delete/skg_delete.rc
|
||||
share/apps/skg_file/skg_file.rc
|
||||
share/apps/skg_highlight/skg_highlight.rc
|
||||
share/apps/skg_monthly/skg_monthly.rc
|
||||
share/apps/skg_print/skg_print.rc
|
||||
share/apps/skg_properties/skg_properties.rc
|
||||
share/apps/skg_selectall/skg_selectall.rc
|
||||
|
@ -83,6 +84,7 @@ share/apps/skrooge/html/default/categories_month_table.html
|
|||
share/apps/skrooge/html/default/categories_previous_month_table.html
|
||||
share/apps/skrooge/html/default/income_vs_expenditure_table.html
|
||||
share/apps/skrooge/html/default/unit_table.html
|
||||
share/apps/skrooge/html/main.txt
|
||||
share/apps/skrooge/images/logo/absa_bank__632005.png
|
||||
share/apps/skrooge/images/logo/aib.png
|
||||
share/apps/skrooge/images/logo/allianz.png
|
||||
|
@ -166,7 +168,6 @@ share/apps/skrooge_budget/skrooge_budget.rc
|
|||
share/apps/skrooge_calculator/skrooge_calculator.rc
|
||||
share/apps/skrooge_categories/skrooge_categories.rc
|
||||
share/apps/skrooge_importexport/skrooge_importexport.rc
|
||||
share/apps/skrooge_monthly/skrooge_monthly.rc
|
||||
share/apps/skrooge_operation/skrooge_operation.rc
|
||||
share/apps/skrooge_payee/skrooge_payee.rc
|
||||
share/apps/skrooge_report/skrooge_report.rc
|
||||
|
@ -175,6 +176,7 @@ share/apps/skrooge_search/skrooge_search.rc
|
|||
share/apps/skrooge_tracker/skrooge_tracker.rc
|
||||
share/apps/skrooge_unit/skrooge_unit.rc
|
||||
share/config.kcfg/skgbasegui_settings.kcfg
|
||||
share/config.kcfg/skgbookmark_settings.kcfg
|
||||
share/config.kcfg/skgdashboard_settings.kcfg
|
||||
share/config.kcfg/skgfile_settings.kcfg
|
||||
share/config.kcfg/skgimportexport_settings.kcfg
|
||||
|
@ -271,6 +273,9 @@ share/doc/HTML/en/skrooge/zoom_graph.png
|
|||
share/doc/HTML/es/skrooge/common
|
||||
share/doc/HTML/es/skrooge/index.cache.bz2
|
||||
share/doc/HTML/es/skrooge/index.docbook
|
||||
share/doc/HTML/fr/skrooge/common
|
||||
share/doc/HTML/fr/skrooge/index.cache.bz2
|
||||
share/doc/HTML/fr/skrooge/index.docbook
|
||||
share/doc/HTML/lt/skrooge/after_mass_update.png
|
||||
share/doc/HTML/lt/skrooge/bank_accounts.png
|
||||
share/doc/HTML/lt/skrooge/before_mass_update.png
|
||||
|
@ -476,6 +481,7 @@ share/kde4/services/skg-plugin-debug.desktop
|
|||
share/kde4/services/skg-plugin-delete.desktop
|
||||
share/kde4/services/skg-plugin-file.desktop
|
||||
share/kde4/services/skg-plugin-highlight.desktop
|
||||
share/kde4/services/skg-plugin-monthly.desktop
|
||||
share/kde4/services/skg-plugin-print.desktop
|
||||
share/kde4/services/skg-plugin-properties.desktop
|
||||
share/kde4/services/skg-plugin-selectall.desktop
|
||||
|
@ -498,7 +504,6 @@ share/kde4/services/skrooge-plugin-budget.desktop
|
|||
share/kde4/services/skrooge-plugin-calculator.desktop
|
||||
share/kde4/services/skrooge-plugin-categories.desktop
|
||||
share/kde4/services/skrooge-plugin-importexport.desktop
|
||||
share/kde4/services/skrooge-plugin-monthly.desktop
|
||||
share/kde4/services/skrooge-plugin-operation.desktop
|
||||
share/kde4/services/skrooge-plugin-payee.desktop
|
||||
share/kde4/services/skrooge-plugin-report.desktop
|
||||
|
@ -555,6 +560,7 @@ share/mime/packages/x-skg.xml
|
|||
@dirrm share/doc/HTML/pt/skrooge
|
||||
@dirrm share/doc/HTML/nl/skrooge
|
||||
@dirrm share/doc/HTML/lt/skrooge
|
||||
@dirrm share/doc/HTML/fr/skrooge
|
||||
@dirrm share/doc/HTML/es/skrooge
|
||||
@dirrm share/doc/HTML/en/skrooge
|
||||
@dirrm share/apps/skrooge_unit
|
||||
|
@ -564,7 +570,6 @@ share/mime/packages/x-skg.xml
|
|||
@dirrm share/apps/skrooge_report
|
||||
@dirrm share/apps/skrooge_payee
|
||||
@dirrm share/apps/skrooge_operation
|
||||
@dirrm share/apps/skrooge_monthly
|
||||
@dirrm share/apps/skrooge_importexport
|
||||
@dirrm share/apps/skrooge_categories
|
||||
@dirrm share/apps/skrooge_calculator
|
||||
|
@ -581,6 +586,18 @@ share/mime/packages/x-skg.xml
|
|||
@dirrm share/apps/skrooge/images/logo/l10n
|
||||
@dirrm share/apps/skrooge/images/logo
|
||||
@dirrm share/apps/skrooge/images
|
||||
@dirrm share/apps/skrooge/html/skrooge_unit
|
||||
@dirrm share/apps/skrooge/html/skrooge_tracker
|
||||
@dirrm share/apps/skrooge/html/skrooge_search
|
||||
@dirrm share/apps/skrooge/html/skrooge_scheduled
|
||||
@dirrm share/apps/skrooge/html/skrooge_report
|
||||
@dirrm share/apps/skrooge/html/skrooge_payee
|
||||
@dirrm share/apps/skrooge/html/skrooge_operation
|
||||
@dirrm share/apps/skrooge/html/skrooge_importexport
|
||||
@dirrm share/apps/skrooge/html/skrooge_categories
|
||||
@dirrm share/apps/skrooge/html/skrooge_calculator
|
||||
@dirrm share/apps/skrooge/html/skrooge_budget
|
||||
@dirrm share/apps/skrooge/html/skrooge_bank
|
||||
@dirrm share/apps/skrooge/html/default
|
||||
@dirrm share/apps/skrooge/html
|
||||
@dirrm share/apps/skrooge
|
||||
|
@ -588,6 +605,7 @@ share/mime/packages/x-skg.xml
|
|||
@dirrm share/apps/skg_selectall
|
||||
@dirrm share/apps/skg_properties
|
||||
@dirrm share/apps/skg_print
|
||||
@dirrm share/apps/skg_monthly
|
||||
@dirrm share/apps/skg_highlight
|
||||
@dirrm share/apps/skg_file
|
||||
@dirrm share/apps/skg_delete
|
||||
|
|
Loading…
Reference in a new issue