Update to 0.8.2
Approved by: maintainer
This commit is contained in:
parent
5cb34ba408
commit
2ab00b7de6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=83444
21 changed files with 96 additions and 93 deletions
|
@ -5,7 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= simicq
|
||||
PORTVERSION= 0.8.1
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= net kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
|
||||
|
@ -16,6 +16,7 @@ COMMENT= ICQ client which supports Version 8 of the ICQ protocol (ICQ 2001)
|
|||
|
||||
USE_GMAKE= yes
|
||||
USE_QT_VER= 3
|
||||
USE_PERL5_BUILD= yes
|
||||
GNU_CONFIGURE= yes
|
||||
.if !defined(WITHOUT_SSL)
|
||||
USE_OPENSSL= yes
|
||||
|
@ -23,8 +24,7 @@ USE_OPENSSL= yes
|
|||
CONFIGURE_ARGS+=--disable-openssl
|
||||
.endif
|
||||
CONFIGURE_TARGET=
|
||||
CONFIGURE_ARGS+= --disable-fast-perl \
|
||||
--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
.if defined(WITHOUT_KDE)
|
||||
CONFIGURE_ARGS+= --disable-kde --enable-mt
|
||||
|
@ -35,7 +35,8 @@ USE_KDELIBS_VER= 3
|
|||
|
||||
post-patch:
|
||||
.if defined(WITHOUT_KDE)
|
||||
${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," ${WRKSRC}/configure
|
||||
${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," \
|
||||
${WRKSRC}/configure
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (sim-0.8.1.tar.gz) = 5b00e474a71609f8d7e960acefcb9319
|
||||
MD5 (sim-0.8.2.tar.gz) = c04ecb5569746df71dd330d71eed89f0
|
||||
|
|
11
net-im/sim-im/files/patch-Makefile.in
Normal file
11
net-im/sim-im/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Sun Jun 22 16:38:25 2003
|
||||
+++ Makefile.in Sun Jun 22 16:38:50 2003
|
||||
@@ -591,8 +591,6 @@
|
||||
uninstall-info-recursive uninstall-recursive
|
||||
|
||||
|
||||
-$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
|
||||
- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
|
||||
|
||||
$(top_srcdir)/subdirs:
|
||||
cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
|
10
net-im/sim-im/files/patch-configure
Normal file
10
net-im/sim-im/files/patch-configure
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.orig Sun Jun 22 16:33:46 2003
|
||||
+++ configure Sun Jun 22 16:33:56 2003
|
||||
@@ -25216,7 +25216,6 @@
|
||||
|
||||
ac_config_files="$ac_config_files ./Makefile"
|
||||
|
||||
-ac_config_files="$ac_config_files gkrellm_plugin/Makefile"
|
||||
|
||||
ac_config_files="$ac_config_files pict/Makefile"
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
|
||||
--- sim/libicq/icqssl.cpp.orig Wed Mar 12 14:20:53 2003
|
||||
+++ sim/libicq/icqssl.cpp Wed Mar 12 14:21:08 2003
|
||||
@@ -151,7 +151,7 @@
|
||||
#else
|
||||
SSL_CTX_set_cipher_list(gSSL_CTX, "ADH");
|
||||
#endif
|
||||
- SSL_CTX_set_info_callback(gSSL_CTX, (void (*)())ssl_info_callback);
|
||||
+ SSL_CTX_set_info_callback(gSSL_CTX, (void (*)(const SSL*, int, int))ssl_info_callback);
|
||||
DH *dh = get_dh512();
|
||||
SSL_CTX_set_tmp_dh(gSSL_CTX, dh);
|
||||
DH_free(dh);
|
||||
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- toolsetup.h.old Tue Dec 17 13:25:36 2002
|
||||
+++ toolsetup.h Tue Dec 17 13:57:26 2002
|
||||
@@ -23,7 +23,7 @@
|
||||
#include "toolsetupbase.h"
|
||||
#include "toolbtn.h"
|
||||
|
||||
-class ToolBarSetup : public ToolBarSetupBase
|
||||
+class ToolBarSetup : ToolBarSetupBase
|
||||
{
|
||||
Q_OBJECT
|
||||
public:
|
|
@ -1,16 +1,21 @@
|
|||
bin/sim
|
||||
bin/simctrl
|
||||
lib/menu/sim-kde.menu
|
||||
share/applnk/Internet/sim.desktop
|
||||
share/icons/locolor/32x32/apps/sim.png
|
||||
share/icons/locolor/16x16/apps/sim.png
|
||||
share/icons/hicolor/16x16/apps/sim.png
|
||||
share/icons/hicolor/32x32/apps/sim.png
|
||||
share/locale/bg/LC_MESSAGES/sim.mo
|
||||
share/locale/cs/LC_MESSAGES/sim.mo
|
||||
share/locale/de/LC_MESSAGES/sim.mo
|
||||
share/locale/es/LC_MESSAGES/sim.mo
|
||||
share/locale/he/LC_MESSAGES/sim.mo
|
||||
share/locale/fr/LC_MESSAGES/sim.mo
|
||||
share/locale/it/LC_MESSAGES/sim.mo
|
||||
share/locale/nl/LC_MESSAGES/sim.mo
|
||||
share/locale/pl/LC_MESSAGES/sim.mo
|
||||
share/locale/sk/LC_MESSAGES/sim.mo
|
||||
share/locale/ru/LC_MESSAGES/sim.mo
|
||||
share/locale/tr/LC_MESSAGES/sim.mo
|
||||
share/locale/uk/LC_MESSAGES/sim.mo
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= simicq
|
||||
PORTVERSION= 0.8.1
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= net kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
|
||||
|
@ -16,6 +16,7 @@ COMMENT= ICQ client which supports Version 8 of the ICQ protocol (ICQ 2001)
|
|||
|
||||
USE_GMAKE= yes
|
||||
USE_QT_VER= 3
|
||||
USE_PERL5_BUILD= yes
|
||||
GNU_CONFIGURE= yes
|
||||
.if !defined(WITHOUT_SSL)
|
||||
USE_OPENSSL= yes
|
||||
|
@ -23,8 +24,7 @@ USE_OPENSSL= yes
|
|||
CONFIGURE_ARGS+=--disable-openssl
|
||||
.endif
|
||||
CONFIGURE_TARGET=
|
||||
CONFIGURE_ARGS+= --disable-fast-perl \
|
||||
--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
.if defined(WITHOUT_KDE)
|
||||
CONFIGURE_ARGS+= --disable-kde --enable-mt
|
||||
|
@ -35,7 +35,8 @@ USE_KDELIBS_VER= 3
|
|||
|
||||
post-patch:
|
||||
.if defined(WITHOUT_KDE)
|
||||
${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," ${WRKSRC}/configure
|
||||
${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," \
|
||||
${WRKSRC}/configure
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (sim-0.8.1.tar.gz) = 5b00e474a71609f8d7e960acefcb9319
|
||||
MD5 (sim-0.8.2.tar.gz) = c04ecb5569746df71dd330d71eed89f0
|
||||
|
|
11
net-im/simicq/files/patch-Makefile.in
Normal file
11
net-im/simicq/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Sun Jun 22 16:38:25 2003
|
||||
+++ Makefile.in Sun Jun 22 16:38:50 2003
|
||||
@@ -591,8 +591,6 @@
|
||||
uninstall-info-recursive uninstall-recursive
|
||||
|
||||
|
||||
-$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
|
||||
- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
|
||||
|
||||
$(top_srcdir)/subdirs:
|
||||
cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
|
10
net-im/simicq/files/patch-configure
Normal file
10
net-im/simicq/files/patch-configure
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.orig Sun Jun 22 16:33:46 2003
|
||||
+++ configure Sun Jun 22 16:33:56 2003
|
||||
@@ -25216,7 +25216,6 @@
|
||||
|
||||
ac_config_files="$ac_config_files ./Makefile"
|
||||
|
||||
-ac_config_files="$ac_config_files gkrellm_plugin/Makefile"
|
||||
|
||||
ac_config_files="$ac_config_files pict/Makefile"
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
|
||||
--- sim/libicq/icqssl.cpp.orig Wed Mar 12 14:20:53 2003
|
||||
+++ sim/libicq/icqssl.cpp Wed Mar 12 14:21:08 2003
|
||||
@@ -151,7 +151,7 @@
|
||||
#else
|
||||
SSL_CTX_set_cipher_list(gSSL_CTX, "ADH");
|
||||
#endif
|
||||
- SSL_CTX_set_info_callback(gSSL_CTX, (void (*)())ssl_info_callback);
|
||||
+ SSL_CTX_set_info_callback(gSSL_CTX, (void (*)(const SSL*, int, int))ssl_info_callback);
|
||||
DH *dh = get_dh512();
|
||||
SSL_CTX_set_tmp_dh(gSSL_CTX, dh);
|
||||
DH_free(dh);
|
||||
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- toolsetup.h.old Tue Dec 17 13:25:36 2002
|
||||
+++ toolsetup.h Tue Dec 17 13:57:26 2002
|
||||
@@ -23,7 +23,7 @@
|
||||
#include "toolsetupbase.h"
|
||||
#include "toolbtn.h"
|
||||
|
||||
-class ToolBarSetup : public ToolBarSetupBase
|
||||
+class ToolBarSetup : ToolBarSetupBase
|
||||
{
|
||||
Q_OBJECT
|
||||
public:
|
|
@ -1,16 +1,21 @@
|
|||
bin/sim
|
||||
bin/simctrl
|
||||
lib/menu/sim-kde.menu
|
||||
share/applnk/Internet/sim.desktop
|
||||
share/icons/locolor/32x32/apps/sim.png
|
||||
share/icons/locolor/16x16/apps/sim.png
|
||||
share/icons/hicolor/16x16/apps/sim.png
|
||||
share/icons/hicolor/32x32/apps/sim.png
|
||||
share/locale/bg/LC_MESSAGES/sim.mo
|
||||
share/locale/cs/LC_MESSAGES/sim.mo
|
||||
share/locale/de/LC_MESSAGES/sim.mo
|
||||
share/locale/es/LC_MESSAGES/sim.mo
|
||||
share/locale/he/LC_MESSAGES/sim.mo
|
||||
share/locale/fr/LC_MESSAGES/sim.mo
|
||||
share/locale/it/LC_MESSAGES/sim.mo
|
||||
share/locale/nl/LC_MESSAGES/sim.mo
|
||||
share/locale/pl/LC_MESSAGES/sim.mo
|
||||
share/locale/sk/LC_MESSAGES/sim.mo
|
||||
share/locale/ru/LC_MESSAGES/sim.mo
|
||||
share/locale/tr/LC_MESSAGES/sim.mo
|
||||
share/locale/uk/LC_MESSAGES/sim.mo
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= simicq
|
||||
PORTVERSION= 0.8.1
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= net kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
|
||||
|
@ -16,6 +16,7 @@ COMMENT= ICQ client which supports Version 8 of the ICQ protocol (ICQ 2001)
|
|||
|
||||
USE_GMAKE= yes
|
||||
USE_QT_VER= 3
|
||||
USE_PERL5_BUILD= yes
|
||||
GNU_CONFIGURE= yes
|
||||
.if !defined(WITHOUT_SSL)
|
||||
USE_OPENSSL= yes
|
||||
|
@ -23,8 +24,7 @@ USE_OPENSSL= yes
|
|||
CONFIGURE_ARGS+=--disable-openssl
|
||||
.endif
|
||||
CONFIGURE_TARGET=
|
||||
CONFIGURE_ARGS+= --disable-fast-perl \
|
||||
--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
.if defined(WITHOUT_KDE)
|
||||
CONFIGURE_ARGS+= --disable-kde --enable-mt
|
||||
|
@ -35,7 +35,8 @@ USE_KDELIBS_VER= 3
|
|||
|
||||
post-patch:
|
||||
.if defined(WITHOUT_KDE)
|
||||
${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," ${WRKSRC}/configure
|
||||
${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," \
|
||||
${WRKSRC}/configure
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (sim-0.8.1.tar.gz) = 5b00e474a71609f8d7e960acefcb9319
|
||||
MD5 (sim-0.8.2.tar.gz) = c04ecb5569746df71dd330d71eed89f0
|
||||
|
|
11
net/simicq/files/patch-Makefile.in
Normal file
11
net/simicq/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Sun Jun 22 16:38:25 2003
|
||||
+++ Makefile.in Sun Jun 22 16:38:50 2003
|
||||
@@ -591,8 +591,6 @@
|
||||
uninstall-info-recursive uninstall-recursive
|
||||
|
||||
|
||||
-$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
|
||||
- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
|
||||
|
||||
$(top_srcdir)/subdirs:
|
||||
cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
|
10
net/simicq/files/patch-configure
Normal file
10
net/simicq/files/patch-configure
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.orig Sun Jun 22 16:33:46 2003
|
||||
+++ configure Sun Jun 22 16:33:56 2003
|
||||
@@ -25216,7 +25216,6 @@
|
||||
|
||||
ac_config_files="$ac_config_files ./Makefile"
|
||||
|
||||
-ac_config_files="$ac_config_files gkrellm_plugin/Makefile"
|
||||
|
||||
ac_config_files="$ac_config_files pict/Makefile"
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
|
||||
--- sim/libicq/icqssl.cpp.orig Wed Mar 12 14:20:53 2003
|
||||
+++ sim/libicq/icqssl.cpp Wed Mar 12 14:21:08 2003
|
||||
@@ -151,7 +151,7 @@
|
||||
#else
|
||||
SSL_CTX_set_cipher_list(gSSL_CTX, "ADH");
|
||||
#endif
|
||||
- SSL_CTX_set_info_callback(gSSL_CTX, (void (*)())ssl_info_callback);
|
||||
+ SSL_CTX_set_info_callback(gSSL_CTX, (void (*)(const SSL*, int, int))ssl_info_callback);
|
||||
DH *dh = get_dh512();
|
||||
SSL_CTX_set_tmp_dh(gSSL_CTX, dh);
|
||||
DH_free(dh);
|
||||
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- toolsetup.h.old Tue Dec 17 13:25:36 2002
|
||||
+++ toolsetup.h Tue Dec 17 13:57:26 2002
|
||||
@@ -23,7 +23,7 @@
|
||||
#include "toolsetupbase.h"
|
||||
#include "toolbtn.h"
|
||||
|
||||
-class ToolBarSetup : public ToolBarSetupBase
|
||||
+class ToolBarSetup : ToolBarSetupBase
|
||||
{
|
||||
Q_OBJECT
|
||||
public:
|
|
@ -1,16 +1,21 @@
|
|||
bin/sim
|
||||
bin/simctrl
|
||||
lib/menu/sim-kde.menu
|
||||
share/applnk/Internet/sim.desktop
|
||||
share/icons/locolor/32x32/apps/sim.png
|
||||
share/icons/locolor/16x16/apps/sim.png
|
||||
share/icons/hicolor/16x16/apps/sim.png
|
||||
share/icons/hicolor/32x32/apps/sim.png
|
||||
share/locale/bg/LC_MESSAGES/sim.mo
|
||||
share/locale/cs/LC_MESSAGES/sim.mo
|
||||
share/locale/de/LC_MESSAGES/sim.mo
|
||||
share/locale/es/LC_MESSAGES/sim.mo
|
||||
share/locale/he/LC_MESSAGES/sim.mo
|
||||
share/locale/fr/LC_MESSAGES/sim.mo
|
||||
share/locale/it/LC_MESSAGES/sim.mo
|
||||
share/locale/nl/LC_MESSAGES/sim.mo
|
||||
share/locale/pl/LC_MESSAGES/sim.mo
|
||||
share/locale/sk/LC_MESSAGES/sim.mo
|
||||
share/locale/ru/LC_MESSAGES/sim.mo
|
||||
share/locale/tr/LC_MESSAGES/sim.mo
|
||||
share/locale/uk/LC_MESSAGES/sim.mo
|
||||
|
|
Loading…
Reference in a new issue