Adding erun version 1.2.
A simple epplet for launching arbitrary programs. PR: 19361 Submitted by: Kelly Yancey <kbyanc@posi.net>
This commit is contained in:
parent
21f96c05b7
commit
2abf26ecde
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30424
7 changed files with 59 additions and 0 deletions
|
@ -19,6 +19,7 @@
|
|||
SUBDIR += ebuttons
|
||||
SUBDIR += efancylauncher
|
||||
SUBDIR += emu
|
||||
SUBDIR += erun
|
||||
SUBDIR += eterm
|
||||
SUBDIR += eweather
|
||||
SUBDIR += fbsd-icons
|
||||
|
|
21
x11/erun/Makefile
Normal file
21
x11/erun/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# New ports collection makefile for: E-Run 1.2
|
||||
# Date created: 17 June 2000
|
||||
# Whom: Kelly Yancey <kbyanc@posi.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= E-Run
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://void.mapopolis.com/~jacob/c0de/
|
||||
|
||||
MAINTAINER= kbyanc@posi.net
|
||||
|
||||
LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/epplets
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11/erun/distinfo
Normal file
1
x11/erun/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (E-Run-1.2.tar.gz) = 2f57ef2f32bd545bd0522cd0f7613f2b
|
30
x11/erun/files/patch-aa
Normal file
30
x11/erun/files/patch-aa
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- Makefile.orig Tue Dec 14 11:14:20 1999
|
||||
+++ Makefile Sun Jun 18 01:38:17 2000
|
||||
@@ -1,12 +1,17 @@
|
||||
-CFLAGS = -O3 -g
|
||||
-LINKFLAGS = -lepplet
|
||||
+CFLAGS ?= -O3 -g
|
||||
+LINKFLAGS = -lepplet -L/usr/X11R6/lib
|
||||
+INCLUDEDIRS = -I/usr/X11R6/include
|
||||
|
||||
-CC = gcc
|
||||
+CFLAGS += $(INCLUDEDIRS)
|
||||
+
|
||||
+CC ?= gcc
|
||||
|
||||
EXEC_NAME = E-Run.epplet
|
||||
EXEC_OBJECTS = E-Run.o
|
||||
|
||||
-INSTALL_DIR = /usr/local/bin
|
||||
+PREFIX ?= /usr/local
|
||||
+INSTALL_DIR = ${PREFIX}/bin
|
||||
+INSTALL_PROGRAM ?= install -c -m 755
|
||||
|
||||
all: $(EXEC_OBJECTS)
|
||||
$(CC) -o $(EXEC_NAME) $(EXEC_OBJECTS) $(LINKFLAGS)
|
||||
@@ -15,4 +20,4 @@
|
||||
rm -f $(EXEC_OBJECTS) $(EXEC_NAME) *~
|
||||
|
||||
install:
|
||||
- install -o root -m 0555 $(EXEC_NAME) $(INSTALL_DIR)
|
||||
+ $(INSTALL_PROGRAM) $(EXEC_NAME) $(INSTALL_DIR)
|
1
x11/erun/pkg-comment
Normal file
1
x11/erun/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A simple epplet for launching arbitrary programs
|
4
x11/erun/pkg-descr
Normal file
4
x11/erun/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
This epplet provides a small text entry field for launching programs.
|
||||
|
||||
-Kelly
|
||||
kbyanc@posi.net
|
1
x11/erun/pkg-plist
Normal file
1
x11/erun/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/E-Run.epplet
|
Loading…
Reference in a new issue