* lcrzo library was renamed to netwib

* update to 5.20.0 and move to net category
* new maintainer

PR:             ports/69608
Submitted by:   Janos Mohacsi <janos.mohacsi@bsd.hu>
This commit is contained in:
Sergey Matveychuk 2004-08-01 08:56:07 +00:00
parent ca43881a49
commit 2ac0930fe4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115192
8 changed files with 196 additions and 81 deletions

1
MOVED
View file

@ -1214,3 +1214,4 @@ java/eclipse-xsd|java/eclipse-emf|2004-07-25|merged
emulators/freesci|games/freesci|2004-07-26|Moved to better category games
net/zebra-devel||2004-07-27|The same as net/zebra for some time
mail/pear-mailparse|mail/pecl-mailparse|2004-07-30|Renamed
security/lcrzo|net/netwib|2004-08-01|The project has been renamed and port moved to better category

View file

@ -368,6 +368,7 @@
SUBDIR += netspeed_applet
SUBDIR += netstrain
SUBDIR += nettest
SUBDIR += netwib
SUBDIR += newsbot
SUBDIR += ng_daphne
SUBDIR += ng_netflow

View file

@ -1,32 +1,32 @@
# New ports collection makefile for: lcrzo
# Date created: Wed Apr 10 02:42:20 CEST 2002
# Whom: king@v2project.com
# New ports collection makefile for: netwox
# Date created: 23.07.2004
# Whom: janos.mohacsi@bsd.hu
#
# $FreeBSD$
#
PORTNAME= lcrzo
PORTVERSION= 4.17.0
CATEGORIES= security
MASTER_SITES= http://www.laurentconstantin.com/common/netw/netwib/download/v4/ \
http://fresh.t-systems-sfr.com/unix/src/privat2/
EXTRACT_SUFX= -src.tgz
PORTNAME= netwib
PORTVERSION= 5.20.0
CATEGORIES= net devel ipv6
MASTER_SITES= http://www.laurentconstantin.com/common/netw/netwib/download/v5/ \
http://membres.lycos.fr/lauconstantin/common/netw/netwib/download/v5/ \
http://laurentconstantin.free.fr/common/netw/netwib/download/v5/
DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz ${PORTNAME}-${PORTVERSION}-doc_html.tgz
MAINTAINER= king@v2project.com
COMMENT= Lcrzo is a network library (used by Lcrzoex, network testing toolbox)
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Netwib network programming library
WRKSRC= ${WRKDIR}/${PKGNAME}-src/src
ONLY_FOR_ARCHS= i386 alpha
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
MAN3= lcrzo.3 lcrzo_address.3 lcrzo_conf.3 lcrzo_data.3 lcrzo_device.3 \
lcrzo_error.3 lcrzo_file.3 lcrzo_global.3 lcrzo_header.3 \
lcrzo_icmp.3 lcrzo_ipc.3 lcrzo_ipopt.3 lcrzo_list.3 lcrzo_misc.3 \
lcrzo_obso.3 lcrzo_packet.3 lcrzo_print.3 lcrzo_process.3 \
lcrzo_record.3 lcrzo_sniff.3 lcrzo_sock.3 lcrzo_spoof.3 \
lcrzo_string.3 lcrzo_tcpopt.3 lcrzo_time.3 lcrzo_types.3 lcrzo_wait.3 \
lcrzo_fd2.3 lcrzo_winhandle.3 lcrzo_kbd.3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src/src
USE_REINPLACE= yes
MAN3= netwib.3 netwib_dat.3 netwib_err.3 netwib_net.3 \
netwib_pkt.3 netwib_shw.3 netwib_sys.3
post-patch:
cd ${WRKSRC} && ${SH} ${WRKSRC}/genemake
do-configure:
@${REINPLACE_CMD} \
-e 's|%%PREFIX%%|${PREFIX}|' \
${WRKSRC}/config.dat
(cd ${WRKSRC} ; ${SH} ${WRKSRC}/genemake )
.include <bsd.port.mk>

View file

@ -1,2 +1,4 @@
MD5 (lcrzo-4.17.0-src.tgz) = 042fcf6ee956b871e607d2686655ba29
SIZE (lcrzo-4.17.0-src.tgz) = 765067
MD5 (netwib-5.20.0-src.tgz) = 5641b2aaf1360cbd36bb5be511c200d0
SIZE (netwib-5.20.0-src.tgz) = 592049
MD5 (netwib-5.20.0-doc_html.tgz) = 91f286427b4abd2d44f028c72b85fed4
SIZE (netwib-5.20.0-doc_html.tgz) = 130409

View file

@ -1,14 +1,20 @@
--- config.dat.orig Wed Apr 10 03:06:53 2002
+++ config.dat Wed Apr 10 03:07:04 2002
@@ -41,9 +41,9 @@
### - MacOS_10_ppc : MacOS X under PowerPC
### - Etc.
#LCRZODEF_SYS=FreeBSD_3_i386
-#LCRZODEF_SYS=FreeBSD_4_i386
+LCRZODEF_SYS=FreeBSD_4_i386
#LCRZODEF_SYS=FreeBSD_4_alpha
-LCRZODEF_SYS=Linux_X_i386
+#LCRZODEF_SYS=Linux_X_i386
#LCRZODEF_SYS=Linux_X_ia64
#LCRZODEF_SYS=Linux_X_alpha
#LCRZODEF_SYS=MacOS_10_ppc
$FreeBSD$
--- config.dat.orig Fri Jul 23 14:25:20 2004
+++ config.dat Fri Jul 23 14:26:07 2004
@@ -15,12 +15,12 @@
##########################################################################
### directories
-NETWIBDEF_INSTPREFIX=/usr/local
+NETWIBDEF_INSTPREFIX=%%PREFIX%%
NETWIBDEF_INSTINCLUDE=${NETWIBDEF_INSTPREFIX}/include
NETWIBDEF_INSTLIB=${NETWIBDEF_INSTPREFIX}/lib
NETWIBDEF_INSTBIN=${NETWIBDEF_INSTPREFIX}/bin
NETWIBDEF_INSTMAN=${NETWIBDEF_INSTPREFIX}/man
NETWIBDEF_INSTMAN1=${NETWIBDEF_INSTMAN}/man1
NETWIBDEF_INSTMAN3=${NETWIBDEF_INSTMAN}/man3
-NETWIBDEF_INSTDOC=${NETWIBDEF_INSTPREFIX}/doc
+NETWIBDEF_INSTDOC=${NETWIBDEF_INSTPREFIX}/share/doc/netwib

View file

@ -1,9 +1,16 @@
Lcrzo is a network library, for network administrators
and network hackers. Its objective is to easily create network programs.
This library provides network functionnalities for Ethernet, IP, UDP, TCP,
ICMP, ARP and RARP protocols. It supports spoofing, sniffing, client and
server creation. Furthermore, lcrzo contains high level functions dealing
with data storage and handling. Using all these functions, you can quickly
create a network test program.
Netwib is a network library providing :
- network features :
+ address conversion
+ udp/tcp clients/servers
+ packet encoding/decoding/displaying
+ spoofing
+ sniffing
+ etc.
- and general features :
+ data conversion
+ linked list, hash
+ portable threads
+ etc.
Using all these functions, a network program can be quickly created.
WWW: http://www.laurentconstantin.com/en/lcrzo/
WWW: http://www.laurentconstantin.com/en/netw/netwib/

View file

@ -1,34 +1,133 @@
bin/lcrzo-config
include/lcrzo.h
include/lcrzo_address.h
include/lcrzo_conf.h
include/lcrzo_data.h
include/lcrzo_debugdefs.h
include/lcrzo_defs.h
include/lcrzo_device.h
include/lcrzo_error.h
include/lcrzo_fd2.h
include/lcrzo_file.h
include/lcrzo_global.h
include/lcrzo_header.h
include/lcrzo_icmp.h
include/lcrzo_ipc.h
include/lcrzo_ipopt.h
include/lcrzo_kbd.h
include/lcrzo_list.h
include/lcrzo_misc.h
include/lcrzo_obso.h
include/lcrzo_packet.h
include/lcrzo_print.h
include/lcrzo_process.h
include/lcrzo_record.h
include/lcrzo_sniff.h
include/lcrzo_sock.h
include/lcrzo_spoof.h
include/lcrzo_string.h
include/lcrzo_tcpopt.h
include/lcrzo_time.h
include/lcrzo_types.h
include/lcrzo_wait.h
include/lcrzo_winhandle.h
lib/liblcrzo.a
bin/netwib520-config
bin/netwib-config
include/netwib.h
include/netwib520.h
include/netwib520/dat.h
include/netwib520/dat/array.h
include/netwib520/dat/buf.h
include/netwib520/dat/bufdec.h
include/netwib520/dat/bufenc.h
include/netwib520/dat/bufpool.h
include/netwib520/dat/c.h
include/netwib520/dat/c2.h
include/netwib520/dat/checksum.h
include/netwib520/dat/fmt.h
include/netwib520/dat/hash.h
include/netwib520/dat/hashi.h
include/netwib520/dat/ptr.h
include/netwib520/dat/regexp.h
include/netwib520/dat/ring.h
include/netwib520/dat/ringi.h
include/netwib520/dat/tlv.h
include/netwib520/dat/types.h
include/netwib520/dat/uint64.h
include/netwib520/def.h
include/netwib520/err.h
include/netwib520/net.h
include/netwib520/net/conf.h
include/netwib520/net/confarp.h
include/netwib520/net/confdev.h
include/netwib520/net/confip.h
include/netwib520/net/confrout.h
include/netwib520/net/device.h
include/netwib520/net/eth.h
include/netwib520/net/eths.h
include/netwib520/net/ethsi.h
include/netwib520/net/ip.h
include/netwib520/net/ips.h
include/netwib520/net/ipsi.h
include/netwib520/net/port.h
include/netwib520/net/ports.h
include/netwib520/net/portsi.h
include/netwib520/net/sniff.h
include/netwib520/net/sock.h
include/netwib520/net/spoof.h
include/netwib520/net/types.h
include/netwib520/pkt.h
include/netwib520/pkt/arphdr.h
include/netwib520/pkt/conv.h
include/netwib520/pkt/icmp4.h
include/netwib520/pkt/icmp6.h
include/netwib520/pkt/icmp6nd.h
include/netwib520/pkt/ip4opt.h
include/netwib520/pkt/ip4opts.h
include/netwib520/pkt/ip64bits.h
include/netwib520/pkt/ip6ext.h
include/netwib520/pkt/ip6exts.h
include/netwib520/pkt/ipfrag.h
include/netwib520/pkt/iphdr.h
include/netwib520/pkt/layer.h
include/netwib520/pkt/linkhdr.h
include/netwib520/pkt/packet.h
include/netwib520/pkt/tcphdr.h
include/netwib520/pkt/tcpopt.h
include/netwib520/pkt/tcpopts.h
include/netwib520/pkt/types.h
include/netwib520/pkt/udphdr.h
include/netwib520/shw.h
include/netwib520/shw/arphdr.h
include/netwib520/shw/array.h
include/netwib520/shw/icmp4.h
include/netwib520/shw/icmp6.h
include/netwib520/shw/icmp6nd.h
include/netwib520/shw/ip4opt.h
include/netwib520/shw/ip4opts.h
include/netwib520/shw/ip6ext.h
include/netwib520/shw/ip6exts.h
include/netwib520/shw/iphdr.h
include/netwib520/shw/linkhdr.h
include/netwib520/shw/packet.h
include/netwib520/shw/tcphdr.h
include/netwib520/shw/tcpopt.h
include/netwib520/shw/tcpopts.h
include/netwib520/shw/types.h
include/netwib520/shw/udphdr.h
include/netwib520/sys.h
include/netwib520/sys/beep.h
include/netwib520/sys/bufdec.h
include/netwib520/sys/bufenc.h
include/netwib520/sys/dir.h
include/netwib520/sys/dirname.h
include/netwib520/sys/disp.h
include/netwib520/sys/error.h
include/netwib520/sys/fd.h
include/netwib520/sys/file.h
include/netwib520/sys/filename.h
include/netwib520/sys/global.h
include/netwib520/sys/init.h
include/netwib520/sys/internal.h
include/netwib520/sys/io.h
include/netwib520/sys/ionew.h
include/netwib520/sys/iousual.h
include/netwib520/sys/kbd.h
include/netwib520/sys/kbdbuf.h
include/netwib520/sys/kbdchar.h
include/netwib520/sys/kbdint.h
include/netwib520/sys/kbdpress.h
include/netwib520/sys/path.h
include/netwib520/sys/pathname.h
include/netwib520/sys/pathstat.h
include/netwib520/sys/rand.h
include/netwib520/sys/record.h
include/netwib520/sys/screen.h
include/netwib520/sys/stream.h
include/netwib520/sys/thread.h
include/netwib520/sys/threadcond.h
include/netwib520/sys/threadlist.h
include/netwib520/sys/threadmut.h
include/netwib520/sys/threadrwl.h
include/netwib520/sys/threadtsd.h
include/netwib520/sys/time.h
include/netwib520/sys/types.h
include/netwib520/sys/unix.h
include/netwib520/sys/wait.h
include/netwib520/sys/waitlist.h
include/netwib520/sys/windows.h
lib/libnetwib520.a
lib/libnetwib.a
@dirrm include/netwib520/dat
@dirrm include/netwib520/net
@dirrm include/netwib520/pkt
@dirrm include/netwib520/shw
@dirrm include/netwib520/sys
@dirrm include/netwib520

View file

@ -154,7 +154,6 @@
SUBDIR += l0phtcrack
SUBDIR += l5
SUBDIR += labrea
SUBDIR += lcrzo
SUBDIR += lcrzoex
SUBDIR += lep
SUBDIR += libassuan