QPDF is a program that can be used to linearize (web-optimize),
encrypt (password-protect), decrypt, and inspect PDF files from the command-line. It does these and other structural, content-preserving transformations on PDF files, reading a PDF file as input and creating a new one as output. It also provides many useful capabilities to developers of PDF-producing software or for people who just want to look at the innards of a PDF file to learn more about how they work. QPDF understands PDF files that use compressed object streams (supported by newer PDF applications) and can convert such files into those that can be read with older viewers. It can also be used for checking PDF files for structural errors, inspecting stream contents, or extracting objects from PDF files. QPDF is not PDF content creation or viewing software -- it does not have the capability to create PDF files from scratch or to display PDF files. WWW: http://qpdf.sourceforge.net PR: ports/174982 Submitted by: Dmitry Kazarov <d.y.kazarov@mail.ru>
This commit is contained in:
parent
0d2dd048d3
commit
2ac57a6d20
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=312391
6 changed files with 151 additions and 0 deletions
|
@ -260,6 +260,7 @@
|
|||
SUBDIR += py-reportlab2
|
||||
SUBDIR += py-rtf
|
||||
SUBDIR += py-trml2pdf
|
||||
SUBDIR += qpdf
|
||||
SUBDIR += qpdfview
|
||||
SUBDIR += rlpr
|
||||
SUBDIR += rprint
|
||||
|
|
27
print/qpdf/Makefile
Normal file
27
print/qpdf/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# Created by: Dmitry Kazarov <d.y.kazarov@mail.ru>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= qpdf
|
||||
PORTVERSION= 4.0.0
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
MAINTAINER= d.y.kazarov@mail.ru
|
||||
COMMENT= Command-line tools for transforming and inspecting PDF files
|
||||
|
||||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
|
||||
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAN1= fix-qdf.1 qpdf.1 zlib-flate.1
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
|
||||
-e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
|
||||
${WRKSRC}/make/libtool.mk
|
||||
|
||||
.include <bsd.port.mk>
|
2
print/qpdf/distinfo
Normal file
2
print/qpdf/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (qpdf-4.0.0.tar.gz) = 446af92ef79d8c3014dca2621dedec1edff736f259ab7bebd9a6510d2fabafe3
|
||||
SIZE (qpdf-4.0.0.tar.gz) = 5029024
|
66
print/qpdf/files/patch-configure
Normal file
66
print/qpdf/files/patch-configure
Normal file
|
@ -0,0 +1,66 @@
|
|||
--- ./configure.orig 2012-09-06 23:48:38.000000000 +0400
|
||||
+++ ./configure 2013-01-05 00:13:47.000000000 +0400
|
||||
@@ -12,6 +12,12 @@
|
||||
## M4sh Initialization. ##
|
||||
## -------------------- ##
|
||||
|
||||
+CPPFLAGS="$CPPFLAGS -I/usr/local/include"
|
||||
+LDFLAGS="$LDFLAGS -L/usr/local/lib"
|
||||
+CONFIG_SHELL=/usr/local/bin/bash
|
||||
+
|
||||
+ac_make=gmake
|
||||
+
|
||||
# Be more Bourne compatible
|
||||
DUALCASE=1; export DUALCASE # for MKS sh
|
||||
if test -n "${ZSH_VERSION+set}" && (emulate sh) >/dev/null 2>&1; then :
|
||||
@@ -1333,7 +1339,7 @@
|
||||
--exec-prefix=EPREFIX install architecture-dependent files in EPREFIX
|
||||
[PREFIX]
|
||||
|
||||
-By default, \`make install' will install all the files in
|
||||
+By default, \`${ac_make} install' will install all the files in
|
||||
\`$ac_default_prefix/bin', \`$ac_default_prefix/lib' etc. You can specify
|
||||
an installation prefix other than \`$ac_default_prefix' using \`--prefix',
|
||||
for instance \`--prefix=\$HOME'.
|
||||
@@ -2381,7 +2387,7 @@
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: error: changes in the environment can compromise the build" >&5
|
||||
$as_echo "$as_me: error: changes in the environment can compromise the build" >&2;}
|
||||
- as_fn_error $? "run \`make distclean' and/or \`rm $cache_file' and start over" "$LINENO" 5
|
||||
+ as_fn_error $? "run \`${ac_make} distclean' and/or \`rm $cache_file' and start over" "$LINENO" 5
|
||||
fi
|
||||
## -------------------- ##
|
||||
## Main body of script. ##
|
||||
@@ -8663,8 +8669,8 @@
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $hard_links" >&5
|
||||
$as_echo "$hard_links" >&6; }
|
||||
if test "$hard_links" = no; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: \`$CC' does not support \`-c -o', so \`make -j' may be unsafe" >&5
|
||||
-$as_echo "$as_me: WARNING: \`$CC' does not support \`-c -o', so \`make -j' may be unsafe" >&2;}
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: \`$CC' does not support \`-c -o', so \`${ac_make} -j' may be unsafe" >&5
|
||||
+$as_echo "$as_me: WARNING: \`$CC' does not support \`-c -o', so \`${ac_make} -j' may be unsafe" >&2;}
|
||||
need_locks=warn
|
||||
fi
|
||||
else
|
||||
@@ -13795,8 +13801,8 @@
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $hard_links" >&5
|
||||
$as_echo "$hard_links" >&6; }
|
||||
if test "$hard_links" = no; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: \`$CC' does not support \`-c -o', so \`make -j' may be unsafe" >&5
|
||||
-$as_echo "$as_me: WARNING: \`$CC' does not support \`-c -o', so \`make -j' may be unsafe" >&2;}
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: \`$CC' does not support \`-c -o', so \`${ac_make} -j' may be unsafe" >&5
|
||||
+$as_echo "$as_me: WARNING: \`$CC' does not support \`-c -o', so \`${ac_make} -j' may be unsafe" >&2;}
|
||||
need_locks=warn
|
||||
fi
|
||||
else
|
||||
@@ -15399,8 +15405,8 @@
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for gnu make >= 3.81" >&5
|
||||
$as_echo_n "checking for gnu make >= 3.81... " >&6; }
|
||||
make_okay=0
|
||||
-if make --version >/dev/null 2>&1; then
|
||||
- v=`make --version | grep 'GNU Make' | sed -e 's/.*Make //'`
|
||||
+if ${ac_make} --version >/dev/null 2>&1; then
|
||||
+ v=`${ac_make} --version | grep 'GNU Make' | sed -e 's/.*Make //'`
|
||||
maj=`echo $v | cut -d. -f 1`
|
||||
min=`echo $v | cut -d. -f 2`
|
||||
if test $maj -gt 3 -o '(' $maj -eq 3 -a $min -ge 81 ')'; then
|
18
print/qpdf/pkg-descr
Normal file
18
print/qpdf/pkg-descr
Normal file
|
@ -0,0 +1,18 @@
|
|||
QPDF is a program that can be used to linearize (web-optimize),
|
||||
encrypt (password-protect), decrypt, and inspect PDF files from the
|
||||
command-line. It does these and other structural, content-preserving
|
||||
transformations on PDF files, reading a PDF file as input and
|
||||
creating a new one as output. It also provides many useful
|
||||
capabilities to developers of PDF-producing software or for people
|
||||
who just want to look at the innards of a PDF file to learn more
|
||||
about how they work.
|
||||
|
||||
QPDF understands PDF files that use compressed object streams
|
||||
(supported by newer PDF applications) and can convert such files into
|
||||
those that can be read with older viewers. It can also be used for
|
||||
checking PDF files for structural errors, inspecting stream contents,
|
||||
or extracting objects from PDF files. QPDF is not PDF content
|
||||
creation or viewing software -- it does not have the capability to
|
||||
create PDF files from scratch or to display PDF files.
|
||||
|
||||
WWW: http://qpdf.sourceforge.net
|
37
print/qpdf/pkg-plist
Normal file
37
print/qpdf/pkg-plist
Normal file
|
@ -0,0 +1,37 @@
|
|||
bin/fix-qdf
|
||||
bin/qpdf
|
||||
bin/zlib-flate
|
||||
include/qpdf/Buffer.hh
|
||||
include/qpdf/BufferInputSource.hh
|
||||
include/qpdf/Constants.h
|
||||
include/qpdf/DLL.h
|
||||
include/qpdf/FileInputSource.hh
|
||||
include/qpdf/InputSource.hh
|
||||
include/qpdf/Pipeline.hh
|
||||
include/qpdf/Pl_Buffer.hh
|
||||
include/qpdf/Pl_Concatenate.hh
|
||||
include/qpdf/Pl_Count.hh
|
||||
include/qpdf/Pl_Discard.hh
|
||||
include/qpdf/Pl_Flate.hh
|
||||
include/qpdf/Pl_StdioFile.hh
|
||||
include/qpdf/PointerHolder.hh
|
||||
include/qpdf/QPDF.hh
|
||||
include/qpdf/QPDFExc.hh
|
||||
include/qpdf/QPDFObject.hh
|
||||
include/qpdf/QPDFObjectHandle.hh
|
||||
include/qpdf/QPDFTokenizer.hh
|
||||
include/qpdf/QPDFWriter.hh
|
||||
include/qpdf/QPDFXRefEntry.hh
|
||||
include/qpdf/QTC.hh
|
||||
include/qpdf/QUtil.hh
|
||||
include/qpdf/Types.h
|
||||
include/qpdf/qpdf-c.h
|
||||
lib/libqpdf.a
|
||||
lib/libqpdf.so
|
||||
lib/libqpdf.so.10
|
||||
libdata/pkgconfig/libqpdf.pc
|
||||
share/doc/qpdf/qpdf-manual.html
|
||||
share/doc/qpdf/qpdf-manual.pdf
|
||||
share/doc/qpdf/stylesheet.css
|
||||
@dirrm share/doc/qpdf
|
||||
@dirrm include/qpdf
|
Loading…
Reference in a new issue