net/unison232: Remove expired port
2024-01-15 net/unison232: More recent versions are in the tree consider using net/unison240
This commit is contained in:
parent
df6b017bd1
commit
2ad711d413
11 changed files with 1 additions and 201 deletions
1
MOVED
1
MOVED
|
@ -2935,3 +2935,4 @@ devel/freebsd-gcc9||2024-01-09|No longer able to build base system, use GCC 12 o
|
|||
net/downzemall|net/arrowdl|2024-01-11|Project was renamed upstream
|
||||
misc/mc-nox11|misc/mc|2024-01-15|No longer useful (misc/mc does not require Xlib at runtime)
|
||||
www/mongrel2||2024-01-15|Has expired: BROKEN for more than 2 years on all platforms after the EOL of 12
|
||||
net/unison232|net/unison240|2024-01-15|Has expired: More recent versions are in the tree consider using net/unison240
|
||||
|
|
|
@ -1578,7 +1578,6 @@
|
|||
SUBDIR += ulxmlrpcpp
|
||||
SUBDIR += unfs3
|
||||
SUBDIR += unison
|
||||
SUBDIR += unison232
|
||||
SUBDIR += unison240
|
||||
SUBDIR += unison248
|
||||
SUBDIR += unison251
|
||||
|
|
|
@ -1,87 +0,0 @@
|
|||
PORTNAME= unison
|
||||
PORTVERSION= 2.32.52
|
||||
PORTREVISION= 14
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= https://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
|
||||
DISTFILES= ${EXTRACT_ONLY} ${_EXTRA_DOCS}
|
||||
DIST_SUBDIR= ${DISTNAME}
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= mandree@FreeBSD.org
|
||||
# Implicit approval for port changes granted to Guido Falsi <madpilot@FreeBSD.org>
|
||||
COMMENT= User-level file synchronization tool
|
||||
WWW= https://www.cis.upenn.edu/~bcpierce/unison/
|
||||
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
DEPRECATED= More recent versions are in the tree consider using net/unison240
|
||||
EXPIRATION_DATE= 2024-01-15
|
||||
BROKEN= fails to build with ocaml 4.08
|
||||
|
||||
FLAVORS= x11 nox11
|
||||
FLAVOR?= ${FLAVORS:[1]}
|
||||
|
||||
USES= gmake
|
||||
|
||||
_VERSIONSUFFIX= 232
|
||||
|
||||
nox11_PKGNAMESUFFIX= ${_VERSIONSUFFIX}-nox11
|
||||
nox11_CONFLICTS_INSTALL= unison${_VERSIONSUFFIX}
|
||||
|
||||
x11_PKGNAMESUFFIX= ${_VERSIONSUFFIX}
|
||||
x11_BUILD_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2 \
|
||||
icotool:graphics/icoutils
|
||||
x11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libharfbuzz.so:print/harfbuzz
|
||||
x11_CONFLICTS_INSTALL= unison${_VERSIONSUFFIX}-nox11
|
||||
|
||||
PLIST_SUB= PORTVERSION=${PORTVERSION}
|
||||
USE_OCAML= yes
|
||||
NO_OCAML_RUNDEPENDS=yes
|
||||
MAKE_ARGS= CFLAGS=""
|
||||
|
||||
TEST_TARGET= selftest
|
||||
|
||||
_DOCS= BUGS.txt NEWS README
|
||||
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
|
||||
_EXTRA_DOCS= ${DISTNAME}-manual.html \
|
||||
${DISTNAME}-manual.pdf ${DISTNAME}-manual.ps
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
.if ${FLAVOR} == nox11
|
||||
MAKE_ARGS+= UISTYLE=text
|
||||
PKGMESSAGE= ${PKGDIR}/pkg-message.nox11
|
||||
PLIST_SUB+= X11="@comment "
|
||||
.else
|
||||
MAKE_ARGS+= UISTYLE=gtk2
|
||||
SUB_FILES= ${PORTNAME}.desktop
|
||||
USE_GNOME+= atk cairo gdkpixbuf2 glib20 gtk20 pango
|
||||
USES+= gettext-runtime gnome
|
||||
PLIST_SUB+= X11=""
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
d=$$(mktemp -d) && trap "rm -rf $$d" 0 && ( cd ${WRKSRC} && HOME=$$d ./unison -selftest -ui text -batch )
|
||||
.if ${FLAVOR} == x11
|
||||
@${ECHO} Building text-only version in ${WRKSRC}
|
||||
${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC} CFLAGS="" UISTYLE=text NAME=${PORTNAME}-text
|
||||
@cd ${WRKSRC}/win32rc && ${LOCALBASE}/bin/icotool -x U.ico
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${_VERSIONSUFFIX}
|
||||
.if ${FLAVOR} == x11
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-text ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${_VERSIONSUFFIX}-text
|
||||
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}/${PORTNAME}${_VERSIONSUFFIX}.desktop
|
||||
${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}${_VERSIONSUFFIX}.png
|
||||
.endif
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${_DOCS} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${_EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,8 +0,0 @@
|
|||
SHA256 (unison-2.32.52/unison-2.32.52.tar.gz) = 1542e5d4ad03e928260e061a8ff9d5e0bca3282481ed8bec5552de17a0270485
|
||||
SIZE (unison-2.32.52/unison-2.32.52.tar.gz) = 697866
|
||||
SHA256 (unison-2.32.52/unison-2.32.52-manual.html) = c898239d8139d8405b96d87e12c06c7f41fd3629cac0c83bc338aad50fed7f81
|
||||
SIZE (unison-2.32.52/unison-2.32.52-manual.html) = 249124
|
||||
SHA256 (unison-2.32.52/unison-2.32.52-manual.pdf) = b3fee7ac99907f3b1ed02c6ac901678e82ea1eed936acb45e9735b95d55cc4eb
|
||||
SIZE (unison-2.32.52/unison-2.32.52-manual.pdf) = 478388
|
||||
SHA256 (unison-2.32.52/unison-2.32.52-manual.ps) = 779924e2a89ab2592c512e808cfcdf302c1a691fb1f2a6a02cc415fdc87770e5
|
||||
SIZE (unison-2.32.52/unison-2.32.52-manual.ps) = 572128
|
|
@ -1,29 +0,0 @@
|
|||
--- Makefile.OCaml.orig 2009-06-18 09:29:40 UTC
|
||||
+++ Makefile.OCaml
|
||||
@@ -65,7 +65,7 @@ OCAMLLIBDIR=$(shell ocamlc -v | tail -n -1 | sed -e 's
|
||||
# This should be set to an appropriate value automatically, depending
|
||||
# on whether the lablgtk library is available
|
||||
LABLGTKLIB=$(OCAMLLIBDIR)/lablgtk
|
||||
-LABLGTK2LIB=$(OCAMLLIBDIR)/lablgtk2
|
||||
+LABLGTK2LIB=$(OCAMLLIBDIR)/site-lib/lablgtk2
|
||||
##BCP [3/2007]: Removed temporarily, since the OSX UI is not working well
|
||||
## at the moment and we don't want to confuse people by building it by default
|
||||
ifeq ($(OSARCH),osx)
|
||||
@@ -84,7 +84,7 @@ buildexecutable::
|
||||
### Default parameters
|
||||
|
||||
INCLFLAGS=-I lwt -I ubase
|
||||
-CAMLFLAGS+=$(INCLFLAGS)
|
||||
+CAMLFLAGS+=$(INCLFLAGS) -unsafe-string
|
||||
|
||||
ifeq ($(OSARCH),win32)
|
||||
# Win32 system
|
||||
@@ -246,7 +246,7 @@ endif
|
||||
|
||||
# Gtk2 GUI
|
||||
ifeq ($(UISTYLE), gtk2)
|
||||
- CAMLFLAGS+=-I +lablgtk2
|
||||
+ CAMLFLAGS+=-I +site-lib/lablgtk2
|
||||
OCAMLOBJS+=pixmaps.cmo uigtk2.cmo linkgtk2.cmo
|
||||
OCAMLLIBS+=lablgtk.cma
|
||||
endif
|
|
@ -1,11 +0,0 @@
|
|||
--- ubase/util.ml.orig 2009-05-02 02:31:27 UTC
|
||||
+++ ubase/util.ml
|
||||
@@ -71,7 +71,7 @@ let set_infos s =
|
||||
if s <> !infos then begin clear_infos (); infos := s; show_infos () end
|
||||
|
||||
let msg f =
|
||||
- clear_infos (); Uprintf.eprintf (fun () -> flush stderr; show_infos ()) f
|
||||
+ clear_infos (); Printf.kfprintf (fun c -> flush c; show_infos ()) stderr f
|
||||
|
||||
let msg : ('a, out_channel, unit) format -> 'a = msg
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
--- uigtk2.ml.orig 2009-05-14 15:59:33 UTC
|
||||
+++ uigtk2.ml
|
||||
@@ -93,12 +93,12 @@ let fontMonospaceMediumPango = lazy (Pango.Font.from_s
|
||||
(* This does not work with the current version of Lablgtk, due to a bug
|
||||
let icon =
|
||||
GdkPixbuf.from_data ~width:48 ~height:48 ~has_alpha:true
|
||||
- (Gpointer.region_of_string Pixmaps.icon_data)
|
||||
+ (Gpointer.region_of_bytes Pixmaps.icon_data)
|
||||
*)
|
||||
let icon =
|
||||
let p = GdkPixbuf.create ~width:48 ~height:48 ~has_alpha:true () in
|
||||
Gpointer.blit
|
||||
- (Gpointer.region_of_string Pixmaps.icon_data) (GdkPixbuf.get_pixels p);
|
||||
+ (Gpointer.region_of_bytes Pixmaps.icon_data) (GdkPixbuf.get_pixels p);
|
||||
p
|
||||
|
||||
(*********************************************************************
|
|
@ -1,13 +0,0 @@
|
|||
Source: https://webdav.seas.upenn.edu/viewvc/unison/branches/2.40/src/update.mli?view=patch&r1=435&r2=457&pathrev=457
|
||||
|
||||
--- update.mli.orig 2009-05-02 02:31:27 UTC
|
||||
+++ update.mli
|
||||
@@ -1,7 +1,7 @@
|
||||
(* Unison file synchronizer: src/update.mli *)
|
||||
(* Copyright 1999-2009, Benjamin C. Pierce (see COPYING for details) *)
|
||||
|
||||
-module NameMap : Map.S with type key = Name.t
|
||||
+module NameMap : MyMap.S with type key = Name.t
|
||||
|
||||
type archive =
|
||||
ArchiveDir of Props.t * archive NameMap.t
|
|
@ -1,13 +0,0 @@
|
|||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Unison 2.32
|
||||
GenericName=File-synchronization tool
|
||||
Type=Application
|
||||
Terminal=false
|
||||
StartupNotify=true
|
||||
Categories=GTK;Utility;
|
||||
Exec=unison232
|
||||
Icon=unison232.png
|
||||
Comment=Synchronize files (directories) over different disks (hosts)
|
||||
Comment[de]=Dateien oder Verzeichnisse über Festplatten oder Computer hinweg abgleichen
|
||||
Comment[ru]=Синхронизация файлов (каталогов) на нескольких дисках (компьютерах)
|
|
@ -1,12 +0,0 @@
|
|||
This is Unison version 2.32, kept for compatibility with older
|
||||
installations on other computer across the network. -- Matthias Andree
|
||||
|
||||
Unison is a file-synchronization tool for Unix and Windows. It allows two
|
||||
replicas of a collection of files and directories to be stored on different
|
||||
hosts (or different disks on the same host), modified separately, and then
|
||||
brought up to date by propagating the changes in each replica to the other.
|
||||
|
||||
Unison shares a number of features with tools such as configuration
|
||||
management packages (CVS, PRCS, etc.) distributed filesystems (Coda, etc.)
|
||||
uni-directional mirroring utilities (rsync, etc.) and other synchronizers
|
||||
(Intellisync, Reconcile, etc).
|
|
@ -1,10 +0,0 @@
|
|||
bin/unison232
|
||||
%%X11%%bin/unison232-text
|
||||
%%X11%%share/applications/unison232.desktop
|
||||
%%X11%%share/pixmaps/unison232.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BUGS.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.ps
|
Loading…
Reference in a new issue