- Update to v0.86
- Add LICENSE information
This commit is contained in:
parent
24c78aae27
commit
2b0df5a72d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=258280
9 changed files with 53 additions and 78 deletions
|
@ -5,18 +5,22 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= usbutils
|
||||
PORTVERSION= 0.73
|
||||
PORTVERSION= 0.86
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= SF/linux-usb/${PORTNAME}/${PORTVERSION}
|
||||
MASTER_SITES= SF/linux-usb/${PORTNAME}
|
||||
|
||||
MAINTAINER= brix@FreeBSD.org
|
||||
COMMENT= Utility for listing USB devices
|
||||
|
||||
LICENSE= GPLv2
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --datadir=${DATADIR}
|
||||
CONFIGURE_ARGS= --datadir=${DATADIR} --enable-zlib
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= pkgconfig
|
||||
|
||||
MAN1= usb-devices.1
|
||||
MAN8= lsusb.8
|
||||
PORTDOCS= AUTHORS ChangeLog NEWS README
|
||||
|
||||
|
@ -24,8 +28,16 @@ PORTDOCS= AUTHORS ChangeLog NEWS README
|
|||
|
||||
.if ${OSVERSION} < 800069
|
||||
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
|
||||
.else
|
||||
CONFIGURE_ENV+= LIBUSB_CFLAGS="-I/usr/include" \
|
||||
LIBUSB_LIBS="-L/usr/lib -lusb"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -i '' \
|
||||
-e 's|/bin/bash|/bin/sh|' \
|
||||
${WRKSRC}/usb-devices
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (usbutils-0.73.tar.gz) = 88978b4ad891f610620b1b8e5e0f43eb
|
||||
SHA256 (usbutils-0.73.tar.gz) = 2edc7cc98fd217f6980d8ba0b3792beed4695d4e8429a11c7237faab04ab47f4
|
||||
SIZE (usbutils-0.73.tar.gz) = 173312
|
||||
MD5 (usbutils-0.86.tar.gz) = 34979f675d2bcb3e1b45012fa830a53f
|
||||
SHA256 (usbutils-0.86.tar.gz) = b3b2bea6d2cd87660c8201a47071bf2a9889d8ed90c7203cc768b597799c12f4
|
||||
SIZE (usbutils-0.86.tar.gz) = 246623
|
||||
|
|
11
sysutils/usbutils/files/patch-Makefile.am
Normal file
11
sysutils/usbutils/files/patch-Makefile.am
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.am.orig 2010-07-13 21:30:02.000000000 +0200
|
||||
+++ Makefile.am 2010-07-13 21:30:21.000000000 +0200
|
||||
@@ -56,7 +56,7 @@ lsusb.8: $(srcdir)/lsusb.8.in
|
||||
usb-devices.1: $(srcdir)/usb-devices.1.in
|
||||
sed 's|VERSION|$(VERSION)|g' $< >$@
|
||||
|
||||
-pkgconfigdir = $(datadir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
pkgconfig_DATA = usbutils.pc
|
||||
|
||||
usbutils.pc: $(srcdir)/usbutils.pc.in
|
11
sysutils/usbutils/files/patch-Makefile.in
Normal file
11
sysutils/usbutils/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig 2010-07-13 21:50:47.000000000 +0200
|
||||
+++ Makefile.in 2010-07-13 21:51:39.000000000 +0200
|
||||
@@ -223,7 +223,7 @@ EXTRA_DIST = \
|
||||
usb-devices \
|
||||
usbutils.pc.in
|
||||
|
||||
-pkgconfigdir = $(datadir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
pkgconfig_DATA = usbutils.pc
|
||||
DISTCLEANFILES = \
|
||||
usb.ids.gz \
|
|
@ -1,22 +0,0 @@
|
|||
--- config.h.in.orig 2006-12-10 21:33:49.000000000 +0100
|
||||
+++ config.h.in 2007-11-14 20:50:36.000000000 +0100
|
||||
@@ -15,6 +15,9 @@
|
||||
*/
|
||||
#undef HAVE_ALLOCA_H
|
||||
|
||||
+/* Define to 1 if you have the <asm/byteorder.h> header file. */
|
||||
+#undef HAVE_ASM_BYTEORDER_H
|
||||
+
|
||||
/* Define to 1 if you have the <dirent.h> header file, and it defines `DIR'.
|
||||
*/
|
||||
#undef HAVE_DIRENT_H
|
||||
@@ -46,6 +49,9 @@
|
||||
/* Define to 1 if you have the `z' library (-lz). */
|
||||
#undef HAVE_LIBZ
|
||||
|
||||
+/* Define to 1 if you have the <machine/endian.h> header file. */
|
||||
+#undef HAVE_MACHINE_ENDIAN_H
|
||||
+
|
||||
/* Define to 1 if your system has a GNU libc compatible `malloc' function, and
|
||||
to 0 otherwise. */
|
||||
#undef HAVE_MALLOC
|
|
@ -1,13 +0,0 @@
|
|||
--- configure.orig 2007-10-23 23:19:49.000000000 +0200
|
||||
+++ configure 2007-11-14 20:50:37.000000000 +0100
|
||||
@@ -4138,7 +4138,9 @@ done
|
||||
|
||||
|
||||
|
||||
-for ac_header in fcntl.h stdlib.h string.h sys/ioctl.h sys/param.h unistd.h getopt.h errno.h
|
||||
+
|
||||
+
|
||||
+for ac_header in fcntl.h stdlib.h string.h sys/ioctl.h sys/param.h unistd.h getopt.h errno.h asm/byteorder.h machine/endian.h
|
||||
do
|
||||
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
||||
if eval "test \"\${$as_ac_Header+set}\" = set"; then
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.in.orig 2007-10-23 23:19:32.000000000 +0200
|
||||
+++ configure.in 2007-11-14 20:50:37.000000000 +0100
|
||||
@@ -20,7 +20,7 @@ AC_PROG_LN_S
|
||||
AC_FUNC_ALLOCA
|
||||
AC_HEADER_DIRENT
|
||||
AC_HEADER_STDC
|
||||
-AC_CHECK_HEADERS([fcntl.h stdlib.h string.h sys/ioctl.h sys/param.h unistd.h getopt.h errno.h ])
|
||||
+AC_CHECK_HEADERS([fcntl.h stdlib.h string.h sys/ioctl.h sys/param.h unistd.h getopt.h errno.h asm/byteorder.h machine/endian.h])
|
||||
|
||||
# Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_C_CONST
|
|
@ -1,33 +1,15 @@
|
|||
--- lsusb.c.orig 2007-10-23 23:04:32.000000000 +0200
|
||||
+++ lsusb.c 2007-11-14 20:50:37.000000000 +0100
|
||||
@@ -35,13 +35,29 @@
|
||||
--- lsusb.c.orig 2009-08-17 22:28:42.000000000 +0000
|
||||
+++ lsusb.c 2010-07-26 13:08:52.000000000 +0000
|
||||
@@ -31,8 +31,11 @@
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <stdarg.h>
|
||||
+
|
||||
+#if defined(HAVE_ASM_BYTEORDER_H)
|
||||
#include <asm/byteorder.h>
|
||||
#define le16_to_cpu __le16_to_cpu
|
||||
+
|
||||
+#elif defined(HAVE_MACHINE_ENDIAN_H)
|
||||
+#include <machine/endian.h>
|
||||
+#if _BYTE_ORDER == _LITTLE_ENDIAN
|
||||
+#define le16_to_cpu(x) (x)
|
||||
+#else
|
||||
+#define le16_to_cpu __bswap16
|
||||
-#include <byteswap.h>
|
||||
+#if defined(HAVE_UNISTD_H)
|
||||
+#include <unistd.h>
|
||||
+#endif
|
||||
+
|
||||
+#else
|
||||
+#error no le16_to_cpu implementation is available
|
||||
+#endif
|
||||
+
|
||||
#include <usb.h>
|
||||
|
||||
/* NOTE: that should be <libusb.h> and it should include
|
||||
- * <linux/usb_ch9.h> ... without it, we keep accumulating
|
||||
+ * <linux/usb/ch9.h> ... without it, we keep accumulating
|
||||
* potentially broken variants of standard types ...
|
||||
+ * also <linux/usb/cdc.h>, <linux/usb/audio.h>, etc
|
||||
*/
|
||||
|
||||
#include "names.h"
|
||||
|
|
|
@ -1,3 +1,8 @@
|
|||
bin/usb-devices
|
||||
libdata/pkgconfig/usbutils.pc
|
||||
sbin/lsusb
|
||||
sbin/update-usbids.sh
|
||||
%%DATADIR%%/usb.ids
|
||||
%%DATADIR%%/usb.ids.gz
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrmtry libdata/pkgconfig
|
||||
|
|
Loading…
Reference in a new issue