- Update to 0.70

- Remove outdated post-patch:
- Sort PLIST

Changes:	http://search.cpan.org/dist/Inline-CPP/Changes
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2015-01-03 07:11:37 +00:00
parent 6681f94701
commit 2b25fb3de0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=376088
4 changed files with 21 additions and 23 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Inline-CPP
PORTVERSION= 0.49
PORTREVISION= 1
PORTVERSION= 0.70
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@ -13,14 +12,13 @@ COMMENT= Write Perl subroutines and classes in C++
LICENSE= ART10
BUILD_DEPENDS= p5-Inline>=0.53:${PORTSDIR}/devel/p5-Inline \
BUILD_DEPENDS= p5-Inline>=0.78:${PORTSDIR}/devel/p5-Inline \
p5-Inline-C>=0.67:${PORTSDIR}/devel/p5-Inline-C \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS:= ${BUILD_DEPENDS}
BUILD_DEPENDS+= p5-ExtUtils-CppGuess>=0.07:${PORTSDIR}/devel/p5-ExtUtils-CppGuess
USES= perl5
USE_PERL5= configure
post-patch:
@${REINPLACE_CMD} -e 's|g++|${CXX}|' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (Inline-CPP-0.49.tar.gz) = 16efc1b908d83379e5ac05fb70225a3f4c88dabe825eb54c7faaf45bd52b672d
SIZE (Inline-CPP-0.49.tar.gz) = 52497
SHA256 (Inline-CPP-0.70.tar.gz) = 1722914110462c36146972720e6985e9c5e13fd5f540ee041fa918e552575568
SIZE (Inline-CPP-0.70.tar.gz) = 63930

View file

@ -1,15 +1,15 @@
--- ./Makefile.PL.orig 2013-01-01 03:27:22.000000000 +0800
+++ ./Makefile.PL 2013-01-01 03:30:52.000000000 +0800
@@ -121,10 +121,9 @@
print "This will configure and build Inline::C++.\n";
--- Makefile.PL.orig 2014-12-26 05:17:26.000000000 +0800
+++ Makefile.PL 2015-01-01 04:23:51.734420696 +0800
@@ -37,10 +37,10 @@
my( $cc_guess, $libs_guess ) = guess_compiler();
my $cpp_compiler
- = prompt( "What default C++ compiler would you like to use?", $cc_guess );
+ = $cc_guess;
- = prompt( "What C++ compiler would you like to use?", $cc_guess );
+ = $cc_guess;
my $libs
- = prompt( "What default libraries would you like to include?", $libs_guess );
+ = $libs_guess;
-my $libs = prompt( "What default libraries would you like to include?",
- $libs_guess );
+my $libs = $libs_guess;
configure_distribution( $test_cpp_filename, $cpp_compiler, $libs );
#============================================================================
# Test whether the compiler prefers <iostream> or <iostream.h>.

View file

@ -1,7 +1,7 @@
%%PERL5_MAN3%%/Inline::CPP.3.gz
%%PERL5_MAN3%%/Inline::CPP::Config.3.gz
%%PERL5_MAN3%%/Inline::CPP::grammar.3.gz
%%SITE_PERL%%/Inline/CPP.pm
%%SITE_PERL%%/Inline/CPP.pod
%%SITE_PERL%%/Inline/CPP/Config.pm
%%SITE_PERL%%/Inline/CPP/grammar.pm
%%SITE_PERL%%/Inline/CPP/Parser/RecDescent.pm
%%PERL5_MAN3%%/Inline::CPP.3.gz
%%PERL5_MAN3%%/Inline::CPP::Config.3.gz
%%PERL5_MAN3%%/Inline::CPP::Parser::RecDescent.3.gz