[NEW PORT] security/openvas-libraries: Libraries for OpenVAS

OpenVAS stands for Open Vulnerability Assessment System and
	is a network security scanner with associated tools like a
	graphical user fontend. The core is a server component with
	a set of network vulnerability tests (NVTs) to detect
	security problems in remote systems and applications.

	WWW: http://www.openvas.org/

PR:		ports/123127
Submitted by:	Tomoyuki Sakurai <cherry@trombik.org>
This commit is contained in:
Edwin Groothuis 2008-06-04 13:15:44 +00:00
parent 654aeea25d
commit 2b7aa4172c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=214310
14 changed files with 201 additions and 0 deletions

View file

@ -315,6 +315,7 @@
SUBDIR += openssl-stable
SUBDIR += openvas-client
SUBDIR += openvas-libnasl
SUBDIR += openvas-libraries
SUBDIR += openvpn
SUBDIR += openvpn-admin
SUBDIR += openvpn-auth-ldap

View file

@ -0,0 +1,27 @@
# New ports collection makefile for: openvas-libraries
# Date created: 2008-04-26
# Whom: Tomoyuki Sakurai <cherry@trombik.org>
#
# $FreeBSD$
#
PORTNAME= openvas-libraries
PORTVERSION= 1.0.1
CATEGORIES= security
MASTER_SITES= http://wald.intevation.org/frs/download.php/419/
MAINTAINER= cherry@trombik.org
COMMENT= Libraries for OpenVAS
LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= libopenvas-config.1
.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (openvas-libraries-1.0.1.tar.gz) = 59eff43239e05bed77f2b3e789e0110b
SHA256 (openvas-libraries-1.0.1.tar.gz) = 6d423d82d6e71e519df79596d30fad6ffefd480ed8a0dd7282fb5b749cee72e3
SIZE (openvas-libraries-1.0.1.tar.gz) = 312409

View file

@ -0,0 +1,43 @@
--- configure.orig 2008-03-27 03:57:28.000000000 +0900
+++ configure 2008-04-26 22:00:22.000000000 +0900
@@ -8136,7 +8136,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lresolv $LIBS"
+LIBS="$LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -8192,7 +8192,7 @@
{ echo "$as_me:$LINENO: result: $ac_cv_lib_resolv___dn_expand" >&5
echo "${ECHO_T}$ac_cv_lib_resolv___dn_expand" >&6; }
if test $ac_cv_lib_resolv___dn_expand = yes; then
- LIBS="-lresolv $LIBS"
+ LIBS="$LIBS"
else
{ { echo "$as_me:$LINENO: error: you need to install resolve library with development files" >&5
echo "$as_me: error: you need to install resolve library with development files" >&2;}
@@ -8290,11 +8290,11 @@
#ifdef __cplusplus
extern "C"
#endif
-char pcap_restart ();
+/* char pcap_restart (); */
int
main ()
{
-return pcap_restart ();
+return 0 /* pcap_restart (); */
;
return 0;
}
@@ -12909,7 +12909,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lresolv $LIBS"
+LIBS="$LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF

View file

@ -0,0 +1,10 @@
--- libopenvas/ftp_funcs.c.orig 2008-04-26 23:23:23.000000000 +0900
+++ libopenvas/ftp_funcs.c 2008-04-26 23:24:01.000000000 +0900
@@ -32,6 +32,7 @@
#include <netinet/in.h>
#include "network.h"
+#include <sys/socket.h>
int ftp_log_in(int soc, char * username, char * passwd)
{

View file

@ -0,0 +1,10 @@
--- libopenvas/ids_send.c.orig 2008-04-26 23:55:47.000000000 +0900
+++ libopenvas/ids_send.c 2008-04-26 23:56:02.000000000 +0900
@@ -36,6 +36,7 @@
#include <unistd.h>
#include <stdlib.h>
#include <arpa/inet.h>
+#include <sys/socket.h>
#include "arglists.h"
#include "bpf_share.h"

View file

@ -0,0 +1,10 @@
--- libopenvas/network.h.orig 2008-04-26 23:22:23.000000000 +0900
+++ libopenvas/network.h 2008-04-26 23:21:49.000000000 +0900
@@ -27,6 +27,7 @@
#define OPENVAS_NETWORK_H
#include "arglists.h"
+#include <sys/select.h>
/* Plugin specific network functions */
int open_sock_tcp(struct arglist * , unsigned int, int );

View file

@ -0,0 +1,23 @@
--- libopenvas/pcap.c.orig 2008-03-21 06:25:01.000000000 +0900
+++ libopenvas/pcap.c 2008-04-26 23:47:15.000000000 +0900
@@ -16,9 +16,7 @@
* Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/
-#include <resolv.h>
#include <pcap.h>
-#include <net/if.h>
#include <arpa/inet.h>
#include <sys/ioctl.h>
#include <netdb.h>
@@ -28,6 +26,10 @@
#include <stdlib.h>
#include <string.h>
#include <unistd.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <sys/param.h>
+#include <net/if.h>
#include "bpf_share.h"
#include "pcap_openvas.h"

View file

@ -0,0 +1,11 @@
--- libopenvas/plugutils.c.orig 2008-04-26 22:03:11.000000000 +0900
+++ libopenvas/plugutils.c 2008-04-26 22:03:21.000000000 +0900
@@ -35,7 +35,7 @@
#include <unistd.h>
#include <errno.h>
#include <signal.h>
-#include <wait.h>
+#include <sys/wait.h>
#include <time.h>
#include "arglists.h"

View file

@ -0,0 +1,10 @@
--- libopenvas/popen.c.orig 2008-04-26 23:50:53.000000000 +0900
+++ libopenvas/popen.c 2008-04-26 23:51:11.000000000 +0900
@@ -26,6 +26,7 @@
#include <errno.h>
#include <fcntl.h>
#include <signal.h>
+#include <sys/resource.h>
#include "system.h"

View file

@ -0,0 +1,11 @@
--- openvas-libraries.tmpl.in.orig 2008-04-26 22:46:43.000000000 +0900
+++ openvas-libraries.tmpl.in 2008-04-26 22:47:03.000000000 +0900
@@ -45,7 +45,7 @@
libsdir=${rootdir}/libs
top_builddir = @PWDD@
-include= -I. -I$(rootdir)/include
+include= -I. -I$(rootdir)/include -I$(includedir)
lib_dir=@libdir@
USE_CIPHER=@cipher_cflags@
INSTALL=@INSTALL@

Binary file not shown.

View file

@ -0,0 +1,6 @@
OpenVAS stands for Open Vulnerability Assessment System and is a network
security scanner with associated tools like a graphical user fontend. The core
is a server component with a set of network vulnerability tests (NVTs) to
detect security problems in remote systems and applications.
WWW: http://www.openvas.org/

View file

@ -0,0 +1,36 @@
@comment $FreeBSD$
bin/libopenvas-config
lib/libopenvas.so.1
lib/libopenvas.so
lib/libopenvas.la
lib/libopenvas.a
lib/libopenvas_hg.so.1
lib/libopenvas_hg.so
lib/libopenvas_hg.la
lib/libopenvas_hg.a
include/openvas/hosts_gatherer.h
include/openvas/hg_utils.h
include/openvas/libopenvas.h
include/openvas/libvers.h
include/openvas/getopt.h
include/openvas/arglists.h
include/openvas/bpf_share.h
include/openvas/ftp_funcs.h
include/openvas/harglists.h
include/openvas/kb.h
include/openvas/network.h
include/openvas/pcap_openvas.h
include/openvas/plugutils.h
include/openvas/popen.h
include/openvas/proctitle.h
include/openvas/rand.h
include/openvas/resolve.h
include/openvas/scanners_utils.h
include/openvas/services1.h
include/openvas/share_fd.h
include/openvas/store.h
include/openvas/system.h
include/openvas/www_funcs.h
@dirrm include/openvas