biology/kallisto: Tag only for 64-bit architectures
Also patch out -march=native Reported by: pkg-fallout
This commit is contained in:
parent
718687d3ee
commit
2b96a02432
2 changed files with 15 additions and 0 deletions
|
@ -1,6 +1,7 @@
|
|||
PORTNAME= kallisto
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.50.0
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= biology
|
||||
|
||||
|
@ -11,6 +12,9 @@ WWW= https://pachterlab.github.io/kallisto/about.html
|
|||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/license.txt
|
||||
|
||||
# Requires a 64-bit processor
|
||||
ONLY_FOR_ARCHS= aarch64 amd64 powerpc64 powerpc64le riscv64
|
||||
|
||||
LIB_DEPENDS= libhdf5.so:science/hdf5 \
|
||||
libsz.so:science/libaec \
|
||||
libhts.so:biology/htslib
|
||||
|
|
11
biology/kallisto/files/patch-ext_bifrost_CMakeLists.txt
Normal file
11
biology/kallisto/files/patch-ext_bifrost_CMakeLists.txt
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ext/bifrost/CMakeLists.txt.orig 2023-07-14 14:27:24 UTC
|
||||
+++ ext/bifrost/CMakeLists.txt
|
||||
@@ -30,8 +30,6 @@ if(COMPILATION_ARCH MATCHES "OFF")
|
||||
message("Disabling native architecture compilation (including AVX2)")
|
||||
else(COMPILATION_ARCH MATCHES "OFF")
|
||||
message("Compilation architecture: ${COMPILATION_ARCH}")
|
||||
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=${COMPILATION_ARCH}")
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=${COMPILATION_ARCH}")
|
||||
endif(COMPILATION_ARCH MATCHES "OFF")
|
||||
|
||||
if(ENABLE_AVX2 MATCHES "OFF")
|
Loading…
Reference in a new issue