Update to 1.2.6. [1]

Add a patch to unbreak compilation with mpich. [2]

PR:		ports/92909 [1], ports/93176 [2]
Submitted by:	Kay Lehmann <kay_lehmann@web.de> (maintainer)
This commit is contained in:
Sam Lawrance 2006-02-17 11:47:41 +00:00
parent afa29ab8ae
commit 2b9e6f9ca0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=156211
4 changed files with 31 additions and 8 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= mbdyn
PORTVERSION= 1.2.4
PORTVERSION= 1.2.6
CATEGORIES= science
MASTER_SITES= http://mbdyn.aero.polimi.it/~masarati/Download/mbdyn/
@ -46,6 +46,7 @@ CONFIGURE_ARGS+= --with-mpi=no
.endif
.if defined(WITH_METIS)
BROKEN= Does not compile with metis enabled
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
CONFIGURE_ARGS+= --with-metis=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
@ -54,7 +55,7 @@ CONFIGURE_ARGS+= --with-metis=no
.endif
.if defined(WITH_GINAC)
IGNORE= "You enabled GiNaC-support, which isn't implemented yet"
IGNORE= you enabled GiNaC-support, which is not implemented yet
#BUILD_DEPENDS+= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
CONFIGURE_ARGS+= --with-ginac=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
@ -63,7 +64,7 @@ CONFIGURE_ARGS+= --with-ginac=no
.endif
.if defined(WITH_TCL)
IGNORE= "You enabled Tcl-support, which isn't implemented yet"
IGNORE= you enabled Tcl-support, which is not implemented yet
LIB_DEPENDS+= tcl84:${PORTSDIR}/lang/tcl84
CONFIGURE_ARGS+= --with-tcl=yes
CPPFLAGS+= -I${LOCALBASE}/include/tcl8.4
@ -72,11 +73,11 @@ CONFIGURE_ARGS+= --with-tcl=no
.endif
.if ${ARCH} == "sparc64"
BROKEN= "Does not compile"
BROKEN= Does not compile
.endif
.if ${OSVERSION} < 500000
BROKEN= "Does not compile"
BROKEN= Does not compile
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (mbdyn-1.2.4.tar.gz) = 9b722c0fa62b0701ab5cb7c54dee0b53
SHA256 (mbdyn-1.2.4.tar.gz) = 3d96266fcdad98a8406e8a45c79c9c34b601b5be8c425cb918531607690e9ddc
SIZE (mbdyn-1.2.4.tar.gz) = 1439038
MD5 (mbdyn-1.2.6.tar.gz) = c77fcd450481054462a70a4426c5f816
SHA256 (mbdyn-1.2.6.tar.gz) = f550ca89a2cc04c5175315ba8a1f5585531423ac02b64a1d80809c714850e9d6
SIZE (mbdyn-1.2.6.tar.gz) = 1599343

View file

@ -0,0 +1,20 @@
Fix to Schur data manager caused by the introduction of the output meter;
only affects MBDyn 1.2.6 when --enable-schur
Index: mbdyn/base/schurdataman.cc
===================================================================
RCS file: /var/cvs/mbdyn/mbdyn/mbdyn-1.0/mbdyn/base/schurdataman.cc,v
retrieving revision 1.40.2.6
retrieving revision 1.40.2.7
diff -u -r1.40.2.6 -r1.40.2.7
--- mbdyn/base/schurdataman.cc 18 Jan 2006 16:29:56 -0000 1.40.2.6
+++ mbdyn/base/schurdataman.cc 8 Feb 2006 20:02:29 -0000 1.40.2.7
@@ -1835,7 +1835,7 @@
DEBUGCOUT("Entering SchurDataManager::Output()" << std::endl);
/* output only at multiples of iOutputFrequency */
- if ((!force) && (iOutputCount++%iOutputFrequency)) {
+ if ((!force) && !pOutputMeter->dGet()) {
return;
}

View file

@ -1,4 +1,6 @@
bin/mbdyn
bin/2vec2phi
bin/trim
bin/autopilot
bin/c81merge
bin/c81test