devel/clxclient: New port: C++ wrapper library around the X Window System API
This commit is contained in:
parent
c6ccf4f343
commit
2ba5725b91
5 changed files with 55 additions and 0 deletions
|
@ -356,6 +356,7 @@
|
|||
SUBDIR += cloudabi-toolchain
|
||||
SUBDIR += clthreads
|
||||
SUBDIR += cltune
|
||||
SUBDIR += clxclient
|
||||
SUBDIR += cmake
|
||||
SUBDIR += cmake-doc
|
||||
SUBDIR += cmake-fedora
|
||||
|
|
35
devel/clxclient/Makefile
Normal file
35
devel/clxclient/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
PORTNAME= clxclient
|
||||
DISTVERSION= 3.9.2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://kokkinizita.linuxaudio.org/linuxaudio/downloads/
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= C++ wrapper library around the X Window System API
|
||||
|
||||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/../COPYING
|
||||
|
||||
BUILD_DEPENDS= clthreads>0:devel/clthreads \
|
||||
freetype2>0:print/freetype2
|
||||
|
||||
USES= gmake localbase:ldflags pkgconfig tar:bz2 xorg
|
||||
USE_XORG= x11 xft
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
ALL_TARGET= libclxclient.so.${DISTVERSION}
|
||||
|
||||
CXXFLAGS+= -I${WRKSRC}
|
||||
|
||||
MAKE_ARGS= LIBDIR=${LOCALBASE}/lib
|
||||
|
||||
WRKSRC_SUBDIR= source
|
||||
|
||||
PLIST_FILES= include/clxclient.h \
|
||||
lib/libclxclient.so \
|
||||
lib/libclxclient.so.${DISTVERSION:R:R} \
|
||||
lib/libclxclient.so.${DISTVERSION}
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libclxclient.so.3.9.2
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/clxclient/distinfo
Normal file
3
devel/clxclient/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1623701720
|
||||
SHA256 (clxclient-3.9.2.tar.bz2) = 8501e964f0e0746abc5083a0b75fe3b937281cc4a9f7d1450ff98e86bc337881
|
||||
SIZE (clxclient-3.9.2.tar.bz2) = 29991
|
12
devel/clxclient/files/patch-Makefile
Normal file
12
devel/clxclient/files/patch-Makefile
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- Makefile.orig 2018-08-24 18:50:31 UTC
|
||||
+++ Makefile
|
||||
@@ -55,7 +55,8 @@ install: $(CLXCLIENT_MIN)
|
||||
install -d $(DESTDIR)$(LIBDIR)
|
||||
install -m 644 $(CLXCLIENT_H) $(DESTDIR)$(INCDIR)
|
||||
install -m 755 $(CLXCLIENT_MIN) $(DESTDIR)$(LIBDIR)
|
||||
- ldconfig
|
||||
+ #ldconfig
|
||||
+ ln -sf $(CLXCLIENT_MIN) $(DESTDIR)$(LIBDIR)/$(CLXCLIENT_MAJ)
|
||||
ln -sf $(CLXCLIENT_MIN) $(DESTDIR)$(LIBDIR)/$(CLXCLIENT_SO)
|
||||
|
||||
uninstall:
|
4
devel/clxclient/pkg-descr
Normal file
4
devel/clxclient/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
clxclient is a C++ wrapper library around the X Window System API that is used
|
||||
in some LinuxAudio-hosted projects.
|
||||
|
||||
WWW: https://kokkinizita.linuxaudio.org/linuxaudio/
|
Loading…
Reference in a new issue