- Update to 1.0.1

PR:		ports/79481, ports/79482
Submitted by:	Ports Fury
This commit is contained in:
Pav Lucistnik 2005-04-04 21:42:06 +00:00
parent a05860a469
commit 2bee492c83
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=132504
25 changed files with 278 additions and 342 deletions

View file

@ -18,16 +18,20 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A web phone that supports SIP protocol
LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm \
jack.0:${PORTSDIR}/audio/jack \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
speex.3:${PORTSDIR}/audio/speex \
osip.9:${PORTSDIR}/net/libosip
osip2.3:${PORTSDIR}/net/libosip2
USE_GNOME= glib20 gnomehack gnometarget intlhack pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LIBTOOL_VER= 15
LIBTOOLFILES= configure oRTP/configure
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-ipv6 --enable-gnome_ui=no \
--with-speex=${LOCALBASE} --with-html-dir=${DOCSDIR}
CONFIGURE_ARGS= --disable-ipv6 --disable-gtk-doc --enable-gnome_ui=no \
--with-speex=${LOCALBASE} --with-osip=${LOCALBASE} \
--with-html-dir=${DOCSDIR}
INSTALLS_SHLIB= yes
MAN1= linphonec.1 sipomatic.1
@ -47,7 +51,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/share/*.wav ${DATADIR}/sounds
@${MKDIR} ${DATADIR}/sounds/rings
${INSTALL_DATA} ${WRKSRC}/share/rings/*.wav ${DATADIR}/sounds/rings
@${MKDIR} ${PREFIX}/share/linphonec
${INSTALL_DATA} ${WRKSRC}/share/linphonec ${PREFIX}/share/linphonec
.include <bsd.port.post.mk>

View file

@ -3,10 +3,10 @@
#
LINPHONE_PORTNAME= linphone
LINPHONE_PORTVERSION= 0.12.2
LINPHONE_PORTREVISION= 1
LINPHONE_PORTVERSION= 1.0.1
LINPHONE_PORTREVISION= 0
LINPHONE_PORTEPOCH= 1
LINPHONE_MASTER_SITES= http://simon.morlat.free.fr/download/${LINPHONE_PORTVERSION}/source/
LINPHONE_MASTER_SITES= http://simon.morlat.free.fr/download/stable/source/
PATCHDIR= ${.CURDIR}/../../net/linphone-base/files
MD5_FILE= ${.CURDIR}/../../net/linphone-base/distinfo

View file

@ -1,2 +1,2 @@
MD5 (linphone-0.12.2.tar.gz) = 86c01dbbcdb41786229f51ec0994ff67
SIZE (linphone-0.12.2.tar.gz) = 3044602
MD5 (linphone-1.0.1.tar.gz) = d65f977dd6512b7725fcb2e2c9713e65
SIZE (linphone-1.0.1.tar.gz) = 7315742

View file

@ -1,24 +1,16 @@
$FreeBSD$
--- Makefile.in.orig Thu Apr 1 05:40:35 2004
+++ Makefile.in Thu Apr 15 03:26:01 2004
@@ -156,13 +156,15 @@
--- Makefile.in.orig Tue Mar 22 00:53:37 2005
+++ Makefile.in Wed Mar 23 18:51:15 2005
@@ -274,9 +274,11 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@BUILD_TRUESPEECH_TRUE@WIN32ACM_DIR = win32acm
-SUBDIRS = m4 support pixmaps po ipkg oRTP gsmlib lpc10-1.5 \
+ifndef SUBDIRS
@BUILD_SPEEX_TRUE@SUBDIRS = support pixmaps ffmpeg po debian ipkg oRTP gsmlib lpc10-1.5 \
@BUILD_SPEEX_TRUE@ $(WIN32ACM_DIR) speex mediastreamer \
@BUILD_SPEEX_TRUE@ media_api osipua coreapi console gnome share developer-docs
-@BUILD_SPEEX_FALSE@SUBDIRS = support pixmaps ffmpeg po debian ipkg oRTP gsmlib lpc10-1.5 \
-@BUILD_SPEEX_FALSE@ $(WIN32ACM_DIR) speex mediastreamer \
-@BUILD_SPEEX_FALSE@ media_api osipua coreapi console gnome share developer-docs
+@BUILD_SPEEX_FALSE@SUBDIRS = support ffmpeg po debian ipkg oRTP lpc10-1.5 \
+@BUILD_SPEEX_FALSE@ $(WIN32ACM_DIR) mediastreamer \
+@BUILD_SPEEX_FALSE@ media_api osipua coreapi console gnome developer-docs
+SUBDIRS = m4 support po ipkg oRTP lpc10-1.5 \
$(WIN32ACM_DIR) mediastreamer mediastreamer2\
- media_api exosip coreapi console gnome share developer-docs
+ media_api exosip coreapi console gnome developer-docs
+endif
EXTRA_DIST = linphone2.glade BUGS linphone.kdevprj \
intltool-extract.in \

View file

@ -0,0 +1,14 @@
--- console/commands.c.orig Tue Mar 8 03:31:49 2005
+++ console/commands.c Wed Mar 23 17:46:13 2005
@@ -112,9 +112,9 @@
void linphonec_proxy_list(LinphoneCore *lc){
GList *proxies;
- int n;
+ int def, n;
proxies=linphone_core_get_proxy_config_list(lc);
- int def=linphone_core_get_default_proxy(lc,NULL);
+ def=linphone_core_get_default_proxy(lc,NULL);
for(n=0;proxies!=NULL;proxies=g_list_next(proxies),n++){
if (n==def)
printf("****** Proxy %i - this is the default one - *******\n",n);

View file

@ -1,10 +1,12 @@
--- coreapi/linphonecore.c.orig Fri Nov 7 00:27:42 2003
+++ coreapi/linphonecore.c Fri Nov 21 11:59:25 2003
@@ -33,6 +33,7 @@
#include <sys/socket.h>
#include <netinet/in.h>
--- coreapi/linphonecore.c.orig Thu Mar 17 01:16:55 2005
+++ coreapi/linphonecore.c Wed Mar 23 13:17:30 2005
@@ -34,9 +34,7 @@
#include <arpa/inet.h>
+#include <netdb.h>
#include <time.h>
#ifdef INET6
-#ifdef INET6
#include <netdb.h>
-#endif
#include "enum.h"

View file

@ -0,0 +1,13 @@
--- coreapi/lpconfig.c.orig Fri Mar 11 21:53:12 2005
+++ coreapi/lpconfig.c Wed Mar 23 17:44:35 2005
@@ -266,8 +266,9 @@
}
int lp_config_sync(LpConfig *lpconfig){
+ FILE *file;
if (lpconfig->filename==NULL) return;
- FILE *file=fopen(lpconfig->filename,"w");
+ file=fopen(lpconfig->filename,"w");
if (file==NULL){
g_warning("Could not write %s !",lpconfig->filename);
return -1;

View file

@ -0,0 +1,12 @@
--- coreapi/proxy.c.orig Fri Mar 11 01:54:25 2005
+++ coreapi/proxy.c Wed Mar 23 17:43:30 2005
@@ -59,8 +59,8 @@
gint linphone_proxy_config_set_server_addr(LinphoneProxyConfig *obj, const gchar *server_addr){
int err;
- if (server_addr==NULL || strlen(server_addr)==0) return -1;
osip_from_t *url;
+ if (server_addr==NULL || strlen(server_addr)==0) return -1;
osip_from_init(&url);
err=osip_from_parse(url,server_addr);
if (err<0){

View file

@ -1,49 +1,40 @@
$FreeBSD$
--- gnome/Makefile.in.orig Wed Aug 20 17:47:19 2003
+++ gnome/Makefile.in Sat Aug 23 01:16:42 2003
@@ -160,7 +160,6 @@
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/oRTP/src \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/oRTP/ \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/mediastreamer \
-@BUILD_GNOME_TRUE@ -I$(top_srcdir)/speex/libspeex \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/coreapi \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/osipua/ \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/osipua/src \
@@ -183,7 +182,7 @@
--- gnome/Makefile.in.orig Tue Mar 22 00:53:38 2005
+++ gnome/Makefile.in Wed Mar 23 19:37:16 2005
@@ -69,8 +69,7 @@
linphone_OBJECTS = $(am_linphone_OBJECTS)
am__DEPENDENCIES_1 =
@BUILD_GNOME_TRUE@linphone_DEPENDENCIES = $(am__DEPENDENCIES_1) \
-@BUILD_GNOME_TRUE@ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
-@BUILD_GNOME_TRUE@ $(top_builddir)/coreapi/liblinphone.la
+@BUILD_GNOME_TRUE@ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
am__linphone_applet_SOURCES_DIST = linphone.c linphone.h gui_utils.c \
gui_utils.h support.c support.h interface.c interface.h \
callbacks.c callbacks.h presence.c presence.h propertybox.c \
@@ -90,8 +89,7 @@
@BUILD_GNOME_APPLET_TRUE@ linphone_applet-applet.$(OBJEXT)
linphone_applet_OBJECTS = $(am_linphone_applet_OBJECTS)
@BUILD_GNOME_APPLET_TRUE@linphone_applet_DEPENDENCIES = \
-@BUILD_GNOME_APPLET_TRUE@ $(am__DEPENDENCIES_1) \
-@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphone.la
+@BUILD_GNOME_APPLET_TRUE@ $(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@@ -355,7 +353,7 @@
@BUILD_GNOME_TRUE@linphone_LDADD = $(LIBGNOMEUI_LIBS) $(INTLLIBS) \
@BUILD_GNOME_TRUE@ $(LIBGNOME_LIBS) \
-@BUILD_GNOME_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
+@BUILD_GNOME_TRUE@ -llinphonegnome
-@BUILD_GNOME_TRUE@ $(top_builddir)/coreapi/liblinphone.la
+@BUILD_GNOME_TRUE@ -llinphone
AM_CFLAGS = $(LIBGNOMEUI_CFLAGS) $(LIBGNOME_CFLAGS) $(GNOME_APPLETS_CFLAGS) $(IPV6_CFLAGS)
@@ -206,7 +205,7 @@
@BUILD_GNOME_APPLET_TRUE@gnome_appletdir = $(libexecdir)
@@ -366,7 +364,7 @@
@BUILD_GNOME_APPLET_TRUE@linphone_applet_CFLAGS = $(AM_CFLAGS) -DLINPHONE_APPLET
@BUILD_GNOME_APPLET_TRUE@linphone_applet_LDADD = \
@BUILD_GNOME_APPLET_TRUE@ $(GNOME_APPLETS_LIBS) \
-@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
+@BUILD_GNOME_APPLET_TRUE@ -llinphonegnome
-@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphone.la
+@BUILD_GNOME_APPLET_TRUE@ -llinphone
@@ -241,7 +240,7 @@
@BUILD_GNOME_TRUE@ propertybox.$(OBJEXT) addressbook.$(OBJEXT)
linphone_OBJECTS = $(am_linphone_OBJECTS)
@BUILD_GNOME_TRUE@linphone_DEPENDENCIES = \
-@BUILD_GNOME_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
+@BUILD_GNOME_TRUE@ -llinphonegnome
@BUILD_GNOME_FALSE@linphone_DEPENDENCIES =
linphone_LDFLAGS =
@BUILD_GNOME_APPLET_TRUE@am_linphone_applet_OBJECTS = \
@@ -256,7 +255,7 @@
@BUILD_GNOME_APPLET_TRUE@ linphone_applet-applet.$(OBJEXT)
linphone_applet_OBJECTS = $(am_linphone_applet_OBJECTS)
@BUILD_GNOME_APPLET_TRUE@linphone_applet_DEPENDENCIES = \
-@BUILD_GNOME_APPLET_TRUE@ $(top_srcdir)/coreapi/liblinphonegnome.la
+@BUILD_GNOME_APPLET_TRUE@ -llinphonegnome
@BUILD_GNOME_APPLET_FALSE@linphone_applet_DEPENDENCIES =
linphone_applet_LDFLAGS =
#uidir = $(datadir)/gnome-2.0/ui

View file

@ -1,11 +0,0 @@
--- gnome/callbacks.c.orig Fri Nov 7 21:08:34 2003
+++ gnome/callbacks.c Fri Nov 21 12:57:20 2003
@@ -82,7 +82,7 @@
on_user_manual1_activate (GtkMenuItem *menuitem,
gpointer user_data)
{
- gnome_help_display("manual/index.html",NULL,NULL);
+ gnome_help_display("index.html",NULL,NULL);
}

View file

@ -0,0 +1,15 @@
--- gnome/linphone.c.orig Fri Mar 11 00:38:56 2005
+++ gnome/linphone.c Wed Mar 23 19:33:00 2005
@@ -255,9 +255,10 @@
LinphoneCore *lc=get_core();
GList *elem=linphone_core_get_proxy_config_list(lc);
LinphoneProxyConfig *cfg=NULL;
- linphone_core_get_default_proxy(lc,&cfg);
GtkWidget *combo;
- GtkWidget *hbox=lookup_widget(window,"proxy_hbox");
+ GtkWidget *hbox;
+ linphone_core_get_default_proxy(lc,&cfg);
+ hbox=lookup_widget(window,"proxy_hbox");
if (elem==NULL){
gtk_widget_hide(hbox);
return;

View file

@ -1,18 +0,0 @@
$FreeBSD$
--- ltmain.sh.orig Wed May 14 00:39:58 2003
+++ ltmain.sh Sun Aug 17 19:29:50 2003
@@ -4325,10 +4325,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -0,0 +1,20 @@
--- mediastreamer2/Makefile.in.orig Tue Mar 22 00:53:40 2005
+++ mediastreamer2/Makefile.in Wed Mar 23 17:53:26 2005
@@ -53,7 +53,7 @@
@BUILD_UGLIB_TRUE@am__DEPENDENCIES_2 = \
@BUILD_UGLIB_TRUE@ $(top_builddir)/support/libuglib.la
libmediastreamer2_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
- ../gsmlib/libgsm.la ../lpc10-1.5/liblpc10.la \
+ ../lpc10-1.5/liblpc10.la \
../oRTP/src/libortp.la $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_2) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
@@ -311,7 +311,7 @@
msringplayer.c msringplayer.h waveheader.h
libmediastreamer2_la_LIBADD = $(GLIB_LIBS) \
- ../gsmlib/libgsm.la \
+ -lgsm \
../lpc10-1.5/liblpc10.la \
../oRTP/src/libortp.la \
$(JACK_LIBS)\

View file

@ -1,37 +1,20 @@
$FreeBSD$
--- mediastreamer/Makefile.in.orig Thu Apr 1 05:40:41 2004
+++ mediastreamer/Makefile.in Thu Apr 15 03:30:15 2004
@@ -222,7 +222,7 @@
--- mediastreamer/Makefile.in.orig Tue Mar 22 00:53:39 2005
+++ mediastreamer/Makefile.in Wed Mar 23 17:52:23 2005
@@ -66,7 +66,7 @@
@BUILD_UGLIB_TRUE@ $(top_builddir)/support/libuglib.la
@BUILD_TRUESPEECH_TRUE@am__DEPENDENCIES_3 = ../win32acm/libwin32acm.a
libmediastreamer_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
- ../gsmlib/libgsm.la ../lpc10-1.5/liblpc10.la \
+ ../lpc10-1.5/liblpc10.la \
../oRTP/src/libortp.la $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_3) \
@@ -493,7 +493,7 @@
$(VIDEO_SOURCES)
libmediastreamer_la_LIBADD = $(GLIB_LIBS) \
- ../gsmlib/libgsm.la \
+ -lgsm \
../lpc10-1.5/liblpc10.la \
../oRTP/src/libortp.la \
$(SUPPORTLIB) \
@@ -336,7 +336,6 @@
-I$(top_srcdir)/mediastreamer \
-I$(top_srcdir)/oRTP/src \
-I$(top_srcdir)/oRTP \
- -I$(top_srcdir)/gsmlib \
-I$(top_srcdir)/lpc10-1.5 \
-I$(top_srcdir)/ffmpeg/libavcodec \
-I/usr/X11R6/include/X11 \
@@ -352,12 +351,12 @@
libmediastreamer_la_LDFLAGS =
@BUILD_TRUESPEECH_TRUE@libmediastreamer_la_DEPENDENCIES = \
-@BUILD_TRUESPEECH_TRUE@ ../gsmlib/libgsm.la \
+@BUILD_TRUESPEECH_TRUE@ -lgsm \
@BUILD_TRUESPEECH_TRUE@ ../lpc10-1.5/liblpc10.la \
@BUILD_TRUESPEECH_TRUE@ ../oRTP/src/libortp.la \
@BUILD_TRUESPEECH_TRUE@ ../win32acm/libwin32acm.a
@BUILD_TRUESPEECH_FALSE@libmediastreamer_la_DEPENDENCIES = \
-@BUILD_TRUESPEECH_FALSE@ ../gsmlib/libgsm.la \
+@BUILD_TRUESPEECH_FALSE@ -lgsm \
@BUILD_TRUESPEECH_FALSE@ ../lpc10-1.5/liblpc10.la \
@BUILD_TRUESPEECH_FALSE@ ../oRTP/src/libortp.la
@BUILD_TRUESPEECH_TRUE@am__objects_1 = mstruespeechencoder.lo \
$(JACK_LIBS)\

View file

@ -0,0 +1,11 @@
--- oRTP/Makefile.in.orig Tue Mar 22 00:53:54 2005
+++ oRTP/Makefile.in Wed Mar 23 18:51:57 2005
@@ -209,7 +209,7 @@
#config.h.in and acconfig.h to avoid a bug in automake that prevent them to be included in the
#dist...
EXTRA_DIST = oRTP.prj ortp-config.h.in TODO pkg.list
-SUBDIRS = src docs build include
+SUBDIRS = src build include
@WITH_EPM_TRUE@PKG_NAME = $(PACKAGE)-$(VERSION)-$(RELEASE)
all: ortp-config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive

View file

@ -1,11 +1,13 @@
--- oRTP/configure.orig Thu Nov 20 19:42:24 2003
+++ oRTP/configure Fri Nov 21 11:14:07 2003
@@ -19430,8 +19430,6 @@
CFLAGS="$CFLAGS +DA2.0W +DS2.0"
fi
fi
-else
- CFLAGS="-O2 -g -Wall"
--- oRTP/configure.orig Wed Mar 23 13:35:19 2005
+++ oRTP/configure Wed Mar 23 13:41:11 2005
@@ -20712,10 +20712,6 @@
posixtimer_interval=20000
fi
build_scheduler=yes
-if test "$GCC" = "yes" ; then
- CFLAGS="$CFLAGS -Werror"
-fi
-
cat >>confdefs.h <<_ACEOF
#define POSIXTIMER_INTERVAL $posixtimer_interval

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- oRTP/src/port_fct.c 2002/12/30 08:13:23 1.1
+++ oRTP/src/port_fct.c 2002/12/30 08:13:35
@@ -20,7 +20,7 @@
/* port_fct.h. define methods to help for portability between unix and win32 */
-
+#include <sched.h>
#include "rtpsession.h"
#include "port_fct.h"

View file

@ -0,0 +1,71 @@
--- oRTP/src/rtpsession.c.orig Thu Mar 10 01:34:59 2005
+++ oRTP/src/rtpsession.c Wed Mar 23 15:27:20 2005
@@ -377,16 +377,22 @@
close_socket (session->rtp.socket);
continue;
}
-#ifndef __hpux
+#if !defined(__hpux) && !defined(__FreeBSD__)
switch (res->ai_family)
{
case AF_INET:
if (IN_MULTICAST(ntohl(((struct sockaddr_in *) res->ai_addr)->sin_addr.s_addr)))
{
+#if !defined(__FreeBSD__)
struct ip_mreqn mreq;
+#else
+ struct ip_mreq mreq;
+#endif
mreq.imr_multiaddr.s_addr = ((struct sockaddr_in *) res->ai_addr)->sin_addr.s_addr;
mreq.imr_address.s_addr = INADDR_ANY;
+#if !defined(__FreeBSD__)
mreq.imr_ifindex = 0;
+#endif
err = setsockopt(session->rtp.socket, IPPROTO_IP, IP_ADD_MEMBERSHIP, &mreq, sizeof(mreq));
if (err < 0)
{
@@ -454,16 +460,22 @@
close_socket (session->rtcp.socket);
continue;
}
-#ifndef __hpux
+#if !defined(__hpux) && !defined(__FreeBSD__)
switch (res->ai_family)
{
case AF_INET:
if (IN_MULTICAST(ntohl(((struct sockaddr_in *) res->ai_addr)->sin_addr.s_addr)))
{
+#if !defined(__FreeBSD__)
struct ip_mreqn mreq;
+#else
+ struct ip_mreq mreq;
+#endif
mreq.imr_multiaddr.s_addr = ((struct sockaddr_in *) res->ai_addr)->sin_addr.s_addr;
mreq.imr_address.s_addr = INADDR_ANY;
+#if !defined(__FreeBSD__)
mreq.imr_ifindex = 0;
+#endif
err = setsockopt(session->rtcp.socket, IPPROTO_IP, IP_ADD_MEMBERSHIP, &mreq, sizeof(mreq));
if (err < 0)
{
@@ -555,13 +567,19 @@
close_socket (session->rtcp.socket);
return -1;
}
-#ifndef __hpux
+#if !defined(__hpux) && !defined(__FreeBSD__)
if (IN_MULTICAST(ntohl(session->rtp.loc_addr.sin_addr.s_addr)))
{
+#if !defined(__FreeBSD__)
struct ip_mreqn mreq;
+#else
+ struct ip_mreq mreq;
+#endif
mreq.imr_multiaddr.s_addr = session->rtp.loc_addr.sin_addr.s_addr;
mreq.imr_address.s_addr = INADDR_ANY;
+#if !defined(__FreeBSD__)
mreq.imr_ifindex = 0;
+#endif
err = setsockopt(session->rtp.socket, IPPROTO_IP, IP_ADD_MEMBERSHIP, &mreq, sizeof(mreq));
if (err == 0)
err = setsockopt(session->rtcp.socket, IPPROTO_IP, IP_ADD_MEMBERSHIP, &mreq, sizeof(mreq));

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- oRTP/src/scheduler.h 2002/12/30 08:15:08 1.1
+++ oRTP/src/scheduler.h 2002/12/30 08:15:16
@@ -20,6 +20,8 @@
#ifndef SCHEDULER_H
#define SCHEDULER_H
+#include <pthread.h>
+
#include "rtpsession.h"
#include "rtptimer.h"
#include "sessionset.h"

View file

@ -1,13 +0,0 @@
$FreeBSD$
--- osipua/src/sdphandler.c 2003/06/13 13:02:40 1.1
+++ osipua/src/sdphandler.c 2003/06/13 13:02:48
@@ -26,6 +26,7 @@
#include <string.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#ifdef HAVE_IFADDRS_H
#include <ifaddrs.h>

View file

@ -1,10 +0,0 @@
--- osipua/src/utils.c.orig Thu Oct 23 13:06:43 2003
+++ osipua/src/utils.c Thu Oct 23 13:07:24 2003
@@ -382,6 +382,7 @@
abort();
return -1;
}
+ ((struct sockaddr_in *)(res->ai_addr))->sin_port=htons(9999);
err=connect(sock,res->ai_addr,res->ai_addrlen);
if (err<0) {
osip_trace(OSIP_ERROR,("Error in connect: %s\n",strerror(errno)));

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- share/Makefile.in.orig Wed Aug 20 17:49:21 2003
+++ share/Makefile.in Sat Aug 23 01:55:33 2003
@@ -170,7 +170,7 @@
confexdir = $(datadir)/linphonec
confex_DATA = linphonec
-pkgconfigdir = $(prefix)/lib/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = linphone.pc
EXTRA_DIST = $(LINPHONE_SOUNDS) \

View file

@ -10,98 +10,53 @@ include/linphone/uglib.h
include/ortp/ortp-config.h
include/ortp/ortp.h
include/ortp/payloadtype.h
include/ortp/port_fct.h
include/ortp/rtcp.h
include/ortp/rtp.h
include/ortp/rtpmod.h
include/ortp/rtpport.h
include/ortp/rtpsession.h
include/ortp/rtpsignaltable.h
include/ortp/rtptimer.h
include/ortp/scheduler.h
include/ortp/sessionset.h
include/ortp/str_utils.h
include/ortp/telephonyevents.h
include/osipua/bodycontext.h
include/osipua/bodyhandler.h
include/osipua/osipdialog.h
include/osipua/osipmanager.h
include/osipua/osipua-config.h
include/osipua/osipua.h
include/osipua/regctxt.h
include/osipua/resolver.h
include/osipua/sdpcontext.h
include/osipua/sdphandler.h
include/osipua/utils.h
lib/liblinphone.a
lib/liblinphone.so
lib/liblinphone.so.0
lib/liblinphonegnome.a
lib/liblinphonegnome.so
lib/liblinphonegnome.so.0
lib/libmediastreamer.a
lib/libmediastreamer.so
lib/libmediastreamer.so.0
lib/libmsspeex.a
lib/libmsspeex.so
lib/libmsspeex.so.0
lib/liblinphone.so.1
lib/libortp.a
lib/libortp.so
lib/libortp.so.0
lib/libosipalloc.a
lib/libosipalloc.so
lib/libosipalloc.so.0
lib/libosipua.a
lib/libosipua.so
lib/libosipua.so.2
lib/libortp.so.7
libdata/pkgconfig/linphone.pc
%%DOCSDIR%%/mediastreamer/book1.html
%%DOCSDIR%%/mediastreamer/coreapi.html
%%DOCSDIR%%/mediastreamer/index.sgml
%%DOCSDIR%%/mediastreamer/mediastreamer-filters.html
%%DOCSDIR%%/mediastreamer/mediastreamer-msringplayer.html
%%DOCSDIR%%/mediastreamer/mediastreamer-mssync.html
%%DOCSDIR%%/mediastreamer/mediastreamer-running-processing-chains.html
%%DOCSDIR%%/mediastreamer/msfilterimplementations.html
%%DOCSDIR%%/mediastreamer/userapi.html
%%DOCSDIR%%/ortp/book1.html
%%DOCSDIR%%/ortp/index.sgml
%%DOCSDIR%%/ortp/ortp-library-management-functions.html
%%DOCSDIR%%/ortp/ortp-multiplexing-sessions-(in-a-one-thread-design).html
%%DOCSDIR%%/ortp/ortp-rtp-payloads-and-profiles.html
%%DOCSDIR%%/ortp/ortp-rtpsession-api.html
%%DOCSDIR%%/ortp/ortp-telephone-events-(rfc2833)-.html
%%DOCSDIR%%/ortp/ortpapi.html
%%DOCSDIR%%/osipua/book1.html
%%DOCSDIR%%/osipua/index.sgml
%%DOCSDIR%%/osipua/osipcallleg.html
%%DOCSDIR%%/osipua/osipua--registrationctxt-api-.html
%%DOCSDIR%%/osipua/osipua-osipcallleg-private-api.html
%%DOCSDIR%%/osipua/osipua-osipcallleg-public-api.html
%%DOCSDIR%%/osipua/osipua-osipua-private-api.html
%%DOCSDIR%%/osipua/osipua-osipua-public-api.html
%%DOCSDIR%%/osipua/osipua.html
%%DOCSDIR%%/osipua/registrationctxt.html
share/doc/linphone/mediastreamer/book1.html
share/doc/linphone/mediastreamer/coreapi.html
share/doc/linphone/mediastreamer/mediastreamer-filters.html
share/doc/linphone/mediastreamer/mediastreamer-msringplayer.html
share/doc/linphone/mediastreamer/mediastreamer-mssync.html
share/doc/linphone/mediastreamer/mediastreamer-running-processing-chains.html
share/doc/linphone/mediastreamer/msfilterimplementations.html
share/doc/linphone/mediastreamer/userapi.html
share/doc/linphone/mediastreamer/index.sgml
%%DATADIR%%/sounds/hello16000.wav
%%DATADIR%%/sounds/hello8000.wav
%%DATADIR%%/sounds/ringback.wav
%%DATADIR%%/sounds/rings/bigben.wav
%%DATADIR%%/sounds/rings/oldphone.wav
%%DATADIR%%/sounds/rings/orig.wav
share/linphonec/linphonec
%%DATADIR%%/sounds/rings/rock.wav
%%DATADIR%%/sounds/rings/sweet.wav
%%DATADIR%%/sounds/rings/synth.wav
%%DATADIR%%/sounds/rings/tapping.wav
%%DATADIR%%/sounds/rings/toy.wav
share/locale/cs/LC_MESSAGES/linphone.mo
share/locale/de/LC_MESSAGES/linphone.mo
share/locale/es/LC_MESSAGES/linphone.mo
share/locale/fr/LC_MESSAGES/linphone.mo
share/locale/it/LC_MESSAGES/linphone.mo
share/locale/ja/LC_MESSAGES/linphone.mo
share/locale/nl/LC_MESSAGES/linphone.mo
share/locale/pl/LC_MESSAGES/linphone.mo
@dirrm share/linphonec
@dirrm share/doc/linphone/mediastreamer
@dirrm share/doc/linphone
@dirrm %%DATADIR%%/sounds/rings
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%/osipua
@dirrm %%DOCSDIR%%/ortp
@dirrm %%DOCSDIR%%/mediastreamer
@dirrm %%DOCSDIR%%
@dirrm include/linphone
@dirrm include/osipua
@dirrm include/ortp
@dirrm include/linphone

View file

@ -16,7 +16,7 @@ MASTER_SITES= ${LINPHONE_MASTER_SITES}
MAINTAINER= ports@FreeBSD.org
COMMENT= A web phone that supports SIP protocol
LIB_DEPENDS= linphone.0:${PORTSDIR}/net/linphone-base
LIB_DEPENDS= linphone.1:${PORTSDIR}/net/linphone-base
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnomepanel
@ -24,7 +24,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-ipv6
CONFIGURE_ARGS= --disable-ipv6 --disable-gtk-doc \
--with-speex=${LOCALBASE} --with-osip=${LOCALBASE}
MAKE_ENV= SUBDIRS="pixmaps gnome"
MAN1= linphone.1
@ -40,14 +41,5 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/share/C/linphone.1 ${MANPREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/share/linphone.desktop \
${PREFIX}/share/gnome/applications
.for lang in C fr it ja
@${MKDIR} ${PREFIX}/share/gnome/help/linphone/${lang}
${INSTALL_DATA} ${WRKSRC}/share/${lang}/manual/*.html \
${PREFIX}/share/gnome/help/linphone/${lang}
.endfor
.for lang in C fr it
${INSTALL_DATA} ${WRKSRC}/share/${lang}/manual/*.css \
${PREFIX}/share/gnome/help/linphone/${lang}
.endfor
.include <bsd.port.post.mk>

View file

@ -3,60 +3,15 @@ libdata/bonobo/servers/GNOME_LinphoneApplet.server
libexec/linphone_applet
share/gnome/applications/linphone.desktop
share/gnome/gnome-2.0/ui/GNOME_LinphoneApplet.xml
share/gnome/help/linphone/C/docbook.css
share/gnome/help/linphone/C/index.html
share/gnome/help/linphone/C/params.html
share/gnome/help/linphone/C/t1.html
share/gnome/help/linphone/C/x118.html
share/gnome/help/linphone/C/x121.html
share/gnome/help/linphone/C/x137.html
share/gnome/help/linphone/C/x143.html
share/gnome/help/linphone/C/x167.html
share/gnome/help/linphone/C/x172.html
share/gnome/help/linphone/C/x188.html
share/gnome/help/linphone/C/x26.html
share/gnome/help/linphone/C/x36.html
share/gnome/help/linphone/fr/docbook.css
share/gnome/help/linphone/fr/params.html
share/gnome/help/linphone/fr/registering.html
share/gnome/help/linphone/fr/t1.html
share/gnome/help/linphone/fr/x116.html
share/gnome/help/linphone/fr/x134.html
share/gnome/help/linphone/fr/x140.html
share/gnome/help/linphone/fr/x164.html
share/gnome/help/linphone/fr/x170.html
share/gnome/help/linphone/fr/x188.html
share/gnome/help/linphone/fr/x24.html
share/gnome/help/linphone/fr/x34.html
share/gnome/help/linphone/it/docbook.css
share/gnome/help/linphone/it/params.html
share/gnome/help/linphone/it/registering.html
share/gnome/help/linphone/it/t1.html
share/gnome/help/linphone/it/x116.html
share/gnome/help/linphone/it/x134.html
share/gnome/help/linphone/it/x140.html
share/gnome/help/linphone/it/x164.html
share/gnome/help/linphone/it/x170.html
share/gnome/help/linphone/it/x189.html
share/gnome/help/linphone/it/x24.html
share/gnome/help/linphone/it/x34.html
share/gnome/help/linphone/ja/params.html
share/gnome/help/linphone/ja/t1.html
share/gnome/help/linphone/ja/x112.html
share/gnome/help/linphone/ja/x115.html
share/gnome/help/linphone/ja/x131.html
share/gnome/help/linphone/ja/x137.html
share/gnome/help/linphone/ja/x161.html
share/gnome/help/linphone/ja/x166.html
share/gnome/help/linphone/ja/x182.html
share/gnome/help/linphone/ja/x25.html
share/gnome/help/linphone/ja/x35.html
share/gnome/pixmaps/linphone/linphone.png
share/gnome/pixmaps/linphone/linphone2.png
share/gnome/pixmaps/linphone/linphone2.xpm
share/gnome/pixmaps/linphone/sip-away.png
share/gnome/pixmaps/linphone/sip-bifm.png
share/gnome/pixmaps/linphone/sip-busy.png
share/gnome/pixmaps/linphone/sip-closed.png
share/gnome/pixmaps/linphone/sip-online.png
share/gnome/pixmaps/linphone/sip-otl.png
share/gnome/pixmaps/linphone/sip-otp.png
share/gnome/pixmaps/linphone/sip-wfa.png
@dirrm share/gnome/pixmaps/linphone
@dirrm share/gnome/help/linphone/ja
@dirrm share/gnome/help/linphone/it
@dirrm share/gnome/help/linphone/fr
@dirrm share/gnome/help/linphone/C
@dirrm share/gnome/help/linphone