- Make static library relocatable
Approved by: Xin LI <delphij@frontfree.net> (maintainer)
This commit is contained in:
parent
8248f236b6
commit
2c01ccf175
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=127699
2 changed files with 16 additions and 7 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= cryptopp
|
||||
PORTVERSION= 5.2.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://www.eskimo.com/~weidai/ \
|
||||
|
@ -24,6 +25,7 @@ USE_ZIP= yes
|
|||
EXTRACT_BEFORE_ARGS= -aq
|
||||
USE_GMAKE= yes
|
||||
MAKEFILE= GNUmakefile
|
||||
CXXFLAGS+= -fPIC
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
|
|
@ -1,15 +1,22 @@
|
|||
--- GNUmakefile.orig Wed Mar 26 17:21:24 2003
|
||||
+++ GNUmakefile Wed Mar 26 17:22:16 2003
|
||||
@@ -47,7 +47,7 @@
|
||||
TESTOBJS = bench.o test.o validat1.o validat2.o validat3.o adhoc.o datatest.o regtest.o
|
||||
LIBOBJS = $(filter-out $(TESTOBJS),$(OBJS))
|
||||
--- GNUmakefile.orig Sun Jun 20 11:22:24 2004
|
||||
+++ GNUmakefile Sun Jan 30 02:09:00 2005
|
||||
@@ -1,5 +1,5 @@
|
||||
# can't use -fno-rtti yet because it causes problems with exception handling in GCC 2.95.2
|
||||
-CXXFLAGS = -g
|
||||
+CXXFLAGS ?= -g
|
||||
# Uncomment the following two lines to do a release build.
|
||||
# Note that you must define NDEBUG for your own application if you define it for Crypto++.
|
||||
# Make sure you run the validation tests and test your own program thoroughly
|
||||
@@ -75,7 +75,7 @@
|
||||
TESTIMPORTOBJS = $(TESTOBJS:.o=.import.o)
|
||||
DLLTESTOBJS = dlltest.dllonly.o
|
||||
|
||||
-all: cryptest.exe
|
||||
+all: cryptest
|
||||
|
||||
clean:
|
||||
$(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS)
|
||||
@@ -56,7 +56,7 @@
|
||||
$(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS) cryptopp.dll libcryptopp.dll.a libcryptopp.import.a cryptest.import.exe dlltest.exe $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTIMPORTOBJS) $(DLLTESTOBJS)
|
||||
@@ -84,7 +84,7 @@
|
||||
$(AR) $(ARFLAGS) $@ $(LIBOBJS)
|
||||
$(RANLIB) $@
|
||||
|
||||
|
|
Loading…
Reference in a new issue